Loading ...
Sorry, an error occurred while loading the content.

Re: MP2 - DBI Problem only under mod_perl: OCIEnvNlsCreate - MOSTLY SOLVED

Expand Messages
  • Thomas Hilbig
    ... Problem mostly resolved. I was checking my init.d settings (/etc/init.d/httpd) to make sure everything was pointing at the correct httpd environment. All
    Message 1 of 26 , Sep 7, 2005
    • 0 Attachment
      --- Geoffrey Young <geoff@...> wrote:
      >
      > DBD::Oracle needs these variables when DBD::Oracle
      > is loaded. which means
      > they need to be in %ENV _before_ the script that
      > first use()s DBD::Oracle is
      > loaded. httpd.conf is generally too late if you
      > preload your modules via a
      > startup.pl, or a module you PerlModule itself
      > somehow loads it.
      >
      > the typical way to do this is to place something
      > like the following in your
      > startup.pl
      >

      Problem mostly resolved.

      I was checking my init.d settings (/etc/init.d/httpd)
      to make sure everything was pointing at the correct
      httpd environment. All was fine, however, I happended
      to notice that I got different results depending if I
      used _service_ or called /etc/init.d/httpd directly:

      service httpd start (mod_perl lost ENV settings)
      /etc/init.d/httpd start (worked fine in mod_perl)

      In the first method, the only ENV variables that made
      it to the dbitrace.log file were those set and
      exported in /etc/init.d/functions . Setting them in
      httpd.conf or via a startup.pl didn't seem to help,
      but I will experiment further.

      Thanks for everyone's help on this,
      Tom

      __________________________________________________
      Do You Yahoo!?
      Tired of spam? Yahoo! Mail has the best spam protection around
      http://mail.yahoo.com
    Your message has been successfully submitted and would be delivered to recipients shortly.