Loading ...
Sorry, an error occurred while loading the content.

Re: [mp1] segmentation fault in Apache->server->dir_config()

Expand Messages
  • Mike Taylor
    ... I did initially try to use mod_perl2 and Apache2, but I couldn t get the HTML::Mason module to work with them; and since Mason is my reason for wanting to
    Message 1 of 3 , Apr 27, 2005
    • 0 Attachment
      > Date: Tue, 26 Apr 2005 22:05:08 -0400
      > From: Stas Bekman <stas@...>
      >
      > hmm, I guess there still some people using mp1. This is so
      > unfashionable. Everybody wears RC5 these days :)

      :-)

      I did initially try to use mod_perl2 and Apache2, but I couldn't get
      the HTML::Mason module to work with them; and since Mason is my reason
      for wanting to use mod_perl at all, I backed down to 1.x.

      >> The bizarre thing is that, as I said, _nothing_ has changed since
      >> yesterday, when this worked just fine.
      >
      > Mike, have you by chance upgraded some modules between the last
      > server startup and reboot? Remember that mod_perl won't see any
      > changes until restarted, so if you did change things you could have
      > known whether they have affected mod_perl or not.

      I wish it were so! But, no; that machine's Apache server has been
      reloaded and restarted half a dozen times every day, as I've tweaked
      its configuration. I am quite certain that I didn't make an
      configuration changes that didn't immediately get tested. So, no,
      nothing explicitly changed between the last restart of Apache before
      the reboot, and the reboot itself. Which makes me think it must be
      something that was in the running state of the computer -- but what?
      I really can't imagine.

      >> I tried to run httpd under both strace and gdb, but I have not
      >> managed to get any useful information out of it that way. I am
      >> using Apache 1.3.33 with mod_perl 1.29 (the most recent 1.x
      >> versions of both, I believe) both built from source.
      >
      > Mike, you need to get the core backtrace. Please check:
      > 'Getting the Backtrace From Core Dumps' at
      > http://perl.apache.org/docs/1.0/guide/help.html#How_to_Report_Problems
      > for details. Also an output of 'perl -V' would be helpful.

      Backtrace to follow. In the mean time, here is the perl -V output.
      Thanks for your help.

      --

      $ perl -V
      Summary of my perl5 (revision 5.0 version 8 subversion 0) configuration:
      Platform:
      osname=linux, osvers=2.4.21-1.1931.2.382.entsmp, archname=i386-linux-thread-multi
      uname='linux stripples.devel.redhat.com 2.4.21-1.1931.2.382.entsmp #1 smp wed aug 6 17:18:52 edt 2003 i686 i686 i386 gnulinux '
      config_args='-des -Doptimize=-O2 -g -pipe -march=i386 -mcpu=i686 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Red Hat, Inc. -Dinstallprefix=/usr -Dprefix=/usr -Darchname=i386-linux -Dvendorprefix=/usr -Dsiteprefix=/usr -Dotherlibdirs=/usr/lib/perl5/5.8.0 -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Dd_dosuid -Dd_semctl_semun -Di_db -Ui_ndbm -Di_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly -Dpager=/usr/bin/less -isr'
      hint=recommended, useposix=true, d_sigaction=define
      usethreads=define use5005threads=undef useithreads=define usemultiplicity=define
      useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
      use64bitint=undef use64bitall=undef uselongdouble=undef
      usemymalloc=n, bincompat5005=undef
      Compiler:
      cc='gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm',
      optimize='-O2 -g -pipe -march=i386 -mcpu=i686',
      cppflags='-D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include -I/usr/include/gdbm'
      ccversion='', gccversion='3.2.2 20030222 (Red Hat Linux 3.2.2-5)', gccosandvers=''
      intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
      d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
      ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
      alignbytes=4, prototype=define
      Linker and Libraries:
      ld='gcc', ldflags =' -L/usr/local/lib'
      libpth=/usr/local/lib /lib /usr/lib
      libs=-lnsl -lgdbm -ldb -ldl -lm -lpthread -lc -lcrypt -lutil
      perllibs=-lnsl -ldl -lm -lpthread -lc -lcrypt -lutil
      libc=/lib/libc-2.3.2.so, so=so, useshrplib=true, libperl=libperl.so
      gnulibc_version='2.3.2'
      Dynamic Linking:
      dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic -Wl,-rpath,/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE'
      cccdlflags='-fPIC', lddlflags='-shared -L/usr/local/lib'


      Characteristics of this binary (from libperl):
      Compile-time options: DEBUGGING MULTIPLICITY USE_ITHREADS USE_LARGE_FILES PERL_IMPLICIT_CONTEXT
      Locally applied patches:
      MAINT18379
      Built under linux
      Compiled at Aug 13 2003 11:47:58
      @INC:
      /usr/lib/perl5/5.8.0/i386-linux-thread-multi
      /usr/lib/perl5/5.8.0
      /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
      /usr/lib/perl5/site_perl/5.8.0
      /usr/lib/perl5/site_perl
      /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
      /usr/lib/perl5/vendor_perl/5.8.0
      /usr/lib/perl5/vendor_perl
      /usr/lib/perl5/5.8.0/i386-linux-thread-multi
      /usr/lib/perl5/5.8.0
      .
      $

      _/|_ ___________________________________________________________________
      /o ) \/ Mike Taylor <mike@...> http://www.miketaylor.org.uk
      )_v__/\ "I want to create an omelet that expresses the meaninglessness
      of existence, and instead they taste like cheese" -- Marty Smith,
      "The Jean-Paul Sartre Cookbook"

      --
      Listen to free demos of soundtrack music for film, TV and radio
      http://www.pipedreaming.org.uk/soundtrack/
    Your message has been successfully submitted and would be delivered to recipients shortly.