Loading ...
Sorry, an error occurred while loading the content.

ERROR when compiled mod_perl with Apache assertion "rv == APR_SUC CESS" failed

Expand Messages
  • SALOME Alexandre
    Good Morning everybody, I need your help. I have installed APACHE2.0.50 with PHP4. I would like to work with ssl. To this, I am trying installed
    Message 1 of 3 , Aug 2, 2004
    • 0 Attachment
       

       

      Good Morning everybody, I need your help.

       I have installed APACHE2.0.50 with PHP4. I would like to work with ssl. To this, I am trying installed mod-perl1.99_14. When I compiled this, I have this message:

      [Mon Aug 02 09:02:02 2004] [crit] [Mon Aug 02 09:02:02 2004] file vhost.c, line 189, assertion "rv == APR_SUCCESS" failed

      . Please, what do Ido?

       

      Alexandre Salomé
      COMAU do Brasil Ind. e Com. Ltda -
      Analista de Sistemas - Engenharia - Divisão System
      Rodovia Fernão Dias, Km 429 BR381 Distr. Industr. Paulo Camilo Pena - CEP
      32536-000
       Betim - MG - Brasil - Galpão 57 externo .         cnpj: 02.693.750/0001-11 I.e: 067.000080.00-22
      Tel: + 55-31-2123-6533 / Fax: + 55-31-2123-6523         http://www.comau.com.br

       

       
    • Stas Bekman
      ... First you submit a proper problem report, as explained here: http://perl.apache.org/bugs/ Make sure to mention when do you get this error. and show us a
      Message 2 of 3 , Aug 2, 2004
      • 0 Attachment
        SALOME Alexandre wrote:
        >
        >
        >
        >
        >
        > Good Morning everybody, I need your help.
        >
        > I have installed APACHE2.0.50 with PHP4. I would like to work with ssl. To
        > this, I am trying installed mod-perl1.99_14. When I compiled this, I have
        > this message:
        >
        > [Mon Aug 02 09:02:02 2004] [crit] [Mon Aug 02 09:02:02 2004] file vhost.c,
        > line 189, assertion "rv == APR_SUCCESS" failed
        >
        > . Please, what do Ido?

        First you submit a proper problem report, as explained here:
        http://perl.apache.org/bugs/

        Make sure to mention when do you get this error. and show us a small
        relevant config section which causes this error.

        Thanks.

        --
        __________________________________________________________________
        Stas Bekman JAm_pH ------> Just Another mod_perl Hacker
        http://stason.org/ mod_perl Guide ---> http://perl.apache.org
        mailto:stas@... http://use.perl.org http://apacheweek.com
        http://modperlbook.org http://apache.org http://ticketmaster.com

        --
        Report problems: http://perl.apache.org/bugs/
        Mail list info: http://perl.apache.org/maillist/modperl.html
        List etiquette: http://perl.apache.org/maillist/email-etiquette.html
      • Philippe M. Chiasson
        ... Looks like something is broken trying to resolve 255.255.255.255 on your platform as seen by this snippet from vhost.c: else if (strcasecmp(host,
        Message 3 of 3 , Aug 2, 2004
        • 0 Attachment
          Stas Bekman wrote:
          > SALOME Alexandre wrote:
          >
          >>
          >>
          >>
          >>
          >>
          >>Good Morning everybody, I need your help.
          >>
          >> I have installed APACHE2.0.50 with PHP4. I would like to work with ssl. To
          >>this, I am trying installed mod-perl1.99_14. When I compiled this, I have
          >>this message:
          >>
          >>[Mon Aug 02 09:02:02 2004] [crit] [Mon Aug 02 09:02:02 2004] file vhost.c,
          >>line 189, assertion "rv == APR_SUCCESS" failed
          >>
          >>. Please, what do Ido?

          Looks like something is broken trying to resolve 255.255.255.255 on your platform
          as seen by this snippet from vhost.c:

          else if (strcasecmp(host, "_default_") == 0
          || strcmp(host, "255.255.255.255") == 0) {
          rv = apr_sockaddr_info_get(&my_addr, "255.255.255.255", APR_INET, port, 0, p);
          ap_assert(rv == APR_SUCCESS); /* must be bug or out of storage */
          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

          So, please submit a proper bug report and make sure you are giving out details of
          the exact OS/Platform you are running on. All points to a problem in apr/httpd land,
          not mod_perl though.

          >
          > First you submit a proper problem report, as explained here:
          > http://perl.apache.org/bugs/
          >
          > Make sure to mention when do you get this error. and show us a small
          > relevant config section which causes this error.
          >
          > Thanks.
          >

          --
          --------------------------------------------------------------------------------
          Philippe M. Chiasson m/gozer\@(apache|cpan|ectoplasm)\.org/ GPG KeyID : 88C3A5A5
          http://gozer.ectoplasm.org/ F9BF E0C2 480E 7680 1AE5 3631 CB32 A107 88C3A5A5
        Your message has been successfully submitted and would be delivered to recipients shortly.