Loading ...
Sorry, an error occurred while loading the content.

Re: [mp1] building mp1 with mod_ssl - what am I doing wrong?

Expand Messages
  • Stas Bekman
    ... Not, unless you want a static build, which is what the quoted instructions do. ... Right. In which case refer to the various sections in
    Message 1 of 5 , Aug 2, 2004
    • 0 Attachment
      Carl Brewer wrote:
      > Stas Bekman wrote:
      >
      >
      >> Carl, can you build Apache w/o mod_perl w/ the rest of the things?
      >
      >
      > Yes, it's just the mod_perl stuff that's barfing. It looks like
      > the mod_perl make install isn't putting the header files into
      > src/includes/.
      >
      >
      >
      > A
      >
      >> quick google shows a bunch of relevant hits:
      >> http://www.google.ca/search?hl=en&ie=UTF-8&q=%22os.h%3A+No+such+file+or+directory%22&btnG=Search&meta=
      >>
      >>
      >> Also make sure that you are following the exact instructions from:
      >> http://perl.apache.org/docs/1.0/guide/install.html#mod_perl_and_mod_ssl___openssl_
      >
      >
      >
      > The list of arguments I want to feed to the actual apache configure
      > make this a bit of a pain, and I thought that it wasn't necessary
      > to build httpd from within mod_perl (and indeed it shouldn't
      > be anyway!).

      Not, unless you want a static build, which is what the quoted
      instructions do.

      > But, at your suggestion, I've now done this, following the instructions
      > on the site you referenced :
      >
      > cd openssl-0.9.7d
      > ./config --prefix=/usr/local/openssl-0.9.7d
      > make
      > make test
      > make install
      >
      > then in the mod_perl dir :
      >
      > perl Makefile.PL USE_APACI=1 EVERYTHING=1 DO_HTTPD=1
      > SSL_BASE=/usr/local/openssl-0.9.7d APACHE_PREFIX=/usr/local/apache-test
      > APACHE_SRC=../apache_1.3.31/src
      > APACI_ARGS='--enable-module=ssl,--enable-module=rewrite,--enable-module=proxy,
      >
      > --enable-module=so,--enable-module=access,--enable-module=auth,
      > --enable-module=include,--enable-module=mime,--enable-module=log_config,
      > --enable-module=alias,--enable-module=vhost_alias,--enable-module=log_agent,
      >
      > --enable-module=headers,--enable-shared=expires,--enable-shared=mime_magic,
      > --enable-shared=ssl'
      >
      > And that compiled ok. Maybe the problem was this :
      >
      > "--activate-module=src/modules/perl/libperl.a" \
      >
      > ?

      Right. In which case refer to the various sections in
      http://perl.apache.org/docs/1.0/guide/install.html that discuss the DSO
      build.



      --
      __________________________________________________________________
      Stas Bekman JAm_pH ------> Just Another mod_perl Hacker
      http://stason.org/ mod_perl Guide ---> http://perl.apache.org
      mailto:stas@... http://use.perl.org http://apacheweek.com
      http://modperlbook.org http://apache.org http://ticketmaster.com

      --
      Report problems: http://perl.apache.org/bugs/
      Mail list info: http://perl.apache.org/maillist/modperl.html
      List etiquette: http://perl.apache.org/maillist/email-etiquette.html
    Your message has been successfully submitted and would be delivered to recipients shortly.