Loading ...
Sorry, an error occurred while loading the content.

Re: Apache::Reload: explicitly registering required library files [p atch included]

Expand Messages
  • Perrin Harkins
    ... It won t with this patch, unless common_subs.pl declares a package. If common_subs.pl is just a bunch of subs that get pulled into the current script s
    Message 1 of 2 , Jul 2, 2004
    • 0 Attachment
      Bevelock, Mike wrote:
      > For example, if a sub in 'lib/common_subs.pl' changed, it would be nice if
      > all code
      > that did this:
      >
      > require 'lib/common_subs.pl';
      >
      > got the fresh code in lib/common_subs.pl.

      It won't with this patch, unless common_subs.pl declares a package. If
      common_subs.pl is just a bunch of subs that get pulled into the current
      script's namespace, Apache::Reload can't change them.

      - Perrin

      --
      Report problems: http://perl.apache.org/bugs/
      Mail list info: http://perl.apache.org/maillist/modperl.html
      List etiquette: http://perl.apache.org/maillist/email-etiquette.html
    Your message has been successfully submitted and would be delivered to recipients shortly.