Loading ...
Sorry, an error occurred while loading the content.

RE: perl sections in windows and linux

Expand Messages
    I ve find an apparent solution for my problem. If i put in httpd.conf the tags Then all my archive.pl works well, without the tags before it
    Message 1 of 3 , Mar 27, 2004
    • 0 Attachment
      I've find an "apparent" solution for my problem.
      If i put in httpd.conf the tags
      <Perl >
      Then all my archive.pl works well, without the tags before it doesn't work.
      For me seems to work (now).
      I installed the version 1.99_13 with a make test failed, and i don't know if
      it worked with 1.99_12 then, or if this solution wouldn't be necessary with
      a make test well done ...

      -----Original Message-----
      From: Stas Bekman
      Cc: 'modperl@...'
      Sent: 3/27/2004 3:07 AM
      Subject: Re: perl sections in windows and linux

      > Hello after some time, i have had my archive.pl configuring apache2
      all this
      > time working perfectly. But today i have tried the same in my linux
      and i
      > get that the same orders that worked on windows (xp) now do not work
      in my
      > linux (suse 9.0).
      > What can be the problem? Here is the code:
      > ...
      > my $b_config = <<'END';
      > <Perl >
      > $Location{'~ .*log$'} = {
      > SetHandler => "perl-script",
      > PerlResponseHandler => "Blogum::UserLog",
      > PerlOptions => "+ParseHeaders",
      > Allow => "from all",
      > };
      > </Perl>
      > END
      > Apache->server->add_config([split /\n/, $b_config]);
      > ...
      > In my windows when url pointed to log, the perl handler did the work,
      now in
      > linux i get a "Not Found. The request URL /log was not found on this
      > server".
      > Windows Xp
      > Apache/2.0.48 (Win32) mod_perl/1.99_13-dev Perl/v5.8.2 Server at xxx
      Port 80
      > Suse 9.0
      > Apache/2.0.48 (Unix) mod_perl/1.99_12 Perl/v5.8.1 Server at xxx Port

      Can you try first and upgrade to 1.19_13 so you don't compare apples to

      > NOTE: It's strange as i compiled last mod_perl version some months
      > than last windows ppm, but windows mod_perl version is newer !?
      > ____________ADDED__________________
      > If i put the <Perl>...</Perl> section inside the httpd.conf file then
      > handlers work. Does the archive.pl need some kind of permisions? it
      must be
      > executable or anything?
      > Thanks

      Stas Bekman JAm_pH ------> Just Another mod_perl Hacker
      http://stason.org/ mod_perl Guide ---> http://perl.apache.org
      mailto:stas@... http://use.perl.org http://apacheweek.com
      http://modperlbook.org http://apache.org http://ticketmaster.com

      Report problems: http://perl.apache.org/bugs/
      Mail list info: http://perl.apache.org/maillist/modperl.html
      List etiquette: http://perl.apache.org/maillist/email-etiquette.html
    Your message has been successfully submitted and would be delivered to recipients shortly.