Loading ...
Sorry, an error occurred while loading the content.

Re: Apache-Cookie

Expand Messages
  • Randy Kobes
    ... With a slightly different configuration (Apache/2.0.48, current cvs mod_perl, Perl/5.8.3) on Win32, I don t have any fundamental problems. A few things to
    Message 1 of 6 , Mar 1, 2004
    View Source
    • 0 Attachment
      On Mon, 1 Mar 2004, Carl Holm wrote:

      > Hello,
      >
      > With the following server environment: SERVER_SOFTWARE =
      > "Apache/2.0.47 (Win32) mod_perl/1.99_10-dev Perl/v5.8.0
      > PHP/4.3.2", and libapreq2 installed via PPM, I am not able
      > to load Apache::Cookie. I would appreciate hearing about
      > any success with this configuration.

      With a slightly different configuration (Apache/2.0.48,
      current cvs mod_perl, Perl/5.8.3) on Win32, I don't have
      any fundamental problems. A few things to check:
      - Is there anything in Apache's error log?
      - Do you have similar problems with Apache::Request?
      - Does a directive
      LoadFile "/Path/to/libapreq2.dll"
      in httpd.conf help?
      - Does mod_perl 2 work OK?

      --
      best regards,
      randy kobes

      --
      Report problems: http://perl.apache.org/bugs/
      Mail list info: http://perl.apache.org/maillist/modperl.html
      List etiquette: http://perl.apache.org/maillist/email-etiquette.html
    • Carl Holm
      ... Thanks for the suggestions. Mod-perl2 works OK. No complaints from Apache::Request. I added the appropriate LoadFile directive, and now get the following
      Message 2 of 6 , Mar 1, 2004
      View Source
      • 0 Attachment
        Randy Kobes wrote:

        >On Mon, 1 Mar 2004, Carl Holm wrote:
        >
        >
        >
        >>Hello,
        >>
        >>With the following server environment: SERVER_SOFTWARE =
        >>"Apache/2.0.47 (Win32) mod_perl/1.99_10-dev Perl/v5.8.0
        >>PHP/4.3.2", and libapreq2 installed via PPM, I am not able
        >>to load Apache::Cookie. I would appreciate hearing about
        >>any success with this configuration.
        >>
        >>
        >
        >With a slightly different configuration (Apache/2.0.48,
        >current cvs mod_perl, Perl/5.8.3) on Win32, I don't have
        >any fundamental problems. A few things to check:
        >- Is there anything in Apache's error log?
        >- Do you have similar problems with Apache::Request?
        >- Does a directive
        > LoadFile "/Path/to/libapreq2.dll"
        >in httpd.conf help?
        >- Does mod_perl 2 work OK?
        >
        >
        >
        Thanks for the suggestions. Mod-perl2 works OK. No complaints from
        Apache::Request. I added the appropriate LoadFile directive, and now get
        the following error stack:

        [Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] Can't load
        'C:/Perl/site/lib/Apache2/auto/APR/Table/Table.dll' for module
        APR::Table: load_file:The specified module could not be found at
        C:/Perl/lib/DynaLoader.pm line 229., referer:
        http://localhost/Maspages/mk.html
        [Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] at
        C:/Perl/site/lib/APR/XSLoader.pm line 16, referer:
        http://localhost/Maspages/mk.html
        [Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] Compilation failed
        in require at C:/Perl/site/lib/Apache/Cookie.pm line 47., referer:
        http://localhost/Maspages/mk.html
        [Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] BEGIN
        failed--compilation aborted at C:/Perl/site/lib/Apache/Cookie.pm line
        47., referer: http://localhost/Maspages/mk.html
        [Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] Compilation failed
        in require at C:\Program Files\Apache Group\Apache2\cgi-bin\sess.pl line
        7., referer: http://localhost/Maspages/mk.html
        [Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] BEGIN
        failed--compilation aborted at C:\Program Files\Apache
        Group\Apache2\cgi-bin\sess.pl line 7., referer:
        http://localhost/Maspages/mk.html

        Regards,

        Carl Holm



        --
        Report problems: http://perl.apache.org/bugs/
        Mail list info: http://perl.apache.org/maillist/modperl.html
        List etiquette: http://perl.apache.org/maillist/email-etiquette.html
      • Randy Kobes
        On Mon, 1 Mar 2004, Carl Holm wrote: [ ... ] ... Just to verify - do you also have LoadModule apreq_module modules/mod_apreq.so LoadModule perl_module
        Message 3 of 6 , Mar 1, 2004
        View Source
        • 0 Attachment
          On Mon, 1 Mar 2004, Carl Holm wrote:

          [ ... ]
          > Thanks for the suggestions. Mod-perl2 works OK. No complaints from
          > Apache::Request. I added the appropriate LoadFile directive, and now get
          > the following error stack:
          >
          > [Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] Can't load
          > 'C:/Perl/site/lib/Apache2/auto/APR/Table/Table.dll' for module
          > APR::Table: load_file:The specified module could not be found at
          > C:/Perl/lib/DynaLoader.pm line 229., referer:
          > http://localhost/Maspages/mk.html

          Just to verify - do you also have
          LoadModule apreq_module modules/mod_apreq.so
          LoadModule perl_module modules/mod_perl.so
          somewhere in httpd.conf?

          --
          best regards,
          randy

          --
          Report problems: http://perl.apache.org/bugs/
          Mail list info: http://perl.apache.org/maillist/modperl.html
          List etiquette: http://perl.apache.org/maillist/email-etiquette.html
        • Carl Holm
          ... Yes, those directives are in place. -- Report problems: http://perl.apache.org/bugs/ Mail list info: http://perl.apache.org/maillist/modperl.html List
          Message 4 of 6 , Mar 2, 2004
          View Source
          • 0 Attachment
            Randy Kobes wrote:

            >On Mon, 1 Mar 2004, Carl Holm wrote:
            >
            >[ ... ]
            >
            >
            >>Thanks for the suggestions. Mod-perl2 works OK. No complaints from
            >>Apache::Request. I added the appropriate LoadFile directive, and now get
            >>the following error stack:
            >>
            >>[Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] Can't load
            >>'C:/Perl/site/lib/Apache2/auto/APR/Table/Table.dll' for module
            >>APR::Table: load_file:The specified module could not be found at
            >>C:/Perl/lib/DynaLoader.pm line 229., referer:
            >>http://localhost/Maspages/mk.html
            >>
            >>
            >
            >Just to verify - do you also have
            > LoadModule apreq_module modules/mod_apreq.so
            > LoadModule perl_module modules/mod_perl.so
            >somewhere in httpd.conf?
            >
            >
            >
            Yes, those directives are in place.




            --
            Report problems: http://perl.apache.org/bugs/
            Mail list info: http://perl.apache.org/maillist/modperl.html
            List etiquette: http://perl.apache.org/maillist/email-etiquette.html
          • Randy Kobes
            ... Do you get the same error by having just a use Apache2; use Apache::Cookie; in a registry script, or minimal handler, without any other Apache modules
            Message 5 of 6 , Mar 3, 2004
            View Source
            • 0 Attachment
              On Tue, 2 Mar 2004, Carl Holm wrote:

              > Randy Kobes wrote:
              >
              > >On Mon, 1 Mar 2004, Carl Holm wrote:
              > >
              > >[ ... ]
              > >
              > >>Thanks for the suggestions. Mod-perl2 works OK. No complaints from
              > >>Apache::Request. I added the appropriate LoadFile directive, and now get
              > >>the following error stack:
              > >>
              > >>[Mon Mar 01 18:05:33 2004] [error] [client 127.0.0.1] Can't load
              > >>'C:/Perl/site/lib/Apache2/auto/APR/Table/Table.dll' for module
              > >>APR::Table: load_file:The specified module could not be found at
              > >>C:/Perl/lib/DynaLoader.pm line 229., referer:
              > >>http://localhost/Maspages/mk.html
              > >>
              > >
              > >Just to verify - do you also have
              > > LoadModule apreq_module modules/mod_apreq.so
              > > LoadModule perl_module modules/mod_perl.so
              > >somewhere in httpd.conf?
              > >
              > Yes, those directives are in place.

              Do you get the same error by having just a
              use Apache2;
              use Apache::Cookie;
              in a registry script, or minimal handler, without any other
              Apache modules loaded, even in a startup script? If so, what
              I'd suggest next is to upgrade mod_perl - you're running
              version 1.99_10, and the current ppm version at
              http://theoryx5.uwinnipeg.ca/ppms/ is 1.99_12. Make sure in
              the upgrade that the mod_perl.so under $APACHE2/modules also
              gets upgraded.

              --
              best regards,
              randy

              --
              Report problems: http://perl.apache.org/bugs/
              Mail list info: http://perl.apache.org/maillist/modperl.html
              List etiquette: http://perl.apache.org/maillist/email-etiquette.html
            Your message has been successfully submitted and would be delivered to recipients shortly.