Loading ...
Sorry, an error occurred while loading the content.

Porting 1.x -> 2.x, some weird results

Expand Messages
  • Andrew Maltsev
    Here is the setup: mod_perl2: redhat 9, mod_perl-1.99_07-5 rpm, httpd-2.0.40-21.5 rpm, perl 5.8.0, pre-fork mpm. mod_perl1: redhat 7.1, mod_perl 1.26, httpd
    Message 1 of 2 , Dec 1, 2003
    • 0 Attachment
      Here is the setup:

      mod_perl2: redhat 9, mod_perl-1.99_07-5 rpm, httpd-2.0.40-21.5 rpm,
      perl 5.8.0, pre-fork mpm.

      mod_perl1: redhat 7.1, mod_perl 1.26, httpd 1.3.22, perl 5.6.1.

      I am having some problems porting an application from mod_perl1 to
      mod_perl2.

      The application installs a PerlTransHandler that might decide to install
      a Perl{Response}Handler to build some dynamic content later on.

      In mod_perl2 if I return OK from the Trans handler the content handler
      is never called. If I return DECLINED it works fine.

      In mod_perl1 if I return OK it works fine, if I return DECLINED it
      attempts to parse the real disk file by URL and if that leads to a
      subrequest (shtml file with #include) again, my content handler is never
      called and the disk file's content is returned.

      Is that a deliberate incompatibility or do I miss something here?

      What is the right way to do the task?

      I can post some code snippets if it'll help.


      Thanx!

      Andrew.

      --
      Reporting bugs: http://perl.apache.org/bugs/
      Mail list info: http://perl.apache.org/maillist/modperl.html
    • Stas Bekman
      ... Please upgrade to mod_perl 1.99_11 and httpd 2.0.46 or higher. ... If the problem still persists, please submit a complete bug report as explained at
      Message 2 of 2 , Dec 1, 2003
      • 0 Attachment
        Andrew Maltsev wrote:
        > Here is the setup:
        >
        > mod_perl2: redhat 9, mod_perl-1.99_07-5 rpm, httpd-2.0.40-21.5 rpm,
        > perl 5.8.0, pre-fork mpm.

        Please upgrade to mod_perl 1.99_11 and httpd 2.0.46 or higher.

        > I can post some code snippets if it'll help.

        If the problem still persists, please submit a complete bug report as
        explained at http://perl.apache.org/bugs/ and a small test we can reproduce
        the problem with.


        __________________________________________________________________
        Stas Bekman JAm_pH ------> Just Another mod_perl Hacker
        http://stason.org/ mod_perl Guide ---> http://perl.apache.org
        mailto:stas@... http://use.perl.org http://apacheweek.com
        http://modperlbook.org http://apache.org http://ticketmaster.com


        --
        Reporting bugs: http://perl.apache.org/bugs/
        Mail list info: http://perl.apache.org/maillist/modperl.html
      Your message has been successfully submitted and would be delivered to recipients shortly.