Loading ...
Sorry, an error occurred while loading the content.

Re: mod_perl install error when attempting to "make"

Expand Messages
  • Stas Bekman
    [please remember to reply back to the list, and not to the person who answered your question. Thanks] ... So why not upgrade to 2.0.47 (2.0.48 should be out
    Message 1 of 3 , Oct 27, 2003
    • 0 Attachment
      [please remember to reply back to the list, and not to the person who answered
      your question. Thanks]

      Lanny Derby wrote:
      > Thank you... i think...
      >
      > I am using mod_perl-1.99_09 because anything beyond that (i.e. mod
      > perl-1.99_10)
      > requires apache 2.0.46 or greater and I am running apache 2.0.45.

      So why not upgrade to 2.0.47 (2.0.48 should be out shortly). Why wasting time
      and suffering from problems that were fixed already. httpd-2.0.45 has bugs as
      well.

      > I went to
      > the page that you sent me the link to and it didn't refer to a "patch". I
      > apologize if I am missing something here, but if there is a patch there, i'm
      > not sure how to apply it. I would greatly appreciate further instructions.
      > Thanks in advance.

      Save it in a file mypath and then run:

      cd modperl-1.99_09/lib/Apache
      patch -p0 < mypatch

      Alternatively, since it's one line change you can do it manually. i.e. add:

      $mm->init_main;

      before

      $mm->init_others;

      in modperl-1.99_09/lib/Apache/Build.pm somewhere around line 1074.

      __________________________________________________________________
      Stas Bekman JAm_pH ------> Just Another mod_perl Hacker
      http://stason.org/ mod_perl Guide ---> http://perl.apache.org
      mailto:stas@... http://use.perl.org http://apacheweek.com
      http://modperlbook.org http://apache.org http://ticketmaster.com
    Your message has been successfully submitted and would be delivered to recipients shortly.