Loading ...
Sorry, an error occurred while loading the content.

Re: Stupid question of the day...

Expand Messages
  • Shannon Eric Peevey
    ... Feel free to contact me, as well. I have contacted the author about porting the module, and if I can use you as a test environment, I can this ported
    Message 1 of 3 , Jun 29, 2003
    • 0 Attachment
      Randy Kobes wrote:

      >On Wed, 25 Jun 2003 cwh0803@... wrote:
      >
      >
      >
      >>I've built and installed a new Apache (2.0.46) with mod_ssl and
      >>mod_perl... My goal is authentication via NIS, so I have the
      >>following in an .htaccess file:
      >>
      >>AuthName TEST
      >>AuthType Basic
      >>PerlAuthenHandler Apache::AuthenNIS;
      >>require valid-user
      >>
      >>My efforts, however, have been thwarted by the following error message:
      >>
      >>Wed Jun 25 15:44:54 2003] [error] failed to resolve handler
      >>`Apache::AuthenNIS;' [Wed Jun 25 15:44:55 2003] [error] [client
      >>xxx.xxx.xxx.xxx] Can't locate object method "boot" via package
      >>"mod_perl::boot" at /opt/apache/lib/perl/Apache/Constants.pm
      >>line 8. Compilation failed in require at
      >>/opt/apache/lib/perl/Apache/AuthenNIS.pm line 4. BEGIN
      >>failed--compilation aborted at
      >>/opt/apache/lib/perl/Apache/AuthenNIS.pm line 4. Compilation
      >>failed in require at (eval 6) line 1.
      >>
      >>
      >
      >Apache::Constants is a mod_perl 1 package, whereas you're using
      >mod_perl 2 (for Apache 2). If use of Apache::compat isn't enough
      >to get this working, some porting of the module may be required -
      >see the discussion of porting Apache Perl modules from mod_perl 1
      >to 2 at http://perl.apache.org/.
      >
      >
      >
      Feel free to contact me, as well. I have contacted the author about
      porting the module, and if I can use you as a test environment, I can
      this ported rather quickly :) (I don't have a NIS environment for me to
      test on, but I can make the changes, and you can test the install for
      me, and then we can get this mod to work for both versions of modperl...)

      Anyone have an installation of apache 1 that is using NIS for
      authentication? (I will need to be able to test the ported mod for
      compatibility with modperl 1, as well.)

      speeves
      cws

      PS We should probably attack Apache::AuthzNIS at the same time... It
      isn't much more work :)
    Your message has been successfully submitted and would be delivered to recipients shortly.