Loading ...
Sorry, an error occurred while loading the content.

Re: Newbie Problems

Expand Messages
  • Stas Bekman
    ... Ah, similar to header_out, header_in, err_header_out the old API is not supported in 2.0 (the method name is the same though). I ve committed a wrapper
    Message 1 of 1 , Apr 11, 2003
    • 0 Attachment
      Stas Bekman wrote:
      > Geoffrey Young wrote:
      > >
      > >
      > > Perrin Harkins wrote:
      > >
      > >> Alan Wilson wrote:
      > >>
      > >>> Line 95 is:
      > >>>
      > >>> $r->notes($imap_username . 'Group', $group);
      >
      > It looks like a bug. Let me ponder on it.

      Ah, similar to header_out, header_in, err_header_out the old API is not
      supported in 2.0 (the method name is the same though). I've committed a
      wrapper that will work as in mp1 with Apache::compat loaded. The compat docs
      are now updated.

      So either use Apache::compat with the latest cvs, or use the new API, which is
      supported by mp1 as well. You get the APR::Table object and then you can call
      methods on it, or use it's tied hash interface. See:
      http://perl.apache.org/docs/2.0/api/APR/Table.html


      __________________________________________________________________
      Stas Bekman JAm_pH ------> Just Another mod_perl Hacker
      http://stason.org/ mod_perl Guide ---> http://perl.apache.org
      mailto:stas@... http://use.perl.org http://apacheweek.com
      http://modperlbook.org http://apache.org http://ticketmaster.com
    Your message has been successfully submitted and would be delivered to recipients shortly.