Loading ...
Sorry, an error occurred while loading the content.

65797Re: Apache2 namespace

Expand Messages
  • Jim Albert
    Jul 5, 2005
    • 0 Attachment
      Philip M. Gollucci wrote:

      > Hmmm.... seems like the example on that page relies on
      >> use mod_perl;
      >> to get $mod_perl::VERSION
      >> However, mod_perl.pm has changed to mod_perl2.pm in the newer version
      >> of mod_perl that's now on my system, so it doesn't appear that the
      >> example at
      >> http://perl.apache.org/docs/2.0/user/porting/compat.html#mod_perl_1_0_and_2_0_Constants_Coexistence
      >> solves this particular problem.
      > s/mod_perl/mod_perl2/g

      Correct, that will change mod_perl to mod_perl2 in my source, but my
      point was that it won't help in the case of attempting to maintain one
      code base (my code) in terms of whether to include modules from the
      Apache:: or Apache2:: namespace. Perhaps the exsitence of and the
      particular value of $ENV{MOD_PERL_API_VERSION} might be better suited.

      Jim Albert
    • Show all 9 messages in this topic