Loading ...
Sorry, an error occurred while loading the content.
 

MEW Subscription

Expand Messages
  • dnaman43
    Is anyone in North America having trouble with their EWA subscription to Model Engineer s Workshop (or Model Engineer, I guess)? Has anyone received Issue #156
    Message 1 of 37 , Dec 2, 2009
      Is anyone in North America having trouble with their EWA subscription to Model Engineer's Workshop (or Model Engineer, I guess)? Has anyone received Issue #156 or later issues?

      I haven't yet received Issue #156 which EWA maintains they mailed on October 21. When I queried it with EWA, at first I could get no response, then (after emailing every one of the multiple addresses I have for them) they responded with:

      "Hello - the new contact for this magazine is

      expsmag@...   or 1 877 363 1310

      They will be able to help you."

      No further explanation. Frankly, if the distributor has changed, I would have thought that it was obligatory (not to mention a courtesy) to inform the subscribers.

      So apparently EWA is no longer in the business of supplying this (and presumably other) magazines. (Whether EWA is in business at all is anyone's guess given their lack of explanation). Experienced readers will remember the previous Wise-Owl and Magicalia fiascos. Are we into yet another of these?



    • William Rutiser
      ... My ME and MEW subscriptions and back issues have also started to arrive. I also got a letter announcing the change of distributors. It referred to Model
      Message 37 of 37 , Jan 20, 2010
        Dave Hylands wrote:
        > Hi,
        >
        > On Wed, Dec 2, 2009 at 8:08 AM, dnaman43 <mevagissy@...> wrote:
        >
        >> Is anyone in North America having trouble with their EWA subscription to Model Engineer's Workshop (or Model Engineer, I guess)? Has anyone received Issue #156 or later issues?
        >>
        >
        > I finally got my issues #157 and #158 (Jan 19, 2010).
        >
        > I noticed that the mailing address was wrong (I'm in Canada). They got
        > the postal code right, but the street address was missing the number,
        > and had the street type in front of the street name. Just thought I'd
        > mention it - you should double check your address label to make sure
        > it's right and give them a call to correct it if it isn't.
        >
        > They also sent me French correspondence - so they've changed my
        > account to English.
        >
        >
        My ME and MEW subscriptions and back issues have also started to arrive.
        I also got a letter announcing the change of distributors. It referred
        to "Model Engineers" (sic) magazine.

        -- Bill
      Your message has been successfully submitted and would be delivered to recipients shortly.