Loading ...
Sorry, an error occurred while loading the content.

Question about PDP 11/40

Expand Messages
  • B. Degnan
    For those who know about PDP 11/40 s This project had been on the back burner, but I thought I d mess with it this week. I have been able to write and read
    Message 1 of 1 , Jun 1, 2008
      For those who know about PDP 11/40's

      This project had been on the back burner, but I thought I'd mess with it this week.  I have been able to write and read back memory using the console.  I have also been able to run a "chase the lights" program.  System is working as it was originally when I got it and it's in a nice air conditioned environment.   I have been working on a memory map.  I assume emply RAM locations are identified with a FFF FFF FFF FFF / 000 000 000 000 pattern as I walk up the memory.  The switch register is present at  777 570.

      Here is what I have installed:

      CARD               SLOT               POSTITION

      empty              1                  --       (IF PRESENT WOULD BE USED FOR A 7239)
      empty              2                  --        (IF PRESENT WOULD BE USED FOR A 7298)
      7232               3                  A-F       (U WORD)
      7231               4                  A-F       (DATA PATHS)
      7233               5                  A-F       (IR DECODE)
      7235               6                  A-F       (STATUS)
      7236               7                  A-F       (TIMING)
      7236               8                  A-F      (MEMORY MANAGER)
      672A               9                  D         (GRANT CONT.)
      UNIBUS    9                  A-B       (RIGHT SIDE OF UNIBUS)
      UNIBUS    10                 A-B       (LEFT SIDE OF UNIBUS)
      M7856     10                 F-C       (RS232 WITH 19.2 OPTION?)
      G7273              11                 C-D
      7891               12                 A-F       (64k MEMORY)
      M9312     13                 A-B       (ROM CARD)
      672A               13                 D         (GRANT CONT.)

      Help needed:
      Things are slow because the original 8K core has been upgraded with a 64K board.  I am not sure if the core is bypassed or supplemented, but I assume the former.  This means that my "stock" docs about the 11/40 are not very useful.  To make it a little harder, the 11/40 docs refer to the LA30 DecWriter but I have a newer LA36 Decwriter II terminal that has in turn been upgraded from 300 baud to 1200 (according to a sticker).  I am flying a bit blind here.

      With all that in mind I wish to explore the terminal interface using the M7856.  I don't have the M7856, 7891, or M9312 docs (still trying to find).  I have the original bootstrap ROM that came with the M9312 still present as it was originally, and the seller of the system was able to get to a "  @  " prompt with it.  I was told to load the address 165144 to activate the terminal bootstrap, but when I examine this location, nothing appears to be loaded into memory (just blank RAM: FFF FFF FFF FFF/ 000 000 000 000 etc.) at 165144. When I attempt to activate the ROM (halt, load address 165144, depress enable, and then start).  There is no change to the data in memory location 165144.  Is there someplace else I should be looking?   Should it be 765144 because of the memory management card (7236)?  Whatever the case I do not get a response from the "terminal".  I understand from my notes of my conversation with the seller that to use the LA 36 DecWriter II with this particular 11/40 I will have to change the baud rate jumpers or switches on the M7856 from 19.2K to a lower setting for the terminal.  So, for the time being I am using a computer with the windows terminal program set for VT 52, 7 bits no parity, and 19.2K baud because I believe that's what it's set for.  I have also tried other settings such as 8 bits no parity, VT 100, etc.  I am confident that the computer running the terminal program is looking at the correct COM port.  Knowing what I know, I would not expect any terminal output yet anyway because there is no program loaded, yes?

      I have worked hard to find answers and docs on my own, but I am at a stand still at the moment.  Any tips you may have would be appreciated. 

      NOTE: There's a note on the DEC terminal to indicate that it was upgraded to 1200.  In local mode the DEC terminal works OK. 

      In the meantime, I will toggle one memory location at a time to map out the 64K in search for code/data.

      Bill Degnan

    Your message has been successfully submitted and would be delivered to recipients shortly.