Loading ...
Sorry, an error occurred while loading the content.

Re: [midatlanticretro] Altair 680 Project Update

Expand Messages
  • B. Degnan
    thanks Dan. I will keep you posted of my progress. Bill
    Message 1 of 48 , Mar 4, 2007
    • 0 Attachment
      thanks Dan. I will keep you posted of my progress.
      Bill

      At 01:51 PM 3/4/2007 -0500, you wrote:

      >well, if you ever need any online tech support, I usually have yahoo IM
      >running in the back here, "rog5673495" and can go thru the schematics as
      >you scope the signals. A webcam helps sometimes to see the signals from
      >here too. It wouldnt be the first time I had to troubleshoot remotely.
      >
      >=Dan
      >
      >[ My Corner of Cyberspace http://ragooman.home.comcast.net/ ]
      >
      >
      >
      >B. Degnan wrote:
      > >
      > > Good and bad then...I don't need the chip, but now I don't know why the
      > > system is not communicating to the terminal. I will return to my original
      > > plan, to put a scope to the system to try to find what's happens when I
      > > engage the monitor program (@ FF02). I have what appears to be a working
      > > monitor prom, at least the memory checks out with the prom code to the
      > > best
      > > of my knowledge.
      > >
      > > I know that Herb Johnson has some ADM terminals for sale, or at least he
      > > did last year..
      > > Bill
      > >
      > > At 02:38 PM 3/3/2007 -0500, you wrote:
      > > >Bill,
      > > >
      > > >That schematic is for the front panel on the 680b, they called it the
      > > >"Display" panel, sheet 4/4 of the schematics. All the LD1 to LD 27
      > > >diodes are actually the LEDs on there--LD for _L_ight emitting _D_iode--
      > > >
      > > >So for the 680b model, IC L is not needed for RS232, you can see on that
      > > >schematic I scanned that the 6850 ACIA pins TX and RX are connected to
      > > >the RS232 Level converter circuit using IC A, Q200, D200 and a few
      > > >resistors. While the Baudot interface with IC L acutally bit bangs the
      > > >baudot code out the connector.
      > > >
      > > >Also on the 680b--in the Assy manual--, the ACIA monitor fits in socket
      > > >IC T while the other option back then was to order the 2 Baudot monitor
      > > >Eproms which fit in sockets IC T and U. You said that your ordered the
      > > >ACIA monitor eprom, right ?
      > > >
      > > >MITS obviously went through a big rev change to make the 680b. I've
      > > >never had seen the Altair 680 up close, just the 680b.
      > > >
      > > >If they dont have the 680b schematics on there, I can scan mine this
      > > >weekend. I can also scan the assembly doc --it'll take a while--which
      > > >shows how to configure all the jumpers and components options--you'll
      > > >have to excuse my notes that I scribbled on there--
      > > >
      > > >Funny you should ask about the I/O on mine, it's still wired for an ASR
      > > >:) since we had access to a teletype back then. Mine works, but I'm only
      > > >using the front panel right now. I'm in the middle of restoring the chip
      > > >sockets 'cause they're getting old and flakey. Once I do that, I was
      > > >going to switch it to RS232 and use my PC to get BASIC running on
      > > this too.
      > > >
      > > >If I'm lucky I can find a ADM terminal real cheap to sit beside this. I
      > > >have my H9 terminal which belongs to my Heathkit H8, but it just doesn't
      > > >match.
      > > >
      > > >=Dan
      > > >
      > > >[ My Corner of Cyberspace http://ragooman.home.comcast.net/
      > > <http://ragooman.home.comcast.net/> ]
      > > >
      > > >
      > > >
      > > >B. Degnan wrote:
      > > > >
      > > > > Dan,
      > > > > I re-read your pages and the manuals I have. Frankly it's confusing.
      > > > >
      > > > > Here is how I interpret what I have read:
      > > > >
      > > > >
      > > http://ragooman.home.comcast.net/files/vintage/altair/assypg16sm.pdf
      > > <http://ragooman.home.comcast.net/files/vintage/altair/assypg16sm.pdf>
      > > > >
      > > <http://ragooman.home.comcast.net/files/vintage/altair/assypg16sm.pdf >
      > <http://ragooman.home.comcast.net/files/vintage/altair/assypg16sm.pdf>>
      > > > > ...seems to indicate that only If I am using a baudout TT I need the
      > > > > 74LS74
      > > > > chip in the L slot, otherwise no IC is needed in IC L.
      > > > >
      > > > > ...but then...
      > > > >
      > > > > Take a look at page 17 of 37:
      > > > >
      > > >
      > >
      > http://www.vintagecomputer.net/MITS/680/MITS_Altair_680b_Theory_of_Operation_Manual.pdf
      >
      > >
      > <http://www.vintagecomputer.net/MITS/680/MITS_Altair_680b_Theory_of_Operation_Manual.pdf>
      >
      > >
      > > >
      > > > >
      > > >
      > >
      > <http://www.vintagecomputer.net/MITS/680/MITS_Altair_680b_Theory_of_Operation_Manual.pdf
      > >
      > <http://www.vintagecomputer.net/MITS/680/MITS_Altair_680b_Theory_of_Operation_Manual.pdf>>
      > > > >
      > > > > How do you interpret this? This is my source for why I think that the
      > > > > 74L123 is needed in slot L.
      > > > >
      > > > > Questions:
      > > > > 1) Do I need *any* chip in the L slot?
      > > > > 2) Do you have a working system that uses a terminal? If you have a
      > > > > working system than I would like to try to match your configuration,
      > > > > being
      > > > > that it works! Schematics confuse me.
      > > > > How does your motherboard I/O circuitry compare with mine?
      > > > > http://vintagecomputer.net/MITS/680/pictures.html
      > > <http://vintagecomputer.net/MITS/680/pictures.html>
      > > > > <http://vintagecomputer.net/MITS/680/pictures.html >
      > <http://vintagecomputer.net/MITS/680/pictures.html>>
      > > > >
      > > > > Thanks very much.
      > > > >
      > > > > Bill
      > > > >
      > > > > At 06:36 PM 3/2/2007 -0500, you wrote:
      > > > >
      > > > > >Well, it seems very odd that with the same rev1-6X motherboard
      > > that MITS
      > > > > >would use two different IC's. I checked your pics of the
      > > motherboard and
      > > > > >its the same as mine. I also have the round toggle switches on mine.
      > > > > >Have you check the Assembly doc PDF's I posted online to compare ?
      > > > > >
      > > > > >All I remember is that the 680 had a front panel with a different
      > > color,
      > > > > >aside from a different rev motherboard too I suppose. I recall
      > > seeing a
      > > > > >pic online somewhere but I don't seem to have that bookmark.
      > > > > >
      > > > > >I posted sheet 2(rt.half) from my schematics showing IC L being a
      > > > > >74LS74, the pinouts checkout accordingly.
      > > > > >http://ragooman.home.comcast.net/computers_altair680.html
      > > <http://ragooman.home.comcast.net/computers_altair680.html>
      > > > > <http://ragooman.home.comcast.net/computers_altair680.html >
      > <http://ragooman.home.comcast.net/computers_altair680.html>>
      > > > > >
      > > > > >=Dan
      > > > > >
      > > > > >[ My Corner of Cyberspace http://ragooman.home.comcast.net/
      > > <http://ragooman.home.comcast.net/>
      > > > > <http://ragooman.home.comcast.net/ >
      > <http://ragooman.home.comcast.net/>> ]
      > > > >
      > > > >
      > > > > ----------------------------------------------------------
      > > > >
      > > > > No virus found in this incoming message.
      > > > > Checked by AVG Free Edition.
      > > > > Version: 7.5.446 / Virus Database: 268.18.6/708 - Release Date:
      > > > 3/2/2007 4:19 PM
      > > > >
      > > >
      > > >
      > > >
      > > >
      > > >Yahoo! Groups Links
      > > >
      > > >
      > > >
      > >
      > >
      > > ------------------------------------------------------------------------
      > >
      > > No virus found in this incoming message.
      > > Checked by AVG Free Edition.
      > > Version: 7.5.446 / Virus Database: 268.18.6/709 - Release Date:
      > 3/3/2007 8:12 AM
      > >
      >
      >
      >
      >
      >Yahoo! Groups Links
      >
      >
      >
    • Evan Koblentz
      DG Eclipse S/140 from a couple of months ago, now on display in our museum, next to Perkin-Elmer 3120.
      Message 48 of 48 , Mar 20, 2011
      • 0 Attachment
        DG Eclipse S/140 from a couple of months ago, now on display in our museum, next to Perkin-Elmer 3120.
      Your message has been successfully submitted and would be delivered to recipients shortly.