Loading ...
Sorry, an error occurred while loading the content.
 

Re: [midatlanticretro] May 18th-19th event

Expand Messages
  • David Gesswein
    ... I had at least one hopefully quick MARCH repair but otherwise the plan was if people wanted my help to help them otherwise work on a MARCH computer. I like
    Message 1 of 13 , Apr 26, 2013
      On Fri, Apr 26, 2013 at 02:01:57PM -0400, David Riley wrote:
      > I was considering bringing my TS05 tape drive (re-badged Cipher F880)
      > which is misbehaving, since it seemed like it would be a fun project.
      > It works most of the way, but there are a few things that are probably
      > power-supply related (and probably fixable with new filter caps) that
      > bear looking into, but I'm not super-experienced with fixing tape
      > drives. Is that within the range of what we were thinking, or is it
      > more fixing MARCH stuff? I'm fine with whatever.
      >
      I had at least one hopefully quick MARCH repair but otherwise the
      plan was if people wanted my help to help them otherwise work on a MARCH
      computer. I like to have a plan though it doesn't all have to be resolved
      now.

      I have repaired an earlier model.
      http://www.pdp8online.com/tu10/tu10-repair.shtml


      > Fixing the power supply would, of course, require someone to have the
      > proper spare caps, but a proper collaborative diagnosis would help.
      >
      > For all relevant projects, I can bring a scope, a 10A power supply,
      > a 20 MHz waveform generator and a decent meter (Fluke 87-V). The
      > scope is 4 channels, 100 MHz bandwidth. Would that be helpful?
      > They'd be there for anyone to use, though I think I might only be
      > able to be there one day (I'll have to see).
      >
      It sound like you have the tools to verify the power supply. The two
      failure modes I see are wrong voltage or too much ripple. We could
      help you test if your not familiar how or you could test and get the parts
      ahead of time.

      Proper prep will make it more productive. Rounding up the service manuals etc
      would be good. What is the problem you are seeing and do you need a
      computer or does it happen in offline mode?

      I'll be their Saturday around lunch and leave whenever Sunday.
    • David Riley
      ... The F880 is a considerably different beast from the TU10. No vacuum columns, etc; it s a pretty basic streamer. DEC sold it as the TS05 but didn t change
      Message 2 of 13 , Apr 26, 2013
        On Apr 26, 2013, at 4:03 PM, David Gesswein <djg@...> wrote:

        > On Fri, Apr 26, 2013 at 02:01:57PM -0400, David Riley wrote:
        > > I was considering bringing my TS05 tape drive (re-badged Cipher F880)
        > > which is misbehaving, since it seemed like it would be a fun project.
        > > It works most of the way, but there are a few things that are probably
        > > power-supply related (and probably fixable with new filter caps) that
        > > bear looking into, but I'm not super-experienced with fixing tape
        > > drives. Is that within the range of what we were thinking, or is it
        > > more fixing MARCH stuff? I'm fine with whatever.
        > >
        > I had at least one hopefully quick MARCH repair but otherwise the
        > plan was if people wanted my help to help them otherwise work on a MARCH
        > computer. I like to have a plan though it doesn't all have to be resolved
        > now.
        >
        > I have repaired an earlier model.
        > http://www.pdp8online.com/tu10/tu10-repair.shtml

        The F880 is a considerably different beast from the TU10. No vacuum
        columns, etc; it's a pretty basic streamer. DEC sold it as the TS05
        but didn't change much except the color of the faceplate and removing
        some options in the Z80 firmware (sigh). The PCB, fortunately, is
        identical to the real thing.

        > > Fixing the power supply would, of course, require someone to have the
        > > proper spare caps, but a proper collaborative diagnosis would help.
        > >
        > > For all relevant projects, I can bring a scope, a 10A power supply,
        > > a 20 MHz waveform generator and a decent meter (Fluke 87-V). The
        > > scope is 4 channels, 100 MHz bandwidth. Would that be helpful?
        > > They'd be there for anyone to use, though I think I might only be
        > > able to be there one day (I'll have to see).
        > >
        > It sound like you have the tools to verify the power supply. The two
        > failure modes I see are wrong voltage or too much ripple. We could
        > help you test if your not familiar how or you could test and get the parts
        > ahead of time.

        I'm familiar with how to debug power supplies, I just haven't had the
        time. I figured having other people around who were more familiar
        with 9-tracks might help, especially since the F880 and cousins were
        pretty popular models. I can bring my PDP-11 in a small, portable
        backplane with a PC power supply and the TSV05 controller card so that
        we can test it out as well; if someone doesn't mind bringing a known
        good tape that will boot on an 11/23 with 256K of RAM, that'd be grand.
        Ideally not something too precious, because I can't guarantee that the
        head doesn't have problems, either. I can bring a blank or otherwise
        reusable tape in case I destroy someone else's; they're some of the
        last Graham magnetics ones that I bought new about 4 years ago and
        didn't realize they were shutting down, or I'd have bought a whole lot
        more of them.

        > Proper prep will make it more productive. Rounding up the service manuals etc
        > would be good. What is the problem you are seeing and do you need a
        > computer or does it happen in offline mode?

        Well, it's a few things.

        1) It's done this since I got it about 4 years ago, but I get a
        tachometer error 80% of the time I load tape, whether I let it
        do the autoload or thread it myself and run the manual override.
        When I run the tachometer test, though, everything looks within
        normal operating parameters, so either I'm reading the service
        manual wrong or something's wrong with part of the tachometer
        circuit that isn't revealed by the tachometer test.

        2) It's started randomly resetting in the past two years or so,
        usually more once it's warmed up some. That's what makes me
        think it's a power supply problem.

        3) Rather recently (the past year or so), it stopped booting
        from tapes which I knew were good on the few occasions I got it
        to behave long enough to try. When I looked at the boot block
        it read in with the "startup" command, it was always either
        zeros or garbage. So either something went off with the heads,
        or it's something to do with the power supply (or the ADCs,
        perhaps).


        I have the operation/maintenance manual which includes the full
        schematic of the drive. I'm printing up a copy of that right
        now to stick in a binder; I'm also printing up a copy of the
        TSV05 controller card manual so we can test with that.

        I have some programs I've written to let me upload binary
        programs to the -11 and SIMH .tap images to the tape drive over
        two serial ports (because I didn't want to deal with mode
        switching from ODT) which run from any Unix command line.
        They've played nicely with my Macbook in the past. The things
        you do when you can't load a proper operating system...

        I can bring my soldering iron if it's necessary, but I figured
        there would be a lot of folks bringing theirs. It's a decent
        Hakko FX-888.


        I can't yet guarantee whether I'll be there on Sunday or not, but
        I'm definitely planning to come up earlyish Saturday. I'll have
        a whole bunch of books and magazines for the library as well. If
        someone wants to help with those (or the 80+ pound tape drive),
        I'd welcome it.


        - Dave
      • Dave McGuire
        ... Earlier is quite the understatement there, Dave. ;) -Dave -- Dave McGuire, AK4HZ New Kensington, PA
        Message 3 of 13 , Apr 26, 2013
          On 04/26/2013 04:03 PM, David Gesswein wrote:
          > On Fri, Apr 26, 2013 at 02:01:57PM -0400, David Riley wrote:
          >> I was considering bringing my TS05 tape drive (re-badged Cipher F880)
          >> which is misbehaving, since it seemed like it would be a fun project.
          >> It works most of the way, but there are a few things that are probably
          >> power-supply related (and probably fixable with new filter caps) that
          >> bear looking into, but I'm not super-experienced with fixing tape
          >> drives. Is that within the range of what we were thinking, or is it
          >> more fixing MARCH stuff? I'm fine with whatever.
          >>
          > I had at least one hopefully quick MARCH repair but otherwise the
          > plan was if people wanted my help to help them otherwise work on a MARCH
          > computer. I like to have a plan though it doesn't all have to be resolved
          > now.
          >
          > I have repaired an earlier model.
          > http://www.pdp8online.com/tu10/tu10-repair.shtml

          "Earlier" is quite the understatement there, Dave. ;)

          -Dave

          --
          Dave McGuire, AK4HZ
          New Kensington, PA
        • David Gesswein
          ... I new the TS were different but haven t actually used one. I am familiar with the nickname TS drives had or was that just for particular models? I have a
          Message 4 of 13 , Apr 26, 2013
            On Fri, Apr 26, 2013 at 06:28:52PM -0400, David Riley wrote:
            >
            > The F880 is a considerably different beast from the TU10. No vacuum
            > columns, etc; it's a pretty basic streamer. DEC sold it as the TS05
            > but didn't change much except the color of the faceplate and removing
            > some options in the Z80 firmware (sigh). The PCB, fortunately, is
            > identical to the real thing.
            >
            I new the TS were different but haven't actually used one. I am familiar
            with the nickname TS drives had or was that just for particular models? I
            have a servo Emerald Systems/Qualstar but I haven't had to do much with it.

            > if someone doesn't mind bringing a known
            > good tape that will boot on an 11/23 with 256K of RAM, that'd be grand.
            >
            I can write 800 and 1600 BPI but I don't have any 11 stuff so know good
            isn't possible.

            > I can bring a blank or otherwise
            > reusable tape in case I destroy someone else's;
            >
            That would be good.

            > 1) It's done this since I got it about 4 years ago, but I get a
            > tachometer error 80% of the time I load tape, whether I let it
            > do the autoload or thread it myself and run the manual override.
            >
            I'll be bringing a 2 channel Rigol digital scope with reasonably deep memory
            which may be useful if your scope is analog.

            > I have some programs I've written to let me upload binary
            > programs to the -11 and SIMH .tap images to the tape drive over
            > two serial ports (because I didn't want to deal with mode
            > switching from ODT) which run from any Unix command line.
            > They've played nicely with my Macbook in the past. The things
            > you do when you can't load a proper operating system...
            >
            I've done similar for my 8's.
            Did they have diagnostics for the drive and do you have a way to run them?
            In the 8 world everything had diagnostics that could be run standalone.
            Not really needed unless the load issue get fixed.

            It sounds like a reasonable plan to see if we can at least identify what
            the drive fault is.
          • David Riley
            ... I don t know about any other TS drives (if there were any, even), but the TS05 is a straight-up Cipher F880, and the TSV05 controller card is a pretty
            Message 5 of 13 , Apr 26, 2013
              On Apr 26, 2013, at 8:39 PM, David Gesswein wrote:

              > I new the TS were different but haven't actually used one. I am familiar
              > with the nickname TS drives had or was that just for particular models? I
              > have a servo Emerald Systems/Qualstar but I haven't had to do much with it.

              I don't know about any other TS drives (if there were any, even), but
              the TS05 is a straight-up Cipher F880, and the TSV05 controller card
              is a pretty straightforward QBUS Pertec controller (I seem to remember
              hearing it was a rebadged Dilog design, but I wouldn't swear to it).
              It's register-compatible with the TS11 controller, with I think a few
              enhancements to it.

              > > if someone doesn't mind bringing a known
              > > good tape that will boot on an 11/23 with 256K of RAM, that'd be grand.
              > >
              > I can write 800 and 1600 BPI but I don't have any 11 stuff so know good
              > isn't possible.

              I know at least some of the members on this list can write -11
              bootable 9-tracks, but I don't know if they're coming. I forgot to
              specify 1600 BPI; that would be ideal. The drive theoretically
              does 800, but I've never tried it, and it doesn't support the
              non-standard 3200 BPI that some of the real F880s did.

              > > 1) It's done this since I got it about 4 years ago, but I get a
              > > tachometer error 80% of the time I load tape, whether I let it
              > > do the autoload or thread it myself and run the manual override.
              > >
              > I'll be bringing a 2 channel Rigol digital scope with reasonably deep memory
              > which may be useful if your scope is analog.

              Definitely. Mine is a Tek 2246, which is perfectly serviceable
              if you don't need any storage. A decent digital scope would go
              a long way.

              > > I have some programs I've written to let me upload binary
              > > programs to the -11 and SIMH .tap images to the tape drive over
              > > two serial ports (because I didn't want to deal with mode
              > > switching from ODT) which run from any Unix command line.
              > > They've played nicely with my Macbook in the past. The things
              > > you do when you can't load a proper operating system...
              > >
              > I've done similar for my 8's.
              > Did they have diagnostics for the drive and do you have a way to run them?
              > In the 8 world everything had diagnostics that could be run standalone.
              > Not really needed unless the load issue get fixed.

              Well, these are all written by me, so no real diagnostics. In
              theory, I could run XXDP, but it's hard to do when the tape
              drive won't run. I could probably load it on a Zip disk from
              Simh and run it from the SCSI card, but that's adding another
              layer of complexity (and the need for a card to sit next to
              the SCSI card in the 4x4 serpentine backplane, so I'd have to
              pull pretty much all the cards out of my VAX... still, could
              be done). I don't think it would reveal much beyond "doesn't
              work", though, since most of the drive-specific diagnostics
              are built into the drive; it actually has a pretty full set
              of diagnostic tests as well as full diagnostic procedures in
              the service manual (most of which end with "replace this big
              chunk of the drive", which was probably more helpful 25 years
              ago than it is now).

              > It sounds like a reasonable plan to see if we can at least identify what
              > the drive fault is.

              Yup. If we can narrow it down, I can always replace the part
              (or parts) responsible on my own time. It's always just the
              inertia of getting it done, and I figure it could be a fun
              project for a weekend. :-)



              - Dave
            • Dave McGuire
              ... It is indeed a re-badged Dilog board. If I m not mistaken, it s a DQ132. ... I can, and will try to come. Dave G sounds like more of a definite though.
              Message 6 of 13 , Apr 26, 2013
                On 04/26/2013 09:15 PM, David Riley wrote:
                >> I new the TS were different but haven't actually used one. I am familiar
                >> with the nickname TS drives had or was that just for particular models? I
                >> have a servo Emerald Systems/Qualstar but I haven't had to do much with it.
                >
                > I don't know about any other TS drives (if there were any, even), but
                > the TS05 is a straight-up Cipher F880, and the TSV05 controller card
                > is a pretty straightforward QBUS Pertec controller (I seem to remember
                > hearing it was a rebadged Dilog design, but I wouldn't swear to it).
                > It's register-compatible with the TS11 controller, with I think a few
                > enhancements to it.

                It is indeed a re-badged Dilog board. If I'm not mistaken, it's a DQ132.

                > I know at least some of the members on this list can write -11
                > bootable 9-tracks, but I don't know if they're coming. I forgot to
                > specify 1600 BPI; that would be ideal. The drive theoretically
                > does 800, but I've never tried it, and it doesn't support the
                > non-standard 3200 BPI that some of the real F880s did.

                I can, and will try to come. Dave G sounds like more of a definite though.

                -Dave

                --
                Dave McGuire, AK4HZ
                New Kensington, PA
              • David Riley
                *sigh* Looks like I forgot a commitment I had on the 18th. So, looks like I ll be there the 19th, then. That might work out a bit better, though, since I can
                Message 7 of 13 , Apr 27, 2013
                  *sigh* Looks like I forgot a commitment I had on the 18th. So, looks like I'll be there the 19th, then. That might work out a bit better, though, since I can be there early-ish (about 9 AM?) on the 19th and it sounds like a lot of folks will already be there.


                  - Dave
                Your message has been successfully submitted and would be delivered to recipients shortly.