Loading ...
Sorry, an error occurred while loading the content.

Re: IMSAI 8080

Expand Messages
  • joshbensadon
    ... Corey, Although I have another priority job, I just couldn t resist starting on this little project. It s like a jig saw puzzle and I can t resist a good
    Message 1 of 61 , Feb 2, 2013
    • 0 Attachment
      --- In midatlanticretro@yahoogroups.com, corey986 wrote:
      >
      > Here are the scans...
      > http://www.myapplecomputer.net/Sol-20/z80_upgrade/index.html
      >

      Corey,

      Although I have another priority job, I just couldn't resist starting on this little project. It's like a jig saw puzzle and I can't resist a good puzzle.

      I was wrong with my first guess about that loose wire...
      It's NOT refresh, but instead it's another feature that the Z80 has which the 8080A never did. It's for the Non-Maskable Interrupt (NMI).
      I guess this NMI would be connected to either a board that monitors for power failure or perhaps a Video board that requires refreshing?

      The 74LS157's are used to double the I/O address on to the upper 8 bits of the address bus. Most 8080 boards decoded A8-A15 for the I/O port, the Z80 doesn't duplicate the I/O address, so this is just 1 of the several mods required to make a Z80 operate the bus like an 8080A.

      It's going to be a harder puzzle to crack because I don't have the board right in front of me (some traces are hidden), but that's ok, I love a good puzzle!

      Cheers,
      Josh
    • DanielB
      Yep, front panel is working good now. One odd thing I have run into is that from the Zapple monitor I can write to the SMB s onboard RAM, but I cannot write to
      Message 61 of 61 , May 14, 2013
      • 0 Attachment
        Yep, front panel is working good now. One odd thing I have run into is that from the Zapple monitor I can write to the SMB's onboard RAM, but I cannot write to the RAM on the memory board but I can write to the memory board from the front panel.

        Dan

        --- In midatlanticretro@yahoogroups.com, joshbensadon <no_reply@...> wrote:
        >
        >
        >
        > --- In midatlanticretro@yahoogroups.com, "DanielB" <danlb_2000@> wrote:
        > >
        > > After bad chips I finally got the front panel working, and after a couple bad tantalum caps on the SMB I also got that working. Very exciting when I got the Zapple monitor prompt!
        > >
        > > https://lh6.googleusercontent.com/-uQShOzInDeE/UZFoWnYYpsI/AAAAAAAACII/80vupyb6Psc/w883-h662-no/IMG_3933.JPG
        > >
        >
        >
        > Daniel,
        >
        > That's looking great! Very well done :)
        >
        > Can you now Examine/Deposit via the front panel?
        >
        > :)J
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.