Loading ...
Sorry, an error occurred while loading the content.

Re: [midatlanticretro] VCF Landenberg .0020

Expand Messages
  • Dan Roganti
    B Degnan wrote: VCF Landenberg .0020 All day Sat April 25 - Sun April 26. S-100 I/O will be the focus. The goal is to bring a few more systems up to the point
    Message 1 of 14 , Apr 20, 2009
    • 0 Attachment


      B Degnan wrote:
      VCF Landenberg .0020
      All day Sat April 25 - Sun April 26.
      
      S-100 I/O will be the focus.  The goal is to bring a few more systems up 
      to the point that they're doing terminal and/or disk I/O.    Testing 
      S-100 cards, identifying drive issues, etc.  Email me with questions.
        

      I'll be there !

      be there or be square_root   --har har har

      =Dan
      [ = http://www2.applegate.org/~ragooman/   ]

    • Mike Loewen
      I ve finally had a few more hours to work on the IMSAI, and things are looking up. After slowly bringing up the electrolytic capacitors in the power supply to
      Message 2 of 14 , Apr 20, 2009
      • 0 Attachment
        I've finally had a few more hours to work on the IMSAI, and things are
        looking up. After slowly bringing up the electrolytic capacitors in the
        power supply to their rated voltage (in stages, monitoring the current), I
        left them sit there for several hours. After bleeding off the charge, I
        put everything back together and powered up the machine with only the
        front panel plugged in. No smoke!

        Next, I plugged in the Cromemco ZPU card, the Fulcrum Omniram 64KB
        static RAM card and the Compupro active terminator card. I tried the
        Deposit and Examine switches, but was getting inconsistent results. After
        some online reading, I decided to disable the Power On Jump (POJ) on the
        ZPU card. Now, the Deposit and Examine switches were working as expected.
        I toggled in a short program, found here:

        http://techtinkering.com/blog/?id=11

        All it does is move an LED back and forth in the Programmed Outputs
        register on the front panel, Cylon-style. You can change the speed by
        turning on the high address switches. It worked:

        http://sturgeon.css.psu.edu/~mloewen/Oldtech/IMSAI/Cylon-S.mp4

        The next step was to insert the Morrow Disk Jockey 2D/B floppy
        controller and connect the dual 8-inch drives and a serial terminal. The
        2D/B has its own POJ logic, which sends the CPU to F800H on reset. No joy
        on booting from diskette, though. From the front panel, I can read the
        jump table at F800H and can follow the program flow. The red LED on the
        2D/B comes on indicating the controller is ready, but the drive select LED
        doesn't pulse as described in the manual. At this point, I ran out of
        time. I'll pick it up later and try to figure out if the drive is
        working.



        Mike Loewen mloewen@...
        Old Technology http://sturgeon.css.psu.edu/~mloewen/Oldtech/
      • Bill Dromgoole
        Good work Mike! Thanks for showing your process and your progress. Bill #3 ... I ve finally had a few more hours to work on the IMSAI, and things are looking
        Message 3 of 14 , Apr 20, 2009
        • 0 Attachment
          Good work Mike!

          Thanks for showing your process and your progress.

          Bill #3

          ----------------------------------------------------------------------------------------------
          I've finally had a few more hours to work on the IMSAI, and things are
          looking up. After slowly bringing up the electrolytic capacitors in the
          power supply to their rated voltage (in stages, monitoring the current), I
          left them sit there for several hours. After bleeding off the charge, I
          put everything back together and powered up the machine with only the
          front panel plugged in. No smoke!

          Next, I plugged in the Cromemco ZPU card, the Fulcrum Omniram 64KB
          static RAM card and the Compupro active terminator card. I tried the
          Deposit and Examine switches, but was getting inconsistent results. After
          some online reading, I decided to disable the Power On Jump (POJ) on the
          ZPU card. Now, the Deposit and Examine switches were working as expected.
          I toggled in a short program, found here:

          http://techtinkering.com/blog/?id=11

          All it does is move an LED back and forth in the Programmed Outputs
          register on the front panel, Cylon-style. You can change the speed by
          turning on the high address switches. It worked:

          http://sturgeon.css.psu.edu/~mloewen/Oldtech/IMSAI/Cylon-S.mp4

          The next step was to insert the Morrow Disk Jockey 2D/B floppy
          controller and connect the dual 8-inch drives and a serial terminal. The
          2D/B has its own POJ logic, which sends the CPU to F800H on reset. No joy
          on booting from diskette, though. From the front panel, I can read the
          jump table at F800H and can follow the program flow. The red LED on the
          2D/B comes on indicating the controller is ready, but the drive select LED
          doesn't pulse as described in the manual. At this point, I ran out of
          time. I'll pick it up later and try to figure out if the drive is
          working.



          Mike Loewen mloewen@...
          Old Technology http://sturgeon.css.psu.edu/~mloewen/Oldtech/


          http://docs.yahoo.com/info/terms/
        • B Degnan
          great news. ... Ah the disk drive issues! Dan and I will be working on this kind of stuff this weekend. Anyone else coming? Bill
          Message 4 of 14 , Apr 21, 2009
          • 0 Attachment
            <snip>

            great news.
            > Now, the Deposit and Examine switches were working as expected.
            > I toggled in a short program, found here:
            >
            > http://techtinkering.com/blog/?id=11
            >
            > All it does is move an LED back and forth in the Programmed Outputs
            > register on the front panel, Cylon-style. You can change the speed by
            > turning on the high address switches. It worked:
            >
            > http://sturgeon.css.psu.edu/~mloewen/Oldtech/IMSAI/Cylon-S.mp4
            >
            > The next step was to insert the Morrow Disk Jockey 2D/B floppy
            > controller and connect the dual 8-inch drives and a serial terminal. The
            > 2D/B has its own POJ logic, which sends the CPU to F800H on reset. No joy
            > on booting from diskette, though. From the front panel, I can read the
            > jump table at F800H and can follow the program flow. The red LED on the
            > 2D/B comes on indicating the controller is ready, but the drive select LED
            > doesn't pulse as described in the manual. At this point, I ran out of
            > time. I'll pick it up later and try to figure out if the drive is
            > working.
            >
            >
            >
            >
            Ah the disk drive issues! Dan and I will be working on this kind of
            stuff this weekend. Anyone else coming?

            Bill
          • Mike Loewen
            ... I wish I could, but I have a gig on Saturday. If anyone could get this thing working, this crew could. Mike Loewen mloewen@cpumagic.scol.pa.us Old
            Message 5 of 14 , Apr 21, 2009
            • 0 Attachment
              On Tue, 21 Apr 2009, B Degnan wrote:

              > Ah the disk drive issues! Dan and I will be working on this kind of
              > stuff this weekend. Anyone else coming?

              I wish I could, but I have a gig on Saturday. If anyone could get this
              thing working, this crew could.


              Mike Loewen mloewen@...
              Old Technology http://sturgeon.css.psu.edu/~mloewen/Oldtech/
            • Dan Roganti
              Mike, Did you have the original manual too ? There s an issue with one of the mods not being documented properly. It s being discussed on cctalk. One of the
              Message 6 of 14 , Apr 21, 2009
              • 0 Attachment
                Mike,

                Did you have the original manual too ?
                There's an issue with one of the mods not being documented properly. It's being discussed on cctalk. One of the diagrams seems to be missing from the pdf files for the CPA section. My manual is original and it only has one of the mods described.  Would yours have any more info about the mods ?

                Here's a snip from the posting on cctalk
                ----------------------------------------------------------------
                The front panel does not work quite right with the combination of CPU and RAM I have in the machine, so I've been debugging various things and have made some decent progress.  Now Examine and Examine Next work properly.  Deposit/Deposit Next, however, do not.

                Reading through the CPA manual I got from http://www.classiccmp.org/dunfield/imsai/cpa.pdf, there's a modification that needs to be done to get the front panel to work with non-IMSAI RAM cards -- this has not been done to my front panel.

                Seems that that might be at least part of the problem.  But step 3 (see pg 26, for those following along at home) refers to Fig 2, referencing points A & B.  Figure 2 is not in the PDF. There is a schematic on page 28 outlining the change, but it's unreadable.
                ----------------------------------------------------------------

                =Dan
                [ = http://www2.applegate.org/~ragooman/   ]


                Mike Loewen wrote:
                    I've finally had a few more hours to work on the IMSAI, and things are 
                looking up.  After slowly bringing up the electrolytic capacitors in the 
                power supply to their rated voltage (in stages, monitoring the current), I 
                left them sit there for several hours.  After bleeding off the charge, I 
                put everything back together and powered up the machine with only the 
                front panel plugged in.  No smoke!
                
                    Next, I plugged in the Cromemco ZPU card, the Fulcrum Omniram 64KB 
                static RAM card and the Compupro active terminator card.  I tried the 
                Deposit and Examine switches, but was getting inconsistent results.  After 
                some online reading, I decided to disable the Power On Jump (POJ) on the 
                ZPU card.  Now, the Deposit and Examine switches were working as expected. 
                I toggled in a short program, found here:
                
                http://techtinkering.com/blog/?id=11
                
                    All it does is move an LED back and forth in the Programmed Outputs 
                register on the front panel, Cylon-style.  You can change the speed by 
                turning on the high address switches.  It worked:
                
                http://sturgeon.css.psu.edu/~mloewen/Oldtech/IMSAI/Cylon-S.mp4
                
                    The next step was to insert the Morrow Disk Jockey 2D/B floppy 
                controller and connect the dual 8-inch drives and a serial terminal.  The 
                2D/B has its own POJ logic, which sends the CPU to F800H on reset.  No joy 
                on booting from diskette, though.  From the front panel, I can read the 
                jump table at F800H and can follow the program flow.  The red LED on the 
                2D/B comes on indicating the controller is ready, but the drive select LED 
                doesn't pulse as described in the manual.  At this point, I ran out of 
                time.  I'll pick it up later and try to figure out if the drive is 
                working.
                
                
                
                Mike Loewen				mloewen@...
                Old Technology	http://sturgeon.css.psu.edu/~mloewen/Oldtech/
                
                
                ------------------------------------
                
                Yahoo! Groups Links
                
                <*> To visit your group on the web, go to:
                    http://groups.yahoo.com/group/midatlanticretro/
                
                <*> Your email settings:
                    Individual Email | Traditional
                
                <*> To change settings online go to:
                    http://groups.yahoo.com/group/midatlanticretro/join
                    (Yahoo! ID required)
                
                <*> To change settings via email:
                    mailto:midatlanticretro-digest@yahoogroups.com 
                    mailto:midatlanticretro-fullfeatured@yahoogroups.com
                
                <*> To unsubscribe from this group, send an email to:
                    midatlanticretro-unsubscribe@yahoogroups.com
                
                <*> Your use of Yahoo! Groups is subject to:
                    http://docs.yahoo.com/info/terms/
                  

                No virus found in this incoming message. Checked by AVG - www.avg.com Version: 8.0.238 / Virus Database: 270.12.1/2071 - Release Date: 04/21/09 08:30:00
              • Mike Loewen
                ... No, just a PDF copy downloaded from the usual sources. ... I haven t checked my CPA for mods. However, given that this was a working system when taken out
                Message 7 of 14 , Apr 21, 2009
                • 0 Attachment
                  On Tue, 21 Apr 2009, Dan Roganti wrote:

                  > Did you have the original manual too ?

                  No, just a PDF copy downloaded from the usual sources.

                  > There's an issue with one of the mods not being documented properly.
                  > It's being discussed on cctalk. One of the diagrams seems to be missing
                  > from the pdf files for the CPA section. My manual is original and it
                  > only has one of the mods described. Would yours have any more info
                  > about the mods ?

                  I haven't checked my CPA for mods. However, given that this was a
                  working system when taken out of service I'm fairly confident that the RAM
                  and ZPU are playing together nicely.

                  I'm following the discussion on cctalk.


                  Mike Loewen mloewen@...
                  Old Technology http://sturgeon.css.psu.edu/~mloewen/Oldtech/
                • Dan Roganti
                  Bill, can you check your Imsai docs too about this ? =Dan [ = http://www2.applegate.org/~ragooman/ ] Mike Loewen wrote: On Tue, 21 Apr 2009, Dan Roganti wrote:
                  Message 8 of 14 , Apr 21, 2009
                  • 0 Attachment

                    Bill, can you check your Imsai docs too about this ?

                    =Dan
                    [ = http://www2.applegate.org/~ragooman/   ]


                    Mike Loewen wrote:
                    On Tue, 21 Apr 2009, Dan Roganti wrote:
                    
                      
                    Did you have the original manual too ?
                        
                        No, just a PDF copy downloaded from the usual sources.
                    
                      
                    There's an issue with one of the mods not being documented properly.
                    It's being discussed on cctalk. One of the diagrams seems to be missing
                    from the pdf files for the CPA section. My manual is original and it
                    only has one of the mods described.  Would yours have any more info
                    about the mods ?
                        
                        I haven't checked my CPA for mods.  However, given that this was a 
                    working system when taken out of service I'm fairly confident that the RAM 
                    and ZPU are playing together nicely.
                    
                        I'm following the discussion on cctalk.
                      

                  • B Degnan
                    OK Currently at Phillies game... bd ... From: Dan Roganti Sent: Tuesday, April 21, 2009 7:14 PM To: midatlanticretro@yahoogroups.com
                    Message 9 of 14 , Apr 21, 2009
                    • 0 Attachment
                      OK
                      Currently at Phillies game...
                      bd



                      From: Dan Roganti <ragooman@...>
                      Sent: Tuesday, April 21, 2009 7:14 PM
                      To: midatlanticretro@yahoogroups.com
                      Subject: Re: [midatlanticretro] Workin' on the IMSAI...




                      Bill, can you check your Imsai docs too about this ?

                      =Dan
                      [ = http://www2.applegate.org/~ragooman/   ]


                      Mike Loewen wrote:
                      On Tue, 21 Apr 2009, Dan Roganti wrote:
                      
                        
                      Did you have the original manual too ?
                          
                          No, just a PDF copy downloaded from the usual sources.
                      
                        
                      There's an issue with one of the mods not being documented properly.
                      It's being discussed on cctalk. One of the diagrams seems to be missing
                      from the pdf files for the CPA section. My manual is original and it
                      only has one of the mods described.  Would yours have any more info
                      about the mods ?
                          
                          I haven't checked my CPA for mods.  However, given that this was a 
                      working system when taken out of service I'm fairly confident that the RAM 
                      and ZPU are playing together nicely.
                      
                          I'm following the discussion on cctalk.
                        



                    • B Degnan
                      Isn t what you re looking for found on page 36 of http://www.classiccmp.org/dunfield/imsai/cpa.pdf ? I checked my manuals, the pages aren t in the same order,
                      Message 10 of 14 , Apr 21, 2009
                      • 0 Attachment
                        Isn't what you're looking for found on page 36 of
                        http://www.classiccmp.org/dunfield/imsai/cpa.pdf ?

                        I checked my manuals, the pages aren't in the same order, but I can't be
                        sure what's missing.

                        Bill


                        Dan Roganti wrote:
                        > <!-- /* start of attachment style */ .ygrp-photo-title{ clear: both;
                        > font-size: smaller; height: 15px; overflow: hidden; text-align:
                        > center; width: 75px; } div.ygrp-photo{ background-position: center;
                        > background-repeat: no-repeat; background-color: white; border: 1px
                        > solid black; height: 62px; width: 62px; } div.photo-title a,
                        > div.photo-title a:active, div.photo-title a:hover, div.photo-title
                        > a:visited { text-decoration: none; } div.attach-table div.attach-row {
                        > clear: both; } div.attach-table div.attach-row div { float: left; /*
                        > margin: 2px;*/ } p { clear: both; padding: 15px 0 3px 0; overflow:
                        > hidden; } div.ygrp-file { width: 30px; valign: middle; }
                        > div.attach-table div.attach-row div div a { text-decoration: none; }
                        > div.attach-table div.attach-row div div span { font-weight: normal; }
                        > div.ygrp-file-title { font-weight: bold; } /* end of attachment style
                        > */ -->
                        >
                        >
                        > Bill, can you check your Imsai docs too about this ?
                        >
                        > =Dan
                        > [ = http://www2.applegate.org/~ragooman/ ]
                        >
                        >
                        > Mike Loewen wrote:
                        >> On Tue, 21 Apr 2009, Dan Roganti wrote:
                        >>
                        >>
                        >>> Did you have the original manual too ?
                        >>>
                        >>
                        >> No, just a PDF copy downloaded from the usual sources.
                        >>
                        >>
                        >>> There's an issue with one of the mods not being documented properly.
                        >>> It's being discussed on cctalk. One of the diagrams seems to be missing
                        >>> from the pdf files for the CPA section. My manual is original and it
                        >>> only has one of the mods described. Would yours have any more info
                        >>> about the mods ?
                        >>>
                        >>
                        >> I haven't checked my CPA for mods. However, given that this was a
                        >> working system when taken out of service I'm fairly confident that the RAM
                        >> and ZPU are playing together nicely.
                        >>
                        >> I'm following the discussion on cctalk.
                        >>
                        >>
                        >
                        >
                        >
                      • Dan Roganti
                        B Degnan wrote: Isn t what you re looking for found on page 36 of http://www.classiccmp.org/dunfield/imsai/cpa.pdf ? I checked my manuals, the pages aren t in
                        Message 11 of 14 , Apr 22, 2009
                        • 0 Attachment



                          B Degnan wrote:
                          Isn't what you're looking for found on page 36 of 
                          http://www.classiccmp.org/dunfield/imsai/cpa.pdf ?
                          
                          I checked my manuals, the pages aren't in the same order, but I can't be 
                          sure what's missing.
                            

                          Page 36 happens to be another separate modification. for mwrite signal, pin 68, on the bus.

                          The modification on page 26 with the missing Fig.2 diagram is for the run signal, pin 71,  on the bus.

                          =Dan
                          [ = http://www2.applegate.org/~ragooman/   ]

                        • B Degnan
                          OK. I ve uploaded a copy of figure 2 to my site vintagecomputer.net/imsai/imsai_fig2.pdf It was a pain to make, because it s a triple fold. I had to piece it
                          Message 12 of 14 , Apr 22, 2009
                          • 0 Attachment
                            OK. I've uploaded a copy of figure 2 to my site
                            vintagecomputer.net/imsai/imsai_fig2.pdf

                            It was a pain to make, because it's a triple fold. I had to piece it
                            together from three scans, so excuse the color variance and cropping to
                            make it fit. Feel free to share as needed.

                            Bill

                            Dan Roganti wrote:
                            > <!-- /* start of attachment style */ .ygrp-photo-title{ clear: both;
                            > font-size: smaller; height: 15px; overflow: hidden; text-align:
                            > center; width: 75px; } div.ygrp-photo{ background-position: center;
                            > background-repeat: no-repeat; background-color: white; border: 1px
                            > solid black; height: 62px; width: 62px; } div.photo-title a,
                            > div.photo-title a:active, div.photo-title a:hover, div.photo-title
                            > a:visited { text-decoration: none; } div.attach-table div.attach-row {
                            > clear: both; } div.attach-table div.attach-row div { float: left; /*
                            > margin: 2px;*/ } p { clear: both; padding: 15px 0 3px 0; overflow:
                            > hidden; } div.ygrp-file { width: 30px; valign: middle; }
                            > div.attach-table div.attach-row div div a { text-decoration: none; }
                            > div.attach-table div.attach-row div div span { font-weight: normal; }
                            > div.ygrp-file-title { font-weight: bold; } /* end of attachment style
                            > */ -->
                            >
                            >
                            >
                            >
                            > B Degnan wrote:
                            >> Isn't what you're looking for found on page 36 of
                            >> http://www.classiccmp.org/dunfield/imsai/cpa.pdf ?
                            >>
                            >> I checked my manuals, the pages aren't in the same order, but I can't be
                            >> sure what's missing.
                            >>
                            >
                            > Page 36 happens to be another separate modification. for mwrite
                            > signal, pin 68, on the bus.
                            >
                            > The modification on page 26 with the missing Fig.2 diagram is for the
                            > run signal, pin 71, on the bus.
                            >
                            > =Dan
                            > [ = http://www2.applegate.org/~ragooman/ ]
                            >
                            >
                            >
                            >
                          • Dan Roganti
                            B Degnan wrote: OK. I ve uploaded a copy of figure 2 to my site vintagecomputer.net/imsai/imsai_fig2.pdf It was a pain to make, because it s a triple fold. I
                            Message 13 of 14 , Apr 23, 2009
                            • 0 Attachment


                              B Degnan wrote:
                              OK.  I've uploaded a copy of figure 2 to my site 
                              vintagecomputer.net/imsai/imsai_fig2.pdf
                              
                              It was a pain to make, because it's a triple fold.  I had to piece it 
                              together from three scans, so excuse the color variance and cropping to 
                              make it fit.  Feel free to share as needed.
                                

                              That's great !
                              The scan came out quite good.
                              I'll forward the link.

                              thanks !
                              =Dan
                              [ = http://www2.applegate.org/~ragooman/   ]

                            Your message has been successfully submitted and would be delivered to recipients shortly.