Loading ...
Sorry, an error occurred while loading the content.

10648Re: [midatlanticretro] Commodore 1541 & 1571 drive repair

Expand Messages
  • Bryan Pope
    Dec 2, 2008
    • 0 Attachment
      Jeffrey Brace wrote:
      > I have two 1541 and one 1571 drives that have some problems. Any
      > chance I could get one of you C64 hardware gurus to take a look at
      > them ? And I have already eliminated dirty drive heads as the
      > problem. I believe that somehow they were damaged when I connected
      > them to my PC via an XE/XA 1541 connected to my PC's parallel port. I
      > have one good drive left, but it would be nice to repair the others to
      > have backups. The damages drives will get a "drive not ready error"
      > message. And I don't believe it is a misaligned head because Validate
      > and Initialize doesn't work.

      Does it also return the "Drive not ready" error when you try to
      format or New a diskette? ie

      OPEN 15,8,15: PRINT #15, "N0:name,id": CLOSE 15



      > ----- Original Message -----
      > *From:* B Degnan <mailto:billdeg@...>
      > *To:* midatlanticretro@yahoogroups.com
      > <mailto:midatlanticretro@yahoogroups.com>
      > *Sent:* Tuesday, December 02, 2008 8:03 AM
      > *Subject:* [midatlanticretro] PET IEEE Testing / Repair
      > Yes. I (and I believe Bryan) will bring IEEE/PET stuff for repairs.
      > This is our specialty, although I prefer not to have to reset the PET
      > monitor CPU "cup" connector by hand if possible :-)
      > I will bring a working system plus all of the diagnostic tools I use
      > when working on these systems. Jim Scheef is already bringing a
      > carload of PETs and drives, so one more wont matter!
      > Please vacuum out the innards / dust of what you bring, if you can,
      > before you come.
      > Bill
    • Show all 6 messages in this topic