Loading ...
Sorry, an error occurred while loading the content.

RE: [metamod] Running metamod in chrooted Linux environment

Expand Messages
  • [ClanBe] Pumuckl
    Jake, I had the same problem today. It turned out, that it was a missing file in /lib For me, it was libcrypt.so.1, however in a your other post I have seen
    Message 1 of 5 , Jul 13, 2002
    View Source
    • 0 Attachment
      Jake,

      I had the same problem today.
      It turned out, that it was a missing file in /lib
      For me, it was libcrypt.so.1, however in a your other post I have seen that you do have
      that file in /lib.

      Try the following:
      go to your hlds/cstrike/dlls directory and for each .so-file enter
      ldd <filename>
      You should see a list of neccessary files.
      Ensure that none of these files is missing in /lib.

      Now my CS-server is running in a chroot-chail :D
      Now if only metamod would support retro-cs...

      cu
      pum


      --------------------
      I am currently running my Linux Counter-strike server in a chrooted compartment.
      The instructions how to do it can be found e.g. from
      http://people.hp.se/frso/hlds-chroot.html

      However, I have encountered some problems while trying to use it with a metamod
      extension. The server starts nice, but will crash after the first player
      joins in. I have tried to debug the event by using a strace but haven't so
      far discovered what causes the crash. Metamod itself doesn't cause crash
      (with an empty metamod.ini everything works fine), but trying to use some
      other modules such as csguard, statsme or adminmod will bring the server
      down.

      Anyone have similar problems or solutions to the situation?
    Your message has been successfully submitted and would be delivered to recipients shortly.