Loading ...
Sorry, an error occurred while loading the content.

Re: ERROR ON INSTALL CMS

Expand Messages
  • Manuel Lemos
    Hello, ... That sounds like you are using MySQL 4.1 that has a backwards compatibility problem of not allowing the setting of default values of auto-increment
    Message 1 of 1 , Nov 20, 2004
    View Source
    • 0 Attachment
      Hello,

      On 11/20/2004 06:13 PM, Jorge Paván wrote:
      > Hello!. I want to begin to test the cms component and, after I compile
      > it, and want to run "metal\metastorage\install\setup\install.php" and I
      > obtain the error: "Error: Could not install database: the database was
      > only partially created: Valor por defecto invalido para 'sequence' ".
      > I can see the error is in metabase_manager.php, line 345
      > Could you help me please?

      That sounds like you are using MySQL 4.1 that has a backwards
      compatibility problem of not allowing the setting of default values of
      auto-increment fields.

      That problem was solved almost 2 months ago, but since I have not made a
      public release of neither Metastorage or Metabase, the fix is only
      available in the CVS version. You may download CVS snapshots from here
      and hopefully the problem will be solved:

      http://www.meta-language.net/download.html#snapshots


      --

      Regards,
      Manuel Lemos

      PHP Classes - Free ready to use OOP components written in PHP
      http://www.phpclasses.org/

      PHP Reviews - Reviews of PHP books and other products
      http://www.phpclasses.org/reviews/

      Metastorage - Data object relational mapping layer generator
      http://www.meta-language.net/metastorage.html
    Your message has been successfully submitted and would be delivered to recipients shortly.