Loading ...
Sorry, an error occurred while loading the content.

Re: [mach1mach2cnc] Re: Version R1.001 online.

Expand Messages
  • Art
    John: Strange, mine repeats the program fine. Does the grenn light beside the repeat box go on when you enter a repeat value? This indicates the program knows
    Message 1 of 11 , Aug 31, 2003
    • 0 Attachment
      John:

      Strange, mine repeats the program fine. Does the grenn light beside the
      repeat box go on when you enter a repeat value? This indicates the program
      knows to repeat when M30 is hit...

      Also, your repeat controls are not on the first "program run" page? Mine
      are...

      I probably screwed up something, I will recompile a new verison.....

      Thanks,
      Art
      www.artofcnc.ca
    • japrenticeuk
      ... page? Mine ... Servo s electronic acronyms file omits the one commonly used for idiots like me :=( The controls were not on Program Run screen because my
      Message 2 of 11 , Sep 1, 2003
      • 0 Attachment
        --- In mach1mach2cnc@yahoogroups.com, Art <fenerty@a...> wrote:
        > John:
        >
        > <snip>
        > Also, your repeat controls are not on the first "program run"
        page? Mine
        > are...

        Servo's electronic acronyms file omits the one commonly used for
        idiots like me :=( The controls were not on Program Run screen
        because my profile was for my development version of 1024.set with
        the caption labels before they were released - I might have worked
        that out for myself - sorry. But.. I still cannot make repeats
        work...

        When you enter the repeat count it does light the LED. However the
        entered Z-inhibit value is not effective. There seems to be two or
        maybe three "stores" for this value. The On/Off button on screen is
        reflected in the Configure Logic dialog but setting a Z-inhibit DRO
        value does not appear in Configure Logic (although changing Z-
        inhibit on Configure Logic does update the DRO). Mach2 seems to use
        the Configure Logic one when handling Z moves and M30 counts down
        the repeat count but does not update either Z-inhibit value. I.e.
        the Configure Logic control, which was 0 at load time, does not
        change and the DRO does not change from its initialised value of -
        1.0. So the tool runs round the rectangle at Z=0 the specified
        repeat count number of times.

        A final observation - Mach2 has just dropped pulse rate to 100 again
        in middle of these tests. Reloaded OK but repeats are still a
        problem.

        I think that Frank's uploaded ZIP file has no contents - at least I
        cannot find anything it it using WinZip 8 or the Windows XP unzipper

        Best wishes
        John Prentice
      • fcccustom
        I m having the same problem here. Every time the cycle ends count is 100. ... John, fixed the file, sorry bout that. Uploades as 18sq one up_r2_FIXED.zip
        Message 3 of 11 , Sep 1, 2003
        • 0 Attachment
          I'm having the same problem here. Every time the cycle ends count is 100.




          > A final observation - Mach2 has just dropped pulse rate to 100 again


          > in middle of these tests. Reloaded OK but repeats are still a


          > problem.


          >


          > I think that Frank's uploaded ZIP file has no contents - at least I


          > cannot find anything it it using WinZip 8 or the Windows XP unzipper




          John, fixed the file, sorry 'bout that. Uploades as 18sq one up_r2_FIXED.zip






          Frank C.
        • Art
          John: Yup, I probably screwed up something again. I will remove the multiple referances to the Safe_z and Inhibit variables to see if this corrects it. The
          Message 4 of 11 , Sep 1, 2003
          • 0 Attachment
            John:

            Yup, I probably screwed up something again. I will remove the multiple
            referances to the Safe_z and Inhibit variables to see if this corrects it.
            The pule dropping to 100 confuses me....

            I will look into this tonight...

            thanks,
            Art
            www.artofcnc.ca
          • Art
            Frank: Thanks for the confirmation. I will try to find the problem this evening... Thanks, Art www.artofcnc.ca
            Message 5 of 11 , Sep 1, 2003
            • 0 Attachment
              Frank:

              Thanks for the confirmation. I will try to find the problem this evening...

              Thanks,
              Art
              www.artofcnc.ca
            Your message has been successfully submitted and would be delivered to recipients shortly.