Loading ...
Sorry, an error occurred while loading the content.

Re: [mach1mach2cnc] Re: Version 1.90 turn bugs

Expand Messages
  • Erie Patsellis
    I d be happy if it d just run for 3 minutes without bombing, any hints? erie
    Message 1 of 20 , Oct 31, 2003
    • 0 Attachment
      I'd be happy if it'd just run for 3 minutes without bombing, any hints?

      erie

      Art wrote:

      > John:
      >
      > >>In Screen Designer 3 the "persistent controls" will be "display
      > >>only" except....
      >
      > Thank you, I know it would keep me from screwing up, I think the loser
      > that designed the screen editor should be shot. I am continuously screwing
      > up little things when I use it. Gros incompetence if you ask me...
      > (Hey, wait a minute..)
      >
      > Art
      > www.artofcnc.ca
      >
      >
      >
      > *Yahoo! Groups Sponsor*
      > ADVERTISEMENT
      > <http://rd.yahoo.com/M=267637.4116719.5338353.1261774/D=egroupweb/S=1705063697:HM/A=1754451/R=0/SIG=11tpj98m3/*http://www.netflix.com/Default?mqso=60178323&partid=4116719>
      >
      >
      >
      > To unsubscribe from this group, send an email to:
      > mach1mach2cnc-unsubscribe@yahoogroups.com
      >
      >
      >
      > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
      > <http://docs.yahoo.com/info/terms/>.
    • Erie Patsellis
      I open a layout, 1024.set to be exact, modify the shortcut to a button, click ok and vroommm, either I get an error and window closes or just diappears. did it
      Message 2 of 20 , Oct 31, 2003
      • 0 Attachment
        I open a layout, 1024.set to be exact, modify the shortcut to a button,
        click ok and vroommm, either I get an error and window closes or just
        diappears. did it on my main pc, figured it was due to the numerous apps
        installed, then did it on my router pc, stock win2k install with mach2
        and mach only. damn frustrating....
        erie

        Art wrote:

        > Erie:
        >
        > Really, it bombs on you...?
        >
        > Art
        > www.artofcnc.ca
        >
        >
        >
        >
        > *Yahoo! Groups Sponsor*
        > <http://rd.yahoo.com/M=259395.3614674.4902533.1261774/D=egroupweb/S=1705063697:HM/A=1524963/R=0/SIG=12o885gmo/*http://hits.411web.com/cgi-bin/autoredir?camp=556&lineid=3614674&prop=egroupweb&pos=HM>
        >
        >
        >
        > To unsubscribe from this group, send an email to:
        > mach1mach2cnc-unsubscribe@yahoogroups.com
        >
        >
        >
        > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
        > <http://docs.yahoo.com/info/terms/>.
      • Erie Patsellis
        for instance, change the run button from Alt-R to R, or even change the text displayed on the button.
        Message 3 of 20 , Oct 31, 2003
        • 0 Attachment
          for instance, change the run button from Alt-R to R, or even change the
          text displayed on the button.

          Art wrote:

          > Hmmm, what do you mean "modify the shortcut to a button?"
          >
          > Art
          > www.artofcnc.ca
          >
          >
          >
          >
          > *Yahoo! Groups Sponsor*
          > ADVERTISEMENT
          > <http://rd.yahoo.com/M=267637.4116719.5338353.1261774/D=egroupweb/S=1705063697:HM/A=1754452/R=0/SIG=11ti8tui3/*http://www.netflix.com/Default?mqso=60178324&partid=4116719>
          >
          >
          >
          > To unsubscribe from this group, send an email to:
          > mach1mach2cnc-unsubscribe@yahoogroups.com
          >
          >
          >
          > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
          > <http://docs.yahoo.com/info/terms/>.
        • Art
          ... another, unopened screen? Say for instance I want the dro s top left on jog screen, but want them bottom right on run screen. Edit dro s in jog, then open
          Message 4 of 20 , Nov 1, 2003
          • 0 Attachment
            Steve:

            >>Yep - seems like if you move a control on one screen, it moves it on
            another, unopened screen? Say for instance I want the dro's top left
            on jog screen, but want them bottom right on run screen. Edit dro's in
            jog, then open run, move dro's to bottom right, go back to jog and
            they have moved down bottom right too?

            Thats because the controls your moveing are on the P screen, which is all
            screens at once. If you cut them from the P screen and paste them on the
            variuos screnes where you wish them to be, they will stay, but since the
            DRO's seem to be on every screen, I made them persistant by putting them on
            the P screen...

            Art
            www.artofcnc.ca
          • Steve Blackmore
            ... Thanks John - that s it, got them to move independently now by deleting from persistent screen. -- Steve Blackmore
            Message 5 of 20 , Nov 1, 2003
            • 0 Attachment
              On Sat, 01 Nov 2003 18:53:29 -0000, you wrote:


              >This gave me a nasty fright that I had introduced a Screen Designer
              >bug. The explanation is simpler though - there are a lot of controls
              >on the persistent screen that should not be there . Probably got
              >there by accident when Art was re-designing workflow.

              Thanks John - that's it, got them to move independently now by
              deleting from persistent screen.


              --
              Steve Blackmore
            • Art
              ... Thank you, I know it would keep me from screwing up, I think the loser that designed the screen editor should be shot. I am continuously screwing up little
              Message 6 of 20 , Nov 1, 2003
              • 0 Attachment
                John:

                >>In Screen Designer 3 the "persistent controls" will be "display
                >>only" except....

                Thank you, I know it would keep me from screwing up, I think the loser
                that designed the screen editor should be shot. I am continuously screwing
                up little things when I use it. Gros incompetence if you ask me...
                (Hey, wait a minute..)

                Art
                www.artofcnc.ca
              • Art
                Erie: Really, it bombs on you...? Art www.artofcnc.ca
                Message 7 of 20 , Nov 1, 2003
                • 0 Attachment
                  Erie:

                  Really, it bombs on you...?

                  Art
                  www.artofcnc.ca
                • Art
                  ... Its either 4 , 8, or 16..... ... Since you have no switches, all you should have to do is the following at the end of file.. G53X0Z0 M30 When you start the
                  Message 8 of 20 , Nov 1, 2003
                  • 0 Attachment
                    Steve:

                    > If it was 8 revs 10 might do it?
                    >
                    Its either 4 , 8, or 16.....


                    > What I'm trying to do is after running one iteration of a program I
                    > want the tool to return to the stock corner to where It first started.
                    >
                    > That "corner" may have been machined away, but tool needs to go there.
                    >

                    > Waht I'm after is....
                    > G???
                    > M30

                    Since you have no switches, all you should have to do is the following
                    at the end of file..

                    G53X0Z0
                    M30

                    When you start the program or want to set the tool initial postion, press
                    Set/Home. Whatever you have in your Reference Home settings on the setup
                    page is what should now appear in the DRO's. (Set those settings to 0's). If
                    you have a part offset turned on (which you would after the first time
                    zero'ing to the stock) the DRO's will read the distance from Z0 and X0, but
                    the position will be correct and repeatable from job to job. So you really
                    only need to turn on Mach2, jog to initial tool postion, press set/home,
                    then zero your stock, run the program. To get back to the initial tool
                    position, press GoHome or have the G53x0z0 at the end of your program.

                    Try it this way, does it work?


                    Thanks,
                    Art
                  • Art
                    Hmmm, what do you mean modify the shortcut to a button? Art www.artofcnc.ca
                    Message 9 of 20 , Nov 1, 2003
                    • 0 Attachment
                      Hmmm, what do you mean "modify the shortcut to a button?"

                      Art
                      www.artofcnc.ca
                    • Art
                      Erie: Very strange. Anyone else have this? Ever seen this John? Can t say I have.. Art www.artofcnc.ca
                      Message 10 of 20 , Nov 1, 2003
                      • 0 Attachment
                        Erie:

                        Very strange. Anyone else have this? Ever seen this John? Can't say I
                        have..

                        Art
                        www.artofcnc.ca
                      • Steve Blackmore
                        ... Unable to test, system now corrupt. Blue screens even with V1.8 now ! Reset light is flashing - no error messages or warnings, trying to check settings in
                        Message 11 of 20 , Nov 2, 2003
                        • 0 Attachment
                          On Sat, 01 Nov 2003 17:52:52 -0400, you wrote:


                          > Try it this way, does it work?

                          Unable to test, system now corrupt. Blue screens even with V1.8 now !

                          Reset light is flashing - no error messages or warnings, trying to
                          check settings in ports and pins crashes XP every time.

                          I'm gonna copy the xml from here, but if that fails it looks like a
                          system rebuild :(

                          --
                          Steve Blackmore
                        • Digital audio Pro
                          Steve, check for virus before to rebuild all. Most of the time (80 % probability) when a machine is crazy without reason it is a virus... Did you install
                          Message 12 of 20 , Nov 2, 2003
                          • 0 Attachment
                            Steve, check for virus before to rebuild all. Most of the time (80 %
                            probability) when a machine is crazy without reason it is a virus... Did you
                            install latest XP security patches ? 3 days ago i got a trojan virus by
                            internet just 5 minutes after the first connection without anti virus, he
                            enter by a XP security hole (SP1 isn'nt sufficient).


                            Regards,

                            Olivier.


                            -----Message d'origine-----
                            De : Steve Blackmore [mailto:steve@...]
                            Envoye : dimanche 2 novembre 2003 16:38
                            A : mach1mach2cnc@yahoogroups.com
                            Objet : Re: [mach1mach2cnc] Version 1.90 turn bugs


                            On Sat, 01 Nov 2003 17:52:52 -0400, you wrote:


                            > Try it this way, does it work?

                            Unable to test, system now corrupt. Blue screens even with V1.8 now !

                            Reset light is flashing - no error messages or warnings, trying to
                            check settings in ports and pins crashes XP every time.

                            I'm gonna copy the xml from here, but if that fails it looks like a
                            system rebuild :(

                            --
                            Steve Blackmore


                            Yahoo! Groups Sponsor
                            ADVERTISEMENT




                            To unsubscribe from this group, send an email to:
                            mach1mach2cnc-unsubscribe@yahoogroups.com



                            Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


                            [Non-text portions of this message have been removed]
                          • Steve Blackmore
                            ... It s behind a firewall on my router, and got checked earlier today, it was clean :) It was a corrupt XML file after all, loaded my old copy over and
                            Message 13 of 20 , Nov 2, 2003
                            • 0 Attachment
                              On Sun, 2 Nov 2003 17:26:30 +0100, you wrote:

                              >Steve, check for virus before to rebuild all. Most of the time (80 %
                              >probability) when a machine is crazy without reason it is a virus... Did you
                              >install latest XP security patches ? 3 days ago i got a trojan virus by
                              >internet just 5 minutes after the first connection without anti virus, he
                              >enter by a XP security hole (SP1 isn'nt sufficient).

                              It's behind a firewall on my router, and got checked earlier today, it
                              was clean :)

                              It was a corrupt XML file after all, loaded my old copy over and
                              rebooted and it appears to be fine. Only thing I had to reset was
                              spindle speeds.

                              Art - your method works fine, thanks for that :)

                              Back to virus stuff, good point, there seems to be a plague of
                              bugbear around again. Norton IS deleted over 40 today so far !!

                              --
                              Steve Blackmore
                            • Art
                              Steve: No, don t go that far. Remove the driver completely and delte all copies. Then reinstall 1.x, that should fix it up. I don t know where that came from ,
                              Message 14 of 20 , Nov 2, 2003
                              • 0 Attachment
                                Steve:

                                No, don't go that far. Remove the driver completely and delte all copies.
                                Then reinstall 1.x, that should fix it up. I don't know where that came from
                                , I've had no BSOD's in many months across many versions. Something must
                                have corrupted for some reason.
                                One person did have some problems in the Ports and Pins in the new
                                emulator window, he was entering things like ^t in the Emulator key codes
                                instaed of a number, this caused a crash, but I haven't heard of it since.
                                You may want to check all emulations are turned off and zero's are in the
                                boxes for the scan codes...

                                Good luck,
                                Art
                                www.artofcnc.ca

                                ----- Original Message -----
                                From: "Steve Blackmore" <steve@...>
                                To: <mach1mach2cnc@yahoogroups.com>
                                Sent: Sunday, November 02, 2003 11:37 AM
                                Subject: Re: [mach1mach2cnc] Version 1.90 turn bugs


                                > On Sat, 01 Nov 2003 17:52:52 -0400, you wrote:
                                >
                                >
                                > > Try it this way, does it work?
                                >
                                > Unable to test, system now corrupt. Blue screens even with V1.8 now !
                                >
                                > Reset light is flashing - no error messages or warnings, trying to
                                > check settings in ports and pins crashes XP every time.
                                >
                                > I'm gonna copy the xml from here, but if that fails it looks like a
                                > system rebuild :(
                                >
                                > --
                                > Steve Blackmore
                                >
                                >
                                >
                                > To unsubscribe from this group, send an email to:
                                > mach1mach2cnc-unsubscribe@yahoogroups.com
                                >
                                >
                                >
                                > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                                >
                                >
                              • japrenticeuk
                                ... button, ... just ... numerous apps ... mach2 ... Erie: Following up from Art, you should expect much more stability from ScreenDesigner. Its handling of
                                Message 15 of 20 , Nov 2, 2003
                                • 0 Attachment
                                  --- In mach1mach2cnc@yahoogroups.com, Erie Patsellis <erie@s...>
                                  wrote:
                                  > I open a layout, 1024.set to be exact, modify the shortcut to a
                                  button,
                                  > click ok and vroommm, either I get an error and window closes or
                                  just
                                  > diappears. did it on my main pc, figured it was due to the
                                  numerous apps
                                  > installed, then did it on my router pc, stock win2k install with
                                  mach2
                                  > and mach only. damn frustrating....
                                  > erie

                                  Erie:

                                  Following up from Art, you should expect much more stability from
                                  ScreenDesigner. Its handling of ovelapped objects and such like are
                                  sometimes funny but (unlike Mach2 which takes liberties with
                                  Windows) it is fairly straightforward code. So we need to find the
                                  problem for you:

                                  Have you any idea when the trouble started: (there have been three
                                  release versions. Art's original and two from me.)?

                                  What version are we talking about.

                                  It makes no clever use of the registry and is I think used by
                                  several Win2K people (can you put up your hands please?) I have not
                                  got easy access to a Win2K testbed but can do this if needed.

                                  On clicking OK on the setup dialog you get an error: can you let me
                                  have the details of some attempts please (offline to
                                  john@... would be fine if you want to send
                                  attachments.)

                                  Is it only the setup dialog for buttons that gives problems?

                                  I will, if you like, send you a debug copy which will narrow down
                                  where we are at when it dies but running this sort of thing
                                  by "remote control" does not always work very well.

                                  It's hard work getting nice screens without it crashing. I am sure
                                  it can be fixed for you.

                                  Best wishes

                                  John Prentice
                                Your message has been successfully submitted and would be delivered to recipients shortly.