Loading ...
Sorry, an error occurred while loading the content.

Inputs on Second Parallel Port

Expand Messages
  • gloimon
    I am trying to test Darwin and have all my home and limit switches connected to a PCI Parallel Port. The Windows hardware manager indicates it is by MosChip
    Message 1 of 8 , Aug 21, 2014
    • 0 Attachment

      I am trying to test Darwin and have all my home and limit switches connected to a PCI

      Parallel Port.  The Windows hardware manager indicates it is by MosChip Semiconductor Technology.

      I have configured it in Darwin and checked the inputs on 2-9 box.  From the lights on my breakout board it does not appear that Darwin is setting the port

      into input mode.


      Has anyone else successfully tried this?


      Eric Nystrom

       

    • art2
      Eric: Just tested on my lava card with 2-9 yesterday, worked fine. I switched the inputs to 8 bit fetches as a 16 bit fetch was hosing one person, but it
      Message 2 of 8 , Aug 21, 2014
      • 0 Attachment
        
        Eric:
         
         Just tested on my lava card with 2-9 yesterday, worked fine. I switched the inputs to 8 bit fetches as a 16 bit fetch was hosing one person,
        but it should all be working if the address is correct.
         
         
        Thanks,
        Art
        www.gearotic.com
         
         
         
         
        ----- Original Message -----
        Sent: Thursday, August 21, 2014 5:53 PM
        Subject: [mach1mach2cnc] Inputs on Second Parallel Port

         

        I am trying to test Darwin and have all my home and limit switches connected to a PCI

        Parallel Port.  The Windows hardware manager indicates it is by MosChip Semiconductor Technology.

        I have configured it in Darwin and checked the inputs on 2-9 box.  From the lights on my breakout board it does not appear that Darwin is setting the port

        into input mode.


        Has anyone else successfully tried this?


        Eric Nystrom

         

      • Eric Nystrom
        Art, I installed Mach 3 and configured the second parallel port.  Mach 3 switches it to inputs correctly, but I cannot get the port to switch to input mode
        Message 3 of 8 , Aug 21, 2014
        • 0 Attachment

          Art,

          I installed Mach 3 and configured the second parallel port.  Mach 3 switches it to inputs correctly,
          but I cannot get the port to switch to input mode using Darwin.

          Any ideas?
           
          Eric Nystrom


          From: "art2 fenerty@... [mach1mach2cnc]" <mach1mach2cnc@yahoogroups.com>
          To: mach1mach2cnc@yahoogroups.com
          Sent: Thursday, August 21, 2014 4:59 PM
          Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

           
          
          Eric:
           
           Just tested on my lava card with 2-9 yesterday, worked fine. I switched the inputs to 8 bit fetches as a 16 bit fetch was hosing one person,
          but it should all be working if the address is correct.
           
           
          Thanks,
          Art
          www.gearotic.com
           
           
           
           
          ----- Original Message -----
          Sent: Thursday, August 21, 2014 5:53 PM
          Subject: [mach1mach2cnc] Inputs on Second Parallel Port

           
          I am trying to test Darwin and have all my home and limit switches connected to a PCI
          Parallel Port.  The Windows hardware manager indicates it is by MosChip Semiconductor Technology.
          I have configured it in Darwin and checked the inputs on 2-9 box.  From the lights on my breakout board it does not appear that Darwin is setting the port
          into input mode.

          Has anyone else successfully tried this?

          Eric Nystrom
           


        • art2
          Eric: Hmm. Cant see why it woudl ave trouble, I basically changed it back to the M3 standard 8 bit fetches. Ill take another look to see if I messed up
          Message 4 of 8 , Aug 21, 2014
          • 0 Attachment
            
            Eric:
             
              Hmm. Cant see why it woudl ave trouble, I basically changed it back to the M3 standard 8 bit fetches.
            Ill take another look to see if I messed up somewhere, but Ive tested all bits here with no trouble. Never hurts
            to test again though..
             
             
            Thanks,
            Art
            www.gearotic.com
             
             
             
             
            ----- Original Message -----
            Sent: Thursday, August 21, 2014 7:31 PM
            Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

             


            Art,

            I installed Mach 3 and configured the second parallel port.  Mach 3 switches it to inputs correctly,
            but I cannot get the port to switch to input mode using Darwin.

            Any ideas?
             
            Eric Nystrom


            From: "art2 fenerty@... [mach1mach2cnc]" <mach1mach2cnc@yahoogroups.com>
            To: mach1mach2cnc@yahoogroups.com
            Sent: Thursday, August 21, 2014 4:59 PM
            Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

             
            
            Eric:
             
             Just tested on my lava card with 2-9 yesterday, worked fine. I switched the inputs to 8 bit fetches as a 16 bit fetch was hosing one person,
            but it should all be working if the address is correct.
             
             
            Thanks,
            Art
            www.gearotic.com
             
             
             
             
            ----- Original Message -----
            Sent: Thursday, August 21, 2014 5:53 PM
            Subject: [mach1mach2cnc] Inputs on Second Parallel Port

             
            I am trying to test Darwin and have all my home and limit switches connected to a PCI
            Parallel Port.  The Windows hardware manager indicates it is by MosChip Semiconductor Technology.
            I have configured it in Darwin and checked the inputs on 2-9 box.  From the lights on my breakout board it does not appear that Darwin is setting the port
            into input mode.

            Has anyone else successfully tried this?

            Eric Nystrom
             


          • handsmfg
            Hi Art So do you recommend running Mach 4 and Darwin in ACPI mode on an XP machine. I have mine set to standard PC so Mach 3 will run. If Mach 4 and Dawrin
            Message 5 of 8 , Aug 21, 2014
            • 0 Attachment
              Hi Art
              So do you recommend running Mach 4 and Darwin in ACPI mode on an XP machine. I have mine set to standard PC so Mach 3 will run. If Mach 4 and Dawrin will run better under ACPI then that explains a lot. Never understood about ACPI until I Googled it. If that's the case I'm just spinning my wheels then.

              Eric.
            • art2
              Eric: Standard pc shoudl work as well as anythign else. Those interrupt modes usually arent good for much for Mach s.. Thanks, Art www.gearotic.com ... From:
              Message 6 of 8 , Aug 22, 2014
              • 0 Attachment
                
                Eric:
                 
                 Standard pc shoudl work as well as anythign else. Those interrupt modes usually arent good for much for Mach's..
                 
                 
                Thanks,
                Art
                www.gearotic.com
                 
                 
                 
                 
                ----- Original Message -----
                Sent: Thursday, August 21, 2014 11:54 PM
                Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

                 

                Hi Art

                So do you recommend running Mach 4 and Darwin in ACPI mode on an XP machine. I have mine set to standard PC so Mach 3 will run. If Mach 4 and Dawrin will run better under ACPI then that explains a lot. Never understood about ACPI until I Googled it. If that's the case I'm just spinning my wheels then.

                Eric.

              • Eric Nystrom
                Art, I uninstalled version 17 and installed version 18 and was able to get it working. I was able to define an X home switch and successfully home X. Thanks,
                Message 7 of 8 , Aug 22, 2014
                • 0 Attachment
                  Art,

                  I uninstalled version 17 and installed version 18 and was able to get it working.

                  I was able to define an X home switch and successfully home X.

                  Thanks,
                   
                  Eric Nystrom


                  From: "art2 fenerty@... [mach1mach2cnc]" <mach1mach2cnc@yahoogroups.com>
                  To: mach1mach2cnc@yahoogroups.com
                  Sent: Thursday, August 21, 2014 9:12 PM
                  Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

                   
                  
                  Eric:
                   
                    Hmm. Cant see why it woudl ave trouble, I basically changed it back to the M3 standard 8 bit fetches.
                  Ill take another look to see if I messed up somewhere, but Ive tested all bits here with no trouble. Never hurts
                  to test again though..
                   
                   
                  Thanks,
                  Art
                  www.gearotic.com
                   
                   
                   
                   


                  ----- Original Message -----
                  Sent: Thursday, August 21, 2014 7:31 PM
                  Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

                   

                  Art,

                  I installed Mach 3 and configured the second parallel port.  Mach 3 switches it to inputs correctly,
                  but I cannot get the port to switch to input mode using Darwin.

                  Any ideas?
                   
                  Eric Nystrom


                  From: "art2 fenerty@... [mach1mach2cnc]" <mach1mach2cnc@yahoogroups.com>
                  To: mach1mach2cnc@yahoogroups.com
                  Sent: Thursday, August 21, 2014 4:59 PM
                  Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

                   
                  
                  Eric:
                   
                   Just tested on my lava card with 2-9 yesterday, worked fine. I switched the inputs to 8 bit fetches as a 16 bit fetch was hosing one person,
                  but it should all be working if the address is correct.
                   
                   
                  Thanks,
                  Art
                  www.gearotic.com
                   
                   
                   
                   
                  ----- Original Message -----
                  Sent: Thursday, August 21, 2014 5:53 PM
                  Subject: [mach1mach2cnc] Inputs on Second Parallel Port

                   
                  I am trying to test Darwin and have all my home and limit switches connected to a PCI
                  Parallel Port.  The Windows hardware manager indicates it is by MosChip Semiconductor Technology.
                  I have configured it in Darwin and checked the inputs on 2-9 box.  From the lights on my breakout board it does not appear that Darwin is setting the port
                  into input mode.

                  Has anyone else successfully tried this?

                  Eric Nystrom
                   




                • art2
                  Eric: Thx, very good to hear. One of the worst things about testing like this is very few report success, only problems and it gives the impression everyone is
                  Message 8 of 8 , Aug 22, 2014
                  • 0 Attachment
                    
                    Eric:
                     
                      Thx, very good to hear. One of the worst things about testing like this is very few report success, only problems and it gives
                    the impression everyone is screwed. :) , so I appreciate hearing as well when it works..
                     
                     
                    Thanks,
                    Art
                    www.gearotic.com
                     
                     
                     
                     
                    ----- Original Message -----
                    Sent: Friday, August 22, 2014 3:04 PM
                    Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

                     

                    Art,

                    I uninstalled version 17 and installed version 18 and was able to get it working.

                    I was able to define an X home switch and successfully home X.

                    Thanks,
                     
                    Eric Nystrom


                    From: "art2 fenerty@... [mach1mach2cnc]" <mach1mach2cnc@yahoogroups.com>
                    To: mach1mach2cnc@yahoogroups.com
                    Sent: Thursday, August 21, 2014 9:12 PM
                    Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

                     
                    
                    Eric:
                     
                      Hmm. Cant see why it woudl ave trouble, I basically changed it back to the M3 standard 8 bit fetches.
                    Ill take another look to see if I messed up somewhere, but Ive tested all bits here with no trouble. Never hurts
                    to test again though..
                     
                     
                    Thanks,
                    Art
                    www.gearotic.com
                     
                     
                     
                     


                    ----- Original Message -----
                    Sent: Thursday, August 21, 2014 7:31 PM
                    Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

                     

                    Art,

                    I installed Mach 3 and configured the second parallel port.  Mach 3 switches it to inputs correctly,
                    but I cannot get the port to switch to input mode using Darwin.

                    Any ideas?
                     
                    Eric Nystrom


                    From: "art2 fenerty@... [mach1mach2cnc]" <mach1mach2cnc@yahoogroups.com>
                    To: mach1mach2cnc@yahoogroups.com
                    Sent: Thursday, August 21, 2014 4:59 PM
                    Subject: Re: [mach1mach2cnc] Inputs on Second Parallel Port

                     
                    
                    Eric:
                     
                     Just tested on my lava card with 2-9 yesterday, worked fine. I switched the inputs to 8 bit fetches as a 16 bit fetch was hosing one person,
                    but it should all be working if the address is correct.
                     
                     
                    Thanks,
                    Art
                    www.gearotic.com
                     
                     
                     
                     
                    ----- Original Message -----
                    Sent: Thursday, August 21, 2014 5:53 PM
                    Subject: [mach1mach2cnc] Inputs on Second Parallel Port

                     
                    I am trying to test Darwin and have all my home and limit switches connected to a PCI
                    Parallel Port.  The Windows hardware manager indicates it is by MosChip Semiconductor Technology.
                    I have configured it in Darwin and checked the inputs on 2-9 box.  From the lights on my breakout board it does not appear that Darwin is setting the port
                    into input mode.

                    Has anyone else successfully tried this?

                    Eric Nystrom
                     




                  Your message has been successfully submitted and would be delivered to recipients shortly.