Loading ...
Sorry, an error occurred while loading the content.

RE: Mach3 Lathe Thread pitch issue

Expand Messages
  • campgems
    I ve seen, but not used a program that turns your PC into an O scope. IT was a free program if I remember correct and was referenced on this group. It would be
    Message 1 of 6 , Sep 20, 2013
    • 0 Attachment

      I've seen, but not used a program that turns your PC into an O scope.  IT was a free program if I remember  correct and was referenced on this group.  It would be interesting to see what the signal off your index looked like.  Also what noise is on that line. 


      A problem I had with my Taig home conversion was random steps on the Z axis with higherr spindle speeds.  I fought the noise issue and could not really isolate a cause.  It was pointed out on this group that older PC's had Parallel Ports with 5V signals while most of the P4 and later mother boards had signals in the 3/5V range.  I dug out an old Win 2000 vintage PC and found it was in fact a 5V signal.  That cured the signal to noise issue.  My stepper Controllers, Parker OEM 650's require a minimum signal of 3.5V.  Any noise, and there is always going to be some was causing false step pulses.  The higher signal to noise ratio with the 5V signal solved it. 


      Last, on your shielded and grounded cables.  Make sure that they are grounded only on the PC end.  Look at your grounding like a tree.  The roots as the ground and and each branch, Ie your index, limits, motors, and machine frame should have only one path to ground, that being at the wall outlet.  Ground loops will drive you batty trying to solve the problems. 


      Don



      --- In mach1mach2cnc@yahoogroups.com, <jakemestre@...> wrote:

      Debounce index is currently set to 10. I've played around with it from 0-100 with no change in the thread. I should mention that I'm using the latest lockdown of mach3, CNC4PC spindle index board, C11G main board, Gecko 203V drives, and an XP computer that's optimized for mach. I tried using a USB smoothstepper but it caused more problems than it was worth, and wouldn't recognize the spindle speed at all. The motion of the axis were smoother though.
      I measured the spindle speed with a hand held tach and it reads 100rpm higher in mach from 100-800rpm then it steadily increases to 200-300RMP over from 800-2700. It's almost like the spindle index is being scaled or something weird.
    • tooci_toucan
      So this problem turned out to be a combination of several weird things. I started off with the sensor. It s a photogate C3 board from CNC4PC. There was
      Message 2 of 6 , Sep 30, 2013
      • 0 Attachment
        So this problem turned out to be a combination of several weird things. I started off with the sensor. It's a photogate C3 board from CNC4PC. There was almost no noise in the index, it's shielded and grounded on one end and produced a very clean signal. I'm building another lathe at the moment so I have all the spare (new boards). The old boards have been through a few rebuilds and I thought with all the wiring, jostling, and powerchecks something might have been fried. I replaced all the chips on the C11G with no change, then I replaced the C11G all together. I tried a different sensor, different C3 index board and pretty much everything I could think of mechanically to fix the problem. After all that the DRO was still displaying 600RPM when I was physically measuring 500.
        So then I moved onto the programming to troubleshoot. I tried reinstalling mach. I saved the XML but dumped everything hoping there was maybe a bug in the install. Nope. Then it occurred to me to try a completely new profile. I copied all the pins, and motor tuning to a new profile and instantly the spindle speed was working correctly.
        The problem was in two things. First the pulleys and secondly the motor tuning steps/rev and velocity settings. I forgot to set the pulley ratio, so the default 1 sent the DRO directly to 500RPM.
        I'm using the PID spindle control, so I think I need to still play around with the steps/rev and speed settings to get it to thread perfectly without PID.
        This was such a weird problem to troubleshoot. Any ideas why the pulleys would mess with the DRO? I thought the index was supposed to be measuring the spindle not the motor. Thanks
        Jake
      Your message has been successfully submitted and would be delivered to recipients shortly.