Loading ...
Sorry, an error occurred while loading the content.
 

My ESS is just not working correctly

Expand Messages
  • Henri Monnier
    I m having some issues with the install of the ESS smoooth-stepper. I have played with settings, and perhaps I just don t understand how this thing works.....
    Message 1 of 7 , May 4, 2013
      I'm having some issues with the install of the ESS smoooth-stepper. I have played with settings, and perhaps I just don't understand how this thing works.....
      The PC is a 3.5 w/3 gig ram running XP w/nothing else running in the background. It was was running via the printer port with no (known to me anyway) issues. The ESS seems to be losing steps, it seems on 'Z'.

      How did I come to that conclusion???? I am cutting a signboard perimeter, about 300K lines of Gcode, I initially set 'X', 'Y', and 'Z' to the proper places, set that as the 'zero' for all axis. Started the run with a finish cut w/0.125BN. Partway into the run, several minutes, it did not look like the 'smoothing' of the finish cut was doing as well as it should be, but I let it finish the entire run.
      I then brought the router back to the start points, all 'zero' and the 'Z' axis was not touching the surface as it should be (it was at the start), it was off by 0.0596.

      I'd be interested in the setups other ESS users have found that works.
      I have the Controller Freq at 512 (had an error at 1HZ, and the stepper error message suggested I try 512)
      All Max Step Freq are set at 256khz, and the max data points is set at 1500.
      Everything else is at the default settings.I have not made any setup changes in the Mach3 settings.

      I know there are a lot of these out there running fine, so what have I screwed up????

      Thanks, Henri
    • Jeffrey Birt
      Henri, the ESS won t loose steps. Most of the time if you are losing steps it is a motor tuning issue, i.e. acceleration or velocity too high, or you have
      Message 2 of 7 , May 4, 2013
        Henri, the ESS won't 'loose' steps. Most of the time if you are losing steps
        it is a motor tuning issue, i.e. acceleration or velocity too high, or you
        have set the step active high setting incorrectly (this can cause a lost
        step each time the axis changes direction). Having your step frequency at
        256 is likely way too high, unless you are running servos with a very high
        encoder count. If you want to send me a copy of your profile I'll have a
        look. I'm guessing if the max step frequency is set correctly you can set
        the controller frequency to 1kHz.



        Jeff Birt

        Soigeneris.com





        From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
        On Behalf Of Henri Monnier
        Sent: Saturday, May 04, 2013 3:50 PM
        To: mach1mach2cnc@yahoogroups.com
        Subject: [mach1mach2cnc] My ESS is just not working correctly





        I'm having some issues with the install of the ESS smoooth-stepper. I have
        played with settings, and perhaps I just don't understand how this thing
        works.....
        The PC is a 3.5 w/3 gig ram running XP w/nothing else running in the
        background. It was was running via the printer port with no (known to me
        anyway) issues. The ESS seems to be losing steps, it seems on 'Z'.

        How did I come to that conclusion???? I am cutting a signboard perimeter,
        about 300K lines of Gcode, I initially set 'X', 'Y', and 'Z' to the proper
        places, set that as the 'zero' for all axis. Started the run with a finish
        cut w/0.125BN. Partway into the run, several minutes, it did not look like
        the 'smoothing' of the finish cut was doing as well as it should be, but I
        let it finish the entire run.
        I then brought the router back to the start points, all 'zero' and the 'Z'
        axis was not touching the surface as it should be (it was at the start), it
        was off by 0.0596.

        I'd be interested in the setups other ESS users have found that works.
        I have the Controller Freq at 512 (had an error at 1HZ, and the stepper
        error message suggested I try 512)
        All Max Step Freq are set at 256khz, and the max data points is set at 1500.
        Everything else is at the default settings.I have not made any setup changes
        in the Mach3 settings.

        I know there are a lot of these out there running fine, so what have I
        screwed up????

        Thanks, Henri





        [Non-text portions of this message have been removed]
      • cd_edwards2002
        If you ever figure out what s going on here, I would appreciate a message on what you did to fix this problem. I had exactly the same issues, although I would
        Message 3 of 7 , May 4, 2013
          If you ever figure out what's going on here, I would appreciate a message on what you did to fix this problem. I had exactly the same issues, although I would loose steps on one cut and gain them on another.. I played with alot of settings and never did get the ESS working so finally gave up on it as a lost cause.


          --- In mach1mach2cnc@yahoogroups.com, "Henri Monnier" <cnc@...> wrote:
          >
          > I'm having some issues with the install of the ESS smoooth-stepper. I have played with settings, and perhaps I just don't understand how this thing works.....
          > The PC is a 3.5 w/3 gig ram running XP w/nothing else running in the background. It was was running via the printer port with no (known to me anyway) issues. The ESS seems to be losing steps, it seems on 'Z'.
          >
          > How did I come to that conclusion???? I am cutting a signboard perimeter, about 300K lines of Gcode, I initially set 'X', 'Y', and 'Z' to the proper places, set that as the 'zero' for all axis. Started the run with a finish cut w/0.125BN. Partway into the run, several minutes, it did not look like the 'smoothing' of the finish cut was doing as well as it should be, but I let it finish the entire run.
          > I then brought the router back to the start points, all 'zero' and the 'Z' axis was not touching the surface as it should be (it was at the start), it was off by 0.0596.
          >
          > I'd be interested in the setups other ESS users have found that works.
          > I have the Controller Freq at 512 (had an error at 1HZ, and the stepper error message suggested I try 512)
          > All Max Step Freq are set at 256khz, and the max data points is set at 1500.
          > Everything else is at the default settings.I have not made any setup changes in the Mach3 settings.
          >
          > I know there are a lot of these out there running fine, so what have I screwed up????
          >
          > Thanks, Henri
          >
        • cd_edwards2002
          Ive looked at the default G540 file from cncrouterparts.com. The differances between mine and it are the following. cncrouterparts in motor ports and pins,
          Message 4 of 7 , May 4, 2013
            Ive looked at the default G540 file from cncrouterparts.com. The differances between mine and it are the following.

            cncrouterparts
            in motor ports and pins, step for the slave axis is set all others are not set.
            in homing/limits everything is off.

            my working xml
            in motor ports and pins step and dir are not set for any axis.
            in homing/limits reversed is set for 3 axis's and not for the fourth.

            speed for xya are set to 400 with 20 accel on both setups.


            --- In mach1mach2cnc@yahoogroups.com, "Henri Monnier" <cnc@...> wrote:
            >
            > I'm having some issues with the install of the ESS smoooth-stepper. I have played with settings, and perhaps I just don't understand how this thing works.....
            > The PC is a 3.5 w/3 gig ram running XP w/nothing else running in the background. It was was running via the printer port with no (known to me anyway) issues. The ESS seems to be losing steps, it seems on 'Z'.
            >
            > How did I come to that conclusion???? I am cutting a signboard perimeter, about 300K lines of Gcode, I initially set 'X', 'Y', and 'Z' to the proper places, set that as the 'zero' for all axis. Started the run with a finish cut w/0.125BN. Partway into the run, several minutes, it did not look like the 'smoothing' of the finish cut was doing as well as it should be, but I let it finish the entire run.
            > I then brought the router back to the start points, all 'zero' and the 'Z' axis was not touching the surface as it should be (it was at the start), it was off by 0.0596.
            >
            > I'd be interested in the setups other ESS users have found that works.
            > I have the Controller Freq at 512 (had an error at 1HZ, and the stepper error message suggested I try 512)
            > All Max Step Freq are set at 256khz, and the max data points is set at 1500.
            > Everything else is at the default settings.I have not made any setup changes in the Mach3 settings.
            >
            > I know there are a lot of these out there running fine, so what have I screwed up????
            >
            > Thanks, Henri
            >
          • Jeffrey Birt
            I m not sure what you mean when you say that in motor ports and pins, step for the slave axis is set all others are not set. . What is set to what? The
            Message 5 of 7 , May 4, 2013
              I'm not sure what you mean when you say that "in motor ports and pins, step
              for the slave axis is set all others are not set.
              ". What is set to what?



              The important thing to look at is the Active Low setting for the step
              signal. For the G540 these should all set to the red 'X'. If it is set to
              the green check symbol then the G540 will be stepping on the wrong edge of
              the step signal. This can cause a missed step on direction changes.



              Depending on your machine an acceleration of 20 i/s/s might be optimistic.
              Most lost steps come from motor tuning problems. Setting the accel back to
              15 might help. With your acceleration at 20 it will take about 0.335 seconds
              to go from 0 to 400IPM. With it set at 15 it will take about 0.45 seconds. A
              few months ago I was tuning a machine to optimize it for acceleration (for
              doing 3D profile type machining). I found that with a difference of 3-4
              i/s/s (took machine from about 16 i/s/s to 12 i/s/s) only increased the
              machining time a few minutes on a program that tool more than two hours to
              complete. After a certain point increasing the acceleration does not really
              increase productivity.



              Jeff Birt

              Soigeneris.com



              From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
              On Behalf Of cd_edwards2002
              Sent: Saturday, May 04, 2013 10:28 PM
              To: mach1mach2cnc@yahoogroups.com
              Subject: [mach1mach2cnc] Re: My ESS is just not working correctly





              Ive looked at the default G540 file from cncrouterparts.com. The differances
              between mine and it are the following.

              cncrouterparts
              in motor ports and pins, step for the slave axis is set all others are not
              set.
              in homing/limits everything is off.

              my working xml
              in motor ports and pins step and dir are not set for any axis.
              in homing/limits reversed is set for 3 axis's and not for the fourth.

              speed for xya are set to 400 with 20 accel on both setups.

              --- In mach1mach2cnc@yahoogroups.com
              <mailto:mach1mach2cnc%40yahoogroups.com> , "Henri Monnier" <cnc@...> wrote:
              >
              > I'm having some issues with the install of the ESS smoooth-stepper. I have
              played with settings, and perhaps I just don't understand how this thing
              works.....
              > The PC is a 3.5 w/3 gig ram running XP w/nothing else running in the
              background. It was was running via the printer port with no (known to me
              anyway) issues. The ESS seems to be losing steps, it seems on 'Z'.
              >
              > How did I come to that conclusion???? I am cutting a signboard perimeter,
              about 300K lines of Gcode, I initially set 'X', 'Y', and 'Z' to the proper
              places, set that as the 'zero' for all axis. Started the run with a finish
              cut w/0.125BN. Partway into the run, several minutes, it did not look like
              the 'smoothing' of the finish cut was doing as well as it should be, but I
              let it finish the entire run.
              > I then brought the router back to the start points, all 'zero' and the 'Z'
              axis was not touching the surface as it should be (it was at the start), it
              was off by 0.0596.
              >
              > I'd be interested in the setups other ESS users have found that works.
              > I have the Controller Freq at 512 (had an error at 1HZ, and the stepper
              error message suggested I try 512)
              > All Max Step Freq are set at 256khz, and the max data points is set at
              1500.
              > Everything else is at the default settings.I have not made any setup
              changes in the Mach3 settings.
              >
              > I know there are a lot of these out there running fine, so what have I
              screwed up????
              >
              > Thanks, Henri
              >





              [Non-text portions of this message have been removed]
            • Henri Monnier
              Jeff, I have sent the XML file to you via email. There are some additional notes in the message. I have checked all the leadscrews for any binding or rough
              Message 6 of 7 , May 5, 2013
                Jeff,

                I have sent the XML file to you via email. There are some additional notes in the message.

                I have checked all the leadscrews for any binding or 'rough' spots. The anti-backlash nuts are relatively new, and have brushes on both sides to keep the leadscrews themselves clean.

                Thanks for your assistance, it is appreciated....
                Henri
              • Jeffrey Birt
                Henri, I wanted to reply here as this type of information might be of use to others as well. The only thing I saw out of kilter with your profile with the Max
                Message 7 of 7 , May 5, 2013
                  Henri,



                  I wanted to reply here as this type of information might be of use to others
                  as well. The only thing I saw out of kilter with your profile with the Max
                  Step Frequency and Controller Frequency setting. You had these set at
                  opposite extremes which may have been causing some resolution issues (I will
                  have to check with Greg at Warp9 about that to be sure though).



                  The "Max Step Frequency" is sort of similar to the kernel frequency in
                  Mach3 insofar that it tells the SmoothStepper the maximum frequency that a
                  particular axis requires at its maximum feed rate. Just like cranking up the
                  kernel frequency in Mach3 for the parallel port driver higher than what is
                  needed does not improve things (in fact it usually makes it worse) the same
                  sort of idea applies to the SmoothStepper. By having this cranked up toe
                  256kHz you were telling the SmoothStepper plugins that it needed a whole lot
                  higher resolution of data than it really needed. With your steps/unit and
                  feed rate you can very safely use the lowest 32kHz setting in the
                  SmoothStepper config dialog. For details about how to calculate the correct
                  setting go to: http://www.soigeneris.com/documentation-content.aspx and look
                  for the Ethernet SmoothStepper Installation Tips document in the
                  SmoothStepper section.



                  The "Controller Frequency" setting allows you to optimize how the
                  SmoothStepper buffer is used. The higher the setting the more velocity
                  updates every second the SmoothStepper receives. If you have a servo system
                  with really high resolution encoders than you will want a faster controller
                  frequency, this gives you more updates per second but less seconds worth of
                  data in the buffer. For most systems a setting of 1kHz will work. That gives
                  you a good compromise between buffer size (in seconds) and velocity updates.
                  Since you had your axis frequencies as set to 256kHz you were generating a
                  whole lot of data for each axis, but then you had your controller frequency
                  set to 500Hz which meant that the SmoothStepper was not getting frequent
                  velocity updates. Basically you had the settings at opposite extremes which
                  could have caused some problems. (I have been trying to think of an analogy
                  to explain how relationship between Step Frequency and Controller frequency
                  but I'm coming up blank.)



                  So they short story is: set all of your Step Frequencies to 32kHz and your
                  Velocity Frequency to 1kHz. Double check that you have your steps/unit set
                  properly for each axis. Then set your acceleration/velocity for each axis to
                  about half what it is now and do some testing. Bump the acceleration up
                  about 5 at a time until you get stalls when accelerating, then drop back to
                  about 2/3 that value. Do the same for velocity. This should provide a nice,
                  safe motor tuning.



                  Hope that help,



                  Jeff Birt

                  Soigeneris.com



                  From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
                  On Behalf Of Henri Monnier
                  Sent: Sunday, May 05, 2013 7:31 AM
                  To: mach1mach2cnc@yahoogroups.com
                  Subject: [mach1mach2cnc] Re: My ESS is just not working correctly





                  Jeff,

                  I have sent the XML file to you via email. There are some additional notes
                  in the message.

                  I have checked all the leadscrews for any binding or 'rough' spots. The
                  anti-backlash nuts are relatively new, and have brushes on both sides to
                  keep the leadscrews themselves clean.

                  Thanks for your assistance, it is appreciated....
                  Henri





                  [Non-text portions of this message have been removed]
                Your message has been successfully submitted and would be delivered to recipients shortly.