Loading ...
Sorry, an error occurred while loading the content.
 

Re: Mach3 Feed changes causing deceleration to 0 first

Expand Messages
  • joeyfredrick@ymail.com
    Thanks a bunch for the suggestion. Version .062 runs the code smooth. I had also tried Jeffrey s suggestion of adding Y and Z coords and that didn t help. It
    Message 1 of 13 , Apr 2, 2013
      Thanks a bunch for the suggestion. Version .062 runs the code smooth. I had also tried Jeffrey's suggestion of adding Y and Z coords and that didn't help. It seems some versions of Mach3 have this problem and some don't.

      --- In mach1mach2cnc@yahoogroups.com, "picengraver" <picengrave@...> wrote:
      >
      > Joey,
      > When I tested Zoli's code, my laser machine was not available, so I used my larger router (with a SmoothStepper/Geckos). I had assumed both machines would run the same. Not true.
      >
      > I just went out and tested Zoli's code on my laser machine (PPort amd HobbyCNC controller) and it runs very smooth, as in Extremely Smooth. Absolutely no jerking or hesitation or feed rate going to zero. So, now I am puzzled. There has to be something different in the two machines. I run .066 on the large machine and .062 on the laser machine. Perhaps that is it. Unfortunately, each of my machines is in a different location, so I can not compare M3 settings just now.
      >
      > I also compiled Zoli's image with my program in inch mode and ran the gcode, and it is just as smooth, so it is not likely a difference in gcode format or metric/inch.
      >
      > I will be happy to work with you off line to see if we can figure out why this is happening (probably would take up too much bandwidth to do it on the group). Please PM me at: picengraveATverizon.net.
      >
      > Regards,
      > John Champlain
    Your message has been successfully submitted and would be delivered to recipients shortly.