Loading ...
Sorry, an error occurred while loading the content.

Re: Mach3 Feed changes causing deceleration to 0 first

Expand Messages
  • jeffery8189
    It s been my experience that Mach runs smoother when there are more then one axis on each line of code even if one axis is not changing any position. The laser
    Message 1 of 13 , Apr 1, 2013
    • 0 Attachment
      It's been my experience that Mach runs smoother when there are more then one axis on each line of code even if one axis is not changing any position. The laser engraved images I did on this page.

      http://hobbycncart.com/forum/63-151-25

      I generated the code in John's program using analog laser code settings first which will be X,Y,& Z on each line then I edited the file and changed all Z- axis moves to F. It's the first picture in post #484. The second picture was done with the analog code where I varied the power of the laser diode instead of varying the feedrate. The picture in post #499 was done with an edited analog to varied feed rate Gcode also.

      Zoli's code has only one axis on each line which will run rougher like a TTL laser Gcode will run in Mach.

      Jeff

      --- In mach1mach2cnc@yahoogroups.com, "joeyfredrick@..." <joeyfredrick@...> wrote:
      >
      > I'm having the same issue as CSEWE aka Zoli is having. You said you tested his variable feed g-code and it ran intermittently (choppy) and yet you're having success using your own similar code? I don't see how that's possible or what the difference could be in your code unless you're including some G-codes that modify pathing like G64, etc. You mentioned that CAM g-code optimization seems to cause problems and that you keep it broken into tiny same-sized movements, but Zoli's code is also unoptimized. What's the difference between your G-code that works and Zoli's?
      >
      >
      > --- In mach1mach2cnc@yahoogroups.com, "picengraver" <picengrave@> wrote:
      > >
      > > I and others are running laser diodes and using variable feed rate (Fx) on each line, and upwards of 300-500K lines successfully. I'm using .066 - not sure about others.
      > >
      > > See this thread: http://hobbycncart.com/forum/63-151-27 for more details.
      > >
      > > John Champlain
      > > www.picengrave.com
      > >
      >
    • picengraver
      Joey and Group, It appears that this issue is caused by running an older version of M3 as verified by some testing I did this morning. Using a later version
      Message 2 of 13 , Apr 2, 2013
      • 0 Attachment
        Joey and Group,
        It appears that this issue is caused by running an older version of M3 as verified by some testing I did this morning. Using a later version (I tried .053 and .062, test code with a feed rate on each line runs smooth and quickly.

        The same test code ran in 21 min 12 sec. on .062, but I'm to old now to wait for it to complete on .029. It appears it will literally take hours for the 24,761 lines of code to finish.

        If any wish to test for them selves, Zoli's test code can be found here: http://hobbycncart.com/forum/63-151-28 - thread #543.

        Regards,
        John Champlain


        --- In mach1mach2cnc@yahoogroups.com, "picengraver" <picengrave@...> wrote:
        >
        > Joey,
        > When I tested Zoli's code, my laser machine was not available, so I used my larger router (with a SmoothStepper/Geckos). I had assumed both machines would run the same. Not true.
      • joeyfredrick@ymail.com
        Thanks a bunch for the suggestion. Version .062 runs the code smooth. I had also tried Jeffrey s suggestion of adding Y and Z coords and that didn t help. It
        Message 3 of 13 , Apr 2, 2013
        • 0 Attachment
          Thanks a bunch for the suggestion. Version .062 runs the code smooth. I had also tried Jeffrey's suggestion of adding Y and Z coords and that didn't help. It seems some versions of Mach3 have this problem and some don't.

          --- In mach1mach2cnc@yahoogroups.com, "picengraver" <picengrave@...> wrote:
          >
          > Joey,
          > When I tested Zoli's code, my laser machine was not available, so I used my larger router (with a SmoothStepper/Geckos). I had assumed both machines would run the same. Not true.
          >
          > I just went out and tested Zoli's code on my laser machine (PPort amd HobbyCNC controller) and it runs very smooth, as in Extremely Smooth. Absolutely no jerking or hesitation or feed rate going to zero. So, now I am puzzled. There has to be something different in the two machines. I run .066 on the large machine and .062 on the laser machine. Perhaps that is it. Unfortunately, each of my machines is in a different location, so I can not compare M3 settings just now.
          >
          > I also compiled Zoli's image with my program in inch mode and ran the gcode, and it is just as smooth, so it is not likely a difference in gcode format or metric/inch.
          >
          > I will be happy to work with you off line to see if we can figure out why this is happening (probably would take up too much bandwidth to do it on the group). Please PM me at: picengraveATverizon.net.
          >
          > Regards,
          > John Champlain
        Your message has been successfully submitted and would be delivered to recipients shortly.