Loading ...
Sorry, an error occurred while loading the content.

Re: [mach1mach2cnc] Run away stepper and locked up PC

Expand Messages
  • Richard
    I can t help on your run away but that is why it s highly recommended that your ESD (Emergency Shutdown) Button switch off main power to the motor supply. I
    Message 1 of 18 , Aug 2, 2012
    • 0 Attachment
      I can't help on your run away but that is why it's highly recommended that your ESD (Emergency Shutdown) Button switch off main power to the motor supply. I had this happen with my big servos and it had enough force to tear up some stuff. Now, the ESD ties into Mach and powers my contactor to the motor supply.

      Richard


      ----- Original Message -----
      From: Don
      To: mach1mach2cnc@yahoogroups.com
      Sent: Thursday, August 02, 2012 7:50 PM
      Subject: [mach1mach2cnc] Run away stepper and locked up PC



      I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.

      It has to be something in Mach3 as it is continuing to pump out step pulses.

      For the jog, I am using the tab key jog and was running it in continuous mode.

      Any Ideas as where to look for the problem???

      Don





      [Non-text portions of this message have been removed]
    • Don
      Art, I had it maxed out at 100. Interesting though, I reset it to 25 and then shut down and re-started. I get a message that one or more axis are set to fast
      Message 2 of 18 , Aug 2, 2012
      • 0 Attachment
        Art, I had it maxed out at 100. Interesting though, I reset it to 25 and then shut down and re-started. I get a message that one or more axis are set to fast for the 25 kernel speed. It turns out I had the A set at 60 in/min. The Z however defaults to 15 in/min because of the 100,000 steps/in micro stepping. The other axes are st a 40,000 steps / in

        The processor is an AMD64 3400. 2.2ghz. with a 1600 FSB an 1 gig memory. I'm running Win XP pro with all the latest updates. The only thing running is Mach3 and until I can find a way to shut it down completely, McAfee AV I have the wireless disabled. A plain vanilla as possible

        Is there a table available to show the max steps for each kernel speed?

        Seems the more I know, the more confused I'm getting.

        Don


        --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@...> wrote:
        >
        > Don:
        >
        > Sounds like a kernal speed set too high... How high do you have it set?
        >
        >
        > Thanks,
        > Art
        > www.gearotic.com
        >
        >
        >
        >
        > ----- Original Message -----
        > From: Don
        > To: mach1mach2cnc@yahoogroups.com
        > Sent: Thursday, August 02, 2012 9:50 PM
        > Subject: [mach1mach2cnc] Run away stepper and locked up PC
        >
        >
        >
        > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
        >
        > It has to be something in Mach3 as it is continuing to pump out step pulses.
        >
        > For the jog, I am using the tab key jog and was running it in continuous mode.
        >
        > Any Ideas as where to look for the problem???
        >
        > Don
        >
        >
        >
        >
        >
        > [Non-text portions of this message have been removed]
        >
      • Don
        Richard, my EPO does shut off the main power to the stepper drives. As for it being tied into Mach, that would have done little good as Mach was frozen up and
        Message 3 of 18 , Aug 2, 2012
        • 0 Attachment
          Richard, my EPO does shut off the main power to the stepper drives. As for it being tied into Mach, that would have done little good as Mach was frozen up and not responding to anything, neither was the PC.

          Don


          --- In mach1mach2cnc@yahoogroups.com, "Richard" <rwskinner@...> wrote:
          >
          > I can't help on your run away but that is why it's highly recommended that your ESD (Emergency Shutdown) Button switch off main power to the motor supply. I had this happen with my big servos and it had enough force to tear up some stuff. Now, the ESD ties into Mach and powers my contactor to the motor supply.
          >
          > Richard
          >
          >
          > ----- Original Message -----
          > From: Don
          > To: mach1mach2cnc@yahoogroups.com
          > Sent: Thursday, August 02, 2012 7:50 PM
          > Subject: [mach1mach2cnc] Run away stepper and locked up PC
          >
          >
          >
          > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
          >
          > It has to be something in Mach3 as it is continuing to pump out step pulses.
          >
          > For the jog, I am using the tab key jog and was running it in continuous mode.
          >
          > Any Ideas as where to look for the problem???
          >
          > Don
          >
          >
          >
          >
          >
          > [Non-text portions of this message have been removed]
          >
        • Richard
          Sorry, I mis-read. I thought they kept running afterwards. My bad. Richard ... From: Don To: mach1mach2cnc@yahoogroups.com Sent: Thursday, August 02, 2012
          Message 4 of 18 , Aug 2, 2012
          • 0 Attachment
            Sorry, I mis-read. I thought they kept running afterwards. My bad.

            Richard

            ----- Original Message -----
            From: Don
            To: mach1mach2cnc@yahoogroups.com
            Sent: Thursday, August 02, 2012 10:28 PM
            Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC




            Richard, my EPO does shut off the main power to the stepper drives. As for it being tied into Mach, that would have done little good as Mach was frozen up and not responding to anything, neither was the PC.

            Don

            --- In mach1mach2cnc@yahoogroups.com, "Richard" <rwskinner@...> wrote:
            >
            > I can't help on your run away but that is why it's highly recommended that your ESD (Emergency Shutdown) Button switch off main power to the motor supply. I had this happen with my big servos and it had enough force to tear up some stuff. Now, the ESD ties into Mach and powers my contactor to the motor supply.
            >
            > Richard
            >
            >
            > ----- Original Message -----
            > From: Don
            > To: mach1mach2cnc@yahoogroups.com
            > Sent: Thursday, August 02, 2012 7:50 PM
            > Subject: [mach1mach2cnc] Run away stepper and locked up PC
            >
            >
            >
            > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
            >
            > It has to be something in Mach3 as it is continuing to pump out step pulses.
            >
            > For the jog, I am using the tab key jog and was running it in continuous mode.
            >
            > Any Ideas as where to look for the problem???
            >
            > Don
            >
            >
            >
            >
            >
            > [Non-text portions of this message have been removed]
            >





            [Non-text portions of this message have been removed]
          • Don
            I wish I could say I never mis-read anything, but it s getting more and more likely I will lately. Anyway, I need to rig up a dump setup for the EPO. In my
            Message 5 of 18 , Aug 2, 2012
            • 0 Attachment
              I wish I could say I never mis-read anything, but it's getting more and more likely I will lately. Anyway, I need to rig up a dump setup for the EPO. In my recent problem, the motor kept turning for close to a second and a half after the EPO switch was hit There is quite a bit of power stored in the PS Filer Cap, enough for a second or two of one motor running.

              My late younger brother was a CNC expert/trainer for GM. He told me once that the one thing he really wanted was what he called a Pucker Switch. As he explained it, you sensed something was going wrong and your back and butt tensed up prior to your being able to reach the EPO and hit it. His Pucker switch would cut the down the response time.

              I could have used one today. Luckily I wasn't operating an connected axis.

              Don


              --- In mach1mach2cnc@yahoogroups.com, "Richard" <rwskinner@...> wrote:
              >
              > Sorry, I mis-read. I thought they kept running afterwards. My bad.
              >
              > Richard
              >
              > ----- Original Message -----
              > From: Don
              > To: mach1mach2cnc@yahoogroups.com
              > Sent: Thursday, August 02, 2012 10:28 PM
              > Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC
              >
              >
              >
              >
              > Richard, my EPO does shut off the main power to the stepper drives. As for it being tied into Mach, that would have done little good as Mach was frozen up and not responding to anything, neither was the PC.
              >
              > Don
              >
              > --- In mach1mach2cnc@yahoogroups.com, "Richard" <rwskinner@> wrote:
              > >
              > > I can't help on your run away but that is why it's highly recommended that your ESD (Emergency Shutdown) Button switch off main power to the motor supply. I had this happen with my big servos and it had enough force to tear up some stuff. Now, the ESD ties into Mach and powers my contactor to the motor supply.
              > >
              > > Richard
              > >
              > >
              > > ----- Original Message -----
              > > From: Don
              > > To: mach1mach2cnc@yahoogroups.com
              > > Sent: Thursday, August 02, 2012 7:50 PM
              > > Subject: [mach1mach2cnc] Run away stepper and locked up PC
              > >
              > >
              > >
              > > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
              > >
              > > It has to be something in Mach3 as it is continuing to pump out step pulses.
              > >
              > > For the jog, I am using the tab key jog and was running it in continuous mode.
              > >
              > > Any Ideas as where to look for the problem???
              > >
              > > Don
              > >
              > >
              > >
              > >
              > >
              > > [Non-text portions of this message have been removed]
              > >
              >
              >
              >
              >
              >
              > [Non-text portions of this message have been removed]
              >
            • Craig
              Don, One thing you will discover as you play with the steppers is the stepper troque really drops off with RPM at 100K pulses per inch your rpm is going to be
              Message 6 of 18 , Aug 2, 2012
              • 0 Attachment
                Don,
                One thing you will discover as you play with the steppers is the stepper troque really drops off with RPM at 100K pulses per inch your rpm is going to be very high with any kind of mill rapids. You can een get to the point where there is not enough torque even to drive the motor's rotor load. Take a look at the RPM vs Torque curve for your motor.

                I am running 10x micro stepping with 20K pulses/inch on my BP conversoin and about the best I can do is 75 to 100 IPM rapids. This is where servos beat steppers.

                Craig


                --- In mach1mach2cnc@yahoogroups.com, "Don" <Don@...> wrote:
                >
                > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
                >
                > It has to be something in Mach3 as it is continuing to pump out step pulses.
                >
                > For the jog, I am using the tab key jog and was running it in continuous mode.
                >
                > Any Ideas as where to look for the problem???
                >
                > Don
                >
              • Don
                Craig, your numbers sound reasonable. In my case, 40 in/min is the best I can do without stalling the steppers if I go with the 10X micro stepping which is
                Message 7 of 18 , Aug 2, 2012
                • 0 Attachment
                  Craig, your numbers sound reasonable. In my case, 40 in/min is the best I can do without stalling the steppers if I go with the 10X micro stepping which is which is where I started. Actually, with the high steps / inch, the RPM drops considerably. There is a balance I cant seem to find. My best speed was 40 in/min rapids at which is way off your numbers.

                  The torque curves from my motors shows I should be able to reach 3K rpm while I'm only able to get into the low 900 rpm range. Something is wrong. It's an interesting problem. Wish I had the budget for Servos.

                  Don

                  --- In mach1mach2cnc@yahoogroups.com, "Craig" <cs6061@...> wrote:
                  >
                  > Don,
                  > One thing you will discover as you play with the steppers is the stepper troque really drops off with RPM at 100K pulses per inch your rpm is going to be very high with any kind of mill rapids. You can een get to the point where there is not enough torque even to drive the motor's rotor load. Take a look at the RPM vs Torque curve for your motor.
                  >
                  > I am running 10x micro stepping with 20K pulses/inch on my BP conversoin and about the best I can do is 75 to 100 IPM rapids. This is where servos beat steppers.
                  >
                  > Craig
                  >
                  >
                  > --- In mach1mach2cnc@yahoogroups.com, "Don" <Don@> wrote:
                  > >
                  > > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
                  > >
                  > > It has to be something in Mach3 as it is continuing to pump out step pulses.
                  > >
                  > > For the jog, I am using the tab key jog and was running it in continuous mode.
                  > >
                  > > Any Ideas as where to look for the problem???
                  > >
                  > > Don
                  > >
                  >
                • John Dammeyer
                  Hi Don, I think you maybe interpreting your torque curves incorrectly. Most Steppers don t get past about 700 RPM without significant torque loss. Bigger
                  Message 8 of 18 , Aug 3, 2012
                  • 0 Attachment
                    Hi Don,

                    I think you maybe interpreting your torque curves incorrectly. Most
                    Steppers don't get past about 700 RPM without significant torque loss.
                    Bigger (size 34 and 43) don't do as well as 23's. Serial winding is 4x as
                    bad as parallel winding configuration.

                    I find with 8steps/step and a 3A driver with 50V that I get about 700RPM
                    with light load. With a GECKO and same voltage and 10 steps/step only a
                    smoother sound from the motor and I have to have a higher step rate to get
                    the same motor speed.

                    For simplicity instead of talking about ipm (dependant on drive belts and
                    ead screw pitch) just report step rates. I think you will find that
                    unless your motors are dramatically over powered for your system that
                    25kHz to 30kHz is all you will manage.

                    To turn that into ipm lets work backwards. Say you can get decent torque
                    at 600 RPM with a 10 step/step driver like a Gecko at 65V. (higher
                    voltage translates to faster motors).

                    600RPM is the same as 10 RPS. And you have a 200 step motor with 10
                    microsteps so you have 2000 steps per rev. That means to get 10RPS if
                    your step rate is 20kHz. With a 5 TPI screw each rev moves 0.2" or at
                    speed 2" per second which is 120"/minute. But the torque falls off quite
                    a bit at that RPM.

                    And really if you only need 0.0005" resolution and you have 5x that this
                    is the place to change things. Use belts instead of direct drive and cut
                    the speed to 10kHz. You now have more torque, the same speed and 0.0002"
                    resolution. For accuracy aim at the half step per 0.0005" so go 1:5.
                    Make the motor receive 2000 steps to move the lead screw 400 divisions or
                    0.0005" again assuming you have a 5 TPI lead screw.

                    The torque would be reduced by 1/5. That may be too much. There will be
                    a compromise.

                    High RPM for the servo motor is almost always reduced back down to stepper
                    motor speeds with belts. Leadscrews don't like to turn 3000 RPM.

                    John Dammeyer

                    > The torque curves from my motors shows I should be able to
                    > reach 3K rpm while I'm only able to get into the low 900 rpm
                    > range. Something is wrong. It's an interesting problem.
                    > Wish I had the budget for Servos.
                    >
                    > Don
                    >
                    > --- In mach1mach2cnc@yahoogroups.com, "Craig" <cs6061@...> wrote:
                    > >
                    > > Don,
                    > > One thing you will discover as you play with the steppers
                    > is the stepper troque really drops off with RPM at 100K
                    > pulses per inch your rpm is going to be very high with any
                    > kind of mill rapids. You can een get to the point where
                    > there is not enough torque even to drive the motor's rotor
                    > load. Take a look at the RPM vs Torque curve for your motor.
                    > >
                    > > I am running 10x micro stepping with 20K pulses/inch on my
                    > BP conversoin and about the best I can do is 75 to 100 IPM
                    > rapids. This is where servos beat steppers.
                    > >
                    > > Craig
                    > >
                    > >
                    > > --- In mach1mach2cnc@yahoogroups.com, "Don" <Don@> wrote:
                    > > >
                    > > > I've been trying to get my steppers to not stall out
                    > above 40 in/min. One of the guys suggested that I change the
                    > micro stepping to see if that helped. I have the Z motor
                    > free on the bench so I've been testing that setup. I was
                    > originally micro stepping at 2000 steps / rev or 40,000 steps
                    > / inch. I went to 5000 steps / rev, or 100,000 per inch. I
                    > hit the Jog, and held it and the motor was running, but no
                    > feed rate was shown on the screen. I let up on the jog and
                    > the motor kept running. The screen was locked up, the DRO
                    > displays were stopped. I hit the EPO to kill the motor
                    > drivers. I had to do the long power on push button to power
                    > off the PC, everything was locked up. After the power off, I
                    > restarted the PC and started Mach3. I had to go back to the
                    > motor tuning and change the Z to the new settings as nothing
                    > was stored do to the crash shutdown. I then powered on the
                    > drivers and hit the jog and run away and locked up PC again.
                    > > >
                    > > > It has to be something in Mach3 as it is continuing to
                    > pump out step pulses.
                    > > >
                    > > > For the jog, I am using the tab key jog and was running
                    > it in continuous mode.
                    > > >
                    > > > Any Ideas as where to look for the problem???
                    > > >
                    > > > Don
                    > > >
                    > >
                    >
                    >
                    >
                    >
                    > ------------------------------------
                    >
                    > www.machsupport.com - Web site AccessYahoo! Groups Links
                    >
                    >
                    >
                    >
                  • Tony Smith
                    ... can ... is ... drops ... 40 ... Mach3 has a test program that ll tell you the maximum kernel speed your PC can run at. You may not need the maximum, of
                    Message 9 of 18 , Aug 3, 2012
                    • 0 Attachment
                      > Craig, your numbers sound reasonable. In my case, 40 in/min is the best I
                      can
                      > do without stalling the steppers if I go with the 10X micro stepping which
                      is
                      > which is where I started. Actually, with the high steps / inch, the RPM
                      drops
                      > considerably. There is a balance I cant seem to find. My best speed was
                      40
                      > in/min rapids at which is way off your numbers.


                      Mach3 has a test program that'll tell you the maximum kernel speed your PC
                      can run at.

                      You may not need the maximum, of course. To work out what you need it's a
                      simple formula: Motor resolution x microsteps x leadscrew pitch x IPM / 60.

                      You didn't say what your leadscrew is so, I'll just use 10 TPI. So you have
                      200 x 10 x 10 x 40 / 60 which is 13,333 steps per second, well under the
                      default 25,000 Mach3 pulse rate.

                      The motor RPM is calculated by the formula: steps per second / (motor
                      resolution x microsteps) x 60, so 13,333 / (200 x 10) x 60, giving 400 RPM.

                      For 60 IPM that goes up to 20,000 steps per second, still well within
                      reason. Motor RPM jumps to 600 RPM, again reasonable.

                      For 16 microsteps & 60 IPM you need 32,000 steps per second, you'd need to
                      bump the Mach3 pulse rate up to 35,000.

                      Setting the pulse rate to 100k is a bit of overkill, and a waste of time.

                      Ignore that fact the motor can turn at 3,000 RPM, it won't have any torque.
                      Without a load it'll work, once back in the machine it'll stall.

                      You might also try dropping the microstepping rate, you may need a bit of
                      trial & error to get something that works.

                      Tony
                    • picengraver
                      Don, What power supply voltage are you using? I don t recall this being mentioned. If you are running low voltage (i.e. 24 VDC), this may be your limiting
                      Message 10 of 18 , Aug 3, 2012
                      • 0 Attachment
                        Don,
                        What power supply voltage are you using? I don't recall this being mentioned.

                        If you are running low voltage (i.e. 24 VDC), this may be your limiting factor. Please describe your controller system.

                        Also, I'm confused about something you wrote. You said (I think) that Mach3 was frozen or locked up, but your steppers kept running for 1.5 seconds because of a large reserve in your power supply. How can this be? Steppers can't run unless receiving pulses from Mach3.

                        Regards,
                        John Champlain
                        www.picengrave.com

                        -
                      • Don
                        John, the power supply is s Copley 66V at 8 amps, with a secondary tap for 33V. As it is currently wired, I m using 66V. The 8 amps is good for three motors in
                        Message 11 of 18 , Aug 3, 2012
                        • 0 Attachment
                          John, the power supply is s Copley 66V at 8 amps, with a secondary tap for 33V. As it is currently wired, I'm using 66V. The 8 amps is good for three motors in series. The motors are rated at 2.3 amps in series and 4.6 in parallel. The drivers are current limiting, and set for the 2.3 amp ratting of the steppers.

                          The Compumotor user guide states to wire parallel for 24V - 48V and Series for 48V - 75V. So, for the amps available and this recommendation, I went with a series wiring.

                          Now, on your question about the motor continuing to turn after the EPO was hit. The EPO only cuts power to the driver by disrupting the primary of the power supply. While the PC was locked up, mach3 was still pumping out step pulses or the motors would have stopped as you pointed out. My plan is to use the secondary switch in the EPO to drive the "Remote Input" signal which will allow me to cut power to the motors. I just haven't got to that point in the rebuild yet, but was wishing I had yesterday.


                          I'm not arguing that my setup is correct, but just explaining why it is the way it is.


                          Tony, I ran the kernel test before choosing the 100K it showed a steady good stream at 100K. I'll check it again though.

                          Don

                          --- In mach1mach2cnc@yahoogroups.com, "picengraver" <picengrave@...> wrote:
                          >
                          > Don,
                          > What power supply voltage are you using? I don't recall this being mentioned.
                          >
                          > If you are running low voltage (i.e. 24 VDC), this may be your limiting factor. Please describe your controller system.
                          >
                          > Also, I'm confused about something you wrote. You said (I think) that Mach3 was frozen or locked up, but your steppers kept running for 1.5 seconds because of a large reserve in your power supply. How can this be? Steppers can't run unless receiving pulses from Mach3.
                          >
                          > Regards,
                          > John Champlain
                          > www.picengrave.com
                          >
                          > -
                          >
                        • art2
                          Don: Thats why then. Stay away from 100K, rarely can a computer handle it. Set it to 65K and live whith whatever top speed you can get. There is no max
                          Message 12 of 18 , Aug 3, 2012
                          • 0 Attachment
                            Don:

                            Thats why then. Stay away from 100K, rarely can a computer handle it. Set it to 65K and live whith whatever top speed you can get. There is no max steps/unit at any speed, but if you set a max velocity that cant be handled at a particular kernal speed youll get a warning to slow it down. Kernal speeds limit max speed, not steps/unit. If you have an axis set to 100K steps per unit, and a kernal speed of 50K, then your maxed at 1/2 unit per second, or 30 inches per minute.

                            Thanks,
                            Art
                            www.gearotic.com




                            ----- Original Message -----
                            From: Don
                            To: mach1mach2cnc@yahoogroups.com
                            Sent: Friday, August 03, 2012 12:24 AM
                            Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC



                            Art, I had it maxed out at 100. Interesting though, I reset it to 25 and then shut down and re-started. I get a message that one or more axis are set to fast for the 25 kernel speed. It turns out I had the A set at 60 in/min. The Z however defaults to 15 in/min because of the 100,000 steps/in micro stepping. The other axes are st a 40,000 steps / in

                            The processor is an AMD64 3400. 2.2ghz. with a 1600 FSB an 1 gig memory. I'm running Win XP pro with all the latest updates. The only thing running is Mach3 and until I can find a way to shut it down completely, McAfee AV I have the wireless disabled. A plain vanilla as possible

                            Is there a table available to show the max steps for each kernel speed?

                            Seems the more I know, the more confused I'm getting.

                            Don

                            --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@...> wrote:
                            >
                            > Don:
                            >
                            > Sounds like a kernal speed set too high... How high do you have it set?
                            >
                            >
                            > Thanks,
                            > Art
                            > www.gearotic.com
                            >
                            >
                            >
                            >
                            > ----- Original Message -----
                            > From: Don
                            > To: mach1mach2cnc@yahoogroups.com
                            > Sent: Thursday, August 02, 2012 9:50 PM
                            > Subject: [mach1mach2cnc] Run away stepper and locked up PC
                            >
                            >
                            >
                            > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
                            >
                            > It has to be something in Mach3 as it is continuing to pump out step pulses.
                            >
                            > For the jog, I am using the tab key jog and was running it in continuous mode.
                            >
                            > Any Ideas as where to look for the problem???
                            >
                            > Don
                            >
                            >
                            >
                            >
                            >
                            > [Non-text portions of this message have been removed]
                            >





                            [Non-text portions of this message have been removed]
                          • Don
                            Art, I changed the Kernel to 75k and went through the axis again. I can get all three axis to run smooth and strong at 40 in/min. I seem to be stuck with an
                            Message 13 of 18 , Aug 3, 2012
                            • 0 Attachment
                              Art, I changed the Kernel to 75k and went through the axis again. I can get all three axis to run smooth and strong at 40 in/min. I seem to be stuck with an 800rpm max on the steppers I have. I can't seem to get over the mid range stall. I think I can live with it, I'll probably knock the Kernel back another notch just to give me some more cushion on the Mach3 lockup.

                              Thanks to all for your help. I'll probably be back for more later.

                              Don

                              --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@...> wrote:
                              >
                              > Don:
                              >
                              > Thats why then. Stay away from 100K, rarely can a computer handle it. Set it to 65K and live whith whatever top speed you can get. There is no max steps/unit at any speed, but if you set a max velocity that cant be handled at a particular kernal speed youll get a warning to slow it down. Kernal speeds limit max speed, not steps/unit. If you have an axis set to 100K steps per unit, and a kernal speed of 50K, then your maxed at 1/2 unit per second, or 30 inches per minute.
                              >
                              > Thanks,
                              > Art
                              > www.gearotic.com
                              >
                              >
                              >
                              >
                              > ----- Original Message -----
                              > From: Don
                              > To: mach1mach2cnc@yahoogroups.com
                              > Sent: Friday, August 03, 2012 12:24 AM
                              > Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC
                              >
                              >
                              >
                              > Art, I had it maxed out at 100. Interesting though, I reset it to 25 and then shut down and re-started. I get a message that one or more axis are set to fast for the 25 kernel speed. It turns out I had the A set at 60 in/min. The Z however defaults to 15 in/min because of the 100,000 steps/in micro stepping. The other axes are st a 40,000 steps / in
                              >
                              > The processor is an AMD64 3400. 2.2ghz. with a 1600 FSB an 1 gig memory. I'm running Win XP pro with all the latest updates. The only thing running is Mach3 and until I can find a way to shut it down completely, McAfee AV I have the wireless disabled. A plain vanilla as possible
                              >
                              > Is there a table available to show the max steps for each kernel speed?
                              >
                              > Seems the more I know, the more confused I'm getting.
                              >
                              > Don
                              >
                              > --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@> wrote:
                              > >
                              > > Don:
                              > >
                              > > Sounds like a kernal speed set too high... How high do you have it set?
                              > >
                              > >
                              > > Thanks,
                              > > Art
                              > > www.gearotic.com
                              > >
                              > >
                              > >
                              > >
                              > > ----- Original Message -----
                              > > From: Don
                              > > To: mach1mach2cnc@yahoogroups.com
                              > > Sent: Thursday, August 02, 2012 9:50 PM
                              > > Subject: [mach1mach2cnc] Run away stepper and locked up PC
                              > >
                              > >
                              > >
                              > > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
                              > >
                              > > It has to be something in Mach3 as it is continuing to pump out step pulses.
                              > >
                              > > For the jog, I am using the tab key jog and was running it in continuous mode.
                              > >
                              > > Any Ideas as where to look for the problem???
                              > >
                              > > Don
                              > >
                              > >
                              > >
                              > >
                              > >
                              > > [Non-text portions of this message have been removed]
                              > >
                              >
                              >
                              >
                              >
                              >
                              > [Non-text portions of this message have been removed]
                              >
                            • art2
                              Don: Microstepping should be set as close to 2000 or so as you can get it, extra smoothness as you go higher diminishes the higher you go, so 8000 steps per
                              Message 14 of 18 , Aug 3, 2012
                              • 0 Attachment
                                Don:

                                Microstepping should be set as close to 2000 or so as you can get it, extra smoothness as you go higher diminishes the higher you go, so 8000 steps per rev is pretty much the upper limit for a driver, any higher and you just fool yourself into thinking its smoother. The lower you set the microsteps, the more easily youll pass the midrange instability ( so long as your above 2000 or so.). Having it too high actually hurts responce overall. Microsteps are not evenly spaced, they are more of a statistical probability in terms of granularity of distance, so try lowering the microsteps if you have them set too high.
                                Then retune the motors.. Youll likely be happier overall ang get higher speeds..



                                Thanks,
                                Art
                                www.gearotic.com




                                ----- Original Message -----
                                From: Don
                                To: mach1mach2cnc@yahoogroups.com
                                Sent: Friday, August 03, 2012 6:03 PM
                                Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC



                                Art, I changed the Kernel to 75k and went through the axis again. I can get all three axis to run smooth and strong at 40 in/min. I seem to be stuck with an 800rpm max on the steppers I have. I can't seem to get over the mid range stall. I think I can live with it, I'll probably knock the Kernel back another notch just to give me some more cushion on the Mach3 lockup.

                                Thanks to all for your help. I'll probably be back for more later.

                                Don

                                --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@...> wrote:
                                >
                                > Don:
                                >
                                > Thats why then. Stay away from 100K, rarely can a computer handle it. Set it to 65K and live whith whatever top speed you can get. There is no max steps/unit at any speed, but if you set a max velocity that cant be handled at a particular kernal speed youll get a warning to slow it down. Kernal speeds limit max speed, not steps/unit. If you have an axis set to 100K steps per unit, and a kernal speed of 50K, then your maxed at 1/2 unit per second, or 30 inches per minute.
                                >
                                > Thanks,
                                > Art
                                > www.gearotic.com
                                >
                                >
                                >
                                >
                                > ----- Original Message -----
                                > From: Don
                                > To: mach1mach2cnc@yahoogroups.com
                                > Sent: Friday, August 03, 2012 12:24 AM
                                > Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC
                                >
                                >
                                >
                                > Art, I had it maxed out at 100. Interesting though, I reset it to 25 and then shut down and re-started. I get a message that one or more axis are set to fast for the 25 kernel speed. It turns out I had the A set at 60 in/min. The Z however defaults to 15 in/min because of the 100,000 steps/in micro stepping. The other axes are st a 40,000 steps / in
                                >
                                > The processor is an AMD64 3400. 2.2ghz. with a 1600 FSB an 1 gig memory. I'm running Win XP pro with all the latest updates. The only thing running is Mach3 and until I can find a way to shut it down completely, McAfee AV I have the wireless disabled. A plain vanilla as possible
                                >
                                > Is there a table available to show the max steps for each kernel speed?
                                >
                                > Seems the more I know, the more confused I'm getting.
                                >
                                > Don
                                >
                                > --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@> wrote:
                                > >
                                > > Don:
                                > >
                                > > Sounds like a kernal speed set too high... How high do you have it set?
                                > >
                                > >
                                > > Thanks,
                                > > Art
                                > > www.gearotic.com
                                > >
                                > >
                                > >
                                > >
                                > > ----- Original Message -----
                                > > From: Don
                                > > To: mach1mach2cnc@yahoogroups.com
                                > > Sent: Thursday, August 02, 2012 9:50 PM
                                > > Subject: [mach1mach2cnc] Run away stepper and locked up PC
                                > >
                                > >
                                > >
                                > > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
                                > >
                                > > It has to be something in Mach3 as it is continuing to pump out step pulses.
                                > >
                                > > For the jog, I am using the tab key jog and was running it in continuous mode.
                                > >
                                > > Any Ideas as where to look for the problem???
                                > >
                                > > Don
                                > >
                                > >
                                > >
                                > >
                                > >
                                > > [Non-text portions of this message have been removed]
                                > >
                                >
                                >
                                >
                                >
                                >
                                > [Non-text portions of this message have been removed]
                                >





                                [Non-text portions of this message have been removed]
                              • Don
                                Art I started with the micro step at x10 or 2000. I haven t tried to go lower and going higher didn t help either. It turns out that these motors have the
                                Message 15 of 18 , Aug 3, 2012
                                • 0 Attachment
                                  Art

                                  I started with the micro step at x10 or 2000. I haven't tried to go lower and going higher didn't help either. It turns out that these motors have the low inertia rotors, the M22 J series. I don't know it that enters into the mix or not. I have some single stack steppers of the powermaxII series and threw one on in place of my Z and I was able to get it up over 80 in/min without any tuning. This was just to see if I could. I don't have any other two stack motors to try. I do have a single OEM 750 driver that is my next experiment. I just have to find out if I need to put the 5 jumpers on the interface to the indexer card like on the 650's

                                  Don

                                  --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@...> wrote:
                                  >
                                  > Don:
                                  >
                                  > Microstepping should be set as close to 2000 or so as you can get it, extra smoothness as you go higher diminishes the higher you go, so 8000 steps per rev is pretty much the upper limit for a driver, any higher and you just fool yourself into thinking its smoother. The lower you set the microsteps, the more easily youll pass the midrange instability ( so long as your above 2000 or so.). Having it too high actually hurts responce overall. Microsteps are not evenly spaced, they are more of a statistical probability in terms of granularity of distance, so try lowering the microsteps if you have them set too high.
                                  > Then retune the motors.. Youll likely be happier overall ang get higher speeds..
                                  >
                                  >
                                  >
                                  > Thanks,
                                  > Art
                                  > www.gearotic.com
                                  >
                                  >
                                  >
                                  >
                                  > ----- Original Message -----
                                  > From: Don
                                  > To: mach1mach2cnc@yahoogroups.com
                                  > Sent: Friday, August 03, 2012 6:03 PM
                                  > Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC
                                  >
                                  >
                                  >
                                  > Art, I changed the Kernel to 75k and went through the axis again. I can get all three axis to run smooth and strong at 40 in/min. I seem to be stuck with an 800rpm max on the steppers I have. I can't seem to get over the mid range stall. I think I can live with it, I'll probably knock the Kernel back another notch just to give me some more cushion on the Mach3 lockup.
                                  >
                                  > Thanks to all for your help. I'll probably be back for more later.
                                  >
                                  > Don
                                  >
                                  > --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@> wrote:
                                  > >
                                  > > Don:
                                  > >
                                  > > Thats why then. Stay away from 100K, rarely can a computer handle it. Set it to 65K and live whith whatever top speed you can get. There is no max steps/unit at any speed, but if you set a max velocity that cant be handled at a particular kernal speed youll get a warning to slow it down. Kernal speeds limit max speed, not steps/unit. If you have an axis set to 100K steps per unit, and a kernal speed of 50K, then your maxed at 1/2 unit per second, or 30 inches per minute.
                                  > >
                                  > > Thanks,
                                  > > Art
                                  > > www.gearotic.com
                                  > >
                                  > >
                                  > >
                                  > >
                                  > > ----- Original Message -----
                                  > > From: Don
                                  > > To: mach1mach2cnc@yahoogroups.com
                                  > > Sent: Friday, August 03, 2012 12:24 AM
                                  > > Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC
                                  > >
                                  > >
                                  > >
                                  > > Art, I had it maxed out at 100. Interesting though, I reset it to 25 and then shut down and re-started. I get a message that one or more axis are set to fast for the 25 kernel speed. It turns out I had the A set at 60 in/min. The Z however defaults to 15 in/min because of the 100,000 steps/in micro stepping. The other axes are st a 40,000 steps / in
                                  > >
                                  > > The processor is an AMD64 3400. 2.2ghz. with a 1600 FSB an 1 gig memory. I'm running Win XP pro with all the latest updates. The only thing running is Mach3 and until I can find a way to shut it down completely, McAfee AV I have the wireless disabled. A plain vanilla as possible
                                  > >
                                  > > Is there a table available to show the max steps for each kernel speed?
                                  > >
                                  > > Seems the more I know, the more confused I'm getting.
                                  > >
                                  > > Don
                                  > >
                                  > > --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@> wrote:
                                  > > >
                                  > > > Don:
                                  > > >
                                  > > > Sounds like a kernal speed set too high... How high do you have it set?
                                  > > >
                                  > > >
                                  > > > Thanks,
                                  > > > Art
                                  > > > www.gearotic.com
                                  > > >
                                  > > >
                                  > > >
                                  > > >
                                  > > > ----- Original Message -----
                                  > > > From: Don
                                  > > > To: mach1mach2cnc@yahoogroups.com
                                  > > > Sent: Thursday, August 02, 2012 9:50 PM
                                  > > > Subject: [mach1mach2cnc] Run away stepper and locked up PC
                                  > > >
                                  > > >
                                  > > >
                                  > > > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
                                  > > >
                                  > > > It has to be something in Mach3 as it is continuing to pump out step pulses.
                                  > > >
                                  > > > For the jog, I am using the tab key jog and was running it in continuous mode.
                                  > > >
                                  > > > Any Ideas as where to look for the problem???
                                  > > >
                                  > > > Don
                                  > > >
                                  > > >
                                  > > >
                                  > > >
                                  > > >
                                  > > > [Non-text portions of this message have been removed]
                                  > > >
                                  > >
                                  > >
                                  > >
                                  > >
                                  > >
                                  > > [Non-text portions of this message have been removed]
                                  > >
                                  >
                                  >
                                  >
                                  >
                                  >
                                  > [Non-text portions of this message have been removed]
                                  >
                                • Don
                                  Well the OEM750 experiment didn t go well. Seem is is shorted out and blew the fuse in my power supply. It s a shame as it turns out the major difference
                                  Message 16 of 18 , Aug 3, 2012
                                  • 0 Attachment
                                    Well the OEM750 experiment didn't go well. Seem is is shorted out and blew the fuse in my power supply. It's a shame as it turns out the major difference between it and the 650 is that it has a built in circuit to address the mid range stalling. I guess 40 in/min is what I have to work with and I might as well enjoy it.

                                    Thanks again for the pointers and suggestions. Great group.

                                    Don

                                    --- In mach1mach2cnc@yahoogroups.com, "Don" <Don@...> wrote:
                                    >
                                    > Art
                                    >
                                    > I started with the micro step at x10 or 2000. I haven't tried to go lower and going higher didn't help either. It turns out that these motors have the low inertia rotors, the M22 J series. I don't know it that enters into the mix or not. I have some single stack steppers of the powermaxII series and threw one on in place of my Z and I was able to get it up over 80 in/min without any tuning. This was just to see if I could. I don't have any other two stack motors to try. I do have a single OEM 750 driver that is my next experiment. I just have to find out if I need to put the 5 jumpers on the interface to the indexer card like on the 650's
                                    >
                                    > Don
                                    >
                                    > --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@> wrote:
                                    > >
                                    > > Don:
                                    > >
                                    > > Microstepping should be set as close to 2000 or so as you can get it, extra smoothness as you go higher diminishes the higher you go, so 8000 steps per rev is pretty much the upper limit for a driver, any higher and you just fool yourself into thinking its smoother. The lower you set the microsteps, the more easily youll pass the midrange instability ( so long as your above 2000 or so.). Having it too high actually hurts responce overall. Microsteps are not evenly spaced, they are more of a statistical probability in terms of granularity of distance, so try lowering the microsteps if you have them set too high.
                                    > > Then retune the motors.. Youll likely be happier overall ang get higher speeds..
                                    > >
                                    > >
                                    > >
                                    > > Thanks,
                                    > > Art
                                    > > www.gearotic.com
                                    > >
                                    > >
                                    > >
                                    > >
                                    > > ----- Original Message -----
                                    > > From: Don
                                    > > To: mach1mach2cnc@yahoogroups.com
                                    > > Sent: Friday, August 03, 2012 6:03 PM
                                    > > Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC
                                    > >
                                    > >
                                    > >
                                    > > Art, I changed the Kernel to 75k and went through the axis again. I can get all three axis to run smooth and strong at 40 in/min. I seem to be stuck with an 800rpm max on the steppers I have. I can't seem to get over the mid range stall. I think I can live with it, I'll probably knock the Kernel back another notch just to give me some more cushion on the Mach3 lockup.
                                    > >
                                    > > Thanks to all for your help. I'll probably be back for more later.
                                    > >
                                    > > Don
                                    > >
                                    > > --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@> wrote:
                                    > > >
                                    > > > Don:
                                    > > >
                                    > > > Thats why then. Stay away from 100K, rarely can a computer handle it. Set it to 65K and live whith whatever top speed you can get. There is no max steps/unit at any speed, but if you set a max velocity that cant be handled at a particular kernal speed youll get a warning to slow it down. Kernal speeds limit max speed, not steps/unit. If you have an axis set to 100K steps per unit, and a kernal speed of 50K, then your maxed at 1/2 unit per second, or 30 inches per minute.
                                    > > >
                                    > > > Thanks,
                                    > > > Art
                                    > > > www.gearotic.com
                                    > > >
                                    > > >
                                    > > >
                                    > > >
                                    > > > ----- Original Message -----
                                    > > > From: Don
                                    > > > To: mach1mach2cnc@yahoogroups.com
                                    > > > Sent: Friday, August 03, 2012 12:24 AM
                                    > > > Subject: [mach1mach2cnc] Re: Run away stepper and locked up PC
                                    > > >
                                    > > >
                                    > > >
                                    > > > Art, I had it maxed out at 100. Interesting though, I reset it to 25 and then shut down and re-started. I get a message that one or more axis are set to fast for the 25 kernel speed. It turns out I had the A set at 60 in/min. The Z however defaults to 15 in/min because of the 100,000 steps/in micro stepping. The other axes are st a 40,000 steps / in
                                    > > >
                                    > > > The processor is an AMD64 3400. 2.2ghz. with a 1600 FSB an 1 gig memory. I'm running Win XP pro with all the latest updates. The only thing running is Mach3 and until I can find a way to shut it down completely, McAfee AV I have the wireless disabled. A plain vanilla as possible
                                    > > >
                                    > > > Is there a table available to show the max steps for each kernel speed?
                                    > > >
                                    > > > Seems the more I know, the more confused I'm getting.
                                    > > >
                                    > > > Don
                                    > > >
                                    > > > --- In mach1mach2cnc@yahoogroups.com, art2 <fenerty@> wrote:
                                    > > > >
                                    > > > > Don:
                                    > > > >
                                    > > > > Sounds like a kernal speed set too high... How high do you have it set?
                                    > > > >
                                    > > > >
                                    > > > > Thanks,
                                    > > > > Art
                                    > > > > www.gearotic.com
                                    > > > >
                                    > > > >
                                    > > > >
                                    > > > >
                                    > > > > ----- Original Message -----
                                    > > > > From: Don
                                    > > > > To: mach1mach2cnc@yahoogroups.com
                                    > > > > Sent: Thursday, August 02, 2012 9:50 PM
                                    > > > > Subject: [mach1mach2cnc] Run away stepper and locked up PC
                                    > > > >
                                    > > > >
                                    > > > >
                                    > > > > I've been trying to get my steppers to not stall out above 40 in/min. One of the guys suggested that I change the micro stepping to see if that helped. I have the Z motor free on the bench so I've been testing that setup. I was originally micro stepping at 2000 steps / rev or 40,000 steps / inch. I went to 5000 steps / rev, or 100,000 per inch. I hit the Jog, and held it and the motor was running, but no feed rate was shown on the screen. I let up on the jog and the motor kept running. The screen was locked up, the DRO displays were stopped. I hit the EPO to kill the motor drivers. I had to do the long power on push button to power off the PC, everything was locked up. After the power off, I restarted the PC and started Mach3. I had to go back to the motor tuning and change the Z to the new settings as nothing was stored do to the crash shutdown. I then powered on the drivers and hit the jog and run away and locked up PC again.
                                    > > > >
                                    > > > > It has to be something in Mach3 as it is continuing to pump out step pulses.
                                    > > > >
                                    > > > > For the jog, I am using the tab key jog and was running it in continuous mode.
                                    > > > >
                                    > > > > Any Ideas as where to look for the problem???
                                    > > > >
                                    > > > > Don
                                    > > > >
                                    > > > >
                                    > > > >
                                    > > > >
                                    > > > >
                                    > > > > [Non-text portions of this message have been removed]
                                    > > > >
                                    > > >
                                    > > >
                                    > > >
                                    > > >
                                    > > >
                                    > > > [Non-text portions of this message have been removed]
                                    > > >
                                    > >
                                    > >
                                    > >
                                    > >
                                    > >
                                    > > [Non-text portions of this message have been removed]
                                    > >
                                    >
                                  Your message has been successfully submitted and would be delivered to recipients shortly.