Loading ...
Sorry, an error occurred while loading the content.

Re: [mach1mach2cnc] motors not turning

Expand Messages
  • Phill
    HI, many thanks for all the replies, I am only at the stage of a power supply kicking out 28Vdc, 1 bob, 1 driver for now until I can get this working, then put
    Message 1 of 7 , Jun 3, 2010
    • 0 Attachment
      HI, many thanks for all the replies, I am only at the stage of a power
      supply kicking out 28Vdc, 1 bob, 1 driver for now until I can get this
      working, then put it all together on the machine, here is a link to the bob
      and the driver 50, (http://www.diycnc.co.uk/html/system1.html) (
      http://www.diycnc.co.uk/html/driver50.html), all but 1 led¹s light up, I
      don¹t see the led light for the Dir on the driver card.
      I don¹t have anything else connected other than the motor, so not very
      helpful on the diagnostic¹s page.
      Could you help me out with how to the reversal of the step and dir wires ?
      please
      Hope this helps you guy¹s figure out what I am doing wrong.

      Phill


      On 04/06/2010 01:11, "Bob Campbell" <bob@...> wrote:
      >
      > Phill,
      >
      > I am not familiar with your boards. The most common problems are with the 5
      > volt or common ground settings. The next problem is the reversal of the
      > step and dir wires.
      >
      > Bob Campbell
      > Bob Campbell Designs.com
      > www.campbelldesigns.com
      > Breakout boards
      > USB Pendants
      > Electrical Enclosures
      >



      [Non-text portions of this message have been removed]
    • phill005
      Hi, This is a first time cnc project for me, have set up as per Mach3 details on website and PDF but I must be missing something as with power on to motors
      Message 2 of 7 , Jun 3, 2010
      • 0 Attachment
        Hi,
        This is a first time cnc project for me, have set up as per Mach3 details on website and PDF but I must be missing something as with power on to motors they hold but will not turn,
        just done one of the text trials and tried jog but will not turn, would anyone be able to give me some advise before I throw it out the window please.

        setup is Nema hybrid 1.8 2.8A, electronics System 1, 3no 5A stepper motor driver boards from CRH Electronics Design


        Phill
      • Bob Campbell
        Phill, I am not familiar with your boards. The most common problems are with the 5 volt or common ground settings. The next problem is the reversal of the
        Message 3 of 7 , Jun 3, 2010
        • 0 Attachment
          Phill,

          I am not familiar with your boards. The most common problems are with the 5
          volt or common ground settings. The next problem is the reversal of the
          step and dir wires.

          Bob Campbell
          Bob Campbell Designs.com
          www.campbelldesigns.com
          Breakout boards
          USB Pendants
          Electrical Enclosures

          -----Original Message-----
          From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
          On Behalf Of phill005
          Sent: Thursday, June 03, 2010 11:27 AM
          To: mach1mach2cnc@yahoogroups.com
          Subject: [mach1mach2cnc] motors not turning

          Hi,
          This is a first time cnc project for me, have set up as per Mach3 details on
          website and PDF but I must be missing something as with power on to motors
          they hold but will not turn,
          just done one of the text trials and tried jog but will not turn, would
          anyone be able to give me some advise before I throw it out the window
          please.

          setup is Nema hybrid 1.8 2.8A, electronics System 1, 3no 5A stepper motor
          driver boards from CRH Electronics Design


          Phill



          ------------------------------------

          www.machsupport.com - Web site AccessYahoo! Groups Links
        • eloid
          charge pump enable ie wired up, jumper settings, bob has power? to it  gnd etc enable jmp in place ________________________________ From: Bob Campbell
          Message 4 of 7 , Jun 3, 2010
          • 0 Attachment
            charge pump enable ie wired up, jumper settings, bob has power? to it
             gnd etc enable jmp in place




            ________________________________
            From: Bob Campbell <bob@...>
            To: mach1mach2cnc@yahoogroups.com
            Sent: Thu, June 3, 2010 10:11:19 AM
            Subject: RE: [mach1mach2cnc] motors not turning

             
            Phill,

            I am not familiar with your boards. The most common problems are with the 5
            volt or common ground settings. The next problem is the reversal of the
            step and dir wires.

            Bob Campbell
            Bob Campbell Designs.com
            www.campbelldesigns.com
            Breakout boards
            USB Pendants
            Electrical Enclosures

            -----Original Message-----
            From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
            On Behalf Of phill005
            Sent: Thursday, June 03, 2010 11:27 AM
            To: mach1mach2cnc@yahoogroups.com
            Subject: [mach1mach2cnc] motors not turning

            Hi,
            This is a first time cnc project for me, have set up as per Mach3 details on
            website and PDF but I must be missing something as with power on to motors
            they hold but will not turn,
            just done one of the text trials and tried jog but will not turn, would
            anyone be able to give me some advise before I throw it out the window
            please.

            setup is Nema hybrid 1.8 2.8A, electronics System 1, 3no 5A stepper motor
            driver boards from CRH Electronics Design

            Phill

            ------------------------------------

            www.machsupport.com - Web site AccessYahoo! Groups Links






            [Non-text portions of this message have been removed]
          • Bear Boy
            Not trying to be funny... Is your EStop setup correctly?  Have you hit the button on the screen?  I want to say that Mach beeps at you when you try
            Message 5 of 7 , Jun 3, 2010
            • 0 Attachment
              Not trying to be funny...

              Is your EStop setup correctly?  Have you hit the <RESET> button on the screen?  I want to say that Mach beeps at you when you try to jog and haven't hit <RESET>. 

              ...I will check when I get home. 


               



              ________________________________
              From: Bob Campbell <bob@...>
              To: mach1mach2cnc@yahoogroups.com
              Sent: Thu, June 3, 2010 1:11:19 PM
              Subject: RE: [mach1mach2cnc] motors not turning

               
              Phill,

              I am not familiar with your boards. The most common problems are with the 5
              volt or common ground settings. The next problem is the reversal of the
              step and dir wires.

              Bob Campbell
              Bob Campbell Designs.com
              www.campbelldesigns.com
              Breakout boards
              USB Pendants
              Electrical Enclosures

              -----Original Message-----
              From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
              On Behalf Of phill005
              Sent: Thursday, June 03, 2010 11:27 AM
              To: mach1mach2cnc@yahoogroups.com
              Subject: [mach1mach2cnc] motors not turning

              Hi,
              This is a first time cnc project for me, have set up as per Mach3 details on
              website and PDF but I must be missing something as with power on to motors
              they hold but will not turn,
              just done one of the text trials and tried jog but will not turn, would
              anyone be able to give me some advise before I throw it out the window
              please.

              setup is Nema hybrid 1.8 2.8A, electronics System 1, 3no 5A stepper motor
              driver boards from CRH Electronics Design

              Phill

              ------------------------------------

              www.machsupport.com - Web site AccessYahoo! Groups Links







              [Non-text portions of this message have been removed]
            • Bob Campbell
              One more test that I always recommend to test the parallel port is to set Mach to the diagnostic page and press any one of the limits. It should show up on the
              Message 6 of 7 , Jun 3, 2010
              • 0 Attachment
                One more test that I always recommend to test the parallel port is to set Mach to the diagnostic page and press any one of the limits. It should show up on the diagnostic page if it is a normally open switch. For normally closed switches you will need to set the active high setting correctly.

                Bob Campbell
                Bob Campbell Designs.com
                www.campbelldesigns.com
                Breakout boards
                USB Pendants
                Electrical Enclosures

                -----Original Message-----
                From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com] On Behalf Of Bear Boy
                Sent: Thursday, June 03, 2010 12:20 PM
                To: mach1mach2cnc@yahoogroups.com
                Subject: Re: [mach1mach2cnc] motors not turning

                Not trying to be funny...

                Is your EStop setup correctly? Have you hit the <RESET> button on the screen? I want to say that Mach beeps at you when you try to jog and haven't hit <RESET>.

                ...I will check when I get home.






                ________________________________
                From: Bob Campbell <bob@...>
                To: mach1mach2cnc@yahoogroups.com
                Sent: Thu, June 3, 2010 1:11:19 PM
                Subject: RE: [mach1mach2cnc] motors not turning


                Phill,

                I am not familiar with your boards. The most common problems are with the 5
                volt or common ground settings. The next problem is the reversal of the
                step and dir wires.

                Bob Campbell
                Bob Campbell Designs.com
                www.campbelldesigns.com
                Breakout boards
                USB Pendants
                Electrical Enclosures

                -----Original Message-----
                From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
                On Behalf Of phill005
                Sent: Thursday, June 03, 2010 11:27 AM
                To: mach1mach2cnc@yahoogroups.com
                Subject: [mach1mach2cnc] motors not turning

                Hi,
                This is a first time cnc project for me, have set up as per Mach3 details on
                website and PDF but I must be missing something as with power on to motors
                they hold but will not turn,
                just done one of the text trials and tried jog but will not turn, would
                anyone be able to give me some advise before I throw it out the window
                please.

                setup is Nema hybrid 1.8 2.8A, electronics System 1, 3no 5A stepper motor
                driver boards from CRH Electronics Design

                Phill

                ------------------------------------

                www.machsupport.com - Web site AccessYahoo! Groups Links







                [Non-text portions of this message have been removed]



                ------------------------------------

                www.machsupport.com - Web site AccessYahoo! Groups Links
              • Robin Howie
                I had a similar symptom when I first set up my system. Ended up using an oscilloscope to see where the pulses were going. Does the motor twitch slightly if
                Message 7 of 7 , Jun 3, 2010
                • 0 Attachment
                  I had a similar symptom when I first set up my system. Ended up using an
                  oscilloscope to see where the pulses were going. Does the motor twitch
                  slightly if you change direction? Try changing the active hi/lo setting on
                  output set up page, and possibly widening the pulse width as well. With it
                  set one way I think the on condition was driving the opto isolator so far
                  into saturation that the short pulse did not get out the other side.



                  Robin



                  _____

                  From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
                  On Behalf Of phill005
                  Sent: 03 June 2010 17:27
                  To: mach1mach2cnc@yahoogroups.com
                  Subject: [mach1mach2cnc] motors not turning





                  Hi,
                  This is a first time cnc project for me, have set up as per Mach3 details on
                  website and PDF but I must be missing something as with power on to motors
                  they hold but will not turn,
                  just done one of the text trials and tried jog but will not turn, would
                  anyone be able to give me some advise before I throw it out the window
                  please.

                  setup is Nema hybrid 1.8 2.8A, electronics System 1, 3no 5A stepper motor
                  driver boards from CRH Electronics Design

                  Phill





                  [Non-text portions of this message have been removed]
                Your message has been successfully submitted and would be delivered to recipients shortly.