Loading ...
Sorry, an error occurred while loading the content.

RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume Motor relay is switched off

Expand Messages
  • Andy Wander
    Is it working any better now?______________________________________ Andy Wander-----Original Message----- From: mach1mach2cnc@yahoogroups.com
    Message 1 of 33 , Nov 1, 2008
    • 0 Attachment
      Is it working any better now?

      ______________________________________
      Andy Wander

      -----Original Message-----
      From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com] On Behalf Of Noel Anthony
      Sent: Saturday, November 01, 2008 7:49 PM
      To: mach1mach2cnc@yahoogroups.com
      Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume Motor relay is switched off

      DC it is and I put a 3 amp Diode across with the stripe on the positive side



      _____

      From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
      On Behalf Of Andy Wander
      Sent: Sunday, 2 November 2008 9:35 AM
      To: mach1mach2cnc@yahoogroups.com
      Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
      Motor relay is switched off



      The relay is a DC relay, right?

      If so, a 1N4003 diode will do just fine.

      ______________________________________
      Andy Wander

      -----Original Message-----
      From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
      yahoogroups.com [mailto:mach1mach2cnc@
      <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com] On Behalf Of Noel
      Anthony
      Sent: Friday, October 31, 2008 11:24 PM
      To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
      Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
      Motor relay is switched off

      Electrics for Dummies. Thankyou very much

      _____

      From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
      yahoogroups.com [mailto:mach1mach2cnc@
      <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
      On Behalf Of Jeffrey T. Birt
      Sent: Saturday, 1 November 2008 1:22 PM
      To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
      Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
      Motor relay is switched off

      It goes across the relay coil terminals. The banded end goes toward the
      positive lead (reversed biased).

      Jeffrey T. Birt

      Soigeneris.com

      From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
      yahoogroups.com [mailto:mach1mach2cnc@
      <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
      On Behalf Of Noel Anthony
      Sent: Friday, October 31, 2008 9:40 PM
      To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
      Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
      Motor relay is switched off

      Hi Jeff

      Oh Dear,, no I don't. Off to the electronics shop I go. Does this sit on the
      coil return. Electrrics not my speciality

      Regards

      Noel

      _____

      From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
      yahoogroups.com <mailto:mach1mach2cnc%40yahoogroups.com>
      [mailto:mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
      yahoogroups.com
      <mailto:mach1mach2cnc%40yahoogroups.com> ]
      On Behalf Of Jeffrey T. Birt
      Sent: Saturday, 1 November 2008 12:31 PM
      To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
      <mailto:mach1mach2cnc%40yahoogroups.com>
      Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
      Motor relay is switched off

      Do you have a bypass diode (reversed biased) on the relay coil? When relays
      shut off they create a huge reverse voltage spike that can really drive
      other stuff crazy (and destroy boards.)

      Jeffrey T. Birt

      Soigeneris.com

      From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
      yahoogroups.com [mailto:mach1mach2cnc@
      <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
      On Behalf Of wildgrav
      Sent: Friday, October 31, 2008 8:36 PM
      To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
      Subject: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
      Motor relay is switched off

      Set up SS to turn suction motor on and off using Spindle Toggle on
      Diagnostic Page with Pin 1 using BOB and toggles on fine but when you
      toggle it off SS loses communication. Any one had this? Have a common 2
      amp power supply that supplies 5v and 12v to the board and relay

      Regards

      Noel

      [Non-text portions of this message have been removed]

      [Non-text portions of this message have been removed]

      [Non-text portions of this message have been removed]

      [Non-text portions of this message have been removed]

      ------------------------------------

      www.machsupport.com - Web site AccessYahoo! Groups Links

      This communication including any attachments, are intended
      for the exclusive use of the addressee(s) and contains
      confidential or copyrighted materials. Duplication,
      distribution or reproduction is strictly prohibited by law
      without written permission of Verrex





      [Non-text portions of this message have been removed]


      ------------------------------------

      www.machsupport.com - Web site AccessYahoo! Groups Links



      This communication including any attachments, are intended
      for the exclusive use of the addressee(s) and contains
      confidential or copyrighted materials. Duplication,
      distribution or reproduction is strictly prohibited by law
      without written permission of Verrex
    • Noel Anthony
      HAD A WIN Now have two power supplies on the BOB and another on the Relay that drives the Vac. Thankyou for all who assisted. Regards Noel
      Message 33 of 33 , Nov 2, 2008
      • 0 Attachment
        HAD A WIN

        Now have two power supplies on the BOB and another on the Relay that drives
        the Vac.



        Thankyou for all who assisted.



        Regards



        Noel

        www.wildgravity.com.au



        _____

        From: mach1mach2cnc@yahoogroups.com [mailto:mach1mach2cnc@yahoogroups.com]
        On Behalf Of Jeffrey T. Birt
        Sent: Monday, 3 November 2008 2:07 AM
        To: mach1mach2cnc@yahoogroups.com
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off



        You can't do that! You need completely separate power supplies for each side
        of the BOB or the opto-isolation is worthless! In other words your letting
        all the machine noise right back into the SS and PC. You should have one
        power supply powering the SS and PC side of BOB and a COMPLETELY DIFFERENT
        power supply powering the machine side of the BOB.

        Jeff Birt

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com [mailto:mach1mach2cnc@
        <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
        On Behalf Of Noel Anthony
        Sent: Sunday, November 02, 2008 1:22 AM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        The 5v 2000va PS runs the whole BOB . You have to run a jumper wire to pick
        up either side of it

        _____

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com <mailto:mach1mach2cnc%40yahoogroups.com>
        [mailto:mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com> ]
        On Behalf Of Jeffrey T. Birt
        Sent: Sunday, 2 November 2008 3:41 PM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com>
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        OK, but what is powering the machine side of your BOB??

        Jeff Birt

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com [mailto:mach1mach2cnc@
        <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
        On Behalf Of Noel Anthony
        Sent: Saturday, November 01, 2008 10:49 PM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        Removed all relay and Vac power. All works well without it

        POO

        _____

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com <mailto:mach1mach2cnc%40yahoogroups.com>
        [mailto:mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com> ]
        On Behalf Of Jeffrey T. Birt
        Sent: Sunday, 2 November 2008 1:09 PM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com>
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        OK, how do you have your BOB powered? Look at the wiring diagram. Notice it
        has two different 5V inputs, these should be from two completely different
        power supplies. I saw a note on the wiring diagram that stated you did not
        need to hook up the PC side power supply if using a SmoothStepper as the SS
        would power it. As the SS is a low power USB device it only has 100mA or
        current to dole out. I would doubt that the USB port can supply enough
        current (in all circumstances) to power the SS and your BOB, leading to
        possible brown out situations.

        I would suggest having a separate 5V supply powering your SS and then let
        the SS power your BOB. Use a completely separate 5V supply for the machine
        side of your BOB. Your motor leads should not run parallel to any signal
        lines, if they have to get close it is best to let them cross at 90deg
        angles.

        Hope that helps,

        Jeff Birt

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com [mailto:mach1mach2cnc@
        <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
        On Behalf Of Noel Anthony
        Sent: Saturday, November 01, 2008 5:33 PM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        Hi Bert

        The relay is off a BOB
        http://www.cnc4pc
        <http://www.cnc4pc
        <http://www.cnc4pc
        <http://www.cnc4pc.com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33
        <http://www.cnc4pc
        <http://www.cnc4pc
        <http://www.cnc4pc
        <http://www.cnc4pc.com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33
        <http://www.cnc4pc
        <http://www.cnc4pc
        <http://www.cnc4pc
        <http://www.cnc4pc.com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33
        <http://www.cnc4pc
        <http://www.cnc4pc
        <http://www.cnc4pc.com/Store/osc/product_info.php?cPath=33>
        com/Store/osc/product_info.php?cPath=33
        <http://www.cnc4pc
        <http://www.cnc4pc.com/Store/osc/product_info.php?cPath=33&products_id=182>
        com/Store/osc/product_info.php?cPath=33&products_id=182>
        &products_id=182>
        com/Store/osc/product_info.php?cPath=33&products_id=182>
        &products_id=182>
        com/Store/osc/product_info.php?cPath=33&products_id=182>
        &products_id=182>
        &products_id=182.

        Running 1 amp 12v to the BOB to drive the relay.

        The relay is mounted 6" from the board. Motor leads are near but do not
        cross any boards as they drop straight out the bottom of the control box

        _____

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com <mailto:mach1mach2cnc%40yahoogroups.com>
        [mailto:mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com> ]
        On Behalf Of Jeffrey T. Birt
        Sent: Sunday, 2 November 2008 1:38 AM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com>
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        Sounds like the vacuum motor is causing surges that are getting back to the
        rest of your system. Are you driving the really directly with the SS? I
        think its outputs will only drive 30mA or so, what does your relay coil
        draw? Where is the relay mounted? Are you bringing motor leads near your SS
        and other controls?

        Jeff Birt

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com [mailto:mach1mach2cnc@
        <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
        On Behalf Of Noel Anthony
        Sent: Saturday, November 01, 2008 6:44 AM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        Might have a few faults . Installed the Diode and was fractionally better.
        Gave the coil a separate power supply and no different. Turn off the # Phase
        Vacume and you can turn the relay on and off all day.

        _____

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com <mailto:mach1mach2cnc%40yahoogroups.com>
        [mailto:mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com> ]
        On Behalf Of Jeffrey T. Birt
        Sent: Saturday, 1 November 2008 1:22 PM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com>
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        It goes across the relay coil terminals. The banded end goes toward the
        positive lead (reversed biased).

        Jeffrey T. Birt

        Soigeneris.com

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com [mailto:mach1mach2cnc@
        <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
        On Behalf Of Noel Anthony
        Sent: Friday, October 31, 2008 9:40 PM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        Hi Jeff

        Oh Dear,, no I don't. Off to the electronics shop I go. Does this sit on the
        coil return. Electrrics not my speciality

        Regards

        Noel

        _____

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com <mailto:mach1mach2cnc%40yahoogroups.com>
        [mailto:mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com> ]
        On Behalf Of Jeffrey T. Birt
        Sent: Saturday, 1 November 2008 12:31 PM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        <mailto:mach1mach2cnc%40yahoogroups.com>
        Subject: RE: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        Do you have a bypass diode (reversed biased) on the relay coil? When relays
        shut off they create a huge reverse voltage spike that can really drive
        other stuff crazy (and destroy boards.)

        Jeffrey T. Birt

        Soigeneris.com

        From: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com>
        yahoogroups.com [mailto:mach1mach2cnc@
        <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com]
        On Behalf Of wildgrav
        Sent: Friday, October 31, 2008 8:36 PM
        To: mach1mach2cnc@ <mailto:mach1mach2cnc%40yahoogroups.com> yahoogroups.com
        Subject: [mach1mach2cnc] Smooth Stepper looses communication when Vacume
        Motor relay is switched off

        Set up SS to turn suction motor on and off using Spindle Toggle on
        Diagnostic Page with Pin 1 using BOB and toggles on fine but when you
        toggle it off SS loses communication. Any one had this? Have a common 2
        amp power supply that supplies 5v and 12v to the board and relay

        Regards

        Noel

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]

        [Non-text portions of this message have been removed]





        [Non-text portions of this message have been removed]
      Your message has been successfully submitted and would be delivered to recipients shortly.