Loading ...
Sorry, an error occurred while loading the content.
 

APM with X

Expand Messages
  • pukalcho
    Problem: with X running, I close the lid, then open after a while. The screen shows a fuzzy pattern of pixels and everything hangs. Need to reboot afterwards
    Message 1 of 2 , Mar 20, 2002
      Problem: with X running, I close the lid, then
      open after a while. The screen shows a fuzzy
      pattern of pixels and everything hangs. Need to
      reboot afterwards (CTRL-ALT-DEL works).

      If the lid stays open, though, screen just
      blanks and then gets back to normal, after pressing
      a key (as expected).

      Is this because of the APM/AGP issues with the
      NVidia g2g card? Short of turning off AGP, is
      there any other alternative solution at this time?

      My configuration: I 8100, NV g2g 16MB graphics,
      Slackware 8.0, kernel 2.4.5, XFree 4.2, the latest Nvidia
      (1.0-2802) GLX drivers, APM + apmd enabled
      (kernel setup:: Ignore USER SUSPEND: no; Enable PM
      at boot time: yes; Make CPU Idle calls when idle: Yes;
      Enable console blanking using APM: yes; Power off on
      shudown: yes)

      --George
    • smart352
      Ive seen a windows laptop do this. Its just the screen and the videocard being finicky. I havent found a solution.
      Message 2 of 2 , Apr 14, 2002
        Ive seen a windows laptop do this. Its just the screen and the
        videocard being finicky. I havent found a solution.

        --- In linuxonlaptop@y..., "pukalcho" <pukalcho@y...> wrote:
        > Problem: with X running, I close the lid, then
        > open after a while. The screen shows a fuzzy
        > pattern of pixels and everything hangs. Need to
        > reboot afterwards (CTRL-ALT-DEL works).
        >
        > If the lid stays open, though, screen just
        > blanks and then gets back to normal, after pressing
        > a key (as expected).
        >
        > Is this because of the APM/AGP issues with the
        > NVidia g2g card? Short of turning off AGP, is
        > there any other alternative solution at this time?
        >
        > My configuration: I 8100, NV g2g 16MB graphics,
        > Slackware 8.0, kernel 2.4.5, XFree 4.2, the latest Nvidia
        > (1.0-2802) GLX drivers, APM + apmd enabled
        > (kernel setup:: Ignore USER SUSPEND: no; Enable PM
        > at boot time: yes; Make CPU Idle calls when idle: Yes;
        > Enable console blanking using APM: yes; Power off on
        > shudown: yes)
        >
        > --George
      Your message has been successfully submitted and would be delivered to recipients shortly.