Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Re: PTT Configuration Problem

Expand Messages
  • Ed
    ... Gerry, you can do this easily with the --config-dir switch, and create seperate desktop launchers for each. I have one like this :: fldigi --config-dir
    Message 1 of 13 , Jul 12, 2010
    • 0 Attachment
      On 07/11/2010 08:55 PM, Gerald K. Sherman wrote:
      > On 10-07-11 01:37 PM, David wrote:
      >>
      >> Hello Larry,
      >>
      >> I think I know what your problem is. I have a Yaesu FT-950 and I found that the Hamlib-asserted PTT will actually listen to the MIC on the front of the radio and not the "data" port on the back! Very confusing and I don't think this is configurable on my radio (maybe it is on yours). Anyway, I used the PTT line on the data jack and things work well but this does require a serial port to bring up the PTT.
      >>
      >> If you're looking for supported (and decent) USB to serial converters, look for ones that are supported for Mac OSX. OSX is FreeBSD under the hood and generally work for Linux. I'd recommend to stay away from Prolific-based stuff as it's always flaked out on me several months later. I've had good luck with FTDI-based gear. The trick is finding out what chip is in what product before you buy.
      >>
      >> Good luck!
      >>
      >> 73s,
      >> --David
      >> KI6ZHD
      >>
      >>
      > Re: USB-serial converters
      >
      > I don't have a USB-serial converter, as such, but I use a Rig Expert
      > "Standard" interface with my ICOM gear (7200 or 746 - I have one of
      > each),& it seems to work OK. It also contains a free serial port. I
      > know the 7200 has a USB port in it, but with the "R/E" you have level
      > controls on the R/E front panel,& don't have to set the levels in
      > Linux. The f/p knobs are easier to use,& with the audio codecs in the
      > R/E, it doesn't tie up the PC's audio ports on the sound card. You
      > don't need a driver for the R/E - it's already in the Linux, or, at
      > least, it's in the Debian (Ubuntu) distro.
      >
      > Hope this provides some help.
      >
      > I do have another question re Fldigi. Probably Dave can answer this
      > one,& if there isn't a good answer right now, it might be an item to
      > consider adding in future releases. Is it possible to have more than
      > one set of configurations for a user, and select the proper set at
      > startup, similar to what can be done with the macro definition files? I
      > can see 2 possible uses for this feature. One is when using multiple
      > call signs, like your personal one most of the time, and a club call in
      > a contest like Field Day. The other would be when operating from either
      > your base (home) QTH, or else a portable QTH like a summer cottage. I
      > could have used the 1st occasion a few weeks ago. (I was hoping to use
      > digital mode on Field Day, but Mr. Murphy's gremlins, in the form of a
      > good electrical storm, + a leaky tent, had other thoughts. I had to
      > cover the gear at the time with what was handy during the storm, then
      > shut down& take the ICOMs& the PC home for a good dry out.)
      >
      > Thanks
      >
      > Gerry, VE4GKS
      >

      Gerry, you can do this easily with the --config-dir switch, and create
      seperate desktop launchers for each.

      I have one like this ::

      fldigi --config-dir /home/ed/test and another ::

      fldigi --config-dir /home/ed/contest

      you can make as many of these as you want, and each will have its own
      configuration file.

      Ed W3NR
    • w1hkj
      ... And you can decide whether they will use separate logbook storage or share a common one simply by opening the target logbook adif file. Dave
      Message 2 of 13 , Jul 12, 2010
      • 0 Attachment
        > Gerry, you can do this easily with the --config-dir switch, and create
        > seperate desktop launchers for each.
        >
        > I have one like this ::
        >
        > fldigi --config-dir /home/ed/test and another ::
        >
        > fldigi --config-dir /home/ed/contest
        >
        > you can make as many of these as you want, and each will have its own
        > configuration file.
        >

        And you can decide whether they will use separate logbook storage or
        share a common one simply by opening the target logbook adif file.

        Dave
      • Larry
        In my original post on this subject, I mentioned that I was unable to get the latest version of FLdigi to key my separate serial port PTT switch, and I
        Message 3 of 13 , Jul 14, 2010
        • 0 Attachment
          In my original post on this subject, I mentioned that I was unable to
          get the latest version of FLdigi to key my separate serial port PTT
          switch, and I received many thoughtful comments. I had mentioned that I
          was dual booting Slackware 12.2 and Fedora 13. All worked well with
          Slackware, but the problem occured when using Fedora. I have found the
          problem and want to report it to the group.

          The computer here has two native serial ports, ttyS0 and ttyS1. I also
          have a plug & play PCI Siig card for two additional serial ports, ttyS2
          & ttyS3. I had my PTT switch on ttyS3. It seems that Fedora does not
          find the S3 port, but has no problem with S0, S1, & S2. I found this by
          using the "setserial -g /dev/ttyS*" command. It lists all the ports
          except the one I was trying to use (naturally!). Of course the quick
          solution was to change the PTT switch to an unused port and all is
          well. Life is beautiful. But I still don't have a clue as to why
          Fedora doesn't see ttyS3.

          Secondly I mentioned that I was using an older version of FLDigi on
          Slackware. When I try to run the latest version (the binary download),
          it complains that it needs compiler upgrades. Here is the error message:

          ./fldigi: /usr/lib/libstdc++.so.6:version 'GLIBCXX_3.4.10' not found
          (required by ./fldigi)
          and
          ./fldigi: /lib/libc.so.6:version 'GLIBCXX_2.8' not found (required by
          ./fldigi)

          If I interpret this correctly, I need to upgrade my glibc package.
          Everything I have read about this is that this is not a trivial matter,
          and can cause big headaches because other programs might be affected.
          Does anyone have any experience with this?

          But the bottom line is that I am back in business enjoying FLDigi and
          making QSO's.

          Thanks for listening & 73's,
          Larry W4LK
        • Ed
          ... This is not for the faint of heart. And I would say yes, its going to break something somewhere. I tried basically the same thing in Debian a few years
          Message 4 of 13 , Jul 14, 2010
          • 0 Attachment
            On 07/14/2010 04:03 PM, Larry wrote:

            > ./fldigi: /usr/lib/libstdc++.so.6:version 'GLIBCXX_3.4.10' not found
            > (required by ./fldigi)
            > and
            > ./fldigi: /lib/libc.so.6:version 'GLIBCXX_2.8' not found (required by
            > ./fldigi)
            >
            > If I interpret this correctly, I need to upgrade my glibc package.
            > Everything I have read about this is that this is not a trivial matter,
            > and can cause big headaches because other programs might be affected.
            > Does anyone have any experience with this?

            This is not for the faint of heart. And I would say yes, its going to
            break something somewhere.

            I tried basically the same thing in Debian a few years ago, no joy.
            Luckily I had backed up all the important info.


            > Thanks for listening& 73's,
            > Larry W4LK
            >

            Ed W3NR
          • w1hkj
            ... Larry, If you do not want to upgrade your Slackware install then you probably will need to build fldigi from source. Dave
            Message 5 of 13 , Jul 14, 2010
            • 0 Attachment
              Larry wrote:
              > In my original post on this subject, I mentioned that I was unable to
              > get the latest version of FLdigi to key my separate serial port PTT
              > switch, and I received many thoughtful comments. I had mentioned that I
              > was dual booting Slackware 12.2 and Fedora 13. All worked well with
              > Slackware, but the problem occured when using Fedora. I have found the
              > problem and want to report it to the group.
              >
              > The computer here has two native serial ports, ttyS0 and ttyS1. I also
              > have a plug & play PCI Siig card for two additional serial ports, ttyS2
              > & ttyS3. I had my PTT switch on ttyS3. It seems that Fedora does not
              > find the S3 port, but has no problem with S0, S1, & S2. I found this by
              > using the "setserial -g /dev/ttyS*" command. It lists all the ports
              > except the one I was trying to use (naturally!). Of course the quick
              > solution was to change the PTT switch to an unused port and all is
              > well. Life is beautiful. But I still don't have a clue as to why
              > Fedora doesn't see ttyS3.
              >
              > Secondly I mentioned that I was using an older version of FLDigi on
              > Slackware. When I try to run the latest version (the binary download),
              > it complains that it needs compiler upgrades. Here is the error message:
              >
              > ./fldigi: /usr/lib/libstdc++.so.6:version 'GLIBCXX_3.4.10' not found
              > (required by ./fldigi)
              > and
              > ./fldigi: /lib/libc.so.6:version 'GLIBCXX_2.8' not found (required by
              > ./fldigi)
              >
              > If I interpret this correctly, I need to upgrade my glibc package.
              > Everything I have read about this is that this is not a trivial matter,
              > and can cause big headaches because other programs might be affected.
              > Does anyone have any experience with this?
              >
              Larry,

              If you do not want to upgrade your Slackware install then you probably
              will need to build fldigi from source.

              Dave
            • Larry
              ... Dave, I tried compiling fldigi from source and that worked nicely. I had to compile fltk from source, also, as I could not find a Slackware package that
              Message 6 of 13 , Jul 14, 2010
              • 0 Attachment
                w1hkj wrote:
                 

                Larry wrote:
                > In my original post on this subject, I mentioned that I was unable to
                > get the latest version of FLdigi to key my separate serial port PTT
                > switch, and I received many thoughtful comments. I had mentioned that I
                > was dual booting Slackware 12.2 and Fedora 13. All worked well with
                > Slackware, but the problem occured when using Fedora. I have found the
                > problem and want to report it to the group.
                >
                > The computer here has two native serial ports, ttyS0 and ttyS1. I also
                > have a plug & play PCI Siig card for two additional serial ports, ttyS2
                > & ttyS3. I had my PTT switch on ttyS3. It seems that Fedora does not
                > find the S3 port, but has no problem with S0, S1, & S2. I found this by
                > using the "setserial -g /dev/ttyS*" command. It lists all the ports
                > except the one I was trying to use (naturally!). Of course the quick
                > solution was to change the PTT switch to an unused port and all is
                > well. Life is beautiful. But I still don't have a clue as to why
                > Fedora doesn't see ttyS3.
                >
                > Secondly I mentioned that I was using an older version of FLDigi on
                > Slackware. When I try to run the latest version (the binary download),
                > it complains that it needs compiler upgrades. Here is the error message:
                >
                > ./fldigi: /usr/lib/libstdc++.so.6:version 'GLIBCXX_3.4.10' not found
                > (required by ./fldigi)
                > and
                > ./fldigi: /lib/libc.so.6:version 'GLIBCXX_2.8' not found (required by
                > ./fldigi)
                >
                > If I interpret this correctly, I need to upgrade my glibc package.
                > Everything I have read about this is that this is not a trivial matter,
                > and can cause big headaches because other programs might be affected.
                > Does anyone have any experience with this?
                >
                Larry,

                If you do not want to upgrade your Slackware install then you probably
                will need to build fldigi from source.

                Dave

                Dave,
                I tried compiling fldigi from source and that worked nicely.  I had to compile fltk from source, also, as I could not find a Slackware package that was built with threads enabled.

                The menu fonts look somewhat thinner than those from the binary version, but I'll get used to it (unless you know of an easy way to change them).

                73's & Thanks,
                Larry W4LK

              • w1hkj
                ... Did you build fltk with the configure switch --enable-xft ? Without that the fonts will look like the Alabama beaches right now (crappy). Dave
                Message 7 of 13 , Jul 14, 2010
                • 0 Attachment
                  Larry wrote:
                  w1hkj wrote:
                   

                  Larry wrote:
                  > In my original post on this subject, I mentioned that I was unable to
                  > get the latest version of FLdigi to key my separate serial port PTT
                  > switch, and I received many thoughtful comments. I had mentioned that I
                  > was dual booting Slackware 12.2 and Fedora 13. All worked well with
                  > Slackware, but the problem occured when using Fedora. I have found the
                  > problem and want to report it to the group.
                  >
                  > The computer here has two native serial ports, ttyS0 and ttyS1. I also
                  > have a plug & play PCI Siig card for two additional serial ports, ttyS2
                  > & ttyS3. I had my PTT switch on ttyS3. It seems that Fedora does not
                  > find the S3 port, but has no problem with S0, S1, & S2. I found this by
                  > using the "setserial -g /dev/ttyS*" command. It lists all the ports
                  > except the one I was trying to use (naturally!). Of course the quick
                  > solution was to change the PTT switch to an unused port and all is
                  > well. Life is beautiful. But I still don't have a clue as to why
                  > Fedora doesn't see ttyS3.
                  >
                  > Secondly I mentioned that I was using an older version of FLDigi on
                  > Slackware. When I try to run the latest version (the binary download),
                  > it complains that it needs compiler upgrades. Here is the error message:
                  >
                  > ./fldigi: /usr/lib/libstdc++.so.6:version 'GLIBCXX_3.4.10' not found
                  > (required by ./fldigi)
                  > and
                  > ./fldigi: /lib/libc.so.6:version 'GLIBCXX_2.8' not found (required by
                  > ./fldigi)
                  >
                  > If I interpret this correctly, I need to upgrade my glibc package.
                  > Everything I have read about this is that this is not a trivial matter,
                  > and can cause big headaches because other programs might be affected.
                  > Does anyone have any experience with this?
                  >
                  Larry,

                  If you do not want to upgrade your Slackware install then you probably
                  will need to build fldigi from source.

                  Dave

                  Dave,
                  I tried compiling fldigi from source and that worked nicely.  I had to compile fltk from source, also, as I could not find a Slackware package that was built with threads enabled.

                  The menu fonts look somewhat thinner than those from the binary version, but I'll get used to it (unless you know of an easy way to change them).

                  73's & Thanks,
                  Larry W4LK

                  Did you build fltk with the configure switch "--enable-xft" ?

                  Without that the fonts will look like the Alabama beaches right now (crappy).

                  Dave
                • Larry
                  ... No, but I re-compiled it with the --enable-xft switch and it looks 100% better - like the beach at Hilton Head we go to. Again, thanks & 73 s, Larry
                  Message 8 of 13 , Jul 14, 2010
                  • 0 Attachment
                    w1hkj wrote:
                     

                    Larry wrote:

                    w1hkj wrote:
                     

                    Larry wrote:
                    > In my original post on this subject, I mentioned that I was unable to
                    > get the latest version of FLdigi to key my separate serial port PTT
                    > switch, and I received many thoughtful comments. I had mentioned that I
                    > was dual booting Slackware 12.2 and Fedora 13. All worked well with
                    > Slackware, but the problem occured when using Fedora. I have found the
                    > problem and want to report it to the group.
                    >
                    > The computer here has two native serial ports, ttyS0 and ttyS1. I also
                    > have a plug & play PCI Siig card for two additional serial ports, ttyS2
                    > & ttyS3. I had my PTT switch on ttyS3. It seems that Fedora does not
                    > find the S3 port, but has no problem with S0, S1, & S2. I found this by
                    > using the "setserial -g /dev/ttyS*" command. It lists all the ports
                    > except the one I was trying to use (naturally!) . Of course the quick
                    > solution was to change the PTT switch to an unused port and all is
                    > well. Life is beautiful. But I still don't have a clue as to why
                    > Fedora doesn't see ttyS3.
                    >
                    > Secondly I mentioned that I was using an older version of FLDigi on
                    > Slackware. When I try to run the latest version (the binary download),
                    > it complains that it needs compiler upgrades. Here is the error message:
                    >
                    > ./fldigi: /usr/lib/libstdc+ +.so.6:version 'GLIBCXX_3.4. 10' not found
                    > (required by ./fldigi)
                    > and
                    > ./fldigi: /lib/libc.so. 6:version 'GLIBCXX_2.8' not found (required by
                    > ./fldigi)
                    >
                    > If I interpret this correctly, I need to upgrade my glibc package.
                    > Everything I have read about this is that this is not a trivial matter,
                    > and can cause big headaches because other programs might be affected.
                    > Does anyone have any experience with this?
                    >
                    Larry,

                    If you do not want to upgrade your Slackware install then you probably
                    will need to build fldigi from source.

                    Dave

                    Dave,
                    I tried compiling fldigi from source and that worked nicely.  I had to compile fltk from source, also, as I could not find a Slackware package that was built with threads enabled.

                    The menu fonts look somewhat thinner than those from the binary version, but I'll get used to it (unless you know of an easy way to change them).

                    73's & Thanks,
                    Larry W4LK

                    Did you build fltk with the configure switch "--enable-xft" ?

                    Without that the fonts will look like the Alabama beaches right now (crappy).

                    Dave
                    No, but I re-compiled it with the "--enable-xft" switch and it looks 100% better - like the beach at Hilton Head we go to.  Again, thanks & 73's,
                    Larry
                  Your message has been successfully submitted and would be delivered to recipients shortly.