Loading ...
Sorry, an error occurred while loading the content.

Re: Another LoTW issue with fldigi modes

Expand Messages
  • Mark
    ... Just have tqsl re-map the modes for you automatically when it signs your log. Start tqsl and select File- Preferences- ADIF Modes. Use the Add button
    Message 1 of 10 , Apr 1, 2010
    • 0 Attachment
      --- In linuxham@yahoogroups.com, Dick Kriss <aa5vu@...> wrote:

      > It is too hard to remember what modes are not supported by LoTW. Fldigi
      > complies with the ADIF Specification so the best way to figure out what will
      > not be accepted is to ask tqsl to sign the fldigi exported log and then go
      > back
      > and edit the tilts to DATA like I did in the posting.
      >
      > I would like to know if there is a better solution.

      Just have tqsl re-map the modes for you automatically when it signs your log. Start tqsl and select File->Preferences->ADIF Modes. Use the "Add" button to add as many translations as you like.
    • Dick Kriss
      ... Mark, Good suggestion but it did not work for me. As you suggested I opened the tqsl Preferences/ADIF MODES and used the Add button to add PSK250 and
      Message 2 of 10 , Apr 1, 2010
      • 0 Attachment
        On 4/1/10 11:38 AM, "Mark" <yahoogroups@...> wrote:
        >
        > --- In linuxham@yahoogroups.com <mailto:linuxham%40yahoogroups.com> , Dick
        > Kriss <aa5vu@...> wrote:
        >
        >> It is too hard to remember what modes are not supported by LoTW. Fldigi
        >> complies with the ADIF Specification so the best way to figure out what will
        >> not be accepted is to ask tqsl to sign the fldigi exported log and then go
        >> back
        >> and edit the tilts to DATA like I did in the posting.
        >>
        >> I would like to know if there is a better solution.
        >
        > Just have tqsl re-map the modes for you automatically when it signs your log.
        > Start tqsl and select File->Preferences->ADIF Modes. Use the "Add" button to
        > add as many translations as you like.
        >

        Mark,

        Good suggestion but it did not work for me. As you suggested I opened the
        tqsl Preferences/ADIF MODES and used the Add button to add PSK250 and
        selected DATA. This resulted in a Custom ADIF mode mapping that says
        PSK250 -> DATA. I then tried to have tqsl sign the test.adif file that
        contained <MODE:6>PSK250 and tqsl barfed saying

        Error: Invalid MODE (PSK250) on line 6

        Have you actually tried it? I must be doing something wrong.


        73 Dick AA5VU
      • Rick Ellison
        The reason it barfed on the mode is PSK250 is not a ADIF supported mode....ADIF only defines PSK125 as the highest of the PSK speeds... 73 Rick N2AMG
        Message 3 of 10 , Apr 1, 2010
        • 0 Attachment
          The reason it barfed on the mode is PSK250 is not a ADIF supported
          mode....ADIF only defines PSK125 as the highest of the PSK speeds...

          73 Rick N2AMG
          www.n2amg.com

          -----Original Message-----
          From: linuxham@yahoogroups.com [mailto:linuxham@yahoogroups.com] On Behalf
          Of Dick Kriss
          Sent: Thursday, April 01, 2010 4:35 PM
          To: fldigi list
          Subject: Re: [linuxham] Re: Another LoTW issue with fldigi modes

          On 4/1/10 11:38 AM, "Mark" <yahoogroups@...> wrote:
          >
          > --- In linuxham@yahoogroups.com <mailto:linuxham%40yahoogroups.com> , Dick
          > Kriss <aa5vu@...> wrote:
          >
          >> It is too hard to remember what modes are not supported by LoTW. Fldigi
          >> complies with the ADIF Specification so the best way to figure out what
          will
          >> not be accepted is to ask tqsl to sign the fldigi exported log and then
          go
          >> back
          >> and edit the tilts to DATA like I did in the posting.
          >>
          >> I would like to know if there is a better solution.
          >
          > Just have tqsl re-map the modes for you automatically when it signs your
          log.
          > Start tqsl and select File->Preferences->ADIF Modes. Use the "Add" button
          to
          > add as many translations as you like.
          >

          Mark,

          Good suggestion but it did not work for me. As you suggested I opened the
          tqsl Preferences/ADIF MODES and used the Add button to add PSK250 and
          selected DATA. This resulted in a Custom ADIF mode mapping that says
          PSK250 -> DATA. I then tried to have tqsl sign the test.adif file that
          contained <MODE:6>PSK250 and tqsl barfed saying

          Error: Invalid MODE (PSK250) on line 6

          Have you actually tried it? I must be doing something wrong.


          73 Dick AA5VU




          ------------------------------------

          Yahoo! Groups Links
        • Dick Kriss
          Rick, The unmodified tqsl can handle PSK125 without a change. I was trying to map an unsupported mode, like PSK250 to be DATA. I guess I will have to revert
          Message 4 of 10 , Apr 1, 2010
          • 0 Attachment
            Rick,

            The unmodified tqsl can handle PSK125 without a change. I was trying
            to map an unsupported mode, like PSK250 to be DATA. I guess I will have
            to revert to my first suggestion to try the fldigi saved .adif file then
            manually change the exceptions to DATA. I know that works

            Thanks for the comment

            Dick


            On 4/1/10 6:47 PM, "Rick Ellison" <rellison@...> wrote:
            >
            > The reason it barfed on the mode is PSK250 is not a ADIF supported
            > mode....ADIF only defines PSK125 as the highest of the PSK speeds...
            >
            > 73 Rick N2AMG
            > www.n2amg.com
            >
            > -----Original Message-----
            > From: linuxham@yahoogroups.com <mailto:linuxham%40yahoogroups.com>
            > [mailto:linuxham@yahoogroups.com <mailto:linuxham%40yahoogroups.com> ] On
            > Behalf
            > Of Dick Kriss
            > Sent: Thursday, April 01, 2010 4:35 PM
            > To: fldigi list
            > Subject: Re: [linuxham] Re: Another LoTW issue with fldigi modes
            >
            > On 4/1/10 11:38 AM, "Mark" <yahoogroups@...
            > <mailto:yahoogroups%40markc.users.panix.com> > wrote:
            >>
            >> --- In linuxham@yahoogroups.com <mailto:linuxham%40yahoogroups.com>
            >> <mailto:linuxham%40yahoogroups.com> , Dick
            >> Kriss <aa5vu@...> wrote:
            >>
            >>> It is too hard to remember what modes are not supported by LoTW. Fldigi
            >>> complies with the ADIF Specification so the best way to figure out what
            > will
            >>> not be accepted is to ask tqsl to sign the fldigi exported log and then
            > go
            >>> back
            >>> and edit the tilts to DATA like I did in the posting.
            >>>
            >>> I would like to know if there is a better solution.
            >>
            >> Just have tqsl re-map the modes for you automatically when it signs your
            > log.
            >> Start tqsl and select File->Preferences->ADIF Modes. Use the "Add" button
            > to
            >> add as many translations as you like.
            >>
            >
            > Mark,
            >
            > Good suggestion but it did not work for me. As you suggested I opened the
            > tqsl Preferences/ADIF MODES and used the Add button to add PSK250 and
            > selected DATA. This resulted in a Custom ADIF mode mapping that says
            > PSK250 -> DATA. I then tried to have tqsl sign the test.adif file that
            > contained <MODE:6>PSK250 and tqsl barfed saying
            >
            > Error: Invalid MODE (PSK250) on line 6
            >
            > Have you actually tried it? I must be doing something wrong.
            >
            > 73 Dick AA5VU
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
          • Mark
            ... I tried it this morning and it worked for me. Here is the ADIF file I used: File: stdout /home/cudworth/postgres/qso/dump_adif.pl
            Message 5 of 10 , Apr 2, 2010
            • 0 Attachment
              --- In linuxham@yahoogroups.com, Dick Kriss <aa5vu@...> wrote:
              > Good suggestion but it did not work for me. As you suggested I opened the
              > tqsl Preferences/ADIF MODES and used the Add button to add PSK250 and
              > selected DATA. This resulted in a Custom ADIF mode mapping that says
              > PSK250 -> DATA. I then tried to have tqsl sign the test.adif file that
              > contained <MODE:6>PSK250 and tqsl barfed saying
              >
              > Error: Invalid MODE (PSK250) on line 6
              >
              > Have you actually tried it? I must be doing something wrong.

              I tried it this morning and it worked for me. Here is the ADIF file I used:

              File: stdout
              <PROGRAMID:40>/home/cudworth/postgres/qso/dump_adif.pl
              <PROGRAMVERSION:3>1.1
              <EOH>
              <CALL:6>KC9LWZ
              <MODE:6>PSK250
              <FREQ:9>14.071500
              <BAND:3>20m
              <QSO_DATE:8>20100402
              <TIME_ON:6>143800
              <MY_RIG:12>ICOM 746 Pro
              <NAME:3>Dan
              <COUNTRY:2>US
              <QSL_SENT:1>N
              <QSL_RCVD:1>N
              <EQSL_QSL_SENT:1>N
              <EQSL_QSL_RCVD:1>N
              <LOTW_QSL_SENT:1>N
              <LOTW_QSL_RCVD:1>N
              <EOR>

              And here is the resulting TQ8 file (which I have unzipped):

              <TQSL_IDENT:34>TQSL V1.11 Lib: V2.0 Config: V1.12
              <Rec_Type:5>tCERT
              <CERT_UID:1>1
              <CERTIFICATE:1686>MIIE2DCCBEGgAwIBAgIDApKRMA0GCSqGSIb3DQEBBAUAMIHYMQswCQYDVQQGEwJV
              UzELMAkGA1UECBMCQ1QxEjAQBgNVBAcTCU5ld2luZ3RvbjEkMCIGA1UEChMbQW1l
              cmljYW4gUmFkaW8gUmVsYXkgTGVhZ3VlMR0wGwYDVQQLExRMb2dib29rIG9mIHRo
              ZSBXb3JsZDErMCkGA1UEAxMiTG9nYm9vayBvZiB0aGUgV29ybGQgUHJvZHVjdGlv
              biBDQTEYMBYGCgmSJomT8ixkARkWCGFycmwub3JnMRwwGgYJKoZIhvcNAQkBFg1s
              b3R3QGFycmwub3JnMB4XDTEwMDIxNjEzMjEwOFoXDTEzMDIxNTEzMjEwOFowWTEU
              MBIGCSsGAQQB4DwBARMFVzlGWEMxFjAUBgNVBAMTDU1hcmsgQ3Vkd29ydGgxKTAn
              BgkqhkiG9w0BCQEWGmxvdHdAbWFya2MudXNlcnMucGFuaXguY29tMIGfMA0GCSqG
              SIb3DQEBAQUAA4GNADCBiQKBgQDHKijcpKdPS330YGfZEBhaxzMTokmmtl6n3jNb
              TwepWeUVJnm9N//1IvRc+HP5gMRDbO2kRXQvWKk7D7jiasfSmo+PbqPpdNfuMr3W
              xicIGtYjnf1NW0619L9w0vh4VFjundieYPCwBKP1hpg28ZylixwbwIbwCgCD5k1Q
              StZaaQIDAQABo4ICLDCCAigwHQYDVR0OBBYEFGjokHMDyUtJL2kwfKgjWBboq97D
              MIH/BgNVHSMEgfcwgfSAFOspADK1TLsIc/XpX9lwcu/yG/rooYHYpIHVMIHSMQsw
              CQYDVQQGEwJVUzELMAkGA1UECBMCQ1QxEjAQBgNVBAcTCU5ld2luZ3RvbjEkMCIG
              A1UEChMbQW1lcmljYW4gUmFkaW8gUmVsYXkgTGVhZ3VlMR0wGwYDVQQLExRMb2di
              b29rIG9mIHRoZSBXb3JsZDElMCMGA1UEAxMcTG9nYm9vayBvZiB0aGUgV29ybGQg
              Um9vdCBDQTEYMBYGCgmSJomT8ixkARkWCGFycmwub3JnMRwwGgYJKoZIhvcNAQkB
              Fg1sb3R3QGFycmwub3JnggEFMAkGA1UdEwQCMAAwCwYDVR0PBAQDAgXgMBcGCSsG
              AQQB4DwBAgQKMjAwNi0wNC0wNjAXBgkrBgEEAeA8AQMECjIwMTMtMDItMTUwEAYJ
              KwYBBAHgPAEEBAMyOTEwgagGCSsGAQQB4DwBBQSBmi9DPVVTL1NUPUNUL0w9TmV3
              aW5ndG9uL089QW1lcmljYW4gUmFkaW8gUmVsYXkgTGVhZ3VlL09VPUxvZ2Jvb2sg
              b2YgdGhlIFdvcmxkL0NOPUxvZ2Jvb2sgb2YgdGhlIFdvcmxkIFByb2R1Y3Rpb24g
              Q0EvREM9YXJybC5vcmcvRW1haWw9bG90d0BhcnJsLm9yZzsxMTkyNzAwDQYJKoZI
              hvcNAQEEBQADgYEAdqkaXmPD5ng9f2TLzvlwEUmJwvoV+9T3DdYZnvzjQmEQeqrf
              ICcfXUKZ18sZWO0ts5Mj/3LHTRMX8+vK0/ZQOXwh9cmM7Lnmhcld8T1tDhMpi21x
              rEm2172T1jWqvC7saDcBdZtwc5jJsg46rmENqL9UlAFZIDnkE3zXmg6u4jI=
              <eor>

              <Rec_Type:8>tSTATION
              <STATION_UID:1>1
              <CERT_UID:1>1
              <CALL:5>W9FXC
              <DXCC:3>291
              <GRIDSQUARE:6>EM69vv
              <ITUZ:1>8
              <CQZ:1>4
              <US_STATE:2>IN
              <US_COUNTY:6>Marion
              <eor>

              <Rec_Type:8>tCONTACT
              <STATION_UID:1>1
              <CALL:6>KC9LWZ
              <BAND:3>20M
              <MODE:4>DATA
              <FREQ:9>14.071500
              <QSO_DATE:10>2010-04-02
              <QSO_TIME:9>14:38:00Z
              <SIGN_LOTW_V1.0:175:6>FeOrU14q39jw0tXAW5Wb3/ogWmAW2/h/wCPCohJJsEu66b2i9ZTC/eedWtqIl8cI
              EywP1NR/FFgxr/X7SiTGzaMsLIuajOvws1pBt/708AeUZ1+FyM4OFRubBNrPgnFY
              TxCBShmOx/v9U/7JI+8xTCPupxQ8YOP8bBDBqoEecLo=
              <SIGNDATA:57>4EM69VV8MARIONIN20MKC9LWZ14.071500DATA2010-04-0214:38:00Z
              <eor>

              Note the "<MODE:4>DATA" line. Which version of tqsl are you using?
              (I didn't try uploading the file since the QSO is bogus.)
            • Dick Kriss
              ... But you did not use fldigi to generate the dump_adif.pl file ... sniped data ... Mark, I am using tqsl version 1.11 that I think is the most current. I
              Message 6 of 10 , Apr 2, 2010
              • 0 Attachment
                On 4/2/10 10:03 AM, "Mark" <yahoogroups@...> wrote:
                > --- In linuxham@yahoogroups.com <mailto:linuxham%40yahoogroups.com> , Dick
                > Kriss <aa5vu@...> wrote:
                >> Good suggestion but it did not work for me. As you suggested I opened the
                >> tqsl Preferences/ADIF MODES and used the Add button to add PSK250 and
                >> selected DATA. This resulted in a Custom ADIF mode mapping that says
                >> PSK250 -> DATA. I then tried to have tqsl sign the test.adif file that
                >> contained <MODE:6>PSK250 and tqsl barfed saying
                >>
                >> Error: Invalid MODE (PSK250) on line 6
                >>
                >> Have you actually tried it? I must be doing something wrong.
                >
                > I tried it this morning and it worked for me. Here is the ADIF file I used:

                But you did not use fldigi to generate the dump_adif.pl file

                >
                > File: stdout
                > <PROGRAMID:40>/home/cudworth/postgres/qso/dump_adif.pl
                > <PROGRAMVERSION:3>1.1
                > <EOH>
                > <CALL:6>KC9LWZ
                > <MODE:6>PSK250
                > <FREQ:9>14.071500
                > <BAND:3>20m
                > <QSO_DATE:8>20100402
                > <TIME_ON:6>143800
                > <MY_RIG:12>ICOM 746 Pro
                > <NAME:3>Dan
                > <COUNTRY:2>US
                > <QSL_SENT:1>N
                > <QSL_RCVD:1>N
                > <EQSL_QSL_SENT:1>N
                > <EQSL_QSL_RCVD:1>N
                > <LOTW_QSL_SENT:1>N
                > <LOTW_QSL_RCVD:1>N
                > <EOR>
                >
                sniped data


                >
                > <Rec_Type:8>tCONTACT
                > <STATION_UID:1>1
                > <CALL:6>KC9LWZ
                > <BAND:3>20M
                > <MODE:4>DATA
                > <FREQ:9>14.071500
                > <QSO_DATE:10>2010-04-02
                > <QSO_TIME:9>14:38:00Z
                > <SIGN_LOTW_V1.0:175:6>FeOrU14q39jw0tXAW5Wb3/ogWmAW2/h/wCPCohJJsEu66b2i9ZTC/eed

                >
                > Note the "<MODE:4>DATA" line. Which version of tqsl are you using?
                > (I didn't try uploading the file since the QSO is bogus.)
                >

                Mark,

                I am using tqsl version 1.11 that I think is the most current.

                I don't think you used fldigi to generate the .adif file as it contains
                some items not included by fldigi.

                Please try the test QSO again using the fldigi Export ADIF option to
                generate the .adif file.

                I am trying to figure out what may be wrong.

                Dick AA5VU
              • Dick Kriss
                ... To make a long story short.... I have it fixed and now my tqsl remaps PSK250 to DATA and all good. I must have had a bad export on the first try. Thanks
                Message 7 of 10 , Apr 2, 2010
                • 0 Attachment
                  Re: [linuxham] Re: Another LoTW issue with fldigi modes >On 4/2/10 10:03 AM, "Mark" <yahoogroups@...
                  > wrote:
                  >
                  > I tried it this morning and it worked for me.  

                  To make a long story short.... I have it fixed and now my tqsl remaps PSK250 to
                  DATA and all good.

                  I must have had a bad export on the first try.  

                  Thanks for the tip to open the tqsl Preferences/ADIF MODES and to use the
                  ADD button to remap whatever to DATA.  


                  73 Dick AA5VU
                Your message has been successfully submitted and would be delivered to recipients shortly.