Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Trouble with fltk

Expand Messages
  • Nate Bargmann
    Did you, as root, run ldconfig after make install? Does /etc/ld.so.conf have the directory FLTK was installed into? e.g. /usr/local/lib ? 73, de Nate --
    Message 1 of 9 , Mar 2 4:12 AM
    • 0 Attachment
      Did you, as root, run ldconfig after make install?

      Does /etc/ld.so.conf have the directory FLTK was installed into? e.g.
      /usr/local/lib ?

      73, de Nate >>

      --
      Wireless | Amateur Radio Station N0NB | Successfully Microsoft
      Amateur radio exams; ham radio; Linux info @ | free since January 1998.
      http://www.qsl.net/n0nb/ | "Debian, the choice of
      My Kawasaki KZ-650 SR @ | a GNU generation!"
      http://www.networksplus.net/n0nb/ | http://www.debian.org
    • johnrmace
      Nate, I haven t got as far as make install yet, it bombs out during make. When I get that far, if there s a problem I ll know one of the things to look for,
      Message 2 of 9 , Mar 2 4:39 AM
      • 0 Attachment
        Nate,
        I haven't got as far as make install yet, it bombs out during make.
        When I get that far, if there's a problem I'll know one of the things
        to look for, thanks.
        73 John G3ZTU

        --- In linuxham@yahoogroups.com, Nate Bargmann <n0nb@...> wrote:
        >
        > Did you, as root, run ldconfig after make install?
        >
        > Does /etc/ld.so.conf have the directory FLTK was installed into? e.g.
        > /usr/local/lib ?
        >
        > 73, de Nate >>
        >
        > --
        > Wireless | Amateur Radio Station N0NB | Successfully
        Microsoft
        > Amateur radio exams; ham radio; Linux info @ | free since January
        1998.
        > http://www.qsl.net/n0nb/ | "Debian, the
        choice of
        > My Kawasaki KZ-650 SR @ | a GNU generation!"
        > http://www.networksplus.net/n0nb/ |
        http://www.debian.org
        >
      • johnrmace
        Stelios, I thought it was dangerous to assume everything I d need would be in the build-essential package. I was also cautious about using a pre-compiled
        Message 3 of 9 , Mar 2 4:50 AM
        • 0 Attachment
          Stelios,
          I thought it was dangerous to assume everything I'd need would be in
          the build-essential package.
          I was also cautious about using a pre-compiled binary, following
          Dave's advice, but if there's a package out there which has all the
          right buttons pressed I'll give it a try.
          There's enough advice in your mail to keep me playing for ages tonight
          when I get home from work, looking forward to it, thanks!
          I now know why it was easy to get up and running on Fedora Core 4 - 4
          CD's full of stuff! Ubuntu's single disk is a dream to install and
          use, but there's a lot more to download to start tinkering.
          I'm not complaining, it's what this hobby is all about. Fun!
          Thanks again Stelios, and see you on the bands!
          73 John G3ZTU


          --- In linuxham@yahoogroups.com, Stelios Bounanos <lham@...> wrote:
          >
          > >>>>> On Thu, 01 Mar 2007 21:19:33 -0000, johnrmace
          > >>>>> <no_reply@yahoogroups.com> was rumoured to have said:
          >
          > > Dave and the crew,
          > > I've been using fldigi on a Fedora Core 4 system for some time, having
          > > compiled from source, but I took the decision to convert to Ubuntu
          > > 6.06 and start over. The fldigi binary works fine, but in the best ham
          > > tradition I want to tinker under the hood and so I tried to install
          > > fltk. I nursed it through the ./configure stage after telling it where
          > > to find the X11 libs, but now it won't "make". I think the linker
          > > fails after compiling fluid:
          > > .
          > > .
          > > .
          > > Compiling factory.cxx...
          > > Compiling file.cxx...
          > > Compiling fluid.cxx...
          > > Compiling function_panel.cxx...
          > > Compiling template_panel.cxx...
          > > Compiling undo.cxx...
          > > Compiling widget_panel.cxx...
          > > Linking fluid...
          > > /usr/bin/ld: cannot find -lXext
          > > collect2: ld returned 1 exit status
          > > make[1]: *** [fluid] Error 1
          > > john@linux:~/fltk-1.1.7$
          >
          > [snip]
          >
          >
          > John,
          >
          > If the linker fails for -lfoo, then it cannot find libfoo.so or libfoo.a
          > in its library search path. You can find out which package contains
          > libfoo.so using, for instance,
          >
          > "apt-file search libfoo.so"
          >
          > (you would need to install apt-file and do "apt-file update" first).
          >
          > At the moment you are missing libXext.so, which is in libxext-dev.
          >
          > On Debian/Ubuntu there used to be a single package that contained all
          > X11 development headers and libraries, but with the introduction of
          > modular X.org, it was broken into various smaller packages. So of those
          > you want libxext-dev, but see below.
          >
          >
          > Is there some advantage to recompiling fltk manually? I'm too lazy to
          > check the Ubuntu package, but on Debian unstable libfltk1.1
          > build-depends on the jpeg, zlib and png libraries, and is compiled with
          >
          > "--enable-shared --enable-threads --enable-xft --enable-xinerama
          > --without-links"
          >
          > This should have the same effect as the
          >
          > "./configure $* --enable-threads --enable-xft --enable-localjpeg
          > --enable-localpng --enable-localzlib"
          >
          > proposed elsewhere in this thread because the enable-local* flags
          > default to auto.
          >
          >
          > So, John, try installing libfltk1.1-dev instead. This will take care of
          > the fltk side of things. You may also want hamlib-dev and so on.
          >
          > If you do need to recompile fltk from source, try
          >
          > "apt-get build-dep libfltk1.1"
          >
          > first. This will bring in libxext-dev and everything else that fltk
          > needs to compile.
          >
          >
          > Rgds,
          > /-sb.
          >
        • johnrmace
          ... Stelios, not wanting to be beaten, I persevered with building fltk by doing apt-get build-dep libfltk1.1 and that did the trick - fltk compiled and
          Message 4 of 9 , Mar 4 6:52 AM
          • 0 Attachment
            --- In linuxham@yahoogroups.com, Stelios Bounanos <lham@...> wrote:
            >
            > >>>>> On Thu, 01 Mar 2007 21:19:33 -0000, johnrmace
            > >>>>> <no_reply@yahoogroups.com> was rumoured to have said:
            >
            > > Dave and the crew,
            > > I've been using fldigi on a Fedora Core 4 system for some time, having
            > > compiled from source, but I took the decision to convert to Ubuntu
            > > 6.06 and start over. The fldigi binary works fine, but in the best ham
            > > tradition I want to tinker under the hood and so I tried to install
            > > fltk. I nursed it through the ./configure stage after telling it where
            > > to find the X11 libs, but now it won't "make". I think the linker
            > > fails after compiling fluid:
            > > .
            > > .
            > > .
            > > Compiling factory.cxx...
            > > Compiling file.cxx...
            > > Compiling fluid.cxx...
            > > Compiling function_panel.cxx...
            > > Compiling template_panel.cxx...
            > > Compiling undo.cxx...
            > > Compiling widget_panel.cxx...
            > > Linking fluid...
            > > /usr/bin/ld: cannot find -lXext
            > > collect2: ld returned 1 exit status
            > > make[1]: *** [fluid] Error 1
            > > john@linux:~/fltk-1.1.7$
            >
            > [snip]
            >
            >
            > John,
            >
            > If the linker fails for -lfoo, then it cannot find libfoo.so or libfoo.a
            > in its library search path. You can find out which package contains
            > libfoo.so using, for instance,
            >
            > "apt-file search libfoo.so"
            >
            > (you would need to install apt-file and do "apt-file update" first).
            >
            > At the moment you are missing libXext.so, which is in libxext-dev.
            >
            > On Debian/Ubuntu there used to be a single package that contained all
            > X11 development headers and libraries, but with the introduction of
            > modular X.org, it was broken into various smaller packages. So of those
            > you want libxext-dev, but see below.
            >
            >
            > Is there some advantage to recompiling fltk manually? I'm too lazy to
            > check the Ubuntu package, but on Debian unstable libfltk1.1
            > build-depends on the jpeg, zlib and png libraries, and is compiled with
            >
            > "--enable-shared --enable-threads --enable-xft --enable-xinerama
            > --without-links"
            >
            > This should have the same effect as the
            >
            > "./configure $* --enable-threads --enable-xft --enable-localjpeg
            > --enable-localpng --enable-localzlib"
            >
            > proposed elsewhere in this thread because the enable-local* flags
            > default to auto.
            >
            >
            > So, John, try installing libfltk1.1-dev instead. This will take care of
            > the fltk side of things. You may also want hamlib-dev and so on.
            >
            > If you do need to recompile fltk from source, try
            >
            > "apt-get build-dep libfltk1.1"
            >
            > first. This will bring in libxext-dev and everything else that fltk
            > needs to compile.
            >
            >
            > Rgds,
            > /-sb.
            >
            Stelios,
            not wanting to be beaten, I persevered with building fltk by doing
            "apt-get build-dep libfltk1.1" and that did the trick - fltk compiled
            and installed, and I was then able to build fldigi successfully.
            I'm on the air again!
            1.30 works great, save the transmit audio (red) fader on the left -
            doesn't have any effect, but I can adjust my tx level from the pcm
            control on the config window. I've always been baffled by audio in Linux.
            My build behaves identically to the binary download.
            Thanks again, Stelios, for your help, you got me on the air.
            73,
            John G3ZTU
          Your message has been successfully submitted and would be delivered to recipients shortly.