Loading ...
Sorry, an error occurred while loading the content.

tx / rx 'volume' controls

Expand Messages
  • o11oo1oo
    I m not getting anywhere figuring out why, with the manage mixer box in soundcard configuration mixer checked, adjusting the sliders on the main fldigi
    Message 1 of 7 , Feb 7, 2010
    • 0 Attachment
      I'm not getting anywhere figuring out why, with the 'manage mixer' box in soundcard configuration>mixer checked, adjusting the sliders on the main fldigi screen appears to have no effect on anything.

      Reading the online documentation i see it mentions that I need to have 'libportaudio2' on my system. I can't find anything exactly like that, only 'portaudio-19-9'. I have been able to decode signals off the air ok. Does this tell me I don't need to keep trying to find libportaudio2 ?

      I'm trying to use a signalink USB, which has its own TX and RX pots., so maybe I'm safe just leaving 'manage mixer' un-checked and just using the physical knobs on the signalink?

      Also in my surfing for answers I found Fedora 12's repository, it appears to me, does not contain the most current release of fldigi. Could this be my problem? Do I need to see about a different method for getting version 3.12 installed instead of what I have (3.11.6)?

      N0YZS
      Fedora 12
      eeePC1000he
    • Roger G6CKR
      ... Hi I run a SignaLink USB and have the manager mixer unchecked and it works fine. I m running Ubuntu so can t be specific but I would have thought that the
      Message 2 of 7 , Feb 7, 2010
      • 0 Attachment
        On Sun, 2010-02-07 at 22:35 +0000, o11oo1oo wrote:
        > I'm not getting anywhere figuring out why, with the 'manage mixer' box in soundcard configuration>mixer checked, adjusting the sliders on the main fldigi screen appears to have no effect on anything.
        >
        > Reading the online documentation i see it mentions that I need to have 'libportaudio2' on my system. I can't find anything exactly like that, only 'portaudio-19-9'. I have been able to decode signals off the air ok. Does this tell me I don't need to keep trying to find libportaudio2 ?
        >
        > I'm trying to use a signalink USB, which has its own TX and RX pots., so maybe I'm safe just leaving 'manage mixer' un-checked and just using the physical knobs on the signalink?
        >
        > Also in my surfing for answers I found Fedora 12's repository, it appears to me, does not contain the most current release of fldigi. Could this be my problem? Do I need to see about a different method for getting version 3.12 installed instead of what I have (3.11.6)?
        >
        > N0YZS
        > Fedora 12
        > eeePC1000he
        Hi
        I run a SignaLink USB and have the manager mixer unchecked and it works
        fine.
        I'm running Ubuntu so can't be specific but I would have thought that
        the binaries from the <http://www.w1hkj.com/index.htm> web site should
        work for you.
        73 Roger G6CKR
      • Rick Kunath
        ... I don t have the Signalink unit, so don t know the specifics on the soundcard in it. Does the KDE or Gnome mixer have controls for the Signalink unit on a
        Message 3 of 7 , Feb 7, 2010
        • 0 Attachment
          On Sunday 07 February 2010 05:35:08 pm you wrote:
          > I'm not getting anywhere figuring out why, with the 'manage mixer' box in
          > soundcard configuration>mixer checked, adjusting the sliders on the main
          > fldigi screen appears to have no effect on anything.

          I don't have the Signalink unit, so don't know the specifics on the soundcard
          in it.

          Does the KDE or Gnome mixer have controls for the Signalink unit on a tab?
          I.e. can the soundcard's levels be adjusted via a software mixer at all?

          If not, you are not going to get the mixer sliders in Fldigi working.

          As far as I know there haven't been any changes to the mixer portion of Fldigi
          for a while, so what you have should be workable.

          Since this Signalink unit is a second soundcard, you will have to alias the
          mixer controls and the then (probably) map mixer elements manually. On some
          primary soundcards this is needed also.

          Fldigi used the alsa-oss emulated mixer to adjust the soundcard's software
          mixer elements. Make sure this is installed. Then make sure the alsa-oss
          emulated mixer elements are mapped to the correct actual controls on your
          soundcard. The package maintainer for your soundcard driver generally does
          this mapping, but it's not always done right.

          I have posted details on how to determine what to do and how to re-map these
          mixer controls (if you need to) on the list a few times. You will find the
          details on a list search at the list's Yahoo page.

          But again, if the Signalink unit has no software adjustable controls, you are
          out of luck.

          Does anyone know if it does?

          Rick Kunath, k9ao
        • o11oo1oo
          Roger & Rick Thanks for the info. I ll try some more searching of the list here about the remapping , but if nothing makes sense to me (I a Linux noob) it
          Message 4 of 7 , Feb 7, 2010
          • 0 Attachment
            Roger & Rick

            Thanks for the info. I'll try some more searching of the list here about the 'remapping', but if nothing makes sense to me (I a Linux noob) it appears it won't be a deal-breaker.

            Dan
          • Rick Kunath
            ... The first thing is to see if there are even software controls for the Signalink unit. The mixer for the driver in use should have these shown. In KDE (or
            Message 5 of 7 , Feb 7, 2010
            • 0 Attachment
              On Sunday 07 February 2010 06:43:43 pm you wrote:

              > Thanks for the info. I'll try some more searching of the list here about
              > the 'remapping', but if nothing makes sense to me (I a Linux noob) it
              > appears it won't be a deal-breaker.

              The first thing is to see if there are even software controls for the Signalink
              unit. The mixer for the driver in use should have these shown.

              In KDE (or Gnome) you'd get a mixer window with a tab for each recognized
              soundcard. If you see one for the Signalink unit, you can likely get the
              Fldigi mixer sliders working easily.



              Rick Kunath, k9ao
            • Ed
              ... Here is the link :: http://groups.yahoo.com/group/linuxham/message/3691 Ed W3NR
              Message 6 of 7 , Feb 7, 2010
              • 0 Attachment
                o11oo1oo wrote:
                > Roger & Rick
                >
                > Thanks for the info. I'll try some more searching of the list here about the 'remapping', but if nothing makes sense to me (I a Linux noob) it appears it won't be a deal-breaker.
                >
                > Dan
                >

                Here is the link ::

                http://groups.yahoo.com/group/linuxham/message/3691


                Ed W3NR
              • Mike
                Just leave the standard audio settings on the netbook at maximum. Be sure to tag the Audio Codec soundcard in the fldigi soundcard menu. This works just fine
                Message 7 of 7 , Feb 8, 2010
                • 0 Attachment
                  Just leave the standard audio settings on the netbook at maximum.  Be sure to tag the Audio Codec soundcard in the fldigi soundcard menu.
                   
                  This works just fine with the EeePC 900 and the USB SignaLink in Ubunto. 
                   
                  Vy 73 de Mike  GU3WHN
                   
                  ----- Original Message -----
                  From: o11oo1oo
                  Sent: Sunday, February 07, 2010 10:35 PM
                  Subject: [linuxham] tx / rx 'volume' controls

                   

                  I'm not getting anywhere figuring out why, with the 'manage mixer' box in soundcard configuration> mixer checked, adjusting the sliders on the main fldigi screen appears to have no effect on anything.

                  Reading the online documentation i see it mentions that I need to have 'libportaudio2' on my system. I can't find anything exactly like that, only 'portaudio-19- 9'. I have been able to decode signals off the air ok. Does this tell me I don't need to keep trying to find libportaudio2 ?

                  I'm trying to use a signalink USB, which has its own TX and RX pots., so maybe I'm safe just leaving 'manage mixer' un-checked and just using the physical knobs on the signalink?

                  Also in my surfing for answers I found Fedora 12's repository, it appears to me, does not contain the most current release of fldigi. Could this be my problem? Do I need to see about a different method for getting version 3.12 installed instead of what I have (3.11.6)?

                  N0YZS
                  Fedora 12
                  eeePC1000he

                Your message has been successfully submitted and would be delivered to recipients shortly.