Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Win XP/FLDigi/Tentec Jupiter setup

Expand Messages
  • W7ZAC
    Hi Dave Yes it does try to work at first then it loses sync and sets a 5xxx.xx frequency and then will not track. I will keep playing with it, but the Jupiter
    Message 1 of 13 , Jan 1, 2010
    • 0 Attachment
      Hi Dave
       
      Yes it does try to work at first then it loses sync and sets a 5xxx.xx frequency and then will not track. I will keep playing with it, but the Jupiter only has four control/data lines to the DSP Board (max232SM chip) CTS,RTS, RXD, TXD so that is all we have to work with. I have been working with Mike Cubbucio who writes callsign software on this for several years now as a beta tester for him. I look forward to testing it with you when you get your Jupiter there. Mike has a Routing Bridge now in his software, and I will also be trying to get that to work with Fldigi.
       
      Thanks and best 73 HNY
       
      Keith
       
      ----- Original Message -----
      From: w1hkj
      Sent: Thursday, December 31, 2009 2:25 PM
      Subject: Re: [linuxham] Win XP/FLDigi/Tentec Jupiter setup

       

      W7ZAC wrote:



      HI Ed
       
      Yes, I tried that. The Jupiter user 57600 baud 8,n,1 and hardware (RTS/CTS) Handshaking. That is fixed in the firmware. I use a SignaLink USB Soundcard interface,
      so that is easy to set up and requires no PTT to be used. I have downloaded flrig 0.9.99B and I am attempting to get it to work. It does see the rig and does initially
      set the frequency, and mode, and has audio controls and passband tuning, but it will not keep up with the jupiter right, and I haven't been able to get it to connect
      to Fldigi 3.13BK yet. I think I will just give up and just use Ham Radio Deluxe. Much easier to use. But I like to experiment, so who knows?
       
      Thanks for the reply.
       
      Keith
       
      W7ZAC
      Well, I have a Jupiter coming to me next week Keith, so I might be able to see why flrig is not working as expected.  I think it might still have to do with your timing values.  If you can send me a screenshot of just the configuration dialog for flrig and the jupiter.

      To get it to talk correctly with fldigi you will need to get the two programs to talk to each other.

      Start fldigi and open the rig control configuration dialog tab.  Deselect all controls except for the "XMLRPC" tab.  Set that to use and press initialize.

      Save the configuration.

      Then start flrig and two should be talking.

      Dave

    • w1hkj
      ... Please send me your settings on the flrig configuration tab. The initial values look like this: Dave
      Message 2 of 13 , Jan 1, 2010
      • 0 Attachment
        W7ZAC wrote:


        Hi Dave
         
        Yes it does try to work at first then it loses sync and sets a 5xxx.xx frequency and then will not track. I will keep playing with it, but the Jupiter only has four control/data lines to the DSP Board (max232SM chip) CTS,RTS, RXD, TXD so that is all we have to work with. I have been working with Mike Cubbucio who writes callsign software on this for several years now as a beta tester for him. I look forward to testing it with you when you get your Jupiter there. Mike has a Routing Bridge now in his software, and I will also be trying to get that to work with Fldigi.
         
        Thanks and best 73 HNY
         
        Keith
        Please send me your settings on the flrig configuration tab.  The initial values look like this:




        Dave
      • W7ZAC
        Dave, I just enabled DTR and it is working fine now. I guess the PC side (comm port) needs to see this to keep the link going. 73 Keith W7ZAC ... From: w1hkj
        Message 3 of 13 , Jan 1, 2010
        • 0 Attachment
          Dave, I just enabled  DTR and it is working fine now. I guess the PC side (comm port) needs to see this to keep the link going.
           
          73
           
          Keith
           
          W7ZAC
           
          ----- Original Message -----
          From: w1hkj
          Sent: Thursday, December 31, 2009 2:25 PM
          Subject: Re: [linuxham] Win XP/FLDigi/Tentec Jupiter setup

           

          W7ZAC wrote:



          HI Ed
           
          Yes, I tried that. The Jupiter user 57600 baud 8,n,1 and hardware (RTS/CTS) Handshaking. That is fixed in the firmware. I use a SignaLink USB Soundcard interface,
          so that is easy to set up and requires no PTT to be used. I have downloaded flrig 0.9.99B and I am attempting to get it to work. It does see the rig and does initially
          set the frequency, and mode, and has audio controls and passband tuning, but it will not keep up with the jupiter right, and I haven't been able to get it to connect
          to Fldigi 3.13BK yet. I think I will just give up and just use Ham Radio Deluxe. Much easier to use. But I like to experiment, so who knows?
           
          Thanks for the reply.
           
          Keith
           
          W7ZAC
          Well, I have a Jupiter coming to me next week Keith, so I might be able to see why flrig is not working as expected.  I think it might still have to do with your timing values.  If you can send me a screenshot of just the configuration dialog for flrig and the jupiter.

          To get it to talk correctly with fldigi you will need to get the two programs to talk to each other.

          Start fldigi and open the rig control configuration dialog tab.  Deselect all controls except for the "XMLRPC" tab.  Set that to use and press initialize.

          Save the configuration.

          Then start flrig and two should be talking.

          Dave

        • w1hkj
          ... The Jupiter should also be responsive to the TT-550 (Pegasus) command set Keith. Testing both the native and the emulation control modes is on my list of
          Message 4 of 13 , Jan 1, 2010
          • 0 Attachment
            W7ZAC wrote:


            Hi Dave
             
            Yes it does try to work at first then it loses sync and sets a 5xxx.xx frequency and then will not track. I will keep playing with it, but the Jupiter only has four control/data lines to the DSP Board (max232SM chip) CTS,RTS, RXD, TXD so that is all we have to work with. I have been working with Mike Cubbucio who writes callsign software on this for several years now as a beta tester for him. I look forward to testing it with you when you get your Jupiter there. Mike has a Routing Bridge now in his software, and I will also be trying to get that to work with Fldigi.
             
            Thanks and best 73 HNY
             
            Keith
            The Jupiter should also be responsive to the TT-550 (Pegasus) command set Keith.  Testing both the native and the emulation control modes is on my list of to-do's when the Jupiter arrives.

            Dave
          • W7ZAC
            Hi Dave My settings are the same except I had to tick the DTR line high to keep the PC Comm Port linked up to the Jupiter. I am using com6 and also using Win
            Message 5 of 13 , Jan 1, 2010
            • 0 Attachment
              Hi Dave
               
              My settings are the same except I had to tick the DTR line high to keep the PC Comm Port linked up to the Jupiter. I am using com6 and also using Win XP Pro on a
              3.33 Ghz Intel processor PC.
               
              So, it all works except the ptt line, I will work on that. It is not needed though, because the Jupiter is not using the pegasus emulation mode for this software.
               
              73
              Keith
               
              W7ZAC
               
              ----- Original Message -----
              From: w1hkj
              Sent: Friday, January 01, 2010 6:26 AM
              Subject: Re: [linuxham] Win XP/FLDigi/Tentec Jupiter setup

              W7ZAC wrote:


              Hi Dave
               
              Yes it does try to work at first then it loses sync and sets a 5xxx.xx frequency and then will not track. I will keep playing with it, but the Jupiter only has four control/data lines to the DSP Board (max232SM chip) CTS,RTS, RXD, TXD so that is all we have to work with. I have been working with Mike Cubbucio who writes callsign software on this for several years now as a beta tester for him. I look forward to testing it with you when you get your Jupiter there. Mike has a Routing Bridge now in his software, and I will also be trying to get that to work with Fldigi.
               
              Thanks and best 73 HNY
               
              Keith
              Please send me your settings on the flrig configuration tab.  The initial values look like this:




              Dave
            • w1hkj
              ... Did you enable DTR on the Jupiter or the flrig program? Dave
              Message 6 of 13 , Jan 1, 2010
              • 0 Attachment
                W7ZAC wrote:


                Dave, I just enabled  DTR and it is working fine now. I guess the PC side (comm port) needs to see this to keep the link going.
                 
                73
                 
                Keith
                 
                W7ZAC
                Did you enable DTR on the Jupiter or the flrig program?

                Dave
              • W7ZAC
                Hi Dave I will try that. Callsign Software uses the pegasus emulation mode. Keith ... From: w1hkj To: linuxham@yahoogroups.com Sent: Friday, January 01, 2010
                Message 7 of 13 , Jan 1, 2010
                • 0 Attachment
                  Hi Dave
                   
                  I will try that. Callsign Software uses the pegasus emulation mode.
                   
                  Keith
                   
                   
                   
                  ----- Original Message -----
                  From: w1hkj
                  Sent: Friday, January 01, 2010 6:28 AM
                  Subject: Re: [linuxham] Win XP/FLDigi/Tentec Jupiter setup

                   

                  W7ZAC wrote:



                  Hi Dave
                   
                  Yes it does try to work at first then it loses sync and sets a 5xxx.xx frequency and then will not track. I will keep playing with it, but the Jupiter only has four control/data lines to the DSP Board (max232SM chip) CTS,RTS, RXD, TXD so that is all we have to work with. I have been working with Mike Cubbucio who writes callsign software on this for several years now as a beta tester for him. I look forward to testing it with you when you get your Jupiter there. Mike has a Routing Bridge now in his software, and I will also be trying to get that to work with Fldigi.
                   
                  Thanks and best 73 HNY
                   
                  Keith
                  The Jupiter should also be responsive to the TT-550 (Pegasus) command set Keith.  Testing both the native and the emulation control modes is on my list of to-do's when the Jupiter arrives.

                  Dave

                • W7ZAC
                  Hi Dave I enabled it in the flrig program. There are no controls available in the jupiter firmware setup, it is all done inside the DSP board itself, and no
                  Message 8 of 13 , Jan 1, 2010
                  • 0 Attachment
                    Hi Dave
                     
                    I enabled it in the flrig program. There are no controls available in the jupiter firmware setup, it is all done inside the DSP board itself, and no way to change anything (baud rates, flow control, etc). 57,600, 8,n,1 RTS/CTS control is burned into the firmware, TenTec says.
                     
                    Keith
                     
                    W7ZAC
                     
                    ----- Original Message -----
                    From: w1hkj
                    Sent: Friday, January 01, 2010 6:38 AM
                    Subject: Re: [linuxham] Win XP/FLDigi/Tentec Jupiter setup

                     

                    W7ZAC wrote:



                    Dave, I just enabled  DTR and it is working fine now. I guess the PC side (comm port) needs to see this to keep the link going.
                     
                    73
                     
                    Keith
                     
                    W7ZAC
                    Did you enable DTR on the Jupiter or the flrig program?

                    Dave

                  • w1hkj
                    ... OK I will change the default to DTR - ON for the Jupiter and the Pegasus. The transceiver wants to know there is a live computer connected. Dave
                    Message 9 of 13 , Jan 1, 2010
                    • 0 Attachment
                      W7ZAC wrote:


                      Hi Dave
                       
                      I enabled it in the flrig program. There are no controls available in the jupiter firmware setup, it is all done inside the DSP board itself, and no way to change anything (baud rates, flow control, etc). 57,600, 8,n,1 RTS/CTS control is burned into the firmware, TenTec says.
                       
                      Keith
                      OK I will change the default to DTR - ON for the Jupiter and the Pegasus.  The transceiver wants to know there is a live computer connected.

                      Dave
                    Your message has been successfully submitted and would be delivered to recipients shortly.