Loading ...
Sorry, an error occurred while loading the content.

Re: [NBEMSham] Setup for two Radios

Expand Messages
  • w1hkj
    ... I am sure that other s will have the same question, so I am posting this response on all three fldigi support groups. Please refer to the following on-line
    Message 1 of 1 , Dec 19, 2009
    • 0 Attachment
      k4hcp wrote:
      This past Friday I was able to get fldigi working with my rigblaster plus and Icom756Pro3. I would also like to use the program for a signalink USB interface with a Icom706MK2G. Can the program be reloaded under a different name or can there be an additional configuration file done for the current program. What is the best option?
      I am sure that other's will have the same question, so I am posting this response on all three fldigi support groups.

      Please refer to the following on-line help pages:


      and to the following email excerpt

      Subject: Re: Two copies of fldigi/flarq running at the same time

      Gary Wescom wrote:
      Tom, Joe,
      The there is a trick to having multiple configurations for fldigi available on Win32.  I assume this same thing can be done on UNIX but don't run that here.  You need to have separate configuration directories for each copy.  As delivered, the configuration directory defaults to something like "C:\Documents and Settings\wescom\fldigi.files".  I decided to not only create a second directory but to create two directories, one name "C:\NBEMS_HF" and one named "C:NBEMS_VHF" corresponding to my two external sound card digital interfaces.  You need create only one new directory if you wish.
      I'll describe the full setup now in procedure form.
      1. Create a new fldigi configuration directory.  As an example, I created "C:NBEMS_VHF" (like I described above)
      2. Create a second shortcut identical to the existing fldigi.exe shortcut.  In XP all you do is right click on the shortcut icon and click copy.  You then slip the cursor to a blank spot on the screen, right click again, and click the paste option. You now have two identical icons to start fldigi.
      3. Rename that icon to something other than that of the original icon so you will be able to tell them apart.
      4. Right click on your new icon.
      5. Select the properties option.  There will be line labeled "Target."  It should contain something like this: "C:\Program Files\Fldigi-3.13BD\fldigi.exe"  The actual filename may change as versions change but it should look similar to this.
      6. Add the following text to the Target line (except use the name of the directory you created in step 1 above): --config-dir C:\NBEMS_VHF  (Note that it is dash dash config dash dir)
      7. Click "Apply" and "OK" to exit the properties box.
      8. Click on the your new icon to start the second copy of fldigi and configure it as needed.
      OK, now you can run two copies of fldigi at the same time.  What about flarq.  If you choose to run only one of your fldigi configurations at a time, flarq will hook up with whichever one is running.  A problem comes up if you try to run flarq with two copies of fldigi running at the same time.  flarq communicates with fldigi using TCP/IP port 3122.  Whichever copy of fldigi is started first will claim that port.  flarq will only be able to talk to that one.  To have two copies of flarq running with two configurations of fldigi running it is necessary to have them use different TCP/IP ports.  The procedure for changing the arq server port number in fldigi is similar to how we changed its default directory.  We add it as an additional parameter on the icon Target line.  My NBEMS_VHF target line looks like this:
      "C:\Program Files\Fldigi-3.13BD\fldigi.exe" --config-dir C:\NBEMS_VHF --arq-server-port 3123
      Notice that I simply added one to the default 3122 port number to get 3123.  It is not scientific but it works in my machine.
      Next, we need to create a second flarq icon as in steps 2 and 3 above.  I named it "flarq_vhf".  Add the --arq-server-port 3123 thing to end of its target line.  My flarq_vhf target line looks like:
      "C:\Program Files\Fldigi-3.13BD\flarq.exe" --arq-server-port 3123
      Notice that there is no --config-dir parameter used.  flarq does not recognize that parameter and will not start if it is added.  Instead, it defaults to something like:
      C:\Documents and Settings\wescom\NBEMS.files
      That is OK with me, in fact I was planning on having both versions use the same directory space anyway to simplify moving stuff between HF and VHF.
      Anyway, that is what I have done so far.  My PC is has not turned into a smoking heap nor has anything bad happened yet so I'm hoping I got this procedure correct..
      Gary - N0GW
      YOU GOT IT NEARLY 100% GARY, and well written also.  Here is the missing piece.

      You do not need to create the fldigi data files folders before creating the multiple launchers.  Fldigi will do that for you the first time you launch the program.

      Be sure that you use a fully qualified folder name if it is is a place that has spaces in the name, ie:

      --config-dir "c:\Documents and Settings\dave\fldigi_VHF.fies"

      Spaces in folder names are a hazard and I have not idea why MS decided on that name for the default files folder.

    Your message has been successfully submitted and would be delivered to recipients shortly.