Loading ...
Sorry, an error occurred while loading the content.

Issues with 3.12.5 In Kbuntu 9.10 with KDE 4.3.3 (AMD 64 bit)

Expand Messages
  • Donald Walters
    Situation: I have recompiled and installed fldigi 3.12.5 in Kbuntu 9.10 (64 bit) with KDE 4.3.3 .  Compared to the repository version of  fldigi
    Message 1 of 5 , Dec 6, 2009
    • 0 Attachment
      Situation:

      I have recompiled and installed fldigi 3.12.5 in Kbuntu 9.10 (64 bit) with KDE 4.3.3 .  Compared to the repository version of  fldigi Kbuntu/Ubuntu/ Debian repository 3.11.4.
      3.15.5 does seem to work ok, but there are serious issues:

      1.  Fonts are very poor in all the text in 3.12.15, particular the upper left frequency displayed.. All the fonts look like old dot matrix printer fonts.

      I don't remember seeing this with 3.12.15 installed in the earlier LDS Hardy  8.53 (which is still there sitting inactive on a second, spare drive ). 

      2. Also, I notice that the default  fonts that at are available in 3.11.4 are all different from those in 3.12.5.  I remember that this was a deliberate change for 3.12.5... Is this a problem with 64 bit

      3.  How do I change the default starting frequency.  At start up, both 3.11.4 and 3.12.5 start with 3.850, but can I change this.   I remember in earlier version, and perhaps is was gmfsk where this was changeable in the startup file.

      4.  I notice when I run the the PSK browser, then the whole Kbuntu session becomes unstable, there is a ~50% chance that if I start up Firefox or some other program, that the sound card will no longer function...(very strange).  At best I have to stop the X  session, but usually have to reboot to get the sound back... Ideas??

      5.  By the way, the ONLY way I could get the sound card to work in Kbuntu 9.10 64 bit was to use ALSA/OSS  sound.  Amaroc, VLC, fldigi, etc would not work otherwise.

       Port auto or pulse audio have never worked in any fldigi version..   (not sure with hardy, but I think OSS is the working sound mode there also)

      In any case, I HAD to install the NVIDIA restricted drivers to get the SOUND card  to work in Kbuntu 9.10 64 bit... go figure? 

      Nada otherwise, no matter what choice of /ALSA/OSS  port-audio, pulse-audio that I tired would work. (but the sound card would sound on session startup...!)

      Suggestions requested.  I can alter and recompile the source code as necessary. (hopefully, without having to alter the kernel source which is now 2.6.31-16-generic)

      73

      Don W
      W9DKI
      (New to this group)

    • w1hkj
      ... You did not compile the Fast Light Toolkit (fltk) with the --enable-xft switch set when running configure . Please review the build instructions found
      Message 2 of 5 , Dec 7, 2009
      • 0 Attachment
        Donald Walters wrote:


        Situation:

        I have recompiled and installed fldigi 3.12.5 in Kbuntu 9.10 (64 bit) with KDE 4.3.3 .  Compared to the repository version of  fldigi Kbuntu/Ubuntu/ Debian repository 3.11.4.
        3.15.5 does seem to work ok, but there are serious issues:

        1.  Fonts are very poor in all the text in 3.12.15, particular the upper left frequency displayed.. All the fonts look like old dot matrix printer fonts.

        I don't remember seeing this with 3.12.15 installed in the earlier LDS Hardy  8.53 (which is still there sitting inactive on a second, spare drive ). 

        2. Also, I notice that the default  fonts that at are available in 3.11.4 are all different from those in 3.12.5.  I remember that this was a deliberate change for 3.12.5... Is this a problem with 64 bit
        You did not compile the Fast Light Toolkit (fltk) with the --enable-xft switch set when running "configure".  Please review the build instructions found here: https://fedorahosted.org/fldigi/wiki ... drill down on FAQ.

        3.  How do I change the default starting frequency.  At start up, both 3.11.4 and 3.12.5 start with 3.850, but can I change this.   I remember in earlier version, and perhaps is was gmfsk where this was changeable in the startup file.
        Either wait until 3.13 is published or download and compile that in alpha form from http://www.w1hkj.com/alpha

        4.  I notice when I run the the PSK browser, then the whole Kbuntu session becomes unstable, there is a ~50% chance that if I start up Firefox or some other program, that the sound card will no longer function...(very strange).  At best I have to stop the X  session, but usually have to reboot to get the sound back... Ideas??
        Either disable the desktop manager access to the sound card or use a sound card manager such as "jack".

        5.  By the way, the ONLY way I could get the sound card to work in Kbuntu 9.10 64 bit was to use ALSA/OSS  sound.  Amaroc, VLC, fldigi, etc would not work otherwise.

         Port auto or pulse audio have never worked in any fldigi version..   (not sure with hardy, but I think OSS is the working sound mode there also)
        Strange, I have both working on Ubuntu 9.04 on the following:  Acer Aspire E2180 desktop, Compaq Pavilion notebook, and Lenovo S10 netbook. (all 32 bit).

        In any case, I HAD to install the NVIDIA restricted drivers to get the SOUND card  to work in Kbuntu 9.10 64 bit... go figure? 

        Nada otherwise, no matter what choice of /ALSA/OSS  port-audio, pulse-audio that I tired would work. (but the sound card would sound on session startup...!)

        Suggestions requested.  I can alter and recompile the source code as necessary. (hopefully, without having to alter the kernel source which is now 2.6.31-16-generic)
        Can you install a 32 bit 9.1x image to boot from?  Some of your problems may stem from h/w specific 64 bit drivers.

        73, Dave, W1HKJ

      • Ed
        On Sun, 6 Dec 2009 22:43:19 -0800 (PST) ... To save you some Google time, I also had the same issue. Seems that Firefox claims the sound card at its startup.
        Message 3 of 5 , Dec 7, 2009
        • 0 Attachment
          On Sun, 6 Dec 2009 22:43:19 -0800 (PST)
          Donald Walters <popadoc_atmo@...> wrote:

          > Situation:
          >
          > I have recompiled and installed fldigi 3.12.5 in Kbuntu 9.10 (64 bit)
          > with KDE 4.3.3 .  Compared to the repository version of  fldigi
          > Kbuntu/Ubuntu/ Debian repository 3.11.4. 3.15.5 does seem to work ok,
          > but there are serious issues:
          >
          > 1.  Fonts are very poor in all the text in 3.12.15, particular the
          > upper left frequency displayed.. All the fonts look like old dot
          > matrix printer fonts.
          >
          > I don't remember seeing this with 3.12.15 installed in the earlier
          > LDS Hardy  8.53 (which is still there sitting inactive on a second,
          > spare drive ).. 
          >
          > 2. Also, I notice that the default  fonts that at are available in
          > 3.11.4 are all different from those in 3.12.5.  I remember that this
          > was a deliberate change for 3.12.5... Is this a problem with 64 bit
          >
          > 3.  How do I change the default starting frequency.  At start up,
          > both 3.11.4 and 3.12.5 start with 3.850, but can I change this.   I
          > remember in earlier version, and perhaps is was gmfsk where this was
          > changeable in the startup file.
          >
          > 4.  I notice when I run the the PSK browser, then the whole Kbuntu
          > session becomes unstable, there is a ~50% chance that if I start up
          > Firefox or some other program, that the sound card will no longer
          > function...(very strange).  At best I have to stop the X  session,
          > but usually have to reboot to get the sound back... Ideas??


          To save you some Google time, I also had the same issue. Seems that
          Firefox claims the sound card at its startup. The easiest work around
          is to install a 2nd card. Firefox then will grab card0 by default and
          you can use card1 for fldigi. My solution was to pick up a usb codec
          from Ebay. I also let the system sounds have the same card as Firefox.

          Anothe Google find was to install the Pulse Audio gui, and in the
          Playback tab with a sound event running in Firefox you have the option
          to re-direct the sound.


          > 5.  By the way, the ONLY way I could get the sound card to work in
          > Kbuntu 9.10 64 bit was to use ALSA/OSS  sound.  Amaroc, VLC, fldigi,
          > etc would not work otherwise.

          Make sure you have alsa-oss installed.


          >  Port auto or pulse audio have never worked in any fldigi version.
          > (not sure with hardy, but I think OSS is the working sound mode there
          > also)

          All work here with Port Audio being my choice for fldigi. I control all
          non fldigi sound events via Pulse.


          > In any case, I HAD to install the NVIDIA restricted drivers to get
          > the SOUND card  to work in Kbuntu 9.10 64 bit... go figure? 
          >
          > Nada otherwise, no matter what choice of /ALSA/OSS  port-audio,
          > pulse-audio that I tired would work. (but the sound card would sound
          > on session startup...!)
          >
          > Suggestions requested.  I can alter and recompile the source code as
          > necessary. (hopefully, without having to alter the kernel source
          > which is now 2..6.31-16-generic)
          >
          > 73
          >
          > Don W
          > W9DKI
          > (New to this group)

          I'm not sure how you went about building from source, but with
          Ubuntu/Debian take a look as Dave suggested here ::


          https://fedorahosted.org/fldigi/


          Ed W3NR
        • Donald Walters
          Dave:/ Ed Thanks my problem with fldigi 3.12.5 running under Kbuntu 9.10, AMD-64 bit was the compiler flag for fltk --enable-xft That worked but it was much
          Message 4 of 5 , Dec 10, 2009
          • 0 Attachment
            Dave:/ Ed

            Thanks my problem with fldigi 3.12.5 running under  Kbuntu 9.10, AMD-64 bit  was the compiler flag for fltk --enable-xft

            That worked but it was much easier to add

            deb http://download2.berlios.de/pub/fldigi/binaries/karmic/main

            to the repositories in Synaptic ....and sure enough...3.12.5 was there. 

            Even though I am using Kbuntu where KPackageKit is the new default package manager, the old Adept (from Hardy)  and Synaptic from Ubuntu are much better since they show ALL the packages installed, and that are available.

            The repository version of 3.12.5  solved the poor font quality problem.  Now the default font is ...sans... which is a good, clear choice with smoothly formed fonts.

            *********

            Ed:  You were correct, the problem with fldigi loosing control of the sound card under Kbuntu 9.10  (64 bit) occurs with I click on the call sign menu button in fldigi to look up the call sign info in QRZ.   That calls Firefox 3.5.5 on my machine and thin I loose control of the  sound card on return to fldigi.  This is an immediate SK, and requires a reboot / or logout of X-11 to get it back.

             Ubuntu/Kbuntu 9.10 now use Firefox 3.5.5 .   This could be a new issue with 3.5.5.   I did not have this problem with Hardy which uses an earlier version of Firefox   (3.5.0... I think).   I could never get Firefox 3.5.5 to  work under Hardy even with a 100% recompile of Firefox.  I did try to compile firefox from the source,  but gave up with too many dependency issues.

            73

            Don
            w9dki


          • Donald Walters
            FLDIGI sound card problems in 64 bit, kbuntu 9.10 karmic/kola appear to be resolved by a recent kernel upgrade release to 2.6.31-17-generic, at least foro alsa
            Message 5 of 5 , Jan 10, 2010
            • 0 Attachment
              FLDIGI sound card problems in 64 bit, kbuntu 9.10 karmic/kola appear to be resolved by a recent kernel upgrade release to 2.6.31-17-generic, at least foro alsa oss sound card use .  

              The previous sound card problems  with loosing tx with either fldigi or gmsk  in 9.10 Kbuntu/Ubuntu when calling  firefox,  pidgin, vlc or other programs that use the sound card  appear to be resolved, at last for now

              I can now call qrz through firefox with the fldigi  call button now   without having to reboot to get tx back... which always terminated a deep dx contact.  I hope it lasts.

              Now I need to test and see if either portaudio or pulse audio are working.

              don
              w9dki


              From: Donald Walters <popadoc_atmo@...>
              To: linuxham@yahoogroups.com
              Sent: Sun, December 6, 2009 10:43:19 PM
              Subject: [linuxham] Issues with 3.12.5 In Kbuntu 9.10 with KDE 4.3.3 (AMD 64 bit)

               

              Situation:

              I have recompiled and installed fldigi 3.12.5 in Kbuntu 9.10 (64 bit) with KDE 4.3.3 .  Compared to the repository version of  fldigi Kbuntu/Ubuntu/ Debian repository 3.11.4.
              3.15.5 does seem to work ok, but there are serious issues:

              1.  Fonts are very poor in all the text in 3..12.15, particular the upper left frequency displayed.. All the fonts look like old dot matrix printer fonts.

              I don't remember seeing this with 3.12.15 installed in the earlier LDS Hardy  8.53 (which is still there sitting inactive on a second, spare drive ). 

              2. Also, I notice that the default  fonts that at are available in 3.11.4 are all different from those in 3.12.5.  I remember that this was a deliberate change for 3.12.5... Is this a problem with 64 bit

              3.  How do I change the default starting frequency.  At start up, both 3.11.4 and 3.12.5 start with 3.850, but can I change this.   I remember in earlier version, and perhaps is was gmfsk where this was changeable in the startup file.

              4.  I notice when I run the the PSK browser, then the whole Kbuntu session becomes unstable, there is a ~50% chance that if I start up Firefox or some other program, that the sound card will no longer function...( very strange).  At best I have to stop the X  session, but usually have to reboot to get the sound back... Ideas??

              5.  By the way, the ONLY way I could get the sound card to work in Kbuntu 9.10 64 bit was to use ALSA/OSS  sound.  Amaroc, VLC, fldigi, etc would not work otherwise.

               Port auto or pulse audio have never worked in any fldigi version..   (not sure with hardy, but I think OSS is the working sound mode there also)

              In any case, I HAD to install the NVIDIA restricted drivers to get the SOUND card  to work in Kbuntu 9.10 64 bit... go figure? 

              Nada otherwise, no matter what choice of /ALSA/OSS  port-audio, pulse-audio that I tired would work. (but the sound card would sound on session startup...!)

              Suggestions requested.  I can alter and recompile the source code as necessary. (hopefully, without having to alter the kernel source which is now 2.6.31-16-generic)

              73

              Don W
              W9DKI
              (New to this group)


            Your message has been successfully submitted and would be delivered to recipients shortly.