Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] Upgrade OS and fldigi

Expand Messages
  • Warren Stritter
    ... I have been to my daughter s home for thanksgiving and did not have much computer time. When I enter the command I get this warren@warren-mini9laptop:~$
    Message 1 of 20 , Dec 2, 2009
    • 0 Attachment
      On Mon, Nov 23, 2009 at 7:18 AM, Ed <autek@...> wrote:
       

      On Sun, 22 Nov 2009 22:17:44 -0500


      Warren Stritter <wb4ahd@...> wrote:

      > OK everything is working now including the wireless connection!
      > When I run fldigi and go to hamilb to setup my rig, Paragon 585 does
      > not show like it does with 3.12.5 on my xp machine. Is there a
      > different hamlib in each system? I would like to help to get hamlib
      > working with my Paragon but it looks like it will be better to work
      > with linux instead of xp. Tnks for all the help so far. It's been
      > great. Warren WB4AHD

      Open a terminal enter this ::

      rigctl --list

      It should list the Paragon ::

      1609 Ten-Tec TT-585 Paragon 0.1 Alpha

      Ed W3NR

      I have been to my daughter's home for thanksgiving and did not have much computer time.
       When I enter the command I get this
      warren@warren-mini9laptop:~$ rigctl --list
      The program 'rigctl' is currently not installed.  You can install it by typing:
      sudo apt-get install libhamlib-utils
      rigctl: command not found
      warren@warren-mini9laptop:~$
      Then I get
      warren@warren-mini9laptop:~$ sudo apt-get install libhamlib-utls
      [sudo] password for warren:
      Reading package lists... Done
      Building dependency tree      
      Reading state information... Done
      E: Couldn't find package libhamlib-utls
      When I first installed fldigi, I had downloaded the tgz file from your web site. I thought the latest version of hamib would be included. Can I install the latest version of hamlib?
      Tnx Ed for all your trouble. I really appreciate it.
      Warren WB4AHD


    • Bob Nielsen
      Try hamlib-utils , not hamlib-utls . 73, Bob N7XY
      Message 2 of 20 , Dec 2, 2009
      • 0 Attachment
        Try 'hamlib-utils', not 'hamlib-utls'.

        73, Bob N7XY

        On Dec 2, 2009, at 8:21 AM, Warren Stritter wrote:

        >
        >
        >
        >
        > On Mon, Nov 23, 2009 at 7:18 AM, Ed <autek@...> wrote:
        >
        > On Sun, 22 Nov 2009 22:17:44 -0500
        >
        >
        > Warren Stritter <wb4ahd@...> wrote:
        >
        > > OK everything is working now including the wireless connection!
        > > When I run fldigi and go to hamilb to setup my rig, Paragon 585 does
        > > not show like it does with 3.12.5 on my xp machine. Is there a
        > > different hamlib in each system? I would like to help to get hamlib
        > > working with my Paragon but it looks like it will be better to work
        > > with linux instead of xp. Tnks for all the help so far. It's been
        > > great. Warren WB4AHD
        >
        > Open a terminal enter this ::
        >
        > rigctl --list
        >
        > It should list the Paragon ::
        >
        > 1609 Ten-Tec TT-585 Paragon 0.1 Alpha
        >
        > Ed W3NR
        >
        > I have been to my daughter's home for thanksgiving and did not have
        > much computer time.
        > When I enter the command I get this
        > warren@warren-mini9laptop:~$ rigctl --list
        > The program 'rigctl' is currently not installed. You can install
        > it by typing:
        > sudo apt-get install libhamlib-utils
        > rigctl: command not found
        > warren@warren-mini9laptop:~$
        > Then I get
        > warren@warren-mini9laptop:~$ sudo apt-get install libhamlib-utls
        > [sudo] password for warren:
        > Reading package lists... Done
        > Building dependency tree
        > Reading state information... Done
        > E: Couldn't find package libhamlib-utls
        > When I first installed fldigi, I had downloaded the tgz file from
        > your web site. I thought the latest version of hamib would be
        > included. Can I install the latest version of hamlib?
        > Tnx Ed for all your trouble. I really appreciate it.
        > Warren WB4AHD
        >
        >
        >
        >
        > <!-- #ygrp-mkp { border: 1px solid #d8d8d8; font-family: Arial;
        > margin: 10px 0; padding: 0 10px; } #ygrp-mkp hr { border: 1px solid
        > #d8d8d8; } #ygrp-mkp #hd { color: #628c2a; font-size: 85%; font-
        > weight: 700; line-height: 122%; margin: 10px 0; } #ygrp-mkp #ads
        > { margin-bottom: 10px; } #ygrp-mkp .ad { padding: 0 0; } #ygrp-
        > mkp .ad a { color: #0000ff; text-decoration: none; } #ygrp-sponsor
        > #ygrp-lc { font-family: Arial; } #ygrp-sponsor #ygrp-lc #hd
        > { margin: 10px 0px; font-weight: 700; font-size: 78%; line-height:
        > 122%; } #ygrp-sponsor #ygrp-lc .ad { margin-bottom: 10px; padding:
        > 0 0; } a { color: #1e66ae; } #actions { font-family: Verdana; font-
        > size: 11px; padding: 10px 0; } #activity { background-color:
        > #e0ecee; float: left; font-family: Verdana; font-size: 10px;
        > padding: 10px; } #activity span { font-weight: 700; } #activity
        > span:first-child { text-transform: uppercase; } #activity span a
        > { color: #5085b6; text-decoration: none; } #activity span span
        > { color: #ff7900; } #activity span .underline { text-decoration:
        > underline; } .attach { clear: both; display: table; font-family:
        > Arial; font-size: 12px; padding: 10px 0; width: 400px; } .attach
        > div a { text-decoration: none; } .attach img { border: none;
        > padding-right: 5px; } .attach label { display: block; margin-
        > bottom: 5px; } .attach label a { text-decoration: none; }
        > blockquote { margin: 0 0 0 4px; } .bold { font-family: Arial; font-
        > size: 13px; font-weight: 700; } .bold a { text-decoration: none; }
        > dd.last p a { font-family: Verdana; font-weight: 700; } dd.last p
        > span { margin-right: 10px; font-family: Verdana; font-weight:
        > 700; } dd.last p span.yshortcuts { margin-right: 0; } div.attach-
        > table div div a { text-decoration: none; } div.attach-table
        > { width: 400px; } div.file-title a, div.file-title a:active,
        > div.file-title a:hover, div.file-title a:visited { text-decoration:
        > none; } div.photo-title a, div.photo-title a:active, div.photo-
        > title a:hover, div.photo-title a:visited { text-decoration: none; }
        > div#ygrp-mlmsg #ygrp-msg p a span.yshortcuts { font-family:
        > Verdana; font-size: 10px; font-weight: normal; } .green { color:
        > #628c2a; } .MsoNormal { margin: 0 0 0 0; } o { font-size: 0; }
        > #photos div { float: left; width: 72px; } #photos div div { border:
        > 1px solid #666666; height: 62px; overflow: hidden; width: 62px; }
        > #photos div label { color: #666666; font-size: 10px; overflow:
        > hidden; text-align: center; white-space: nowrap; width: 64px; }
        > #reco-category { font-size: 77%; } #reco-desc { font-size:
        > 77%; } .replbq { margin: 4px; } #ygrp-actbar div a:first-child { /
        > * border-right: 0px solid #000;*/ margin-right: 2px; padding-right:
        > 5px; } #ygrp-mlmsg { font-size: 13px; font-family: Arial,
        > helvetica,clean, sans-serif; *font-size: small; *font: x-small; }
        > #ygrp-mlmsg table { font-size: inherit; font: 100%; } #ygrp-mlmsg
        > select, input, textarea { font: 99% Arial, Helvetica, clean, sans-
        > serif; } #ygrp-mlmsg pre, code { font:115% monospace; *font-size:
        > 100%; } #ygrp-mlmsg * { line-height: 1.22em; } #ygrp-mlmsg #logo
        > { padding-bottom: 10px; } #ygrp-mlmsg a { color: #1E66AE; } #ygrp-
        > msg p a { font-family: Verdana; } #ygrp-msg p#attach-count span
        > { color: #1E66AE; font-weight: 700; } #ygrp-reco #reco-head
        > { color: #ff7900; font-weight: 700; } #ygrp-reco { margin-bottom:
        > 20px; padding: 0px; } #ygrp-sponsor #ov li a { font-size: 130%;
        > text-decoration: none; } #ygrp-sponsor #ov li { font-size: 77%;
        > list-style-type: square; padding: 6px 0; } #ygrp-sponsor #ov ul
        > { margin: 0; padding: 0 0 0 8px; } #ygrp-text { font-family:
        > Georgia; } #ygrp-text p { margin: 0 0 1em 0; } #ygrp-text tt { font-
        > size: 120%; } #ygrp-vital ul li:last-child { border-right: none !
        > important; } -->
      • Warren Stritter
        ... Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no
        Message 3 of 20 , Dec 2, 2009
        • 0 Attachment
          On Wed, Dec 2, 2009 at 11:35 AM, Bob Nielsen <n7xy@...> wrote:
          Try 'hamlib-utils', not 'hamlib-utls'.

          73, Bob N7XY

          On Dec 2, 2009, at 8:21 AM, Warren Stritter wrote:

          >
          >
          >
          >
          > On Mon, Nov 23, 2009 at 7:18 AM, Ed <autek@...> wrote:
          >
          > On Sun, 22 Nov 2009 22:17:44 -0500
          >
          >
          > Warren Stritter <wb4ahd@...> wrote:
          >
          > > OK everything is working now including the wireless connection!
          > > When I run fldigi and go to hamilb to setup my rig, Paragon 585 does
          > > not show like it does with 3.12.5 on my xp machine. Is there a
          > > different hamlib in each system? I would like to help to get hamlib
          > > working with my Paragon but it looks like it will be better to work
          > > with linux instead of xp. Tnks for all the help so far. It's been
          > > great. Warren WB4AHD
          >
          > Open a terminal enter this ::
          >
          > rigctl --list
          >
          > It should list the Paragon ::
          >
          > 1609  Ten-Tec TT-585 Paragon 0.1 Alpha
          >
          > Ed W3NR
          >
          > I have been to my daughter's home for thanksgiving and did not have
          > much computer time.
          >  When I enter the command I get this
          > warren@warren-mini9laptop:~$ rigctl --list
          > The program 'rigctl' is currently not installed.  You can install
          > it by typing:
          > sudo apt-get install libhamlib-utils
          > rigctl: command not found
          > warren@warren-mini9laptop:~$
          > Then I get
          > warren@warren-mini9laptop:~$ sudo apt-get install libhamlib-utls
          > [sudo] password for warren:
          > Reading package lists... Done
          > Building dependency tree
          > Reading state information... Done
          > E: Couldn't find package libhamlib-utls
          > When I first installed fldigi, I had downloaded the tgz file from
          > your web site. I thought the latest version of hamib would be
          > included. Can I install the latest version of hamlib?
          > Tnx Ed for all your trouble. I really appreciate it.
          > Warren WB4AHD
          >
          >
          >
          >
          OK. Did it right and got this:
          Reading package lists... Done
          Building dependency tree      
          Reading state information... Done
          The following packages were automatically installed and are no longer required:
            extra-xdg-menus
          Use 'apt-get autoremove' to remove them.
          The following NEW packages will be installed:
            libhamlib-utils
          0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
          Need to get 0B/129kB of archives.
          After this operation, 397kB of additional disk space will be used.
          Selecting previously deselected package libhamlib-utils.
          (Reading database ... 139925 files and directories currently installed.)
          Unpacking libhamlib-utils (from .../libhamlib-utils_1.2.9-1ubuntu1_i386.deb) ...
          Processing triggers for man-db ...
          Setting up libhamlib-utils (1.2.9-1ubuntu1) ...
          When I did rigctl --list, there was  9 for Ten -Tec rigs but none were for the Paragon 585.
          Warren WB4AHD


          ------------------------------------

          Yahoo! Groups Links

          <*> To visit your group on the web, go to:
             http://groups.yahoo.com/group/linuxham/

          <*> Your email settings:
             Individual Email | Traditional

          <*> To change settings online go to:
             http://groups.yahoo.com/group/linuxham/join
             (Yahoo! ID required)

          <*> To change settings via email:
             linuxham-digest@yahoogroups.com
             linuxham-fullfeatured@yahoogroups.com

          <*> To unsubscribe from this group, send an email to:
             linuxham-unsubscribe@yahoogroups.com

          <*> Your use of Yahoo! Groups is subject to:
             http://docs.yahoo.com/info/terms/


        • Ed
          On Wed, 2 Dec 2009 16:01:39 -0500 ... Well, its listed as shown below:: 1609 Ten-Tec TT-585 Paragon 0.1 Alpha I m using 1.2.10 for hamlib.
          Message 4 of 20 , Dec 2, 2009
          • 0 Attachment
            On Wed, 2 Dec 2009 16:01:39 -0500
            Warren Stritter <wb4ahd@...> wrote:


            > > OK. Did it right and got this:
            > >
            > Reading package lists... Done
            > Building dependency tree
            > Reading state information... Done
            > The following packages were automatically installed and are no longer
            > required:
            > extra-xdg-menus
            > Use 'apt-get autoremove' to remove them.
            > The following NEW packages will be installed:
            > libhamlib-utils
            > 0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
            > Need to get 0B/129kB of archives.
            > After this operation, 397kB of additional disk space will be used.
            > Selecting previously deselected package libhamlib-utils.
            > (Reading database ... 139925 files and directories currently
            > installed.) Unpacking libhamlib-utils
            > (from .../libhamlib-utils_1.2.9-1ubuntu1_i386.deb) ...
            > Processing triggers for man-db ...
            > Setting up libhamlib-utils (1.2.9-1ubuntu1) ...
            > When I did rigctl --list, there was 9 for Ten -Tec rigs but none
            > were for the Paragon 585.
            > Warren WB4AHD


            Well, its listed as shown below::


            1609 Ten-Tec TT-585 Paragon 0.1 Alpha

            I'm using 1.2.10 for hamlib. Ubuntu uses 1.2.9, but that shouldn't
            matter. A newer version of hamlib usauly is bug fixes and adding new
            rigs.

            This is the general area where I found it ::

            2601 Video4Linux SW/FM radio 0.2 Beta
            2201 TAPR DSP-10 0.2 Alpha
            1801 Kachina 505DSP 0.3 Alpha
            1609 Ten-Tec TT-585 Paragon 0.1 Alpha
            505 AOR AR3030 0.4 Untested
            361 Icom IC-7200 0.5 Untested


            Ed W3NR
          • Nate Bargmann
            ... In this case it matters. The TT-585 Paragon was added to tentec.c on April 22, 2009, well after 1.2.9 was released so what is there is included in 1.2.10.
            Message 5 of 20 , Dec 2, 2009
            • 0 Attachment
              * Ed <autek@...> [2009 Dec 02 15:44 -0600]:
              > Well, its listed as shown below::
              >
              >
              > 1609 Ten-Tec TT-585 Paragon 0.1 Alpha
              >
              > I'm using 1.2.10 for hamlib. Ubuntu uses 1.2.9, but that shouldn't
              > matter. A newer version of hamlib usauly is bug fixes and adding new
              > rigs.

              In this case it matters. The TT-585 Paragon was added to tentec.c on
              April 22, 2009, well after 1.2.9 was released so what is there is
              included in 1.2.10. However, what is there is only a skeleton of
              backend functions that do nothing except return the -RIG_ENIMPL error
              value. The Paragon backend is in need of a lot of development to be
              useful at all.

              You can check
              http://hamlib.svn.sourceforge.net/viewvc/hamlib/trunk/tentec/paragon.c?view=log
              to see if any new code has been checked in and thus needs testing via
              the daily SVN snapshot:

              http://n0nb.users.sourceforge.net/

              Sorry that the Paragon has yet to receive any love in Hamlib.

              73, de Nate >>

              --

              "The optimist proclaims that we live in the best of all
              possible worlds. The pessimist fears this is true."

              Ham radio, Linux, bikes, and more: http://n0nb.us/index.html
            • Warren Stritter
              ... The man files are very specific but you have to know how to do it and use the man file to figure out the details. I Down loaded the hamlib 1.2.10 solurce
              Message 6 of 20 , Dec 11, 2009
              • 0 Attachment
                On Wed, Dec 2, 2009 at 6:10 PM, Nate Bargmann <n0nb@...> wrote:
                 

                * Ed <autek@...> [2009 Dec 02 15:44 -0600]:


                > Well, its listed as shown below::
                >
                >
                > 1609 Ten-Tec TT-585 Paragon 0.1 Alpha
                >
                > I'm using 1.2.10 for hamlib. Ubuntu uses 1.2.9, but that shouldn't
                > matter. A newer version of hamlib usauly is bug fixes and adding new
                > rigs.

                In this case it matters. The TT-585 Paragon was added to tentec.c on
                April 22, 2009, well after 1.2.9 was released so what is there is
                included in 1.2.10. However, what is there is only a skeleton of
                backend functions that do nothing except return the -RIG_ENIMPL error
                value. The Paragon backend is in need of a lot of development to be
                useful at all.

                You can check
                http://hamlib.svn.sourceforge.net/viewvc/hamlib/trunk/tentec/paragon.c?view=log
                to see if any new code has been checked in and thus needs testing via
                the daily SVN snapshot:

                http://n0nb.users.sourceforge.net/

                Sorry that the Paragon has yet to receive any love in Hamlib.

                73, de Nate >>

                --
                I have looked for documentation on how to download, and install programs. I have found some stuff that is rather gneric and some that is explicit but nothing that describes in general how to do it.
                    The man files are very specific but you have to know how to do it and use the man file to figure out  the details.
                I Down loaded the hamlib 1.2.10 solurce files and found some instructions on how to install it. Here are the steps I took:
                1. I unzipped the files by double clipping the tar ball.
                2. In terminal I got to the directory that had the source.
                3. I entered ./configure.
                3. make.
                4. sudo make load
                Everything seemed to work ok and did a search for  hamlib and found it in local/bin.
                I executed rigcTL -l and it apparently found the old hamlib, because the Paragon was not in there and fldigi did not have the paragon in it's list either.What am I doing wrong and where can I find a document of some sort to figure out what to do?
                I have programmed in fortran, assembly language, and visual c++, but that was many years ago. I'm retired now and maybe to old to do this any more.
                Warren WB4AHD
                "The optimist proclaims that we live in the best of all
                possible worlds. The pessimist fears this is true."

                Ham radio, Linux, bikes, and more: http://n0nb.us/index.html

              • Ed
                On Fri, 11 Dec 2009 13:23:01 -0500 ... Try..... sudo make install You may have to go back and uninstall the old version of hamlib first. I do this as a matter
                Message 7 of 20 , Dec 11, 2009
                • 0 Attachment
                  On Fri, 11 Dec 2009 13:23:01 -0500
                  Warren Stritter <wb4ahd@...> wrote:


                  > I Down loaded the hamlib 1.2.10 solurce files and found some
                  > instructions on how to install it. Here are the steps I took:
                  > 1. I unzipped the files by double clipping the tar ball.
                  > 2. In terminal I got to the directory that had the source.
                  > 3. I entered ./configure.
                  > 3. make.
                  > 4. sudo make load

                  Try..... sudo make install

                  You may have to go back and uninstall the old version of hamlib first.
                  I do this as a matter of routine no matter the application I'm working
                  with. May not be the "correct" way, but it works for me.

                  > Everything seemed to work ok and did a search for hamlib and found
                  > it in local/bin.
                  > I executed rigcTL -l and it apparently found the old hamlib, because
                  > the Paragon was not in there and fldigi did not have the paragon in
                  > it's list either.What am I doing wrong and where can I find a
                  > document of some sort to figure out what to do?
                  > I have programmed in fortran, assembly language, and visual c++, but
                  > that was many years ago. I'm retired now and maybe to old to do this
                  > any more. Warren WB4AHD

                  I just Googled "compiling from source" there were 6,790,000 articles on
                  how-to.

                  Normally you will have

                  ./configure

                  make

                  sudo make install

                  Usually in the top level of the application is a readme and/or an
                  install file where the author should have defined any special configure
                  switches or instructions.

                  Ed W3NR
                • Nate Bargmann
                  ... As this is the first time you ve likely installed Hamlib from source, you will need to run `sudo ldconfig so that the dynamic loader ld.so can find your
                  Message 8 of 20 , Dec 11, 2009
                  • 0 Attachment
                    * Warren Stritter <wb4ahd@...> [2009 Dec 11 12:26 -0600]:

                    > > I have looked for documentation on how to download, and install programs. I
                    > > have found some stuff that is rather gneric and some that is explicit but
                    > > nothing that describes in general how to do it.
                    > >
                    > The man files are very specific but you have to know how to do it and
                    > use the man file to figure out the details.
                    > I Down loaded the hamlib 1.2.10 solurce files and found some instructions on
                    > how to install it. Here are the steps I took:
                    > 1. I unzipped the files by double clipping the tar ball.
                    > 2. In terminal I got to the directory that had the source.
                    > 3. I entered ./configure.
                    > 3. make.
                    > 4. sudo make load
                    > Everything seemed to work ok and did a search for hamlib and found it in
                    > local/bin.
                    > I executed rigcTL -l and it apparently found the old hamlib, because the
                    > Paragon was not in there and fldigi did not have the paragon in it's list
                    > either.What am I doing wrong and where can I find a document of some sort to
                    > figure out what to do?

                    As this is the first time you've likely installed Hamlib from source,
                    you will need to run `sudo ldconfig' so that the dynamic loader ld.so
                    can find your newly installed Hamlib. You can also take a look at
                    /etc/ld.so.conf to be certain that /usr/local/lib is in that file on a
                    line by itself.

                    > I have programmed in fortran, assembly language, and visual c++, but that
                    > was many years ago. I'm retired now and maybe to old to do this any more.

                    It's a libc issue. Normally when you install software packages from
                    the Ubuntu repositories the scripts included with the packages handle
                    running ldconfig for you so you never really see it. When installing
                    from source we have to be sure to do that step so the system can find
                    the new library files.

                    Now, it may be wise to remove the old version of Hamlib installed
                    through your package manager unless you have other software installed
                    that would be removed due to the dependency on Hamlib. The two should
                    coexist but be aware that a potential for conflict does exist.

                    73, de Nate >>

                    --

                    "The optimist proclaims that we live in the best of all
                    possible worlds. The pessimist fears this is true."

                    Ham radio, Linux, bikes, and more: http://n0nb.us/index.html
                  • Warren Stritter
                    I hope everyone has had a merry christmas! I finally got 1.2.10 loaded. With some desperate tries I was able to try the new version on fldigi but got a rig
                    Message 9 of 20 , Dec 28, 2009
                    • 0 Attachment
                      I hope everyone has had a merry christmas!
                      I finally got 1.2.10 loaded. With some desperate tries I was able to try the new version on fldigi but got a rig does not respond error instead of the error I should have gotten. Also found out the the rigctl program is now rigctld. I think this thread is long enough and, with some exceptions is complete. Comming later may be needhe help on getting rid of the garbage left over from my many unsuccessful tries! I will start another thread on using rigctld.
                      Thanks to everyone and a happy new year to all!
                      Warren WB4AHD

                      On Fri, Dec 11, 2009 at 10:04 PM, Nate Bargmann <n0nb@...> wrote:
                       

                      * Warren Stritter <wb4ahd@...> [2009 Dec 11 12:26 -0600]:



                      > > I have looked for documentation on how to download, and install programs. I
                      > > have found some stuff that is rather gneric and some that is explicit but
                      > > nothing that describes in general how to do it.
                      > >
                      > The man files are very specific but you have to know how to do it and
                      > use the man file to figure out the details.
                      > I Down loaded the hamlib 1.2.10 solurce files and found some instructions on
                      > how to install it. Here are the steps I took:
                      > 1. I unzipped the files by double clipping the tar ball.
                      > 2. In terminal I got to the directory that had the source.
                      > 3. I entered ./configure.
                      > 3. make.
                      > 4. sudo make load
                      > Everything seemed to work ok and did a search for hamlib and found it in
                      > local/bin.
                      > I executed rigcTL -l and it apparently found the old hamlib, because the
                      > Paragon was not in there and fldigi did not have the paragon in it's list
                      > either.What am I doing wrong and where can I find a document of some sort to
                      > figure out what to do?

                      As this is the first time you've likely installed Hamlib from source,
                      you will need to run `sudo ldconfig' so that the dynamic loader ld.so
                      can find your newly installed Hamlib. You can also take a look at
                      /etc/ld.so.conf to be certain that /usr/local/lib is in that file on a
                      line by itself.


                      > I have programmed in fortran, assembly language, and visual c++, but that
                      > was many years ago. I'm retired now and maybe to old to do this any more.

                      It's a libc issue. Normally when you install software packages from
                      the Ubuntu repositories the scripts included with the packages handle
                      running ldconfig for you so you never really see it. When installing
                      from source we have to be sure to do that step so the system can find
                      the new library files.

                      Now, it may be wise to remove the old version of Hamlib installed
                      through your package manager unless you have other software installed
                      that would be removed due to the dependency on Hamlib. The two should
                      coexist but be aware that a potential for conflict does exist.

                      73, de Nate >>

                      --

                      "The optimist proclaims that we live in the best of all
                      possible worlds. The pessimist fears this is true."

                      Ham radio, Linux, bikes, and more: http://n0nb.us/index.html

                    • Nate Bargmann
                      ... Not exactly. The rigctld program is intended as a way for a program to communicate with Hamlib via a network socket. This is useful from various
                      Message 10 of 20 , Dec 28, 2009
                      • 0 Attachment
                        * Warren Stritter <wb4ahd@...> [2009 Dec 28 12:05 -0600]:
                        > Also found out the the rigctl program is now rigctld.

                        Not exactly. The rigctld program is intended as a way for a program to
                        communicate with Hamlib via a network socket. This is useful from
                        various "scripting" languages but also opens up many possibilities for
                        network control. It is still evolving and is still considered
                        experimental.

                        Meanwhile, rigctl is the interactive program for the console (or one
                        shot command) and is our primary debugging tool.

                        Don't spend too much time trying to figure out rigctld unless you're
                        writing a program and wish to use a network socket to communicate with
                        your radio.

                        73, de Nate >>

                        --

                        "The optimist proclaims that we live in the best of all
                        possible worlds. The pessimist fears this is true."

                        Ham radio, Linux, bikes, and more: http://n0nb.us/index.html
                      Your message has been successfully submitted and would be delivered to recipients shortly.