Loading ...
Sorry, an error occurred while loading the content.

Re: High CPU load with 3.12.4

Expand Messages
  • jhaynesatalumni
    What I ve learned so far is that reducing the size of the fldigi window reduces the CPU usage. If I bring another window into the foreground, partially
    Message 1 of 16 , Sep 3, 2009
    • 0 Attachment
      What I've learned so far is that reducing the size of the fldigi
      window reduces the CPU usage. If I bring another window into the
      foreground, partially covering the fldigi window, the cpu usage
      drops, but it doesn't seem to matter which part of the window is
      covered.

      I just removed xorg.conf, since X11 doesn't seem to need one anymore,
      and now the CPU loading is quite modest. So guess there was something
      funny in the xorg.conf that was in use.
    • Harry Bloomberg
      ... I noticed the same thing on my Ubuntu 9.04 box. So I also removed the xorg.conf and my CPU loading went down too! This really bothers me as I don t see
      Message 2 of 16 , Sep 3, 2009
      • 0 Attachment
        On Thu, Sep 3, 2009 at 4:42 PM, jhaynesatalumni<jhhaynes@...> wrote:

        >
        > I just removed xorg.conf, since X11 doesn't seem to need one anymore,
        > and now the CPU loading is quite modest. So guess there was something
        > funny in the xorg.conf that was in use.
        >
        I noticed the same thing on my Ubuntu 9.04 box. So I also removed
        the xorg.conf and my CPU loading went down too!

        This really bothers me as I don't see anything in the xorg.conf
        file that I think could cause it. Here's the non-comment contents of
        the file. As you can see, this looks pretty harmless to me.

        Section "Device"
        Identifier "Configured Video Device"
        EndSection

        Section "Monitor"
        Identifier "Configured Monitor"
        EndSection

        Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
        EndSection


        73,
        Harry Bloomberg W3YJ
        hbloomb@...
      • Ed
        ... If xorg.conf is no longer being used, then what/where is the replacement My xorg.conf is not empty, Ubuntu 9.04 ... Ed W3NR
        Message 3 of 16 , Sep 4, 2009
        • 0 Attachment
          Harry Bloomberg wrote:
          > On Thu, Sep 3, 2009 at 4:42 PM, jhaynesatalumni<jhhaynes@...> wrote:
          >
          >> I just removed xorg.conf, since X11 doesn't seem to need one anymore,
          >> and now the CPU loading is quite modest. So guess there was something
          >> funny in the xorg.conf that was in use.
          >>
          > I noticed the same thing on my Ubuntu 9.04 box. So I also removed
          > the xorg.conf and my CPU loading went down too!
          >
          > This really bothers me as I don't see anything in the xorg.conf
          > file that I think could cause it. Here's the non-comment contents of
          > the file. As you can see, this looks pretty harmless to me.
          >
          > Section "Device"
          > Identifier "Configured Video Device"
          > EndSection
          >
          > Section "Monitor"
          > Identifier "Configured Monitor"
          > EndSection
          >
          > Section "Screen"
          > Identifier "Default Screen"
          > Monitor "Configured Monitor"
          > Device "Configured Video Device"
          > EndSection
          >
          >
          > 73,
          > Harry Bloomberg W3YJ
          > hbloomb@...


          If xorg.conf is no longer being used, then what/where is the replacement

          My xorg.conf is not empty, Ubuntu 9.04



          > Section "Screen"
          > Identifier "Default Screen"
          > Monitor "Configured Monitor"
          > Device "Configured Video Device"
          > DefaultDepth 24
          > Option "AddARGBGLXVisuals" "True"
          > EndSection
          >
          > Section "Module"
          > Load "glx"
          > EndSection
          >
          > Section "Device"
          > Identifier "Configured Video Device"
          > Driver "nvidia"
          > Option "NoLogo" "True"
          > EndSection



          Ed W3NR
        • pa3gwh
          Perhaps this has nothing to do with it, but haven t we seen this before when using specific fonts? Richard
          Message 4 of 16 , Sep 4, 2009
          • 0 Attachment
            Perhaps this has nothing to do with it, but
            haven't we seen this before when using specific fonts?

            Richard

            >
            > I'm seeing this on the Ubuntu 9.04 system at W5YM, which has
            > a 2.5 GHz Pentium 4. Running fldigi the CPU load goes very high,
            > almost maxed out. I've tried various combinations of rig control,
            > makes no difference. Checked that the fonts are fixed pitch.
            >
            > I notice when I open another window in front of fldigi, such as the
            > configuration window or a terminal window, the CPU load drops so
            > long as the main fldigi window is partially covered, goes back
            > high as soon as I bring fldigi into the foreground.
            >
            > One of the guys who should know says this cpu loading is not
            > happening under Windows, only under Linux. And I am not seeing it
            > at home where I'm running Fedora 11.
            >
            > Any clues what I should be looking for?
            >
            > Jim W6JVE
            >
          • Larry Levesque
            I have seen this happen before with compiz enabled. Try diabling it.
            Message 5 of 16 , Sep 4, 2009
            • 0 Attachment
              I have seen this happen before with compiz enabled. Try diabling it.
              On Fri, Sep 04, 2009 at 11:45:01AM -0000, pa3gwh wrote:
              >
              > Perhaps this has nothing to do with it, but
              > haven't we seen this before when using specific fonts?
              >
              > Richard
              >
              > >
              > > I'm seeing this on the Ubuntu 9.04 system at W5YM, which has
              > > a 2.5 GHz Pentium 4. Running fldigi the CPU load goes very high,
              > > almost maxed out. I've tried various combinations of rig control,
              > > makes no difference. Checked that the fonts are fixed pitch.
              > >
              > > I notice when I open another window in front of fldigi, such as the
              > > configuration window or a terminal window, the CPU load drops so
              > > long as the main fldigi window is partially covered, goes back
              > > high as soon as I bring fldigi into the foreground.
              > >
              > > One of the guys who should know says this cpu loading is not
              > > happening under Windows, only under Linux. And I am not seeing it
              > > at home where I'm running Fedora 11.
              > >
              > > Any clues what I should be looking for?
              > >
              > > Jim W6JVE
              > >
              >
              >
            • Ed
              ... I think you both are on the right track. I disable compiz right off the bat. Its annoying as the devil. Ed W3NR
              Message 6 of 16 , Sep 4, 2009
              • 0 Attachment
                Larry Levesque wrote:
                > I have seen this happen before with compiz enabled. Try diabling it.
                > On Fri, Sep 04, 2009 at 11:45:01AM -0000, pa3gwh wrote:
                >> Perhaps this has nothing to do with it, but
                >> haven't we seen this before when using specific fonts?
                >>
                >> Richard

                I think you both are on the right track. I disable compiz right off the
                bat. Its annoying as the devil.

                Ed W3NR
              • jhaynesatalumni
                I don t pretend to understand things anymore, but apparently with monitors telling the computer what their characteristics are, and with standardization of
                Message 7 of 16 , Sep 4, 2009
                • 0 Attachment
                  I don't pretend to understand things anymore, but apparently
                  with monitors telling the computer what their characteristics
                  are, and with standardization of things, X11 now has everything
                  it needs, such as modelines, compiled in. So you only need
                  the xorg.conf if you need to override something

                  The talk about fonts has to do with proportional-spaced fonts.
                  They cause a lot of CPU consumption. If you choose fixed-width
                  fonts you don't have that problem.

                  I don't know what compiz is, and apparently it is not installed
                  on my home machine. I'll have to check on the Ubuntu machine
                  at W5YM that was having the problem. Where do you go to
                  disable it?

                  Jim W6JVE
                • Larry Levesque
                  ... Compiz is a graphical manager for the desktop. It add the desktop cube and fancy effects. Go to the System - Preference - Appearance menu item or just
                  Message 8 of 16 , Sep 4, 2009
                  • 0 Attachment
                    On Fri, Sep 04, 2009 at 04:14:30PM -0000, jhaynesatalumni wrote:
                    > I don't pretend to understand things anymore, but apparently
                    > with monitors telling the computer what their characteristics
                    > are, and with standardization of things, X11 now has everything
                    > it needs, such as modelines, compiled in. So you only need
                    > the xorg.conf if you need to override something
                    >
                    > The talk about fonts has to do with proportional-spaced fonts.
                    > They cause a lot of CPU consumption. If you choose fixed-width
                    > fonts you don't have that problem.
                    >
                    > I don't know what compiz is, and apparently it is not installed
                    > on my home machine. I'll have to check on the Ubuntu machine
                    > at W5YM that was having the problem. Where do you go to
                    > disable it?
                    >
                    > Jim W6JVE
                    >


                    Compiz is a graphical manager for the desktop. It add the desktop cube and fancy effects.

                    Go to the "System - Preference - Appearance" menu item or just right click on the empty desktop.
                    Choose the Visual Effects tab and choose None.

                    KA1VGM
                  • w1hkj
                    ... I recently installed Ubuntu 9.04 on two smaller computers, a Notebook and a Netbook. The default desktop installation is to preset the Visual Effects at
                    Message 9 of 16 , Sep 4, 2009
                    • 0 Attachment
                      Larry Levesque wrote:
                      > Compiz is a graphical manager for the desktop. It add the desktop cube and fancy effects.
                      >
                      > Go to the "System - Preference - Appearance" menu item or just right click on the empty desktop.
                      > Choose the Visual Effects tab and choose None.
                      >
                      > KA1VGM
                      >
                      >
                      I recently installed Ubuntu 9.04 on two smaller computers, a Notebook
                      and a Netbook. The default desktop installation is to preset the Visual
                      Effects at moderate. The first thing I do is open that tab and select
                      None. I can only be mesmerized by sliding, flipping, dissolving windows
                      for about 2 seconds and then it is in my face.

                      Dave
                    • jhaynesatalumni
                      ... OK, on my home system there is no visual effects tab, so I guess that confirms I don t have compiz installed.
                      Message 10 of 16 , Sep 4, 2009
                      • 0 Attachment
                        --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
                        >
                        > Larry Levesque wrote:
                        > > Compiz is a graphical manager for the desktop. It add the desktop cube and fancy effects.
                        > >
                        > > Go to the "System - Preference - Appearance" menu item or just right click on the empty desktop.
                        > > Choose the Visual Effects tab and choose None.
                        > >
                        > > KA1VGM
                        OK, on my home system there is no visual effects tab, so I guess
                        that confirms I don't have compiz installed.
                      • Nate Bargmann
                        ... There isn t one. The X server determines everything at run time. It s also why later Xorg packages depend on the hal package much to the consternation of
                        Message 11 of 16 , Sep 4, 2009
                        • 0 Attachment
                          * Ed <autek@...> [2009 Sep 04 04:59 -0500]:

                          > If xorg.conf is no longer being used, then what/where is the replacement

                          There isn't one. The X server determines everything at run time. It's
                          also why later Xorg packages depend on the hal package much to the
                          consternation of some users.

                          73, de Nate >>

                          --

                          "The optimist proclaims that we live in the best of all
                          possible worlds. The pessimist fears this is true."

                          Ham radio, Linux, bikes, and more: http://n0nb.us/index.html
                        Your message has been successfully submitted and would be delivered to recipients shortly.