Loading ...
Sorry, an error occurred while loading the content.

Re: [linuxham] fldigi/iC-746

Expand Messages
  • John Lindsay
    Hi Dave I tried your suggestions and here is what my results are. use seperate serial port selected com 1 selected neither rts nor dtr have any effect with
    Message 1 of 12 , Sep 2, 2009
    • 0 Attachment
      Hi Dave

      I tried your suggestions and here is what my results are.

      use seperate serial port selected
      com 1 selected
      neither rts nor dtr have any effect
      with RTS=+V selected the CW led on the RB come on and radio goes into TX
      and initialize button goes to black HOWEVER it does not go back to RX. I
      have to delselect RTS=+V and re-initialize to get rig to RX.
      With DTR selected nothing happens
      With DTR=+V selected RB CW led goes on but rig stays in RX mode
      There is no information being returned as frequency still reads 3580

      Maybe I should try a different interface or tripple check my setup.
      Programs that work TX and RX are HRD (it reports the corrrect frequency
      and can even change frequencies modes etc), digipan and winpsk. Mixw
      also works. Multipsk returns some divide by zero error so is not working
      for me at this time.
      Since three programs work I have to make the assumption that my RB
      hookup and operation is working correctly.
      Still trying.

      john
      ve3sjv

      w1hkj wrote:
      > Which control line are you using for the PTT signal John? RTS or
      > DTR. It's not usually both at the same time. I do not own a
      > Rigblaster Pro, so I am only guessing as to what its signal
      > requirements are, but I would guess that it is NOT stealing power from
      > the RS232 port of the computer.
      >
      > So, I will assume that for now you are going to simply control the PTT
      > via RTS without any CAT serial data flow. Open the rig control
      > configuration dialog to the very first tab.
      >
      >
      > Check the "Use separate serial port PTT.
      > Pick COM1 from the Device combo box
      > Check "Use RTS"
      >
      > Leave the rest unchecked.
      >
      > Press Initialize. If the rig does not key up skip the next two.
      >
      > 1. If your rig immediately keys then that Rigblaster is probably
      > looking for an opposite polarity signal.
      > 2. Check "RTS = +V" and press Initialize again.
      >
      >
      > Now try the T/R button on the main dialog and see if the rig keys.
      >
      > Let us know how things go.
      >
      > Dave, W1HKJ
      >
    • Ed
      ... Not needed so you can uncheck this. ... If I m reading the Rigblaster manual correctly, you should not need either RTS or DTR. Sorry I m not of more help,
      Message 2 of 12 , Sep 3, 2009
      • 0 Attachment
        John Lindsay wrote:
        > Hi Ed
        >
        > Tried your suggestions and here is how my configuration stands at this
        > time --

        > Under Rigcat
        >
        > use rigcat checked
        > using 746.xml file as downloaded from web
        > commands are echoed checked
        > cat command for ptt checked
        > rts/ts flow control checked


        Not needed so you can uncheck this.


        > initialize keys the RB and radio
        > trying to transmit does not key the RB or radio
        > if any other box selected ie toggle rts or dtr then cat command goes
        > unselected
        >
        > Still at a loss!! also selecting dtr+12 rts+12 makes no difference.
        >
        > John
        > ve3sjv


        If I'm reading the Rigblaster manual correctly, you should not need
        either RTS or DTR.

        Sorry I'm not of more help, but I use a simple inexpensive setup here.


        Ed W3NR
      • John Lindsay
        ... HI Dave I didn t see this message until this am. Quite a few hours after I sent out my message at 10:50PM. Com1 and Com2 go to Rigblaster Pro serial ports
        Message 3 of 12 , Sep 3, 2009
        • 0 Attachment
          w1hkj wrote:
          >
          >
          > John Lindsay wrote:
          > > Under Rigcat
          > >
          > > use rigcat checked
          > > using 746.xml file as downloaded from web
          > > commands are echoed checked
          > > cat command for ptt checked
          > > rts/ts flow control checked
          > >
          > Icoms do not generally use RTS/CTS flow control. Do not check that
          > box! I run fldigi with a 746Pro on both Linux and Vista. The
          > IC746PRO.xml file is correct on the web site.
          >
          > What kind of CI-V interface are you using. Did you spring for the real
          > thing (a $150 CT-17 from Icom) or are you using a cheap one that steals
          > power from the RS232 port? If the latter then you must know which of
          > the control lines is providing the power for your interface. Typically
          > that would be DTR or RTS. The CT-17 uses an external power source.
          >
          > Dave
          >
          >
          HI Dave

          I didn't see this message until this am. Quite a few hours after I sent
          out my message at 10:50PM.
          Com1 and Com2 go to Rigblaster Pro serial ports 1 and 2 . The radio is
          connected from the mic plug to the rigblaster and audio from the rig
          goes through the RB. I do have a Donner interface that I could try. I
          would just have to rewire the RB to use only one serial port. I could
          possibly try it this weekend.

          John
        • Ed
          ... OK John, this new info on your setup may help. What function is com1 handling ? rigctl or ptt ? What function is com2 handling ? rigctl or ptt ? Ed W3NR
          Message 4 of 12 , Sep 3, 2009
          • 0 Attachment
            John Lindsay wrote:
            > w1hkj wrote:
            >>
            >>
            >> John Lindsay wrote:
            >>> Under Rigcat
            >>>
            >>> use rigcat checked
            >>> using 746.xml file as downloaded from web
            >>> commands are echoed checked
            >>> cat command for ptt checked
            >>> rts/ts flow control checked
            >>>
            >> Icoms do not generally use RTS/CTS flow control. Do not check that
            >> box! I run fldigi with a 746Pro on both Linux and Vista. The
            >> IC746PRO.xml file is correct on the web site.
            >>
            >> What kind of CI-V interface are you using. Did you spring for the real
            >> thing (a $150 CT-17 from Icom) or are you using a cheap one that steals
            >> power from the RS232 port? If the latter then you must know which of
            >> the control lines is providing the power for your interface. Typically
            >> that would be DTR or RTS. The CT-17 uses an external power source.
            >>
            >> Dave
            >>
            >>
            > HI Dave
            >
            > I didn't see this message until this am. Quite a few hours after I sent
            > out my message at 10:50PM.
            > Com1 and Com2 go to Rigblaster Pro serial ports 1 and 2 . The radio is
            > connected from the mic plug to the rigblaster and audio from the rig
            > goes through the RB. I do have a Donner interface that I could try. I
            > would just have to rewire the RB to use only one serial port. I could
            > possibly try it this weekend.
            >
            > John


            OK John, this new info on your setup may help.

            What function is com1 handling ? rigctl or ptt ?

            What function is com2 handling ? rigctl or ptt ?


            Ed W3NR

            The rigblaster manual is still not an easy doc to follow.
          • Hylton Conacher (ZR1HPC)
            Hi John, ... You might try visiting http://mailman.qth.net/mailman/listinfo/ham-software and becoming a subscriber. You may very well find help there.
            Message 5 of 12 , Sep 4, 2009
            • 0 Attachment
              Hi John,

              jclindsayca wrote:
              > I know the group name is linuxhams but the descriptor suggests anything fldigi related on other OS is acceptable as well. I have copied this over from digitalhams where I got no replies so hoping someone here can help. Fldigi was set up on a debian systems as well and exhibited the same situation.

              <snip>

              You might try visiting
              http://mailman.qth.net/mailman/listinfo/ham-software and becoming a
              subscriber. You may very well find help there.

              HTH

              73 de ZR1HPC
              Hylton
              Ham-Software Moderator
              --
              ========================================================================
              Lions Club member of http://www.fishhoeklionsclub.org.za
              Using openSuSE 11.0 with KDE
              Linux user # 229959 at http://counter.li.org
              ========================================================================
            • John Lindsay
              Hi Ed Just a little up date. I decided to move the PC and rewire the setup and double check my rigblaster setup. I originally had a kenwood transceiver
              Message 6 of 12 , Sep 5, 2009
              • 0 Attachment
                Hi Ed

                Just a little up date. I decided to move the PC and rewire the setup and
                double check my rigblaster setup. I originally had a kenwood transceiver
                attached to the rigblaster and it was working fine. Since the mic pin
                outs are the same and they use the same 8 pin plug I assumed all I had
                to do was to switch radios and cables and set up the microphone
                connector P1. What I overlooked was J16 which is the serial port
                selector/ptt setup. Mine was set for Kenwood. I changed it to
                Icom/ten-tec setting. It now reports the frequency and keys the rig.
                However I do have a problem whereby I don't get audio to/from the radio
                -- it's likely a cable wiring error on my part so back to the reading
                and going back over the wiring,


                John ve3sjv
              • Ed
                On Sat, 05 Sep 2009 17:00:31 -0400
                Message 7 of 12 , Sep 5, 2009
                • 0 Attachment
                  On Sat, 05 Sep 2009 17:00:31 -0400
                  John Lindsay <jclind@...> wrote:

                  > Hi Ed
                  >
                  > Just a little up date. I decided to move the PC and rewire the setup
                  > and double check my rigblaster setup. I originally had a kenwood
                  > transceiver attached to the rigblaster and it was working fine. Since
                  > the mic pin outs are the same and they use the same 8 pin plug I
                  > assumed all I had to do was to switch radios and cables and set up
                  > the microphone connector P1. What I overlooked was J16 which is the
                  > serial port selector/ptt setup. Mine was set for Kenwood. I changed
                  > it to Icom/ten-tec setting. It now reports the frequency and keys the
                  > rig. However I do have a problem whereby I don't get audio to/from
                  > the radio -- it's likely a cable wiring error on my part so back to
                  > the reading and going back over the wiring,
                  >
                  >
                  > John ve3sjv
                  >
                  >
                  > ------------------------------------
                  >
                  > Yahoo! Groups Links
                  >
                  >
                  >
                Your message has been successfully submitted and would be delivered to recipients shortly.