Loading ...
Sorry, an error occurred while loading the content.

Won't start

Expand Messages
  • Murry
    I am trying to use the latest Fldigi, system is Ubuntu 8.04 It wont startup and here is the error I get in a terminal. What am I missing here. ./fldigi:
    Message 1 of 13 , Jul 25, 2009
    • 0 Attachment
      I am trying to use the latest Fldigi, system is Ubuntu 8.04
      It wont startup and here is the error I get in a terminal.
      What am I missing here.



      ./fldigi: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found
      (required by ./fldigi)
      ./fldigi: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found
      (required by ./fldigi)




      Murry VE9MB
    • Murry
      I checked that and don t have the version it is looking for. Glibc 2.7 is in the packages. I ll have a peek at your other suggestion Murry
      Message 2 of 13 , Jul 25, 2009
      • 0 Attachment
        I checked that and don't have the version it is looking for.
        Glibc 2.7 is in the packages.
        I'll have a peek at your other suggestion

        Murry



        w1hkj wrote:
        >
        >
        > Murry wrote:
        > > I am trying to use the latest Fldigi, system is Ubuntu 8.04
        > > It wont startup and here is the error I get in a terminal.
        > > What am I missing here.
        > >
        > >
        > >
        > > ./fldigi: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found
        > > (required by ./fldigi)
        > > ./fldigi: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found
        > > (required by ./fldigi)
        > >
        > >
        > >
        > >
        > > Murry VE9MB
        > >
        > You most likely need to upgrade your glibc which should be available
        > from your Ubuntu repository.
        >
        > You could also try our private repository for Debian / Ubuntu :
        > http://fldigi.berlios.de/binaries/ <http://fldigi.berlios.de/binaries/>
        >
        > This info was posted to this group on 7/23/2009.
        >
        > Dave
        >
        >
      • Eric Lorenz
        Hi Murry: I am guessing that you are missing those libraries...check in Synaptic Package Manager to see. If they are missing, install them and you are ready to
        Message 3 of 13 , Jul 25, 2009
        • 0 Attachment
          Hi Murry:

          I am guessing that you are missing those libraries...check in Synaptic Package Manager to see. If they are missing, install them and you are ready to go.

          Eric KC9FQV
          Sent from my Verizon Wireless BlackBerry

          -----Original Message-----
          From: Murry <murraybr@...>

          Date: Sat, 25 Jul 2009 17:24:31
          To: <linuxham@yahoogroups.com>
          Subject: [linuxham] Won't start


          I am trying to use the latest Fldigi, system is Ubuntu 8.04
          It wont startup and here is the error I get in a terminal.
          What am I missing here.



          ../fldigi: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found
          (required by ./fldigi)
          ./fldigi: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found
          (required by ./fldigi)




          Murry VE9MB


          ------------------------------------

          Yahoo! Groups Links
        • w1hkj
          ... You most likely need to upgrade your glibc which should be available from your Ubuntu repository. You could also try our private repository for Debian /
          Message 4 of 13 , Jul 25, 2009
          • 0 Attachment
            Murry wrote:
            > I am trying to use the latest Fldigi, system is Ubuntu 8.04
            > It wont startup and here is the error I get in a terminal.
            > What am I missing here.
            >
            >
            >
            > ./fldigi: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found
            > (required by ./fldigi)
            > ./fldigi: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found
            > (required by ./fldigi)
            >
            >
            >
            >
            > Murry VE9MB
            >
            You most likely need to upgrade your glibc which should be available
            from your Ubuntu repository.

            You could also try our private repository for Debian / Ubuntu :
            http://fldigi.berlios.de/binaries/

            This info was posted to this group on 7/23/2009.

            Dave
          • w1hkj
            If all else fails you have two other choiced Murry. Upgrade your 8.04 to 9.04. The upgrade is pretty painless. Create a development environment and build
            Message 5 of 13 , Jul 25, 2009
            • 0 Attachment
              If all else fails you have two other choiced Murry.

              Upgrade your 8.04 to 9.04. The upgrade is pretty painless.

              Create a development environment and build fldigi on your computer.

              Dave
            • Murry
              Tried that once, the upgrade was painless but the results were crappy. Think I ll stick with the repos version until updated packages come along. It works
              Message 6 of 13 , Jul 26, 2009
              • 0 Attachment
                Tried that once, the upgrade was painless but the results were crappy.
                Think I'll stick with the repos version until updated packages come
                along. It works fine.
                Thanks for all the suggestions

                Murry VE9MB






                w1hkj wrote:
                >
                >
                > If all else fails you have two other choiced Murry.
                >
                > Upgrade your 8.04 to 9.04. The upgrade is pretty painless.
                >
                > Create a development environment and build fldigi on your computer.
                >
                > Dave
                >
                >
              • Curt Givens
                ... Dave, being new to Linux I m sure this is something I m not entering correctly, but when I try to add the repository address to the third part list in
                Message 7 of 13 , Jul 26, 2009
                • 0 Attachment
                  w1hkj wrote:
                  > You could also try our private repository for Debian / Ubuntu :
                  > http://fldigi.berlios.de/binaries/
                  >
                  > This info was posted to this group on 7/23/2009.
                  >
                  > Dave
                  >
                  >
                  >
                  Dave, being new to Linux I'm sure this is something I'm not entering
                  correctly, but when I try to add the repository address to the third
                  part list in synaptic the dialog never changes the radio button so I can
                  add it. I'm currently running Unbuntu 8.04. Planning to upgrade but want
                  to get fldigi upgraded first. Iv\'ve tried just the line starting with
                  http and also starting at Debian both with and without the spaces.

                  Thanks, Curt
                • w1hkj
                  On a command line execute the following: sudo apt-key adv --recv-keys --keyserver http://fldigi.berlios.de/binaries/fldigi-pkg-key.asc 8E7306F5 Then start
                  Message 8 of 13 , Jul 26, 2009
                  • 0 Attachment
                    On a command line execute the following:

                    sudo apt-key adv --recv-keys --keyserver http://fldigi.berlios.de/binaries/fldigi-pkg-key.asc 8E7306F5
                    
                    Then start synaptic and open the "Settings / Repositories" dialog
                    
                    Click on "Authentication".  You should see the berlios site added to the trusted software providers list.
                    
                    Click on "Third party software"  and press the add button.  Enter the following into the APT line:
                    
                    deb http://ftp.berlios.de/pub/fldigi/binaries <dist> main
                    
                    replacing <dist> with
                    
                    Distribution <dist>

                    Debian 4.0

                    etch

                    Debian 5.0

                    lenny

                    Ubuntu 8.04

                    hardy

                    Ubuntu 8.10

                    intrepid

                    Ubuntu 9.04

                    jaunty

                    the right hand column <dist> name for your Distribution.
                    
                    Press "Add source"
                    
                    You will have to "Refresh" the repository list.  fldigi 3.12.1-0... should show up in your list.  You can do a search for fldigi
                    or select Amateur Radio (universe) on the left hand Sections selector.
                    
                    Hope this helps.
                    
                    Dave
                    

                  • kenwood1995
                    I guess I am a little thick in the head here. Does this do anything for Glibc to change it to 2.8 or does Fldigi then work with the Glibc still at 2.7? Murry
                    Message 9 of 13 , Jul 26, 2009
                    • 0 Attachment
                      I guess I am a little thick in the head here. Does this do anything for Glibc to change it to 2.8 or does Fldigi then work with the Glibc still at 2.7?
                      Murry VE9MB





                      --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
                      >
                      > On a command line execute the following:
                      >
                      > sudo apt-key adv --recv-keys --keyserver http://fldigi.berlios.de/binaries/fldigi-pkg-key.asc 8E7306F5
                      >
                      > Then start synaptic and open the "Settings / Repositories" dialog
                      >
                      > Click on "Authentication". You should see the berlios site added to the trusted software providers list.
                      >
                      > Click on "Third party software" and press the add button. Enter the following into the APT line:
                      >
                      > deb http://ftp.berlios.de/pub/fldigi/binaries <dist> main
                      >
                      > replacing <dist> with
                      >
                      > Distribution <dist>
                      >
                      > Debian 4.0
                      >
                      >
                      >
                      > etch
                      >
                      > Debian 5.0
                      >
                      >
                      >
                      > lenny
                      >
                      > Ubuntu 8.04
                      >
                      >
                      >
                      > hardy
                      >
                      > Ubuntu 8.10
                      >
                      >
                      >
                      > intrepid
                      >
                      > Ubuntu 9.04
                      >
                      >
                      >
                      > jaunty
                      >
                      > the right hand column <dist> name for your Distribution.
                      >
                      > Press "Add source"
                      >
                      > You will have to "Refresh" the repository list. fldigi 3.12.1-0... should show up in your list. You can do a search for fldigi
                      > or select Amateur Radio (universe) on the left hand Sections selector.
                      >
                      > Hope this helps.
                      >
                      > Dave
                      >
                    • Larry Levesque
                      Once you do as listed above and install via synaptic, it should automagically install all of the required packages. Larry Levesque KA1VGM Cheshire County EC
                      Message 10 of 13 , Jul 26, 2009
                      • 0 Attachment
                        Once you do as listed above and install via synaptic, it should
                        automagically install all of the required packages.

                        Larry Levesque
                        KA1VGM
                        Cheshire County EC
                        NHARES



                        On Sun, Jul 26, 2009 at 10:04 AM, kenwood1995<murraybr@...> wrote:
                        >
                        >
                        > I guess I am a little thick in the head here. Does this do anything for
                        > Glibc to change it to 2.8 or does Fldigi then work with the Glibc still at
                        > 2.7?
                        > Murry VE9MB
                        >
                        > --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
                        >>
                        >> On a command line execute the following:
                        >>
                        >> sudo apt-key adv --recv-keys --keyserver
                        >> http://fldigi.berlios.de/binaries/fldigi-pkg-key.asc 8E7306F5
                        >>
                        >> Then start synaptic and open the "Settings / Repositories" dialog
                        >>
                        >> Click on "Authentication". You should see the berlios site added to the
                        >> trusted software providers list.
                        >>
                        >> Click on "Third party software" and press the add button. Enter the
                        >> following into the APT line:
                        >>
                        >> deb http://ftp.berlios.de/pub/fldigi/binaries <dist> main
                        >>
                        >> replacing <dist> with
                        >>
                        >> Distribution <dist>
                        >>
                        >> Debian 4.0
                        >>
                        >>
                        >>
                        >> etch
                        >>
                        >> Debian 5.0
                        >>
                        >>
                        >>
                        >> lenny
                        >>
                        >> Ubuntu 8.04
                        >>
                        >>
                        >>
                        >> hardy
                        >>
                        >> Ubuntu 8.10
                        >>
                        >>
                        >>
                        >> intrepid
                        >>
                        >> Ubuntu 9.04
                        >>
                        >>
                        >>
                        >> jaunty
                        >>
                        >> the right hand column <dist> name for your Distribution.
                        >>
                        >> Press "Add source"
                        >>
                        >> You will have to "Refresh" the repository list. fldigi 3.12.1-0... should
                        >> show up in your list. You can do a search for fldigi
                        >> or select Amateur Radio (universe) on the left hand Sections selector.
                        >>
                        >> Hope this helps.
                        >>
                        >> Dave
                        >>
                        >
                        >
                      • Bob Nielsen
                        There can be problems upgrading directly from 8.04 to 9.04. Upgrading to 8.10 first would probably work better, but I think I ll install 9.04 from scratch
                        Message 11 of 13 , Jul 26, 2009
                        • 0 Attachment
                          There can be problems upgrading directly from 8.04 to 9.04.
                          Upgrading to 8.10 first would probably work better, but I think I'll
                          install 9.04 from scratch here. I have /home and /usr/local on
                          dedicated partitions to make the installation smoother without
                          loosing useful data.

                          Bob, N7XY

                          On Jul 26, 2009, at 2:57 AM, Murry wrote:

                          >
                          > Tried that once, the upgrade was painless but the results were crappy.
                          > Think I'll stick with the repos version until updated packages come
                          > along. It works fine.
                          > Thanks for all the suggestions
                          >
                          > Murry VE9MB
                          >
                          > w1hkj wrote:
                          > >
                          > >
                          > > If all else fails you have two other choiced Murry.
                          > >
                          > > Upgrade your 8.04 to 9.04. The upgrade is pretty painless.
                          > >
                          > > Create a development environment and build fldigi on your computer.
                          > >
                          > > Dave
                          > >
                          > >
                          >
                          >
                          > <!-- #ygrp-mkp{ border: 1px solid #d8d8d8; font-family: Arial;
                          > margin: 14px 0px; padding: 0px 14px; } #ygrp-mkp hr{ border: 1px
                          > solid #d8d8d8; } #ygrp-mkp #hd{ color: #628c2a; font-size: 85%;
                          > font-weight: bold; line-height: 122%; margin: 10px 0px; } #ygrp-mkp
                          > #ads{ margin-bottom: 10px; } #ygrp-mkp .ad{ padding: 0 0; } #ygrp-
                          > mkp .ad a{ color: #0000ff; text-decoration: none; } --> <!-- #ygrp-
                          > sponsor #ygrp-lc{ font-family: Arial; } #ygrp-sponsor #ygrp-lc #hd
                          > { margin: 10px 0px; font-weight: bold; font-size: 78%; line-height:
                          > 122%; } #ygrp-sponsor #ygrp-lc .ad{ margin-bottom: 10px; padding: 0
                          > 0; } --> <!-- #ygrp-mlmsg {font-size:13px; font-family:
                          > arial,helvetica,clean,sans-serif;*font-size:small;*font:x-small;}
                          > #ygrp-mlmsg table {font-size:inherit;font:100%;} #ygrp-mlmsg
                          > select, input, textarea {font:99% arial,helvetica,clean,sans-
                          > serif;} #ygrp-mlmsg pre, code {font:115% monospace;*font-size:
                          > 100%;} #ygrp-mlmsg * {line-height:1.22em;} #ygrp-text{ font-family:
                          > Georgia; } #ygrp-text p{ margin: 0 0 1em 0; } dd.last p a { font-
                          > family: Verdana; font-weight: bold; } #ygrp-vitnav{ padding-top:
                          > 10px; font-family: Verdana; font-size: 77%; margin: 0; } #ygrp-
                          > vitnav a{ padding: 0 1px; } #ygrp-mlmsg #logo{ padding-bottom:
                          > 10px; } #ygrp-reco { margin-bottom: 20px; padding: 0px; } #ygrp-
                          > reco #reco-head { font-weight: bold; color: #ff7900; } #reco-
                          > category{ font-size: 77%; } #reco-desc{ font-size: 77%; }
                          > #ygrp-vital a{ text-decoration: none; } #ygrp-vital a:hover{ text-
                          > decoration: underline; } #ygrp-sponsor #ov ul{ padding: 0 0 0 8px;
                          > margin: 0; } #ygrp-sponsor #ov li{ list-style-type: square;
                          > padding: 6px 0; font-size: 77%; } #ygrp-sponsor #ov li a{ text-
                          > decoration: none; font-size: 130%; } #ygrp-sponsor #nc{ background-
                          > color: #eee; margin-bottom: 20px; padding: 0 8px; } #ygrp-
                          > sponsor .ad{ padding: 8px 0; } #ygrp-sponsor .ad #hd1{ font-family:
                          > Arial; font-weight: bold; color: #628c2a; font-size: 100%; line-
                          > height: 122%; } #ygrp-sponsor .ad a{ text-decoration: none; } #ygrp-
                          > sponsor .ad a:hover{ text-decoration: underline; } #ygrp-
                          > sponsor .ad p{ margin: 0; font-weight: normal; color: #000000; } o
                          > {font-size: 0; } .MsoNormal{ margin: 0 0 0 0; } #ygrp-text tt{ font-
                          > size: 120%; } blockquote{margin: 0 0 0 4px;} .replbq{margin:4}
                          > dd.last p span { margin-right: 10px; font-family: Verdana; font-
                          > weight: bold; } dd.last p span.yshortcuts { margin-right: 0; }
                          > div.photo-title a, div.photo-title a:active, div.photo-title
                          > a:hover, div.photo-title a:visited { text-decoration: none; }
                          > div.file-title a, div.file-title a:active, div.file-title a:hover,
                          > div.file-title a:visited { text-decoration: none; } #ygrp-msg
                          > p#attach-count { clear: both; padding: 15px 0 3px 0; overflow:
                          > hidden; } #ygrp-msg p#attach-count span { color: #1E66AE; font-
                          > weight: bold; } div#ygrp-mlmsg #ygrp-msg p a span.yshortcuts { font-
                          > family: Verdana; font-size: 10px; font-weight: normal; } #ygrp-msg
                          > p a { font-family: Verdana; } #ygrp-mlmsg a { color: #1E66AE; }
                          > div.attach-table div div a { text-decoration: none; } div.attach-
                          > table { width: 400px; } -->
                        • Philip Webb
                          Hi All, Sorry to revisit this after a delay, but I have been away and thought others might come up with the same problem in the meantime - but they havn t. WRT
                          Message 12 of 13 , Jul 31, 2009
                          • 0 Attachment
                            Hi All,

                            Sorry to revisit this after a delay, but I have been away and thought
                            others might come up with the same problem in the meantime - but they
                            havn't.

                            WRT updating the repositories to include the berlios repository.
                            When I follow the instructions which are quite clear and execute without
                            a problem, until I get to the reload, when I get the following error
                            message.

                            ===============
                            GPG error: http://ppa.launchpad.net hardy Release: The following
                            signatures couldn't be verified because the public key is not available:
                            NO_PUBKEY 8AD328D8A58BCAE3Failed to fetch
                            http://ftp.berlios.de/pub/fldigi/binaries/dists/hardy/main/binary-i386/Packages.gz
                            302 Moved Temporarily
                            Some index files failed to download, they have been ignored, or old ones
                            used instead.
                            ===============

                            Using 8.04 (naturally).

                            All the numbers seem to be right.
                            Any thoughts as to what might be the problem ?

                            Thanks

                            Philip
                            VK4HPW
                          • Stelios Bounanos
                            Hi Philip, ... It seems that the ftp.berlios.de URL results in a redirect, and 8.04 s APT does not like that. I have changed the deb URL in the binaries page:
                            Message 13 of 13 , Aug 1, 2009
                            • 0 Attachment
                              Hi Philip,

                              >>>>> On Sat, 01 Aug 2009 12:56:46 +1000, Philip Webb <pwebb@...> said:

                              > Hi All,
                              > Sorry to revisit this after a delay, but I have been away and thought
                              > others might come up with the same problem in the meantime - but they
                              > havn't.

                              > WRT updating the repositories to include the berlios repository.
                              > When I follow the instructions which are quite clear and execute without
                              > a problem, until I get to the reload, when I get the following error
                              > message.

                              > ===============
                              > GPG error: http://ppa.launchpad.net hardy Release: The following
                              > signatures couldn't be verified because the public key is not available:
                              > NO_PUBKEY 8AD328D8A58BCAE3Failed to fetch
                              > http://ftp.berlios.de/pub/fldigi/binaries/dists/hardy/main/binary-i386/Packages.gz
                              > 302 Moved Temporarily
                              > Some index files failed to download, they have been ignored, or old ones
                              > used instead.
                              > ===============

                              > Using 8.04 (naturally).

                              > All the numbers seem to be right.
                              > Any thoughts as to what might be the problem ?

                              It seems that the ftp.berlios.de URL results in a redirect, and 8.04's
                              APT does not like that. I have changed the deb URL in the binaries
                              page:

                              http://fldigi.berlios.de/binaries

                              Please try again with the new repository URL.


                              --

                              73,
                              Stelios, M0GLD.
                            Your message has been successfully submitted and would be delivered to recipients shortly.