Loading ...
Sorry, an error occurred while loading the content.

Flidigi 3.10 and IC-7000 on Ubuntu 8.04 Won't Control Over CI-V

Expand Messages
  • ka6wke_1
    Good evening, I m trying to get Fldigi to control the IC-7000 through a homebrew CI-V interface. This exact setup worked with my 706MKIIG with no problems, but
    Message 1 of 19 , Feb 6, 2009
    • 0 Attachment
      Good evening,

      I'm trying to get Fldigi to control the IC-7000 through a homebrew
      CI-V interface. This exact setup worked with my 706MKIIG with no
      problems, but the 7000 doesn't respond.

      I've tried RigCAT with the ICOM7000.xml file and receive the following:

      rigCAT_init: Xcvr Freq request not answered

      I've tried different baud rates, and at 300 baud on the serial port,
      the rig will briefly PTT.

      I've compiled and tried HamLib too, but get this error message:

      show_error: hamlib_init: Rig not responding

      The rig quickly PTTs, then returns to RX.

      The 7000 has all defaults for CI-V. Anything else I should look at?

      73 - Mark
      KA6WKE
    • Ed
      ... Mark, make sure the rig and rigcat/hamlib are both set to the same baud rate. I know some Icoms use an autobaud setting and these tend to cause a problem.
      Message 2 of 19 , Feb 7, 2009
      • 0 Attachment
        ka6wke_1 wrote:
        > Good evening,
        >
        > I'm trying to get Fldigi to control the IC-7000 through a homebrew
        > CI-V interface. This exact setup worked with my 706MKIIG with no
        > problems, but the 7000 doesn't respond.
        >
        > I've tried RigCAT with the ICOM7000.xml file and receive the following:
        >
        > rigCAT_init: Xcvr Freq request not answered
        >
        > I've tried different baud rates, and at 300 baud on the serial port,
        > the rig will briefly PTT.
        >
        > I've compiled and tried HamLib too, but get this error message:
        >
        > show_error: hamlib_init: Rig not responding
        >
        > The rig quickly PTTs, then returns to RX.
        >
        > The 7000 has all defaults for CI-V. Anything else I should look at?
        >
        > 73 - Mark
        > KA6WKE
        >
        >


        Mark, make sure the rig and rigcat/hamlib are both set to the same baud
        rate. I know some Icoms use an autobaud setting and these tend to cause
        a problem.


        I would leave the PTT go for now until you get rig control set up.


        Set the retries to 4, this seems to be the most common setting. Retry
        interval is the tricky setting, try 50 and adjust in steps of 5 up/down.
        The command interval is also touchy, mine is set at 0, again you will
        need to work with the timimg.

        Hopefully someone is lurking on the list that may be of better help.


        Ed W3NR
      • Rick W
        Hi Mark, I have a homebrew (simple 2 transistor) CI-V interface that I have used in the past with my ICOM 756 Pro series rigs but I don t think I have tested
        Message 3 of 19 , Feb 7, 2009
        • 0 Attachment
          Hi Mark,

          I have a homebrew (simple 2 transistor) CI-V interface that I have used
          in the past with my ICOM 756 Pro series rigs but I don't think I have
          tested this on our 7000's. It should work in a similar manner.

          You probably know this already, but some of these designs require power
          being supplied by the COM port. Thus, you would need the appropriate 12
          vdc line active by checking the box RTS +12 V or DTR +12 v depending
          upon how you are configured. I would set the rig for the highest baud
          rate, 19200, (Auto may not work well), and double check the default
          address of 70h.

          I know how frustrating this can be as I had a difficult time when I was
          running fldigi under Linux. I now run it under WinXP and Vista using
          Hamlib although I switched over the West Mountain RigTalk interface
          which is a very nice solution to going from USB to CI-V:)

          73,

          Rick, KV9U

          ka6wke_1 wrote:
          > Good evening,
          >
          > I'm trying to get Fldigi to control the IC-7000 through a homebrew
          > CI-V interface. This exact setup worked with my 706MKIIG with no
          > problems, but the 7000 doesn't respond.
          >
          > I've tried RigCAT with the ICOM7000.xml file and receive the following:
          >
          > rigCAT_init: Xcvr Freq request not answered
          >
          > I've tried different baud rates, and at 300 baud on the serial port,
          > the rig will briefly PTT.
          >
          > I've compiled and tried HamLib too, but get this error message:
          >
          > show_error: hamlib_init: Rig not responding
          >
          > The rig quickly PTTs, then returns to RX.
          >
          > The 7000 has all defaults for CI-V. Anything else I should look at?
          >
          > 73 - Mark
          > KA6WKE
          >
          >
          >
          > ------------------------------------
          >
          > Yahoo! Groups Links
          >
          >
          >
          > ------------------------------------------------------------------------
          >
          >
          > No virus found in this incoming message.
          > Checked by AVG - www.avg.com
          > Version: 8.0.233 / Virus Database: 270.10.18/1937 - Release Date: 02/05/09 11:34:00
          >
          >
        • alw6hgf
          Hi Mark, I am using Fldigi with the IC-7000 and Rigblaster P&P for sound and CI-V interface through a USB port. I initially had trouble getting the CI-V to
          Message 4 of 19 , Feb 7, 2009
          • 0 Attachment
            Hi Mark,

            I am using Fldigi with the IC-7000 and Rigblaster P&P for sound and
            CI-V interface through a USB port. I initially had trouble getting
            the CI-V to work, and my settings, using Hamlib on Fldigi, that work
            today is the baud rate to 9600. Anything higher did not work for me
            through this interface. It has been a little while, but as I recall
            the IC-7000 was on autobaud, but had to be power cycled to recognize a
            new rate from Fldigi each time I changed it. The PTT seemed only to
            work through Hardware PTT, with the device being my USB port and RTS
            and DTR checked. Once I got it working, I have not tested any other
            configuration, so there may be others that work, but I have this one
            working perfectly for me.

            Let me know if I can check any other settings for you to help get it
            working.

            73

            Al W6HGF

            --- In linuxham@yahoogroups.com, Rick W <mrfarm@...> wrote:
            >
            > Hi Mark,
            >
            > I have a homebrew (simple 2 transistor) CI-V interface that I have used
            > in the past with my ICOM 756 Pro series rigs but I don't think I have
            > tested this on our 7000's. It should work in a similar manner.
            >
            > You probably know this already, but some of these designs require power
            > being supplied by the COM port. Thus, you would need the appropriate 12
            > vdc line active by checking the box RTS +12 V or DTR +12 v depending
            > upon how you are configured. I would set the rig for the highest baud
            > rate, 19200, (Auto may not work well), and double check the default
            > address of 70h.
            >
            > I know how frustrating this can be as I had a difficult time when I was
            > running fldigi under Linux. I now run it under WinXP and Vista using
            > Hamlib although I switched over the West Mountain RigTalk interface
            > which is a very nice solution to going from USB to CI-V:)
            >
            > 73,
            >
            > Rick, KV9U
            >
            > ka6wke_1 wrote:
            > > Good evening,
            > >
            > > I'm trying to get Fldigi to control the IC-7000 through a homebrew
            > > CI-V interface. This exact setup worked with my 706MKIIG with no
            > > problems, but the 7000 doesn't respond.
            > >
            > > I've tried RigCAT with the ICOM7000.xml file and receive the
            following:
            > >
            > > rigCAT_init: Xcvr Freq request not answered
            > >
            > > I've tried different baud rates, and at 300 baud on the serial port,
            > > the rig will briefly PTT.
            > >
            > > I've compiled and tried HamLib too, but get this error message:
            > >
            > > show_error: hamlib_init: Rig not responding
            > >
            > > The rig quickly PTTs, then returns to RX.
            > >
            > > The 7000 has all defaults for CI-V. Anything else I should look at?
            > >
            > > 73 - Mark
            > > KA6WKE
            > >
            > >
            > >
            > > ------------------------------------
            > >
            > > Yahoo! Groups Links
            > >
            > >
            > >
            > >
            ------------------------------------------------------------------------
            > >
            > >
            > > No virus found in this incoming message.
            > > Checked by AVG - www.avg.com
            > > Version: 8.0.233 / Virus Database: 270.10.18/1937 - Release Date:
            02/05/09 11:34:00
            > >
            > >
            >
          • yournotme2003
            ... Same thing here with a IC-751, it was working up to and including 3.04AM.
            Message 5 of 19 , Feb 7, 2009
            • 0 Attachment
              --- In linuxham@yahoogroups.com, "ka6wke_1" <ka6wke@...> wrote:
              >
              > Good evening,
              >
              > I'm trying to get Fldigi to control the IC-7000 through a homebrew
              > CI-V interface. This exact setup worked with my 706MKIIG with no
              > problems, but the 7000 doesn't respond.
              >
              > I've tried RigCAT with the ICOM7000.xml file and receive the following:
              >
              > rigCAT_init: Xcvr Freq request not answered
              >
              > I've tried different baud rates, and at 300 baud on the serial port,
              > the rig will briefly PTT.
              >
              > I've compiled and tried HamLib too, but get this error message:
              >
              > show_error: hamlib_init: Rig not responding
              >
              > The rig quickly PTTs, then returns to RX.
              >
              > The 7000 has all defaults for CI-V. Anything else I should look at?
              >
              > 73 - Mark
              > KA6WKE
              >

              Same thing here with a IC-751, it was working up to and including 3.04AM.
            • yournotme2003
              ... I forgot to mention that you might try it with grig as that is working here but not the new fldigi. Man grig for startup info.
              Message 6 of 19 , Feb 7, 2009
              • 0 Attachment
                --- In linuxham@yahoogroups.com, "ka6wke_1" <ka6wke@...> wrote:
                >
                > Good evening,
                >
                > I'm trying to get Fldigi to control the IC-7000 through a homebrew
                > CI-V interface. This exact setup worked with my 706MKIIG with no
                > problems, but the 7000 doesn't respond.
                >
                > I've tried RigCAT with the ICOM7000.xml file and receive the following:
                >
                > rigCAT_init: Xcvr Freq request not answered
                >
                > I've tried different baud rates, and at 300 baud on the serial port,
                > the rig will briefly PTT.
                >
                > I've compiled and tried HamLib too, but get this error message:
                >
                > show_error: hamlib_init: Rig not responding
                >
                > The rig quickly PTTs, then returns to RX.
                >
                > The 7000 has all defaults for CI-V. Anything else I should look at?
                >
                > 73 - Mark
                > KA6WKE
                >

                I forgot to mention that you might try it with grig as that is working
                here but not the new fldigi. Man grig for startup info.
              • Mark Schoonover
                ... Thanks Ed. I ve tried what you ve recommended, but still no luck. I took a look at the schematic for my 2 transistor CI-V interface, and it requires 12vdc
                Message 7 of 19 , Feb 7, 2009
                • 0 Attachment
                  On Sat, Feb 7, 2009 at 5:02 AM, Ed <autek@...> wrote:
                  > ka6wke_1 wrote:
                  >> Good evening,
                  >>
                  >> I'm trying to get Fldigi to control the IC-7000 through a homebrew
                  >> CI-V interface. This exact setup worked with my 706MKIIG with no
                  >> problems, but the 7000 doesn't respond.
                  >>
                  >> I've tried RigCAT with the ICOM7000.xml file and receive the following:
                  >>
                  >> rigCAT_init: Xcvr Freq request not answered
                  >>
                  >> I've tried different baud rates, and at 300 baud on the serial port,
                  >> the rig will briefly PTT.
                  >>
                  >> I've compiled and tried HamLib too, but get this error message:
                  >>
                  >> show_error: hamlib_init: Rig not responding
                  >>
                  >> The rig quickly PTTs, then returns to RX.
                  >>
                  >> The 7000 has all defaults for CI-V. Anything else I should look at?
                  >>
                  >> 73 - Mark
                  >> KA6WKE
                  >>
                  >>
                  >
                  > Mark, make sure the rig and rigcat/hamlib are both set to the same baud
                  > rate. I know some Icoms use an autobaud setting and these tend to cause
                  > a problem.
                  >
                  > I would leave the PTT go for now until you get rig control set up.
                  >
                  > Set the retries to 4, this seems to be the most common setting. Retry
                  > interval is the tricky setting, try 50 and adjust in steps of 5 up/down.
                  > The command interval is also touchy, mine is set at 0, again you will
                  > need to work with the timimg.
                  >
                  > Hopefully someone is lurking on the list that may be of better help.
                  >
                  > Ed W3NR

                  Thanks Ed. I've tried what you've recommended, but still no luck. I
                  took a look at the schematic for my 2 transistor CI-V interface, and
                  it requires 12vdc in order to operate. This is the CI-V interface I
                  built: http://www.qsl.net/g3vgr/civ.html. I made sure DTR was checked
                  on the config screen for RigCAT. I've set the rig to 9600 baud, plus
                  Fldigi with no success. I've also wiggled the retries and command
                  intervals as well.

                  Has anyone used the West Mountain Radio USB->CI-V interface with
                  Ubuntu and Fldigi? I can always use the interface for the 706.

                  Thanks for all the ideas.

                  --
                  73 - Mark - KA6WKE
                  http://ka6wke.blogspot.com/
                • alw6hgf
                  Mark, Ok first when I first activate the serial port a short ptt on the IC-7000 is normal for me, and then it waits for a command. So if you are seeing the
                  Message 8 of 19 , Feb 7, 2009
                  • 0 Attachment
                    Mark,

                    Ok first when I first activate the serial port a short ptt on the
                    IC-7000 is normal for me, and then it waits for a command. So if you
                    are seeing the short PTT, it is a probably a good sign. If the
                    interface worked on another rig, but does not work here, it could be
                    in the addresses, as I understand it, there can be several rigs on the
                    same CI-V but each with a different address. The default for the
                    IC-7000 is 70h but can be changed if there is a conflict or if two
                    7000's are used. The setting is on the set mode (push the volume
                    control), the OTH button and scroll down to 49. to see what is
                    actually there for address. While you are there, you can scroll up to
                    48 can check to see if the baud rate is still automatic, or if it is
                    set at a specific setting. I know 9600 works, but had no luck getting
                    anything higher to work for me with my interface. I did not see a way
                    to change the address in Hamlib but mine seems to be using the default
                    for the Ic-7000 when using the rig "Icom IC-7000(Untested)". It looks
                    like the address can be changed in the Rigcat XML file. I have not
                    used Rigcat yet so can not confirm. Just a couple more ideas before
                    you give up.

                    73 Al W6HGF



                    --- In linuxham@yahoogroups.com, Mark Schoonover <ka6wke@...> wrote:
                    >
                    > On Sat, Feb 7, 2009 at 5:02 AM, Ed <autek@...> wrote:
                    > > ka6wke_1 wrote:
                    > >> Good evening,
                    > >>
                    > >> I'm trying to get Fldigi to control the IC-7000 through a homebrew
                    > >> CI-V interface. This exact setup worked with my 706MKIIG with no
                    > >> problems, but the 7000 doesn't respond.
                    > >>
                    > >> I've tried RigCAT with the ICOM7000.xml file and receive the
                    following:
                    > >>
                    > >> rigCAT_init: Xcvr Freq request not answered
                    > >>
                    > >> I've tried different baud rates, and at 300 baud on the serial port,
                    > >> the rig will briefly PTT.
                    > >>
                    > >> I've compiled and tried HamLib too, but get this error message:
                    > >>
                    > >> show_error: hamlib_init: Rig not responding
                    > >>
                    > >> The rig quickly PTTs, then returns to RX.
                    > >>
                    > >> The 7000 has all defaults for CI-V. Anything else I should look at?
                    > >>
                    > >> 73 - Mark
                    > >> KA6WKE
                    > >>
                    > >>
                    > >
                    > > Mark, make sure the rig and rigcat/hamlib are both set to the same
                    baud
                    > > rate. I know some Icoms use an autobaud setting and these tend to
                    cause
                    > > a problem.
                    > >
                    > > I would leave the PTT go for now until you get rig control set up.
                    > >
                    > > Set the retries to 4, this seems to be the most common setting. Retry
                    > > interval is the tricky setting, try 50 and adjust in steps of 5
                    up/down.
                    > > The command interval is also touchy, mine is set at 0, again you will
                    > > need to work with the timimg.
                    > >
                    > > Hopefully someone is lurking on the list that may be of better help.
                    > >
                    > > Ed W3NR
                    >
                    > Thanks Ed. I've tried what you've recommended, but still no luck. I
                    > took a look at the schematic for my 2 transistor CI-V interface, and
                    > it requires 12vdc in order to operate. This is the CI-V interface I
                    > built: http://www.qsl.net/g3vgr/civ.html. I made sure DTR was checked
                    > on the config screen for RigCAT. I've set the rig to 9600 baud, plus
                    > Fldigi with no success. I've also wiggled the retries and command
                    > intervals as well.
                    >
                    > Has anyone used the West Mountain Radio USB->CI-V interface with
                    > Ubuntu and Fldigi? I can always use the interface for the 706.
                    >
                    > Thanks for all the ideas.
                    >
                    > --
                    > 73 - Mark - KA6WKE
                    > http://ka6wke.blogspot.com/
                    >
                  • JOHN G WEBER
                    Mark, I used an Icom 706 with Ubuntu and fldigi.  Like you, I had to build a CI-V interface.  The one that I built derived power from the serial port and
                    Message 9 of 19 , Feb 7, 2009
                    • 0 Attachment
                      Mark,
                      I used an Icom 706 with Ubuntu and fldigi.  Like you, I had to build a CI-V interface.  The one that I built derived power from the serial port and would only work when the power was fed on the RTS or DTR lead.  If I remember correctly, I used one of the leads for power and the other for keying.  I tried your link to your interface and the link didn't work.  If you used your current setup for your 706 and it worked, my input is probably not applicable.  However, hope it is of some help.  BTW, I used hamlib and set the baud rate to 9600.

                      john

                      --- On Sat, 2/7/09, Mark Schoonover <ka6wke@...> wrote:
                      From: Mark Schoonover <ka6wke@...>
                      Subject: Re: [linuxham] Flidigi 3.10 and IC-7000 on Ubuntu 8.04 Won't Control Over CI-V
                      To: linuxham@yahoogroups.com
                      Date: Saturday, February 7, 2009, 7:27 PM

                      On Sat, Feb 7, 2009 at 5:02 AM, Ed <autek@comcast. net> wrote:
                      > ka6wke_1 wrote:
                      >> Good evening,
                      >>
                      >> I'm trying to get Fldigi to control the IC-7000 through a homebrew
                      >> CI-V interface. This exact setup worked with my 706MKIIG with no
                      >> problems, but the 7000 doesn't respond.
                      >>
                      >> I've tried RigCAT with the ICOM7000.xml file and receive the following:
                      >>
                      >> rigCAT_init: Xcvr Freq request not answered
                      >>
                      >> I've tried different baud rates, and at 300 baud on the serial port,
                      >> the rig will briefly PTT.
                      >>
                      >> I've compiled and tried HamLib too, but get this error message:
                      >>
                      >> show_error: hamlib_init: Rig not responding
                      >>
                      >> The rig quickly PTTs, then returns to RX.
                      >>
                      >> The 7000 has all defaults for CI-V. Anything else I should look at?
                      >>
                      >> 73 - Mark
                      >> KA6WKE
                      >>
                      >>
                      >
                      > Mark, make sure the rig and rigcat/hamlib are both set to the same baud
                      > rate. I know some Icoms use an autobaud setting and these tend to cause
                      > a problem.
                      >
                      > I would leave the PTT go for now until you get rig control set up.
                      >
                      > Set the retries to 4, this seems to be the most common setting. Retry
                      > interval is the tricky setting, try 50 and adjust in steps of 5 up/down.
                      > The command interval is also touchy, mine is set at 0, again you will
                      > need to work with the timimg.
                      >
                      > Hopefully someone is lurking on the list that may be of better help.
                      >
                      > Ed W3NR

                      Thanks Ed. I've tried what you've recommended, but still no luck. I
                      took a look at the schematic for my 2 transistor CI-V interface, and
                      it requires 12vdc in order to operate. This is the CI-V interface I
                      built: http://www.qsl. net/g3vgr/ civ.html. I made sure DTR was checked
                      on the config screen for RigCAT. I've set the rig to 9600 baud, plus
                      Fldigi with no success. I've also wiggled the retries and command
                      intervals as well.

                      Has anyone used the West Mountain Radio USB->CI-V interface with
                      Ubuntu and Fldigi? I can always use the interface for the 706.

                      Thanks for all the ideas.

                      --
                      73 - Mark - KA6WKE
                      http://ka6wke. blogspot. com/

                    • Ed
                      ... Several of us use the same interface, so we know it works. You have DTR set to +12, have you tried RTS set to +12 ?. Al has some very good suggestions, I
                      Message 10 of 19 , Feb 7, 2009
                      • 0 Attachment
                        Mark Schoonover wrote:
                        > On Sat, Feb 7, 2009 at 5:02 AM, Ed <autek@...> wrote:
                        >> ka6wke_1 wrote:
                        >>> Good evening,
                        >>>
                        >>> I'm trying to get Fldigi to control the IC-7000 through a homebrew
                        >>> CI-V interface. This exact setup worked with my 706MKIIG with no
                        >>> problems, but the 7000 doesn't respond.
                        >>>
                        >>> I've tried RigCAT with the ICOM7000.xml file and receive the following:
                        >>>
                        >>> rigCAT_init: Xcvr Freq request not answered
                        >>>
                        >>> I've tried different baud rates, and at 300 baud on the serial port,
                        >>> the rig will briefly PTT.
                        >>>
                        >>> I've compiled and tried HamLib too, but get this error message:
                        >>>
                        >>> show_error: hamlib_init: Rig not responding
                        >>>
                        >>> The rig quickly PTTs, then returns to RX.
                        >>>
                        >>> The 7000 has all defaults for CI-V. Anything else I should look at?
                        >>>
                        >>> 73 - Mark
                        >>> KA6WKE
                        >>>
                        >>>
                        >> Mark, make sure the rig and rigcat/hamlib are both set to the same baud
                        >> rate. I know some Icoms use an autobaud setting and these tend to cause
                        >> a problem.
                        >>
                        >> I would leave the PTT go for now until you get rig control set up.
                        >>
                        >> Set the retries to 4, this seems to be the most common setting. Retry
                        >> interval is the tricky setting, try 50 and adjust in steps of 5 up/down.
                        >> The command interval is also touchy, mine is set at 0, again you will
                        >> need to work with the timimg.
                        >>
                        >> Hopefully someone is lurking on the list that may be of better help.
                        >>
                        >> Ed W3NR
                        >
                        > Thanks Ed. I've tried what you've recommended, but still no luck. I
                        > took a look at the schematic for my 2 transistor CI-V interface, and
                        > it requires 12vdc in order to operate. This is the CI-V interface I
                        > built: http://www.qsl.net/g3vgr/civ.html. I made sure DTR was checked
                        > on the config screen for RigCAT. I've set the rig to 9600 baud, plus
                        > Fldigi with no success. I've also wiggled the retries and command
                        > intervals as well.

                        Several of us use the same interface, so we know it works. You have DTR
                        set to +12, have you tried RTS set to +12 ?.

                        Al has some very good suggestions, I agree the momentary PTT is a good
                        sign. My Omni as well as the Icom 735 do the exact same. The command
                        intervals can be tricky at times.


                        It seems strange that some times rig control works, and other times
                        using the same rig and settings, the next guy plays havoc to get it going.


                        > Has anyone used the West Mountain Radio USB->CI-V interface with
                        > Ubuntu and Fldigi? I can always use the interface for the 706.
                        >
                        > Thanks for all the ideas.
                        >


                        Be careful, some of these require the use of a virtual comport that
                        require M$ drivers.


                        Ed W3NR
                      • Dennis Mingear
                        Mark Schoonover wrote: ? ... If you are referring to West Mountain s RigTalk USB CI/V interface, I m using it with 32 bit Ubuntu 8.10 and FLdigi 3.10 and a
                        Message 11 of 19 , Feb 7, 2009
                        • 0 Attachment
                          Mark Schoonover wrote: ?

                          > Has anyone used the West Mountain Radio USB->CI-V interface with
                          > Ubuntu and Fldigi? I can always use the interface for the 706.

                          If you are referring to West Mountain's RigTalk USB CI/V interface, I'm using it with 32 bit Ubuntu 8.10 and FLdigi 3.10 and a Icom 718.

                          It was plug and play without any driver issues at all.

                          Denny ... kd6cyl

                          Hope keeps you going ... Fear keeps you alive!
                          Brought to you by Ubuntu 8.10, and FireFox 3.0.3 through the magic of Linux.


                        • Mark Schoonover
                          Thanks Ed. I ve been working on this some more, but no luck. This is what I ve tried. I ve set the serial port to 9600 baud via setserial. I ve set the PC BIOS
                          Message 12 of 19 , Feb 7, 2009
                          • 0 Attachment
                            Thanks Ed. I've been working on this some more, but no luck. This is
                            what I've tried.

                            I've set the serial port to 9600 baud via setserial.
                            I've set the PC BIOS to force COM1 instead of auto.
                            I've set the rig to 9600 baud.

                            I've tried rigctl: rigctl -r /dev/ttyS0 -c 70 -m 360 -s 9600
                            Output is:

                            rigctl -r /dev/ttyS0 -c 70 -m 360 -s 9600

                            Rig command: f
                            read_string: timedout without reading a character
                            read_string: timedout without reading a character
                            read_string: timedout without reading a character
                            read_string: timedout without reading a character
                            get_freq: error = Communication bus error

                            Rig command: q


                            I've verified the CI-V I built requires +12v on DTR.
                            I've tried +12v on DTR and RTS at the same time.

                            I've looked at the RigCAT IC7000.xml file for CI-V address, but didn't
                            see a setting for it.
                            I've double checked my interface just incase something broke.
                            I've confirmed the current CI-V settings on the 7000 work by testing
                            with my BetterRF tuner adapter.

                            Pretty much have run out of ideas!

                            Thanks for all the help so far.


                            --
                            73 - Mark - KA6WKE
                            http://ka6wke.blogspot.com/


                            On Sat, Feb 7, 2009 at 7:15 PM, Ed <autek@...> wrote:
                            > Mark Schoonover wrote:
                            >> On Sat, Feb 7, 2009 at 5:02 AM, Ed <autek@...> wrote:
                            >>> ka6wke_1 wrote:
                            >>>> Good evening,
                            >>>>
                            >>>> I'm trying to get Fldigi to control the IC-7000 through a homebrew
                            >>>> CI-V interface. This exact setup worked with my 706MKIIG with no
                            >>>> problems, but the 7000 doesn't respond.
                            >>>>
                            >>>> I've tried RigCAT with the ICOM7000.xml file and receive the following:
                            >>>>
                            >>>> rigCAT_init: Xcvr Freq request not answered
                            >>>>
                            >>>> I've tried different baud rates, and at 300 baud on the serial port,
                            >>>> the rig will briefly PTT.
                            >>>>
                            >>>> I've compiled and tried HamLib too, but get this error message:
                            >>>>
                            >>>> show_error: hamlib_init: Rig not responding
                            >>>>
                            >>>> The rig quickly PTTs, then returns to RX.
                            >>>>
                            >>>> The 7000 has all defaults for CI-V. Anything else I should look at?
                            >>>>
                            >>>> 73 - Mark
                            >>>> KA6WKE
                            >>>>
                            >>>>
                            >>> Mark, make sure the rig and rigcat/hamlib are both set to the same baud
                            >>> rate. I know some Icoms use an autobaud setting and these tend to cause
                            >>> a problem.
                            >>>
                            >>> I would leave the PTT go for now until you get rig control set up.
                            >>>
                            >>> Set the retries to 4, this seems to be the most common setting. Retry
                            >>> interval is the tricky setting, try 50 and adjust in steps of 5 up/down.
                            >>> The command interval is also touchy, mine is set at 0, again you will
                            >>> need to work with the timimg.
                            >>>
                            >>> Hopefully someone is lurking on the list that may be of better help.
                            >>>
                            >>> Ed W3NR
                            >>
                            >> Thanks Ed. I've tried what you've recommended, but still no luck. I
                            >> took a look at the schematic for my 2 transistor CI-V interface, and
                            >> it requires 12vdc in order to operate. This is the CI-V interface I
                            >> built: http://www.qsl.net/g3vgr/civ.html. I made sure DTR was checked
                            >> on the config screen for RigCAT. I've set the rig to 9600 baud, plus
                            >> Fldigi with no success. I've also wiggled the retries and command
                            >> intervals as well.
                            >
                            > Several of us use the same interface, so we know it works. You have DTR
                            > set to +12, have you tried RTS set to +12 ?.
                            >
                            > Al has some very good suggestions, I agree the momentary PTT is a good
                            > sign. My Omni as well as the Icom 735 do the exact same. The command
                            > intervals can be tricky at times.
                            >
                            > It seems strange that some times rig control works, and other times
                            > using the same rig and settings, the next guy plays havoc to get it going.
                            >
                            >> Has anyone used the West Mountain Radio USB->CI-V interface with
                            >> Ubuntu and Fldigi? I can always use the interface for the 706.
                            >>
                            >> Thanks for all the ideas.
                            >>
                            >
                            > Be careful, some of these require the use of a virtual comport that
                            > require M$ drivers.
                            >
                            > Ed W3NR
                          • Rick Kunath
                            Comments inline... ... Have you tried sending the raw rig control commands right to the serial port using something like CuteCom? That s a GUI based serial
                            Message 13 of 19 , Feb 7, 2009
                            • 0 Attachment
                              Comments inline...

                              > I've set the serial port to 9600 baud via setserial.
                              > I've set the PC BIOS to force COM1 instead of auto.
                              > I've set the rig to 9600 baud.
                              >
                              > I've tried rigctl: rigctl -r /dev/ttyS0 -c 70 -m 360 -s 9600
                              > Output is:
                              >
                              > rigctl -r /dev/ttyS0 -c 70 -m 360 -s 9600
                              >
                              > Rig command: f
                              > read_string: timedout without reading a character
                              > read_string: timedout without reading a character
                              > read_string: timedout without reading a character
                              > read_string: timedout without reading a character
                              > get_freq: error = Communication bus error
                              >
                              > Rig command: q

                              Have you tried sending the raw rig control commands right to the serial port
                              using something like CuteCom? That's a GUI based serial port tool. I have
                              used it many times to troubleshoot devices. It should be in your distros
                              repo. At least that way you would know the interface is working.

                              What is this, a real serial port?

                              > I've verified the CI-V I built requires +12v on DTR.
                              > I've tried +12v on DTR and RTS at the same time.

                              Are you actually getting 12 volts from the port (or + and - 12 volts if you
                              need that)? Not all serial ports deliver 12 volts or enough current to drive
                              self powered stuff. I've seen laptop serial ports put out 5 volts only.

                              Don't know if any of this helps.

                              Rick Kunath, k9ao
                            • w1hkj
                              ... You should be able to use 38400 with that rig and your homebrew serial to CI-V converter. Please read your IC7000 manual Mark. You should find that the
                              Message 14 of 19 , Feb 7, 2009
                              • 0 Attachment
                                Mark Schoonover wrote:
                                > Thanks Ed. I've been working on this some more, but no luck. This is
                                > what I've tried.
                                >
                                > I've set the serial port to 9600 baud via setserial.
                                > I've set the PC BIOS to force COM1 instead of auto.
                                > I've set the rig to 9600 baud.
                                >
                                You should be able to use 38400 with that rig and your homebrew serial
                                to CI-V converter.

                                Please read your IC7000 manual Mark. You should find that the default
                                address for the IC7000 is 66. Now look at the IC7000.xml file and you
                                will see the 66 as a part of several command strings as in:

                                <COMMAND>
                                <SYMBOL>SETFREQ</SYMBOL>
                                <SIZE>11</SIZE>
                                <BYTES>FE FE 66 E0</BYTES>
                                <BYTE>05</BYTE>
                                <DATA>
                                <DTYPE>BCD</DTYPE>
                                <SIZE> 9 </SIZE>
                                <MAX> 174000000 </MAX>
                                <MIN> 30000 </MIN>
                                <RESOL> 1 </RESOL>
                                <REV>true</REV>
                                </DATA>
                                <BYTE>FD </BYTE>
                                <OK>OK</OK>
                                <BAD>BAD</BAD>
                                </COMMAND>

                                Make sure that your IC7000 CI-V address is indeed set to 66. It can be
                                set from the front panel of the rig.

                                Be sure that you have the "commands are echoed" box checked on the
                                RigCAT configuration tab. Your homebrew CI-V port echoes all outgoing
                                data back to the serial in on the serial port. That happens because of
                                the way the CI-V bidirectional data is converted to the serial TTY
                                signals in your h/w interface.

                                73, Dave, W1HKJ
                              • Mark Schoonover
                                Thanks Dave. Comments inline. ... The manual clearly states 70h is the default value for CI-V address. I ve been through the manual several times. ... I set it
                                Message 15 of 19 , Feb 7, 2009
                                • 0 Attachment
                                  Thanks Dave. Comments inline.


                                  On Sat, Feb 7, 2009 at 9:02 PM, w1hkj <w1hkj@...> wrote:
                                  > Mark Schoonover wrote:
                                  >> Thanks Ed. I've been working on this some more, but no luck. This is
                                  >> what I've tried.
                                  >>
                                  >> I've set the serial port to 9600 baud via setserial.
                                  >> I've set the PC BIOS to force COM1 instead of auto.
                                  >> I've set the rig to 9600 baud.
                                  >>
                                  > You should be able to use 38400 with that rig and your homebrew serial
                                  > to CI-V converter.
                                  >
                                  > Please read your IC7000 manual Mark. You should find that the default
                                  > address for the IC7000 is 66. Now look at the IC7000.xml file and you
                                  > will see the 66 as a part of several command strings as in:

                                  The manual clearly states 70h is the default value for CI-V address.
                                  I've been through the manual several times.

                                  >
                                  > <COMMAND>
                                  > <SYMBOL>SETFREQ</SYMBOL>
                                  > <SIZE>11</SIZE>
                                  > <BYTES>FE FE 66 E0</BYTES>
                                  > <BYTE>05</BYTE>
                                  > <DATA>
                                  > <DTYPE>BCD</DTYPE>
                                  > <SIZE> 9 </SIZE>
                                  > <MAX> 174000000 </MAX>
                                  > <MIN> 30000 </MIN>
                                  > <RESOL> 1 </RESOL>
                                  > <REV>true</REV>
                                  > </DATA>
                                  > <BYTE>FD </BYTE>
                                  > <OK>OK</OK>
                                  > <BAD>BAD</BAD>
                                  > </COMMAND>
                                  >
                                  > Make sure that your IC7000 CI-V address is indeed set to 66. It can be
                                  > set from the front panel of the rig.

                                  I set it to 66 just to try it out, and enabled "commands are echoed"
                                  checkbox, no luck. Same result:

                                  E: rigCAT_init: Xcvr Freq request not answered

                                  <<snip>>
                                  --
                                  73 - Mark - KA6WKE
                                  http://ka6wke.blogspot.com/
                                • Ed
                                  ... I don t know Mark, but it looks like the interface is the problem, with no response from rigctl. Ed W3NR
                                  Message 16 of 19 , Feb 8, 2009
                                  • 0 Attachment
                                    Mark Schoonover wrote:
                                    > Thanks Ed. I've been working on this some more, but no luck. This is
                                    > what I've tried.
                                    >
                                    > I've set the serial port to 9600 baud via setserial.
                                    > I've set the PC BIOS to force COM1 instead of auto.
                                    > I've set the rig to 9600 baud.
                                    >
                                    > I've tried rigctl: rigctl -r /dev/ttyS0 -c 70 -m 360 -s 9600
                                    > Output is:
                                    >
                                    > rigctl -r /dev/ttyS0 -c 70 -m 360 -s 9600
                                    >
                                    > Rig command: f
                                    > read_string: timedout without reading a character
                                    > read_string: timedout without reading a character
                                    > read_string: timedout without reading a character
                                    > read_string: timedout without reading a character
                                    > get_freq: error = Communication bus error
                                    >
                                    > Rig command: q
                                    >
                                    >
                                    > I've verified the CI-V I built requires +12v on DTR.
                                    > I've tried +12v on DTR and RTS at the same time.
                                    >
                                    > I've looked at the RigCAT IC7000.xml file for CI-V address, but didn't
                                    > see a setting for it.
                                    > I've double checked my interface just incase something broke.
                                    > I've confirmed the current CI-V settings on the 7000 work by testing
                                    > with my BetterRF tuner adapter.
                                    >
                                    > Pretty much have run out of ideas!
                                    >
                                    > Thanks for all the help so far.
                                    >
                                    >


                                    I don't know Mark, but it looks like the interface is the problem, with
                                    no response from rigctl.


                                    Ed W3NR
                                  • rich
                                    Mark, Just to summarize: manual pg 136, Address 70h, baud 9600 at both ends (19200 should work), CI-V transceive to off (default is on). If you have access to
                                    Message 17 of 19 , Feb 8, 2009
                                    • 0 Attachment
                                      Mark,
                                      Just to summarize: manual pg 136, Address 70h, baud 9600 at both ends
                                      (19200 should work), CI-V transceive to off (default is on). If you
                                      have access to a o'scope check interface data and response for correct
                                      level & shape. I have seen a lot of interfaces that distort the shape
                                      of the data pulses just enough to not work between different radios,
                                      dependent on the input circuit of the radio. Many newer designs just
                                      go strait to the microprocessor pin instead of running thru a driver
                                      chip. You should try to borrow a commercial CI-V box from another ham
                                      long enough to confirm that it is or is not a problem.

                                      Rich
                                      WA4SXZ


                                      --- In linuxham@yahoogroups.com, Mark Schoonover <ka6wke@...> wrote:
                                      >
                                      > Thanks Dave. Comments inline.
                                      >
                                      >
                                      > On Sat, Feb 7, 2009 at 9:02 PM, w1hkj <w1hkj@...> wrote:
                                      > > Mark Schoonover wrote:
                                      > >> Thanks Ed. I've been working on this some more, but no luck. This is
                                      > >> what I've tried.
                                      > >>
                                      > >> I've set the serial port to 9600 baud via setserial.
                                      > >> I've set the PC BIOS to force COM1 instead of auto.
                                      > >> I've set the rig to 9600 baud.
                                      > >>
                                      > > You should be able to use 38400 with that rig and your homebrew serial
                                      > > to CI-V converter.
                                      > >
                                      > > Please read your IC7000 manual Mark. You should find that the default
                                      > > address for the IC7000 is 66. Now look at the IC7000.xml file and you
                                      > > will see the 66 as a part of several command strings as in:
                                      >
                                      > The manual clearly states 70h is the default value for CI-V address.
                                      > I've been through the manual several times.
                                      >
                                      > >
                                      > > <COMMAND>
                                      > > <SYMBOL>SETFREQ</SYMBOL>
                                      > > <SIZE>11</SIZE>
                                      > > <BYTES>FE FE 66 E0</BYTES>
                                      > > <BYTE>05</BYTE>
                                      > > <DATA>
                                      > > <DTYPE>BCD</DTYPE>
                                      > > <SIZE> 9 </SIZE>
                                      > > <MAX> 174000000 </MAX>
                                      > > <MIN> 30000 </MIN>
                                      > > <RESOL> 1 </RESOL>
                                      > > <REV>true</REV>
                                      > > </DATA>
                                      > > <BYTE>FD </BYTE>
                                      > > <OK>OK</OK>
                                      > > <BAD>BAD</BAD>
                                      > > </COMMAND>
                                      > >
                                      > > Make sure that your IC7000 CI-V address is indeed set to 66. It can be
                                      > > set from the front panel of the rig.
                                      >
                                      > I set it to 66 just to try it out, and enabled "commands are echoed"
                                      > checkbox, no luck. Same result:
                                      >
                                      > E: rigCAT_init: Xcvr Freq request not answered
                                      >
                                      > <<snip>>
                                      > --
                                      > 73 - Mark - KA6WKE
                                      > http://ka6wke.blogspot.com/
                                      >
                                    • w1hkj
                                      Mark, After following Rich s advice please do the following. Insure that the CI-V address in both the IC7000.xml file and the rig are the same (70H or 66H).
                                      Message 18 of 19 , Feb 8, 2009
                                      • 0 Attachment
                                        Mark,

                                        After following Rich's advice please do the following.

                                        Insure that the CI-V address in both the IC7000.xml file and the rig are the same (70H or 66H).

                                        Open fldigi's event log, "Help / Event log".  Set the level to DEBUG (slider to the right).  Make sure that "Rig control" is checked on the event sources menu.  Clear the event log (right click menu on event text).

                                        Open the RigCAT configuration tab and then adjust as:



                                        Adjust the baud rate to be the one that the transceiver is set to.  You may not need both RTS and DTR set to +12v depending on your interface design.

                                        Press the Initialize button.

                                        You should see the events associated with opening up the serial port and testing for the frequency readout.  They might look something like:

                                        D: [06:31:47] rigcontrol/rigio.cxx:1140: Exiting rigCAT loop, closing serial port
                                        D: [06:31:47] rigcontrol/rigio.cxx:1027: RigCAT closed, count = 199
                                        I: [06:31:47] rigcontrol/rigio.cxx:968:
                                        Serial port parameters:
                                        device     : /dev/ttyS0
                                        baudrate   : 38400
                                        retries    : 2
                                        timeout    : 10
                                        wait       : 50
                                        initial rts: +12
                                        use rts ptt: F
                                        initial dtr: +12
                                        use dtr ptt: F
                                        flowcontrol: F
                                        echo       : T

                                        D: [06:31:47] rigcontrol/rigio.cxx:339: get frequency
                                        D: [06:31:47] rigcontrol/rigio.cxx:73: cmd = FE FE 70 E0 03 FD
                                        D: [06:31:47] rigcontrol/rigio.cxx:99: echoed = FE FE 70 E0 03 FD
                                        D: [06:31:48] rigcontrol/rigio.cxx:110: waiting for 11 bytes
                                        D: [06:31:48] rigcontrol/rigio.cxx:118: resp (0) no reply
                                        D: [06:31:48] rigcontrol/rigio.cxx:99: echoed = FE FE 70 E0 03 FD
                                        D: [06:31:48] rigcontrol/rigio.cxx:110: waiting for 11 bytes
                                        D: [06:31:48] rigcontrol/rigio.cxx:118: resp (1) no reply
                                        E: [06:31:48] rigcontrol/rigio.cxx:980: Xcvr Freq request not answered
                                        I: [06:31:48] rigcontrol/serial.cxx:213: Serial port closed, fd = 31
                                        D: [06:31:48] rigcontrol/rigsupport.cxx:577: no rig

                                        Save the event log to a file (right click menu on the event text).  Since I do not have a 7000 I get the message that you have reported.  The echoed response does tell me that my CI-V interface is working correctly.

                                        Send me the results of the test.  A copy to linuxham@yahoogroups.com and also one direct to me at w1hkj@...

                                        Thanks.

                                        73, Dave, W1HKJ

                                      • Mark Schoonover
                                        ... Dave, Thanks for all the debugging tips, it s working! I started debugging and watching for the echo commands. The initial screen shot you sent me of the
                                        Message 19 of 19 , Feb 8, 2009
                                        • 0 Attachment
                                          On Sun, Feb 8, 2009 at 6:30 AM, w1hkj <w1hkj@...> wrote:
                                          > Mark,
                                          >
                                          > After following Rich's advice please do the following.
                                          >
                                          > Insure that the CI-V address in both the IC7000.xml file and the rig are the
                                          > same (70H or 66H).
                                          >
                                          > Open fldigi's event log, "Help / Event log". Set the level to DEBUG (slider
                                          > to the right). Make sure that "Rig control" is checked on the event sources
                                          > menu. Clear the event log (right click menu on event text).
                                          >
                                          > Open the RigCAT configuration tab and then adjust as:
                                          >
                                          >
                                          >
                                          > Adjust the baud rate to be the one that the transceiver is set to. You may
                                          > not need both RTS and DTR set to +12v depending on your interface design.
                                          >
                                          > Press the Initialize button.
                                          >
                                          > You should see the events associated with opening up the serial port and
                                          > testing for the frequency readout. They might look something like:
                                          >
                                          > D: [06:31:47] rigcontrol/rigio.cxx:1140: Exiting rigCAT loop, closing serial
                                          > port
                                          > D: [06:31:47] rigcontrol/rigio.cxx:1027: RigCAT closed, count = 199
                                          > I: [06:31:47] rigcontrol/rigio.cxx:968:
                                          > Serial port parameters:
                                          > device : /dev/ttyS0
                                          > baudrate : 38400
                                          > retries : 2
                                          > timeout : 10
                                          > wait : 50
                                          > initial rts: +12
                                          > use rts ptt: F
                                          > initial dtr: +12
                                          > use dtr ptt: F
                                          > flowcontrol: F
                                          > echo : T
                                          >
                                          > D: [06:31:47] rigcontrol/rigio.cxx:339: get frequency
                                          > D: [06:31:47] rigcontrol/rigio.cxx:73: cmd = FE FE 70 E0 03 FD
                                          > D: [06:31:47] rigcontrol/rigio.cxx:99: echoed = FE FE 70 E0 03 FD
                                          > D: [06:31:48] rigcontrol/rigio.cxx:110: waiting for 11 bytes
                                          > D: [06:31:48] rigcontrol/rigio.cxx:118: resp (0) no reply
                                          > D: [06:31:48] rigcontrol/rigio.cxx:99: echoed = FE FE 70 E0 03 FD
                                          > D: [06:31:48] rigcontrol/rigio.cxx:110: waiting for 11 bytes
                                          > D: [06:31:48] rigcontrol/rigio.cxx:118: resp (1) no reply
                                          > E: [06:31:48] rigcontrol/rigio.cxx:980: Xcvr Freq request not answered
                                          > I: [06:31:48] rigcontrol/serial.cxx:213: Serial port closed, fd = 31
                                          > D: [06:31:48] rigcontrol/rigsupport.cxx:577: no rig
                                          >
                                          > Save the event log to a file (right click menu on the event text). Since I
                                          > do not have a 7000 I get the message that you have reported. The echoed
                                          > response does tell me that my CI-V interface is working correctly.
                                          >
                                          > Send me the results of the test. A copy to linuxham@yahoogroups.com and
                                          > also one direct to me at w1hkj@...
                                          >
                                          > Thanks.
                                          >
                                          > 73, Dave, W1HKJ
                                          >
                                          >

                                          Dave,

                                          Thanks for all the debugging tips, it's working! I started debugging
                                          and watching for the echo commands. The initial screen shot you sent
                                          me of the config screen had both RTS and DTR checked. My interface
                                          started echoing back commands when the RTS was unchecked, but DTR was
                                          checked. The rig has the following settings:

                                          CI-V Baud Rate: Auto
                                          CI-V Address: 66h
                                          CI-V Tranceive: Off

                                          I'm not sure if the listserv will allow attachements, but I've
                                          attached what my Rig Config screen looks like.

                                          Thanks to all the others for providing assistance, I'm off to hook up
                                          the rest of the interface.

                                          --
                                          73 - Mark - KA6WKE
                                          http://ka6wke.blogspot.com/
                                        Your message has been successfully submitted and would be delivered to recipients shortly.