Loading ...
Sorry, an error occurred while loading the content.

Fldigi 3.1 - MacOS/K2 waterfall freq display problem

Expand Messages
  • Brian Lloyd
    I just switched to Fldigi 3.1 on the Mac. The problems I have run into are a couple of frequency display errors on the waterfall. Config: Elecraft K2; using
    Message 1 of 4 , Feb 3, 2009
    • 0 Attachment
      I just switched to Fldigi 3.1 on the Mac. The problems I have run into
      are a couple of frequency display errors on the waterfall.

      Config: Elecraft K2; using hamlib for rig control at 4800 bps; using
      RTS on a second serial port to control PTT. All this appears to work
      properly.

      1. Selecting mode RTTYR causes the frequency display to be backwards,
      i.e. higher audio frequency is lower RF frequency. Since RTTYR mode is
      really USB, higher audio frequency should be higher RF frequency. USB
      mode displays properly. [The K2 operates in LSB mode (BFO injection
      above the filter passband) for RTTY mode and in USB mode for RTTYR.)

      2. If I select "always show audio frequency" in the waterfall
      configuration pane, the audio frequency display changes as the radio
      is tuned, thus making the audio frequency references useless.

      So, I cannot work around item 1 by using an audio frequency display on
      the waterfall.

      Is this a known problem?

      Thanks in advance.

      73 de Brian, WB6RQN/J79BPL
    • Ed
      ... Brian, there is no reason to use RTTYR. fldigi will decode perfectly regardless of sideband. I use LSB for RTTY take advantage of my 500Hz filter. So just
      Message 2 of 4 , Feb 3, 2009
      • 0 Attachment
        Brian Lloyd wrote:
        > I just switched to Fldigi 3.1 on the Mac. The problems I have run into
        > are a couple of frequency display errors on the waterfall.
        >
        > Config: Elecraft K2; using hamlib for rig control at 4800 bps; using
        > RTS on a second serial port to control PTT. All this appears to work
        > properly.
        >
        > 1. Selecting mode RTTYR causes the frequency display to be backwards,
        > i.e. higher audio frequency is lower RF frequency. Since RTTYR mode is
        > really USB, higher audio frequency should be higher RF frequency. USB
        > mode displays properly. [The K2 operates in LSB mode (BFO injection
        > above the filter passband) for RTTY mode and in USB mode for RTTYR.)
        >
        > 2. If I select "always show audio frequency" in the waterfall
        > configuration pane, the audio frequency display changes as the radio
        > is tuned, thus making the audio frequency references useless.
        >
        > So, I cannot work around item 1 by using an audio frequency display on
        > the waterfall.
        >
        > Is this a known problem?
        >
        > Thanks in advance.
        >
        > 73 de Brian, WB6RQN/J79BPL
        >


        Brian, there is no reason to use RTTYR. fldigi will decode perfectly
        regardless of sideband. I use LSB for RTTY take advantage of my 500Hz
        filter. So just select the desired sideband and leave the reverse alone.

        BTW you can "thank" me (I hope) for instigating this change.


        Ed W3NR
      • Brian Lloyd
        ... The reason for using the RTTY or RTTYR modes is to have the radio automatically reset the settings for the speech processor and mic gain.
        Message 3 of 4 , Feb 3, 2009
        • 0 Attachment
          On Tue, Feb 3, 2009 at 5:21 PM, Ed <autek@...> wrote:
          > Brian Lloyd wrote:
          >> I just switched to Fldigi 3.1 on the Mac. The problems I have run into
          >> are a couple of frequency display errors on the waterfall.
          >>
          >> Config: Elecraft K2; using hamlib for rig control at 4800 bps; using
          >> RTS on a second serial port to control PTT. All this appears to work
          >> properly.
          >>
          >> 1. Selecting mode RTTYR causes the frequency display to be backwards,
          >> i.e. higher audio frequency is lower RF frequency. Since RTTYR mode is
          >> really USB, higher audio frequency should be higher RF frequency. USB
          >> mode displays properly. [The K2 operates in LSB mode (BFO injection
          >> above the filter passband) for RTTY mode and in USB mode for RTTYR.)
          >>
          >> 2. If I select "always show audio frequency" in the waterfall
          >> configuration pane, the audio frequency display changes as the radio
          >> is tuned, thus making the audio frequency references useless.
          >>
          >> So, I cannot work around item 1 by using an audio frequency display on
          >> the waterfall.
          >>
          >> Is this a known problem?
          >>
          >> Thanks in advance.
          >>
          >> 73 de Brian, WB6RQN/J79BPL
          >>
          >
          >
          > Brian, there is no reason to use RTTYR. fldigi will decode perfectly
          > regardless of sideband. I use LSB for RTTY take advantage of my 500Hz
          > filter. So just select the desired sideband and leave the reverse alone.

          The reason for using the RTTY or RTTYR modes is to have the radio
          automatically reset the settings for the speech processor and mic
          gain. Compression/processing is normally enabled in the USB or LSB
          positions. When selecting RTTY or RTTYR the compressor/processor is
          turned off and mic gain set to the proper level for digital modes.
          Going into the menus to change the compressor/processor level is
          several button pushes plus changing settings using the VFO to select
          from various menu items. Since the rig is used in a school by
          elementary and middle school students, it is *<MUCH>* easier to just
          select the proper mode and have the rig reconfigure these settings
          properly. After all, that is what it was designed to do.

          So, the right answer is to use RTTY and RTTYR modes for digital modes
          on the K2. Since most RTTY is copied using LSB Elecraft has opted
          (correctly IMHO) to have the RTTY mode be LSB and the RTTYR mode be
          USB. This means that the frequency display in the waterfall is
          incorrect. The sense of RTTY and RTTYR in the K2 setup of Fldigi needs
          to be reversed.

          And then there is the fact that the AF frequency markings change when
          you change the radio's frequency. This behavior is just plain wrong.

          > BTW you can "thank" me (I hope) for instigating this change.

          I am sure you meant well but, no, I don't think I will thank you yet.
          This is a seriously annoying problem that has now made the station
          unusable for digital modes. Heck, I would be satisfied if the AF
          frequency in the waterfall worked but that doesn't even work properly.
          Unfortunately I erased the old version assuming (we know what that
          means) that 3.1 would work.

          I do need a fix.

          Thanks.

          73 de Brian, WB6RQN/J79BPL
        • w1hkj
          ... This appears to be a problem associated with the backend code in hamlib for the K2. I checked on both 1.2.7 and 1.2.8 (most recent) library souce for the
          Message 4 of 4 , Feb 3, 2009
          • 0 Attachment
            Brian Lloyd wrote:
            > On Tue, Feb 3, 2009 at 5:21 PM, Ed <autek@...> wrote:
            >
            >> Brian Lloyd wrote:
            >>
            >>> I just switched to Fldigi 3.1 on the Mac. The problems I have run into
            >>> are a couple of frequency display errors on the waterfall.
            >>>
            >>> Config: Elecraft K2; using hamlib for rig control at 4800 bps; using
            >>> RTS on a second serial port to control PTT. All this appears to work
            >>> properly.
            >>>
            >>> 1. Selecting mode RTTYR causes the frequency display to be backwards,
            >>> i.e. higher audio frequency is lower RF frequency. Since RTTYR mode is
            >>> really USB, higher audio frequency should be higher RF frequency. USB
            >>> mode displays properly. [The K2 operates in LSB mode (BFO injection
            >>> above the filter passband) for RTTY mode and in USB mode for RTTYR.)
            >>>
            This appears to be a problem associated with the backend code in hamlib
            for the K2. I checked on both 1.2.7 and 1.2.8 (most recent) library
            souce for the K2 and there is no listing for a RTTYR. That means that
            hamlib is still reporting the sideband as LSB for both RTTY and RTTYR.
            Perhaps the developer for the K2 backend might help us to sort this out.

            You can resolve your problem if you use the rigCAT control method for
            the rig. The posted K2.xml CAT definition file for the K2 was written
            by one of the fldigi developers, Leigh, WA5ZNU. It provides the proper
            sideband relationship for RTTY and RTTYR.

            If you really want to revert to 3.03 that is available on the Berlios
            archives for fldigi.

            http://developer.berlios.de/project/showfiles.php?group_id=9149

            This link is available also on the www.w1hkj.com page for the fldigi
            downloads.

            Hope this helps to resolve the RTTYR problem.

            >>> 2. If I select "always show audio frequency" in the waterfall
            >>> configuration pane, the audio frequency display changes as the radio
            >>> is tuned, thus making the audio frequency references useless.
            >>>
            Confirmed by the developers and test team. A fix will be applied to 3.11.

            73, Dave, w1hkj
          Your message has been successfully submitted and would be delivered to recipients shortly.