Loading ...
Sorry, an error occurred while loading the content.

Re: TS570D and hamlib problem.

Expand Messages
  • aalested
    ... Sorry, the link should be: http://www.urbakken.dk/fldigihamlibsetup.jpg 73 Erik OZ4KK
    Message 1 of 24 , Jul 10 12:12 AM
    • 0 Attachment
    • Thomas Beierlein
      Hi Erik, ... That one should be easy. Type IF; and you should get either a long string starting with IF014... (thats your frequency, modes and so on) or a
      Message 2 of 24 , Jul 10 1:27 AM
      • 0 Attachment
        Hi Erik,

        > > Hm. what kind of problems do you observe exactly and what
        > communication
        > > settings are you using?
        >
        > I will try to explain.
        > The /dev/ttyS0 is set to 4800 baud. The TS570D is set to 48-1
        > I have setup minicom to those values, and gets no errors.
        > But I'm not sure how to test the connection from the minicom to the
        > TS570D.

        That one should be easy. Type 'IF;' and you should get either a long string
        starting with 'IF014...' (thats your frequency, modes and so on) or a simple
        'E;' or '?;' indicating an communication error.

        But to be honest, configuring minicom is not as easy as it seems. Getting
        handshaking, baudrate,... right is always a hassle for me :-(.

        > Followed the Hamlib FAQ, I did this:
        > # rigctl -r /dev/ttyS0 -m 204
        > read_string: timedout without reading a character
        > read_string: timedout without reading a character

        > Then I read the man page, whereafter I set the baudrate also:
        >
        > # rigctl -vvvvv -r /dev/ttyS0 -s 4800 -m 204

        Right. As hamlib uses always the maximum allowed baud rate as default (that is
        57600 for the TS570D) you got the wrong rate on first try. (As a reminder, if
        you switch the baudrate in the rig (menu# 35) you must turn the radio off and
        on again to get the change happen).

        > Opened rig model 204, 'TS-570D'
        > Backend version: 0.6.1, Status: Stable
        >
        > Rig command: Frequency: 14086070
        >
        > Does the above indicate, that I have an ok working between the ttyS0 and
        > the TS570D ?

        Yes. That is perfectly fine. If you start rigctl without the -vvvvv you
        should be able to work and experiment with the rig. Try 'f' or 'F' for getting
        and setting frequency, '?' for a list of supported commands or '1' for a list
        of the supported features for the TS570D backend.

        > ALL commands has been done as ROOT. Is this ok, and intended ?.
        >

        It is one possibility. But rigctl should also work fine from your user account.
        If it doesn't there is something wrong about your permissions to use the serial
        port. Please test and come back if it doesn't.

        > Then I started up the fldigi, and did it from a terminal to be able to
        > see what's going on:
        >
        > fldigi
        > Transceiver not responding:
        >
        That is normal, as long as you have choosen hamlib but not configured fldigi
        accordingly.

        > Here I show a screenshot of what my setup looks in fldigi:
        > ...
        > Does that look ok ?

        Yes that looks perfectly ok. To be sure I just tested that setting at my side
        and it work perfectly. No problems. Did you start fldigi as user or also
        as root?


        By the way, what version of hamlib do you using?

        > > That would be 'rigctl -m xxx -r yyy -C post_write_delay=50'. Please
        > try which
        > > delay works best for you.
        >
        > Here is what I did, and there seems to be something not all ok:
        > (even the communication worked as shown above)
        >
        > # rigctl -m 204 -r /dev/ttyS0 s 4800 -C post_write_delay=50
        > read_string: timedout without reading a character
        > read_string: timedout without reading a character
        > read_string: timedout without reading a character

        Opps. It seems you forgot the '-' sign in front of the 's 4800'. So it worked
        again at 57600 Bd. (Murphy at work?)

        Can you please test again?

        > > (Btw, It would be good if you had filed a bug into the hamlib bug
        > database on
        > > sourceforge - http://sourceforge.net/tracker/?group_id=8305)
        >
        > How do I that Thomas ?.

        Go to that side with your browser. Select the link 'Bugs'. On next page you'll
        find a little 'submit new' link. There you can give a short summary (as a
        header line) and a detailed description of the problem.
        But let us sort things out first. Maybe there is no real problem here.


        73,

        de Tom DL1JBE.

        --
        "Do what is needful!"
        Ursula LeGuin: Earthsea
        --
      • aalested
        ... Hi Thomas. ... string ... a simple ... I set the baudrate to 57K6 now on the TS570D, and right, then rigctl just worked: # rigctl -r /dev/ttyS0 -m 204 Rig
        Message 3 of 24 , Jul 10 2:24 AM
        • 0 Attachment
          > Hi Erik,

          Hi Thomas.


          > That one should be easy. Type 'IF;' and you should get either a long
          string
          > starting with 'IF014...' (thats your frequency, modes and so on) or
          a simple
          > 'E;' or '?;' indicating an communication error.

          I set the baudrate to 57K6 now on the TS570D, and right, then rigctl
          just worked:

          # rigctl -r /dev/ttyS0 -m 204

          Rig command: IF
          Tx frequency:
          Rig command: if
          Tx frequency: 14086370

          Rig command: Frequency: 14086370

          Rig command:


          > But to be honest, configuring minicom is not as easy as it seems.
          Getting
          > handshaking, baudrate,... right is always a hassle for me :-(.

          You are quite right, but can be used. I did it those days I ran a MBO
          with my PTC-II.


          > > # rigctl -vvvvv -r /dev/ttyS0 -s 4800 -m 204
          >
          > Right. As hamlib uses always the maximum allowed baud rate as
          default (that is
          > 57600 for the TS570D) you got the wrong rate on first try. (As a
          reminder, if
          > you switch the baudrate in the rig (menu# 35) you must turn the
          radio off and
          > on again to get the change happen).

          Such I did, and it succeded :-)

          > > Opened rig model 204, 'TS-570D'
          > > Backend version: 0.6.1, Status: Stable
          > >
          > > Rig command: Frequency: 14086070
          > >
          > > Does the above indicate, that I have an ok working between the
          ttyS0 and
          > > the TS570D ?
          >
          > Yes. That is perfectly fine. If you start rigctl without the -vvvvv you
          > should be able to work and experiment with the rig. Try 'f' or 'F'
          for getting
          > and setting frequency, '?' for a list of supported commands or '1'
          for a list
          > of the supported features for the TS570D backend.

          Rig command: f
          Frequency: 14086370

          Rig command: F
          Frequency: 1421000

          Rig command: F
          Frequency: 14210000

          l is get level:
          Rig command: l
          Level: 2
          get_level: error = Invalid parameter

          But it works :-)


          > It is one possibility. But rigctl should also work fine from your
          user account.
          > If it doesn't there is something wrong about your permissions to use
          the serial
          > port. Please test and come back if it doesn't.

          The problem persists.


          > > fldigi
          > > Transceiver not responding:
          > >
          > That is normal, as long as you have choosen hamlib but not
          configured fldigi
          > accordingly.

          Now I set the baudrate to 57K6 in hamlib in fldigi, but I get the same
          "Transceiver not responding"

          Oh my, I got it. I'm sure this is due to the permission again for the
          /dev/ttyS0.
          I tried starting fldigi up as root, and did set the hamlib up here
          also, and it works :-)

          The Hamlib Controller now shows the qrg's, and changes them if I turn
          the dial on the TS570D.

          > > Here I show a screenshot of what my setup looks in fldigi:
          > > ...
          > > Does that look ok ?
          >
          > Yes that looks perfectly ok. To be sure I just tested that setting
          at my side
          > and it work perfectly. No problems. Did you start fldigi as user or
          also
          > as root?

          I started it as user.
          >
          > By the way, what version of hamlib do you using?

          I use this:
          hamlib-devel-1.2.7.1-3.4
          hamlib-1.2.7.1-3.4


          > > # rigctl -m 204 -r /dev/ttyS0 s 4800 -C post_write_delay=50
          > > read_string: timedout without reading a character
          > > read_string: timedout without reading a character
          > > read_string: timedout without reading a character
          >
          > Opps. It seems you forgot the '-' sign in front of the 's 4800'. So
          it worked
          > again at 57600 Bd. (Murphy at work?)

          Murphy is always working.

          > Can you please test again?

          I guess it's not necessary, as it works now (but as root)

          > > > (Btw, It would be good if you had filed a bug into the hamlib bug
          > > database on
          > > > sourceforge - http://sourceforge.net/tracker/?group_id=8305)
          > >
          > > How do I that Thomas ?.
          >
          > Go to that side with your browser. Select the link 'Bugs'. On next
          page you'll
          > find a little 'submit new' link. There you can give a short summary
          (as a
          > header line) and a detailed description of the problem.
          > But let us sort things out first. Maybe there is no real problem here.

          I don't think it's necessary now, as it was Murphy and the famous
          error 40 too :-)


          Erik OZ4KK
        • Thomas Beierlein
          Hi Erik, glad you get communication working. ... You have to state which level you want to get, e.g. RFPOWER or MICGAIN. See the output of command 1 and then
          Message 4 of 24 , Jul 10 3:51 AM
          • 0 Attachment
            Hi Erik,

            glad you get communication working.

            > l is get level:
            > Rig command: l
            > Level: 2
            > get_level: error = Invalid parameter

            You have to state which level you want to get, e.g. RFPOWER or MICGAIN. See
            the output of command '1' and then look which 'Set level' or 'Get level' is
            supported. Same for functions 'u' or 'U'.

            > Now I set the baudrate to 57K6 in hamlib in fldigi, but I get the same
            > "Transceiver not responding"
            >
            > Oh my, I got it. I'm sure this is due to the permission again for the
            > /dev/ttyS0.

            Yep. Exactly that seems to be the problem.

            > I tried starting fldigi up as root, and did set the hamlib up here
            > also, and it works :-)

            So, fine. Now you have to figure out how to set your permissions so that you
            are allowed to access /dev/ttyS0 as user. You should *not* use fldigi as root
            on the long run.

            Normally it is handled by adding your user account to some special group
            (mostly 'uucp' or 'tty'), but it depends on the linux distribution you use.

            As a first start you can look at the group /dev/ttyS0 belongs to. At my side
            it belongs to uucp, so I need to be in that group too.

            > ls -l /dev/ttyS0
            crw-rw---- 1 root uucp 4, 64 Jul 10 12:35 /dev/ttyS0

            Here on Gentoo I can run

            usermod -G list_of_groups_to_belong user

            as root to change my group membership. Have a look into the user administration
            for your system.

            > > By the way, what version of hamlib do you using?
            >
            > I use this:
            > hamlib-devel-1.2.7.1-3.4
            > hamlib-1.2.7.1-3.4

            Ok, that is the actual one.


            > > Go to that side with your browser. Select the link 'Bugs'. On next
            > page you'll
            > > find a little 'submit new' link. There you can give a short summary
            > (as a
            > > header line) and a detailed description of the problem.
            > > But let us sort things out first. Maybe there is no real problem here.
            >
            > I don't think it's necessary now, as it was Murphy and the famous
            > error 40 too :-)

            Right. Just remeber it for any problems in future. Or give me a direct call, as
            I am interested in feedback for the rig.

            Glad to help you.

            Vy 73 and lots of fun with fldigi and hamlib,

            Tom DL1JBE.

            --
            "Do what is needful!"
            Ursula LeGuin: Earthsea
            --
          • Nate Bargmann
            Glad to see a resolution on this. Good luck, Erik and thanks, Tom. 73, de Nate -- The optimist proclaims that we live in the best of all possible worlds.
            Message 5 of 24 , Jul 10 5:00 AM
            • 0 Attachment
              Glad to see a resolution on this. Good luck, Erik and thanks, Tom.

              73, de Nate >>

              --

              "The optimist proclaims that we live in the best of all
              possible worlds. The pessimist fears this is true."

              Ham radio, Linux, bikes, and more: http://n0nb.us/index.html
            • aalested
              ... Hi Tom. I m very glad too, and I m very greatfull, that you came here to help me to get it to work. ... MICGAIN. See ... level is ... Ok, will have a look
              Message 6 of 24 , Jul 10 5:30 AM
              • 0 Attachment
                > Hi Erik,
                >
                > glad you get communication working.

                Hi Tom.

                I'm very glad too, and I'm very greatfull, that you came here to help
                me to get it to work.

                > > l is get level:
                > > Rig command: l
                > > Level: 2
                > > get_level: error = Invalid parameter
                >
                > You have to state which level you want to get, e.g. RFPOWER or
                MICGAIN. See
                > the output of command '1' and then look which 'Set level' or 'Get
                level' is
                > supported. Same for functions 'u' or 'U'.

                Ok, will have a look there, and for all the interesting things around
                the project.

                > > Now I set the baudrate to 57K6 in hamlib in fldigi, but I get the same
                > > "Transceiver not responding"
                > >
                > > Oh my, I got it. I'm sure this is due to the permission again for the
                > > /dev/ttyS0.
                >
                > Yep. Exactly that seems to be the problem.

                It was :-)

                > > I tried starting fldigi up as root, and did set the hamlib up here
                > > also, and it works :-)
                >
                > So, fine. Now you have to figure out how to set your permissions so
                that you
                > are allowed to access /dev/ttyS0 as user. You should *not* use
                fldigi as root
                > on the long run.

                No I won't, but was a great help in getting it to work.

                > Normally it is handled by adding your user account to some special group
                > (mostly 'uucp' or 'tty'), but it depends on the linux distribution
                you use.

                I use openSUSE 11.0, and here the tool Yast2 can do it. I now have to
                find out how.

                > As a first start you can look at the group /dev/ttyS0 belongs to. At
                my side
                > it belongs to uucp, so I need to be in that group too.

                It belongs to uucp like yours do:

                ls -l /dev/ttyS0
                crw-rw---- 1 root uucp 4, 64 Jul 10 14:22 /dev/ttyS0
                man man

                > > ls -l /dev/ttyS0
                > crw-rw---- 1 root uucp 4, 64 Jul 10 12:35 /dev/ttyS0
                >
                > Here on Gentoo I can run
                >
                > usermod -G list_of_groups_to_belong user
                >
                > as root to change my group membership. Have a look into the user
                administration
                > for your system.

                I do have the usermod too:

                usermod -G
                usermod: option requires an argument -- 'G'
                Try `usermod --help' or `usermod --usage' for more information.

                But this doesn't show the gorups.

                > > > By the way, what version of hamlib do you using?
                > >
                > > I use this:
                > > hamlib-devel-1.2.7.1-3.4
                > > hamlib-1.2.7.1-3.4
                >
                > Ok, that is the actual one.
                >
                Good.
                > > > Go to that side with your browser. Select the link 'Bugs'. On next
                > > page you'll
                > > > find a little 'submit new' link. There you can give a short summary
                > > (as a
                > > > header line) and a detailed description of the problem.
                > > > But let us sort things out first. Maybe there is no real problem
                here.
                > >
                > > I don't think it's necessary now, as it was Murphy and the famous
                > > error 40 too :-)
                >
                > Right. Just remeber it for any problems in future. Or give me a
                direct call, as
                > I am interested in feedback for the rig.


                For sure I will Tom. I wait for your comments on the usermod here.
                Else I want to again thank you for your valuable help.
                > Glad to help you.

                I'm glad you would.

                > Vy 73 and lots of fun with fldigi and hamlib,
                >
                > Tom DL1JBE.
                >
                > --
                > "Do what is needful!"
                > Ursula LeGuin: Earthsea
                > --
                >
                Erik Oz4kk
              • aalested
                ... I m very glad too Nate. Also for your help, and kindness. ... 73 Erik OZ4KK
                Message 7 of 24 , Jul 10 5:32 AM
                • 0 Attachment
                  > Glad to see a resolution on this. Good luck, Erik and thanks, Tom.
                  >
                  > 73, de Nate >>

                  I'm very glad too Nate. Also for your help, and kindness.

                  > --
                  >
                  > "The optimist proclaims that we live in the best of all
                  > possible worlds. The pessimist fears this is true."
                  >
                  > Ham radio, Linux, bikes, and more: http://n0nb.us/index.html
                  >
                  73 Erik OZ4KK
                • Thomas Beierlein
                  Hi Erik, ... As I have an OpenSuSE too (10.2) I can help: - Start Yast (Graphical Mode) - choose Security and Users in left tab - choose User Management -
                  Message 8 of 24 , Jul 10 5:58 AM
                  • 0 Attachment
                    Hi Erik,

                    > > Normally it is handled by adding your user account to some special group
                    > > (mostly 'uucp' or 'tty'), but it depends on the linux distribution
                    > you use.
                    >
                    > I use openSUSE 11.0, and here the tool Yast2 can do it. I now have to
                    > find out how.
                    >
                    As I have an OpenSuSE too (10.2) I can help:

                    - Start Yast (Graphical Mode)
                    - choose 'Security and Users' in left tab
                    - choose 'User Management'
                    - select your account and click on 'Edit'-button below
                    - choose second tab for 'Details'
                    - scroll down the group list on the right side and select uucp
                    - 'Accept' should do it finally


                    If you want to do it in textmode, see bleow.

                    > I do have the usermod too:
                    >
                    > usermod -G
                    > usermod: option requires an argument -- 'G'

                    Opps. My mistake. Please use the 'groups' command to get the list of groups
                    you are in, e.g.

                    > groups my_account
                    users dialout video wheel

                    Than you can use 'usermod'

                    > usermod -G users,dialout,video,wheel,uucp my_account

                    afterwards you will get

                    > groups my_account
                    users dialout uucp video wheel

                    Be careful to use commas between the groups and no whitespaces.

                    73,

                    de Tom DL1JBE.

                    --
                    "Do what is needful!"
                    Ursula LeGuin: Earthsea
                    --
                  • aalested
                    Hi Tom. ... Ok, but I have fixed it. What I forgot was to log in log out. I ran SuSEconfig, and it didn t work. Then I wondered why it was necessary to reboot.
                    Message 9 of 24 , Jul 10 6:57 AM
                    • 0 Attachment
                      Hi Tom.

                      > As I have an OpenSuSE too (10.2) I can help:
                      >
                      > - Start Yast (Graphical Mode)
                      > - choose 'Security and Users' in left tab
                      > - choose 'User Management'
                      > - select your account and click on 'Edit'-button below
                      > - choose second tab for 'Details'
                      > - scroll down the group list on the right side and select uucp
                      > - 'Accept' should do it finally

                      Ok, but I have fixed it. What I forgot was to log in log out. I ran
                      SuSEconfig, and it didn't work. Then I wondered why it was necessary
                      to reboot. And it wasn't, but after it worked as user too :-)

                      >
                      > If you want to do it in textmode, see bleow.
                      >
                      > > I do have the usermod too:
                      > >
                      > > usermod -G
                      > > usermod: option requires an argument -- 'G'
                      >
                      > Opps. My mistake. Please use the 'groups' command to get the list of
                      groups
                      > you are in, e.g.
                      >
                      > > groups my_account
                      > users dialout video wheel

                      Yes, that also works here:

                      erikja@erikja:~> groups
                      users dialout uucp video

                      :-)


                      > Than you can use 'usermod'
                      >
                      > > usermod -G users,dialout,video,wheel,uucp my_account

                      That I'll save.

                      > afterwards you will get
                      >
                      > > groups my_account
                      > users dialout uucp video wheel
                      >
                      > Be careful to use commas between the groups and no whitespaces.

                      Tnx for the advice.

                      > 73,
                      >
                      > de Tom DL1JBE.
                      >
                      > --
                      > "Do what is needful!"
                      > Ursula LeGuin: Earthsea
                      > --
                      >
                      73,
                      Erik OZ4KK
                    Your message has been successfully submitted and would be delivered to recipients shortly.