Loading ...
Sorry, an error occurred while loading the content.

TS570D and hamlib problem.

Expand Messages
  • aalested
    Hi. I have installed fldigi here on my openSUSE 11.0 box. Installed is also fldigi. I can get linked to the TS570D using rigctl. But if I start up fldigi, and
    Message 1 of 24 , Jul 9, 2008
    • 0 Attachment
      Hi.

      I have installed fldigi here on my openSUSE 11.0 box.

      Installed is also fldigi.

      I can get linked to the TS570D using rigctl.

      But if I start up fldigi, and want to use hamlib for cat -rigctl- it
      cannot get i contact with the TS570D.

      On the ham-linux mailinglist, I got an reply, that another ham have
      had same problem.
      He found that the value of 30ms set in the ts570.c file was too fast
      for his TS2000.

      He changed it to 50ms whereafter it worked.

      That means he had to compile make make install.

      Here I use rpm's for the install, and as such it's a bit difficult to
      handle the same.

      What can I do ?.

      TIA

      73,
      Erik, OZ4KK
    • aalested
      ... Hi again. I did install the hamlib from a tarball now. ... ./rigctl: error while loading shared libraries: libhamlib.so.2: cannot open shared object file:
      Message 2 of 24 , Jul 9, 2008
      • 0 Attachment
        --- In linuxham@yahoogroups.com, "aalested" <oz4kk@...> wrote:
        >
        > Hi.
        >
        > I have installed fldigi here on my openSUSE 11.0 box.
        >
        > Installed is also fldigi.
        >
        > I can get linked to the TS570D using rigctl.
        >
        > But if I start up fldigi, and want to use hamlib for cat -rigctl- it
        > cannot get i contact with the TS570D.
        >
        > On the ham-linux mailinglist, I got an reply, that another ham have
        > had same problem.
        > He found that the value of 30ms set in the ts570.c file was too fast
        > for his TS2000.
        >
        > He changed it to 50ms whereafter it worked.
        >
        > That means he had to compile make make install.
        >
        > Here I use rpm's for the install, and as such it's a bit difficult to
        > handle the same.
        >
        > What can I do ?.
        >
        > TIA
        >
        > 73,
        > Erik, OZ4KK
        >

        Hi again.

        I did install the hamlib from a tarball now.
        If I want to start rigctl, I get this:

        > ./rigctl
        ./rigctl: error while loading shared libraries: libhamlib.so.2: cannot
        open shared object file: No such file or directory

        How do I manage that ?

        73,
        Erik, OZ4KK
      • aalested
        ... Here I found the libhamlib.so.2: find / -name libhamlib.so.2 /opt/hamlib-1.2.7.1/src/.libs/libhamlib.so.2 /usr/local/lib/libhamlib.so.2 Am I missing a
        Message 3 of 24 , Jul 9, 2008
        • 0 Attachment
          > Hi again.
          >
          > I did install the hamlib from a tarball now.
          > If I want to start rigctl, I get this:
          >
          > > ./rigctl
          > ./rigctl: error while loading shared libraries: libhamlib.so.2: cannot
          > open shared object file: No such file or directory
          >
          > How do I manage that ?

          Here I found the libhamlib.so.2:

          find / -name libhamlib.so.2
          /opt/hamlib-1.2.7.1/src/.libs/libhamlib.so.2
          /usr/local/lib/libhamlib.so.2

          Am I missing a symlink or what's the reason ?

          73,
          Erik, OZ4KK
        • roger g6ckr
          I have had hamlib and rigctrl working with mt TS570.one thing to watch is if you are set to 4800 you have 2 choices the wrong one will fail. just a quick
          Message 4 of 24 , Jul 9, 2008
          • 0 Attachment
            I have had hamlib and rigctrl working with mt TS570.one thing to watch
            is if you are set to 4800 you have 2 choices the wrong one will fail.
            just a quick thought.
            73 roger G6CKR
            On Wed, 2008-07-09 at 14:48 +0000, aalested wrote:
            > Hi.
            >
            > I have installed fldigi here on my openSUSE 11.0 box.
            >
            > Installed is also fldigi.
            >
            > I can get linked to the TS570D using rigctl.
            >
            > But if I start up fldigi, and want to use hamlib for cat -rigctl- it
            > cannot get i contact with the TS570D.
            >
            > On the ham-linux mailinglist, I got an reply, that another ham have
            > had same problem.
            > He found that the value of 30ms set in the ts570.c file was too fast
            > for his TS2000.
            >
            > He changed it to 50ms whereafter it worked.
            >
            > That means he had to compile make make install.
            >
            > Here I use rpm's for the install, and as such it's a bit difficult to
            > handle the same.
            >
            > What can I do ?.
            >
            > TIA
            >
            > 73,
            > Erik, OZ4KK
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
          • aalested
            ... Yes I know, There is 48-1 and 48-2. Mine is set to 48-1, adn as such the rig.xml is set with regard to that: /dev/ttyS0
            Message 5 of 24 , Jul 9, 2008
            • 0 Attachment
              --- In linuxham@yahoogroups.com, roger g6ckr <radio@...> wrote:
              >
              > I have had hamlib and rigctrl working with mt TS570.one thing to watch
              > is if you are set to 4800 you have 2 choices the wrong one will fail.
              > just a quick thought.
              > 73 roger G6CKR

              Yes I know, There is 48-1 and 48-2. Mine is set to 48-1, adn as such
              the rig.xml is set with regard to that:

              <PORT>
              <DEVICE>/dev/ttyS0</DEVICE>
              <BAUD>4800</BAUD>
              <STOPBITS>1</STOPBITS>
              <ECHO>false</ECHO>
              <RETRIES>4</RETRIES>
              <TIMEOUT>200</TIMEOUT>
              <WAIT>0</WAIT>
              <DTRINIT>-12</DTRINIT>
              <DTRPTT>false</DTRPTT>
              <RTSINIT>-12</RTSINIT>
              <RTSPTT>false</RTSPTT>
              <RTSCTS>true</RTSCTS>
              </PORT>

              But maybe it has somehting to do with a handshake ?.
              What di you have then ?

              73,
              Erik, OZ4KK
            • roger g6ckr
              ... /dev/ttyS0 4800 1 false 4 200 0
              Message 6 of 24 , Jul 9, 2008
              • 0 Attachment
                On Wed, 2008-07-09 at 16:42 +0000, aalested wrote:
                > --- In linuxham@yahoogroups.com, roger g6ckr <radio@...> wrote:
                > >
                > > I have had hamlib and rigctrl working with mt TS570.one thing to watch
                > > is if you are set to 4800 you have 2 choices the wrong one will fail.
                > > just a quick thought.
                > > 73 roger G6CKR
                >
                > Yes I know, There is 48-1 and 48-2. Mine is set to 48-1, adn as such
                > the rig.xml is set with regard to that:
                >
                > <PORT>
                > <DEVICE>/dev/ttyS0</DEVICE>
                > <BAUD>4800</BAUD>
                > <STOPBITS>1</STOPBITS>
                > <ECHO>false</ECHO>
                > <RETRIES>4</RETRIES>
                > <TIMEOUT>200</TIMEOUT>
                > <WAIT>0</WAIT>
                > <DTRINIT>-12</DTRINIT>
                > <DTRPTT>false</DTRPTT>
                > <RTSINIT>-12</RTSINIT>
                > <RTSPTT>false</RTSPTT>
                > <RTSCTS>true</RTSCTS>
                > </PORT>
                <PORT>
                <DEVICE>/dev/ttyS0</DEVICE>
                <BAUD>4800</BAUD>
                <STOPBITS>1</STOPBITS>
                <ECHO>false</ECHO>
                <RETRIES>4</RETRIES>
                <TIMEOUT>200</TIMEOUT>
                <WAIT>0</WAIT>
                <DTRINIT>-12</DTRINIT>
                <DTRPTT>false</DTRPTT>
                <RTSINIT>-12</RTSINIT>
                <RTSPTT>false</RTSPTT>
                <RTSCTS>true</RTSCTS>
                </PORT>

                looks the same to me.
                I found I needed a full lead but I can't remember if that was for both
                or just one.
                I also seem to recall that if the radio is set too low in frequency it
                can cause a problem. Below topband I think.
                I hope that helps.
                73 Roger


                > But maybe it has somehting to do with a handshake ?.
                > What di you have then ?
                >
                > 73,
                > Erik, OZ4KK
                >
                >
                > ------------------------------------
                >
                > Yahoo! Groups Links
                >
                >
                >
              • aalested
                ... Tnx Roger. What do you mean by too low in frequency ?. For instance 14.080.23 ?. What do you mean by Below topband ? 73 Erik PSE have a look here:
                Message 7 of 24 , Jul 9, 2008
                • 0 Attachment
                  > looks the same to me.
                  > I found I needed a full lead but I can't remember if that was for both
                  > or just one.
                  > I also seem to recall that if the radio is set too low in frequency it
                  > can cause a problem. Below topband I think.
                  > I hope that helps.
                  > 73 Roger

                  Tnx Roger.

                  What do you mean by "too low in frequency" ?. For instance 14.080.23 ?.
                  What do you mean by "Below topband" ?

                  73 Erik

                  PSE have a look here:

                  http://www.urbakken.dk/cat.jpg

                  It shows my cat setup.
                • roger g6ckr
                  ... lower than 1.8 Mhz The name top band comes form the the wavelength in metres was the more normal way to designate a band where it would have been the
                  Message 8 of 24 , Jul 9, 2008
                  • 0 Attachment
                    On Wed, 2008-07-09 at 17:35 +0000, aalested wrote:
                    > > looks the same to me.
                    > > I found I needed a full lead but I can't remember if that was for both
                    > > or just one.
                    > > I also seem to recall that if the radio is set too low in frequency it
                    > > can cause a problem. Below topband I think.
                    > > I hope that helps.
                    > > 73 Roger
                    >
                    > Tnx Roger.
                    >
                    > What do you mean by "too low in frequency" ?. For instance 14.080.23 ?.
                    > What do you mean by "Below topband" ?
                    >
                    > 73 Erik
                    lower than 1.8 Mhz
                    The name top band comes form the the wavelength in metres was the more
                    normal way to designate a band where it would have been the highest
                    number. At least I think that's where the name comes from.
                    I found out when I had been calibrating using a 60 KHz station.
                    > PSE have a look here:
                    >
                    > http://www.urbakken.dk/cat.jpg
                    >
                    > It shows my cat setup.
                    >
                    >
                    > ------------------------------------
                    >
                    > Yahoo! Groups Links
                    >
                    >
                    >
                  • Bob Nielsen
                    ... It looks like /usr/local/lib is not in your library path. You need to edit /etc/ld.so.conf to add that library and run ldconfig as root. Bob, N7XY
                    Message 9 of 24 , Jul 9, 2008
                    • 0 Attachment
                      On Jul 9, 2008, at 8:08 AM, aalested wrote:

                      > > Hi again.
                      > >
                      > > I did install the hamlib from a tarball now.
                      > > If I want to start rigctl, I get this:
                      > >
                      > > > ./rigctl
                      > > ./rigctl: error while loading shared libraries: libhamlib.so.2:
                      > cannot
                      > > open shared object file: No such file or directory
                      > >
                      > > How do I manage that ?
                      >
                      > Here I found the libhamlib.so.2:
                      >
                      > find / -name libhamlib.so.2
                      > /opt/hamlib-1.2.7.1/src/.libs/libhamlib.so.2
                      > /usr/local/lib/libhamlib.so.2
                      >
                      > Am I missing a symlink or what's the reason ?
                      >
                      >

                      It looks like /usr/local/lib is not in your library path. You need
                      to edit /etc/ld.so.conf to add that library and run ldconfig as root.

                      Bob, N7XY
                    • aalested
                      ... Bob, tnx for the reply. I have this: /usr/X11R6/lib/Xaw3d /usr/X11R6/lib /usr/lib/Xaw3d /usr/i386-suse-linux/lib /usr/local/lib /opt/kde3/lib include
                      Message 10 of 24 , Jul 9, 2008
                      • 0 Attachment
                        > It looks like /usr/local/lib is not in your library path. You need
                        > to edit /etc/ld.so.conf to add that library and run ldconfig as root.


                        Bob, tnx for the reply.

                        I have this:

                        /usr/X11R6/lib/Xaw3d
                        /usr/X11R6/lib
                        /usr/lib/Xaw3d
                        /usr/i386-suse-linux/lib
                        /usr/local/lib
                        /opt/kde3/lib
                        include /etc/ld.so.conf.d/*.conf

                        in /etc/ld.so.conf

                        But I have changed a couple of times between the tarball installs and
                        the rpm's. maybe I have confused the system.
                        But I did every time I changed from the tarballs to the rpm's a make
                        uninstall, that I think should do the job, and I also ran an updatedb

                        73, Erik
                      • Jose A. Amador
                        ... Usually I do # ldconfig -v ldconfigured Then, in ldconfigured are all the paths and libraries that ldconfig knows . Jose, CO2JA
                        Message 11 of 24 , Jul 9, 2008
                        • 0 Attachment
                          Bob Nielsen wrote:
                          > On Jul 9, 2008, at 8:08 AM, aalested wrote:
                          >
                          >>> Hi again.
                          >>>
                          >>> I did install the hamlib from a tarball now.
                          >>> If I want to start rigctl, I get this:
                          >>>
                          >>>> ./rigctl
                          >>> ./rigctl: error while loading shared libraries: libhamlib.so.2:
                          >> cannot
                          >>> open shared object file: No such file or directory
                          >>>
                          >>> How do I manage that ?
                          >> Here I found the libhamlib.so.2:
                          >>
                          >> find / -name libhamlib.so.2
                          >> /opt/hamlib-1.2.7.1/src/.libs/libhamlib.so.2
                          >> /usr/local/lib/libhamlib.so.2
                          >>
                          >> Am I missing a symlink or what's the reason ?
                          >>
                          >>
                          >
                          > It looks like /usr/local/lib is not in your library path. You need
                          > to edit /etc/ld.so.conf to add that library and run ldconfig as root.
                          >
                          > Bob, N7XY

                          Usually I do

                          # ldconfig -v > ldconfigured

                          Then, in "ldconfigured" are all the paths and libraries that ldconfig
                          "knows".

                          Jose, CO2JA
                        • aalested
                          ... Tnx Jose for your reply. I got this, and it s not ok in my opinon ? # ldconfig -v ldconfigured ldconfig: Can t stat /usr/X11R6/lib/Xaw3d: No such file or
                          Message 12 of 24 , Jul 9, 2008
                          • 0 Attachment
                            > Usually I do
                            >
                            > # ldconfig -v > ldconfigured
                            >
                            > Then, in "ldconfigured" are all the paths and libraries that ldconfig
                            > "knows".
                            >
                            > Jose, CO2JA
                            >
                            Tnx Jose for your reply.

                            I got this, and it's not ok in my opinon ?

                            # ldconfig -v > ldconfigured
                            ldconfig: Can't stat /usr/X11R6/lib/Xaw3d: No such file or directory
                            ldconfig: Can't stat /usr/lib/Xaw3d: No such file or directory
                            ldconfig: Can't stat /usr/i386-suse-linux/lib: No such file or directory
                            ldconfig: Cannot stat /opt/kde3/lib/libgmcop.so: No such file or directory
                            ldconfig: Cannot stat /usr/lib/libGraphicsMagickWand.so: No such file
                            or directory

                            Erik, OZ4KK
                          • aalested
                            ... Oh Jose, now I can see, what you wanted to tell me. I found the file, and now I have to look at at it. Erik, OZ4KK
                            Message 13 of 24 , Jul 9, 2008
                            • 0 Attachment
                              > Usually I do
                              >
                              > # ldconfig -v > ldconfigured
                              >
                              > Then, in "ldconfigured" are all the paths and libraries that ldconfig
                              > "knows".
                              >
                              > Jose, CO2JA
                              >
                              Oh Jose, now I can see, what you wanted to tell me.
                              I found the file, and now I have to look at at it.

                              Erik, OZ4KK
                            • Thomas Beierlein
                              Hi Erik and the list, let me step in with some ideas to solve your problem. Let me first say that in the moment I am the maintainer of the TS570 backend in
                              Message 14 of 24 , Jul 9, 2008
                              • 0 Attachment
                                Hi Erik and the list,

                                let me step in with some ideas to solve your problem.
                                Let me first say that in the moment I am the maintainer of the TS570 backend
                                in hamlib.

                                On Wed, Jul 09, 2008 at 02:48:05PM -0000, aalested wrote:
                                > I can get linked to the TS570D using rigctl.
                                >
                                > But if I start up fldigi, and want to use hamlib for cat -rigctl- it
                                > cannot get i contact with the TS570D.

                                Hm. what kind of problems do you observe exactly and what communication
                                settings are you using? I am using hamlib together with fldigi for the TS570D
                                via an USB<->serial adapter working on 57600 Bd. It is only sometimes that I
                                miss some responses, but otherwise it works like a i charme.

                                > On the ham-linux mailinglist, I got an reply, that another ham have
                                > had same problem.
                                > He found that the value of 30ms set in the ts570.c file was too fast
                                > for his TS2000.

                                Well, that was spoken for the TS2000, which is a totally other rig. But you are
                                right, there are some problems in the internal command processing in kenwood
                                rigs - especially if you are tuning the frequency at the time the command comes
                                in. Seems they use the same microcontroller for both jobs.

                                > He changed it to 50ms whereafter it worked.

                                You can test the different communication settings without having to recompile
                                hamlib. rigctl has an command line option '-C' after which you can set the
                                configuration parameter.

                                That would be 'rigctl -m xxx -r yyy -C post_write_delay=50'. Please try which
                                delay works best for you. Keep in mind that greater values gives better results
                                but slows down the overall communication and the responsivness of fldigi.

                                Please give some feedback (best for different baud rates) so that I can correct
                                the value in the source files.

                                (Btw, It would be good if you had filed a bug into the hamlib bug database on
                                sourceforge - http://sourceforge.net/tracker/?group_id=8305)

                                I will have a look if we can set the post_write_delay also via the library
                                and if I find a way to config fldigi properly. If not I will discuss the
                                problem in the fldigi developer list.

                                Please keep me informed how it is going. Getting feedback is an important
                                precondition to make the backend better.

                                73,
                                de Tom DL1JBE.


                                --
                                "Do what is needful!"
                                Ursula LeGuin: Earthsea
                                --
                              • aalested
                                ... Hi Thomas. many thanks for the reply. ... backend ... Indeed very nice, as you have the experience then. ... communication ... TS570D ... that I ... I will
                                Message 15 of 24 , Jul 10, 2008
                                • 0 Attachment
                                  --- In linuxham@yahoogroups.com, Thomas Beierlein <tb@...> wrote:
                                  >
                                  > Hi Erik and the list,

                                  Hi Thomas. many thanks for the reply.

                                  > let me step in with some ideas to solve your problem.
                                  > Let me first say that in the moment I am the maintainer of the TS570
                                  backend
                                  > in hamlib.

                                  Indeed very nice, as you have the experience then.

                                  > On Wed, Jul 09, 2008 at 02:48:05PM -0000, aalested wrote:
                                  > > I can get linked to the TS570D using rigctl.
                                  > >
                                  > > But if I start up fldigi, and want to use hamlib for cat -rigctl- it
                                  > > cannot get i contact with the TS570D.
                                  >
                                  > Hm. what kind of problems do you observe exactly and what
                                  communication
                                  > settings are you using? I am using hamlib together with fldigi for the
                                  TS570D
                                  > via an USB<->serial adapter working on 57600 Bd. It is only sometimes
                                  that I
                                  > miss some responses, but otherwise it works like a i charme.

                                  I will try to explain.
                                  The /dev/ttyS0 is set to 4800 baud. The TS570D is set to 48-1
                                  I have setup minicom to those values, and gets no errors.
                                  But I'm not sure how to test the connection from the minicom to the
                                  TS570D.
                                  Followed the Hamlib FAQ, I did this:
                                  # rigctl -r /dev/ttyS0 -m 204
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character

                                  Then I tried this -also from the FAQ-:

                                  # rigctl -vvvvv -r /dev/ttyS0 -m 204
                                  rigctl, Hamlib version 1.2.7.1
                                  Report bugs to <hamlib-developer@...>

                                  rig:rig_init called
                                  rig: loading backend kenwood
                                  kenwood: _init called
                                  rig_register (213)
                                  rig_register (201)
                                  rig_register (225)
                                  rig_register (203)
                                  rig_register (204)
                                  rig_register (216)
                                  rig_register (224)
                                  rig_register (205)
                                  rig_register (207)
                                  rig_register (209)
                                  rig_register (210)
                                  rig_register (222)
                                  rig_register (214)
                                  rig_register (221)
                                  rig_register (202)
                                  rig_register (211)
                                  rig_register (206)
                                  rig_register (208)
                                  rig_register (215)
                                  rig_register (226)
                                  rig_register (217)
                                  rig_register (220)
                                  rig_register (223)
                                  rig_register (227)
                                  rig_register (228)
                                  rig:rig_open called
                                  TX 3 bytes
                                  0000 49 46 3b IF;
                                  read_string: timedout without reading a character
                                  TX 3 bytes
                                  0000 49 46 3b IF;
                                  read_string: timedout without reading a character
                                  TX 3 bytes
                                  0000 49 46 3b IF;
                                  read_string: timedout without reading a character
                                  TX 3 bytes
                                  0000 49 46 3b IF;
                                  read_string: timedout without reading a character
                                  Opened rig model 204, 'TS-570D'
                                  Backend version: 0.6.1, Status: Stable

                                  Then I read the man page, whereafter I set the baudrate also:

                                  # rigctl -vvvvv -r /dev/ttyS0 -s 4800 -m 204
                                  rigctl, Hamlib version 1.2.7.1
                                  Report bugs to <hamlib-developer@...>

                                  rig:rig_init called
                                  rig: loading backend kenwood
                                  kenwood: _init called
                                  rig_register (213)
                                  rig_register (201)
                                  rig_register (225)
                                  rig_register (203)
                                  rig_register (204)
                                  rig_register (216)
                                  rig_register (224)
                                  rig_register (205)
                                  rig_register (207)
                                  rig_register (209)
                                  rig_register (210)
                                  rig_register (222)
                                  rig_register (214)
                                  rig_register (221)
                                  rig_register (202)
                                  rig_register (211)
                                  rig_register (206)
                                  rig_register (208)
                                  rig_register (215)
                                  rig_register (226)
                                  rig_register (217)
                                  rig_register (220)
                                  rig_register (223)
                                  rig_register (227)
                                  rig_register (228)
                                  rig:rig_open called
                                  TX 3 bytes
                                  0000 49 46 3b IF;
                                  RX 2 characters
                                  0000 3f 3b ?;
                                  kenwood_transaction: Unknown command 'IF;'
                                  Opened rig model 204, 'TS-570D'
                                  Backend version: 0.6.1, Status: Stable

                                  if command gave this:

                                  Rig command: if
                                  TX 3 bytes
                                  0000 49 46 3b IF;
                                  RX 38 characters
                                  0000 49 46 30 30 30 31 34 30 38 36 30 37 30 20 20 20
                                  IF00014086070
                                  0010 20 20 20 30 30 39 30 30 30 20 39 30 30 31 30 30
                                  009000 900100
                                  0020 30 30 30 38 20 3b 0008 ;
                                  Tx frequency: 14086070

                                  TX 3 bytes
                                  0000 49 46 3b IF;
                                  RX 38 characters
                                  0000 49 46 30 30 30 31 34 30 38 36 30 37 30 20 20 20
                                  IF00014086070
                                  0010 20 20 20 30 30 39 30 30 30 20 39 30 30 31 30 30
                                  009000 900100
                                  0020 30 30 30 38 20 3b 0008 ;
                                  Rig command: Frequency: 14086070

                                  So far so good.

                                  Does the above indicate, that I have an ok working between the ttyS0 and
                                  the TS570D ?

                                  ALL commands has been done as ROOT. Is this ok, and intended ?.

                                  Then I started up the fldigi, and did it from a terminal to be able to
                                  see what's going on:

                                  fldigi
                                  Transceiver not responding:

                                  Here I show a screenshot of what my setup looks in fldigi:

                                  http://www.urbakken.dk/fldigihamlib.jpg

                                  Does that look ok ?

                                  > > On the ham-linux mailinglist, I got an reply, that another ham have
                                  > > had same problem.
                                  > > He found that the value of 30ms set in the ts570.c file was too fast
                                  > > for his TS2000.
                                  >
                                  > Well, that was spoken for the TS2000, which is a totally other rig.
                                  But you are
                                  > right, there are some problems in the internal command processing in
                                  kenwood
                                  > rigs - especially if you are tuning the frequency at the time the
                                  command comes
                                  > in. Seems they use the same microcontroller for both jobs.

                                  I see, yes that can cause interfering.

                                  > > He changed it to 50ms whereafter it worked.
                                  >
                                  > You can test the different communication settings without having to
                                  recompile
                                  > hamlib. rigctl has an command line option '-C' after which you can set
                                  the
                                  > configuration parameter.


                                  > That would be 'rigctl -m xxx -r yyy -C post_write_delay=50'. Please
                                  try which
                                  > delay works best for you. Keep in mind that greater values gives
                                  better results
                                  > but slows down the overall communication and the responsivness of
                                  fldigi.

                                  Here is what I did, and there seems to be something not all ok:
                                  (even the communication worked as shown above)

                                  # rigctl -m 204 -r /dev/ttyS0 s 4800 -C post_write_delay=50
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  get_split_vfo: error = Communication timed out
                                  Command '' not found!
                                  erikja:~ # rigctl -m 204 -r /dev/ttyS0 s 4800 -C post_write_delay=100
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  get_split_vfo: error = Communication timed out
                                  Command '' not found!
                                  erikja:~ # rigctl -m 204 -r /dev/ttyS0 s 4800 -C post_write_delay=200
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  read_string: timedout without reading a character
                                  get_split_vfo: error = Communication timed out
                                  Command '' not found!
                                  erikja:~ # fuser /dev/ttyS0

                                  Maybe there seems to be a problem with the communication even the above.
                                  I could try the ttyS0 also with my SCS-PTC-II to see if there will be a
                                  communication.
                                  Or as you have done it try it with a usb->serial interface.


                                  > Please give some feedback (best for different baud rates) so that I
                                  can correct
                                  > the value in the source files.

                                  look above.

                                  > (Btw, It would be good if you had filed a bug into the hamlib bug
                                  database on
                                  > sourceforge - http://sourceforge.net/tracker/?group_id=8305)

                                  How do I that Thomas ?.

                                  > I will have a look if we can set the post_write_delay also via the
                                  library
                                  > and if I find a way to config fldigi properly. If not I will discuss
                                  the
                                  > problem in the fldigi developer list.

                                  Many tnx.

                                  > Please keep me informed how it is going. Getting feedback is an
                                  important
                                  > precondition to make the backend better.

                                  For sure I will, and I'm very greatfull, that you wil help me.

                                  > 73,
                                  > de Tom DL1JBE.
                                  >
                                  >
                                  > --
                                  > "Do what is needful!"
                                  > Ursula LeGuin: Earthsea
                                  > --
                                  73, Erik OZ4KK
                                • aalested
                                  ... Sorry, the link should be: http://www.urbakken.dk/fldigihamlibsetup.jpg 73 Erik OZ4KK
                                  Message 16 of 24 , Jul 10, 2008
                                  • 0 Attachment
                                  • Thomas Beierlein
                                    Hi Erik, ... That one should be easy. Type IF; and you should get either a long string starting with IF014... (thats your frequency, modes and so on) or a
                                    Message 17 of 24 , Jul 10, 2008
                                    • 0 Attachment
                                      Hi Erik,

                                      > > Hm. what kind of problems do you observe exactly and what
                                      > communication
                                      > > settings are you using?
                                      >
                                      > I will try to explain.
                                      > The /dev/ttyS0 is set to 4800 baud. The TS570D is set to 48-1
                                      > I have setup minicom to those values, and gets no errors.
                                      > But I'm not sure how to test the connection from the minicom to the
                                      > TS570D.

                                      That one should be easy. Type 'IF;' and you should get either a long string
                                      starting with 'IF014...' (thats your frequency, modes and so on) or a simple
                                      'E;' or '?;' indicating an communication error.

                                      But to be honest, configuring minicom is not as easy as it seems. Getting
                                      handshaking, baudrate,... right is always a hassle for me :-(.

                                      > Followed the Hamlib FAQ, I did this:
                                      > # rigctl -r /dev/ttyS0 -m 204
                                      > read_string: timedout without reading a character
                                      > read_string: timedout without reading a character

                                      > Then I read the man page, whereafter I set the baudrate also:
                                      >
                                      > # rigctl -vvvvv -r /dev/ttyS0 -s 4800 -m 204

                                      Right. As hamlib uses always the maximum allowed baud rate as default (that is
                                      57600 for the TS570D) you got the wrong rate on first try. (As a reminder, if
                                      you switch the baudrate in the rig (menu# 35) you must turn the radio off and
                                      on again to get the change happen).

                                      > Opened rig model 204, 'TS-570D'
                                      > Backend version: 0.6.1, Status: Stable
                                      >
                                      > Rig command: Frequency: 14086070
                                      >
                                      > Does the above indicate, that I have an ok working between the ttyS0 and
                                      > the TS570D ?

                                      Yes. That is perfectly fine. If you start rigctl without the -vvvvv you
                                      should be able to work and experiment with the rig. Try 'f' or 'F' for getting
                                      and setting frequency, '?' for a list of supported commands or '1' for a list
                                      of the supported features for the TS570D backend.

                                      > ALL commands has been done as ROOT. Is this ok, and intended ?.
                                      >

                                      It is one possibility. But rigctl should also work fine from your user account.
                                      If it doesn't there is something wrong about your permissions to use the serial
                                      port. Please test and come back if it doesn't.

                                      > Then I started up the fldigi, and did it from a terminal to be able to
                                      > see what's going on:
                                      >
                                      > fldigi
                                      > Transceiver not responding:
                                      >
                                      That is normal, as long as you have choosen hamlib but not configured fldigi
                                      accordingly.

                                      > Here I show a screenshot of what my setup looks in fldigi:
                                      > ...
                                      > Does that look ok ?

                                      Yes that looks perfectly ok. To be sure I just tested that setting at my side
                                      and it work perfectly. No problems. Did you start fldigi as user or also
                                      as root?


                                      By the way, what version of hamlib do you using?

                                      > > That would be 'rigctl -m xxx -r yyy -C post_write_delay=50'. Please
                                      > try which
                                      > > delay works best for you.
                                      >
                                      > Here is what I did, and there seems to be something not all ok:
                                      > (even the communication worked as shown above)
                                      >
                                      > # rigctl -m 204 -r /dev/ttyS0 s 4800 -C post_write_delay=50
                                      > read_string: timedout without reading a character
                                      > read_string: timedout without reading a character
                                      > read_string: timedout without reading a character

                                      Opps. It seems you forgot the '-' sign in front of the 's 4800'. So it worked
                                      again at 57600 Bd. (Murphy at work?)

                                      Can you please test again?

                                      > > (Btw, It would be good if you had filed a bug into the hamlib bug
                                      > database on
                                      > > sourceforge - http://sourceforge.net/tracker/?group_id=8305)
                                      >
                                      > How do I that Thomas ?.

                                      Go to that side with your browser. Select the link 'Bugs'. On next page you'll
                                      find a little 'submit new' link. There you can give a short summary (as a
                                      header line) and a detailed description of the problem.
                                      But let us sort things out first. Maybe there is no real problem here.


                                      73,

                                      de Tom DL1JBE.

                                      --
                                      "Do what is needful!"
                                      Ursula LeGuin: Earthsea
                                      --
                                    • aalested
                                      ... Hi Thomas. ... string ... a simple ... I set the baudrate to 57K6 now on the TS570D, and right, then rigctl just worked: # rigctl -r /dev/ttyS0 -m 204 Rig
                                      Message 18 of 24 , Jul 10, 2008
                                      • 0 Attachment
                                        > Hi Erik,

                                        Hi Thomas.


                                        > That one should be easy. Type 'IF;' and you should get either a long
                                        string
                                        > starting with 'IF014...' (thats your frequency, modes and so on) or
                                        a simple
                                        > 'E;' or '?;' indicating an communication error.

                                        I set the baudrate to 57K6 now on the TS570D, and right, then rigctl
                                        just worked:

                                        # rigctl -r /dev/ttyS0 -m 204

                                        Rig command: IF
                                        Tx frequency:
                                        Rig command: if
                                        Tx frequency: 14086370

                                        Rig command: Frequency: 14086370

                                        Rig command:


                                        > But to be honest, configuring minicom is not as easy as it seems.
                                        Getting
                                        > handshaking, baudrate,... right is always a hassle for me :-(.

                                        You are quite right, but can be used. I did it those days I ran a MBO
                                        with my PTC-II.


                                        > > # rigctl -vvvvv -r /dev/ttyS0 -s 4800 -m 204
                                        >
                                        > Right. As hamlib uses always the maximum allowed baud rate as
                                        default (that is
                                        > 57600 for the TS570D) you got the wrong rate on first try. (As a
                                        reminder, if
                                        > you switch the baudrate in the rig (menu# 35) you must turn the
                                        radio off and
                                        > on again to get the change happen).

                                        Such I did, and it succeded :-)

                                        > > Opened rig model 204, 'TS-570D'
                                        > > Backend version: 0.6.1, Status: Stable
                                        > >
                                        > > Rig command: Frequency: 14086070
                                        > >
                                        > > Does the above indicate, that I have an ok working between the
                                        ttyS0 and
                                        > > the TS570D ?
                                        >
                                        > Yes. That is perfectly fine. If you start rigctl without the -vvvvv you
                                        > should be able to work and experiment with the rig. Try 'f' or 'F'
                                        for getting
                                        > and setting frequency, '?' for a list of supported commands or '1'
                                        for a list
                                        > of the supported features for the TS570D backend.

                                        Rig command: f
                                        Frequency: 14086370

                                        Rig command: F
                                        Frequency: 1421000

                                        Rig command: F
                                        Frequency: 14210000

                                        l is get level:
                                        Rig command: l
                                        Level: 2
                                        get_level: error = Invalid parameter

                                        But it works :-)


                                        > It is one possibility. But rigctl should also work fine from your
                                        user account.
                                        > If it doesn't there is something wrong about your permissions to use
                                        the serial
                                        > port. Please test and come back if it doesn't.

                                        The problem persists.


                                        > > fldigi
                                        > > Transceiver not responding:
                                        > >
                                        > That is normal, as long as you have choosen hamlib but not
                                        configured fldigi
                                        > accordingly.

                                        Now I set the baudrate to 57K6 in hamlib in fldigi, but I get the same
                                        "Transceiver not responding"

                                        Oh my, I got it. I'm sure this is due to the permission again for the
                                        /dev/ttyS0.
                                        I tried starting fldigi up as root, and did set the hamlib up here
                                        also, and it works :-)

                                        The Hamlib Controller now shows the qrg's, and changes them if I turn
                                        the dial on the TS570D.

                                        > > Here I show a screenshot of what my setup looks in fldigi:
                                        > > ...
                                        > > Does that look ok ?
                                        >
                                        > Yes that looks perfectly ok. To be sure I just tested that setting
                                        at my side
                                        > and it work perfectly. No problems. Did you start fldigi as user or
                                        also
                                        > as root?

                                        I started it as user.
                                        >
                                        > By the way, what version of hamlib do you using?

                                        I use this:
                                        hamlib-devel-1.2.7.1-3.4
                                        hamlib-1.2.7.1-3.4


                                        > > # rigctl -m 204 -r /dev/ttyS0 s 4800 -C post_write_delay=50
                                        > > read_string: timedout without reading a character
                                        > > read_string: timedout without reading a character
                                        > > read_string: timedout without reading a character
                                        >
                                        > Opps. It seems you forgot the '-' sign in front of the 's 4800'. So
                                        it worked
                                        > again at 57600 Bd. (Murphy at work?)

                                        Murphy is always working.

                                        > Can you please test again?

                                        I guess it's not necessary, as it works now (but as root)

                                        > > > (Btw, It would be good if you had filed a bug into the hamlib bug
                                        > > database on
                                        > > > sourceforge - http://sourceforge.net/tracker/?group_id=8305)
                                        > >
                                        > > How do I that Thomas ?.
                                        >
                                        > Go to that side with your browser. Select the link 'Bugs'. On next
                                        page you'll
                                        > find a little 'submit new' link. There you can give a short summary
                                        (as a
                                        > header line) and a detailed description of the problem.
                                        > But let us sort things out first. Maybe there is no real problem here.

                                        I don't think it's necessary now, as it was Murphy and the famous
                                        error 40 too :-)


                                        Erik OZ4KK
                                      • Thomas Beierlein
                                        Hi Erik, glad you get communication working. ... You have to state which level you want to get, e.g. RFPOWER or MICGAIN. See the output of command 1 and then
                                        Message 19 of 24 , Jul 10, 2008
                                        • 0 Attachment
                                          Hi Erik,

                                          glad you get communication working.

                                          > l is get level:
                                          > Rig command: l
                                          > Level: 2
                                          > get_level: error = Invalid parameter

                                          You have to state which level you want to get, e.g. RFPOWER or MICGAIN. See
                                          the output of command '1' and then look which 'Set level' or 'Get level' is
                                          supported. Same for functions 'u' or 'U'.

                                          > Now I set the baudrate to 57K6 in hamlib in fldigi, but I get the same
                                          > "Transceiver not responding"
                                          >
                                          > Oh my, I got it. I'm sure this is due to the permission again for the
                                          > /dev/ttyS0.

                                          Yep. Exactly that seems to be the problem.

                                          > I tried starting fldigi up as root, and did set the hamlib up here
                                          > also, and it works :-)

                                          So, fine. Now you have to figure out how to set your permissions so that you
                                          are allowed to access /dev/ttyS0 as user. You should *not* use fldigi as root
                                          on the long run.

                                          Normally it is handled by adding your user account to some special group
                                          (mostly 'uucp' or 'tty'), but it depends on the linux distribution you use.

                                          As a first start you can look at the group /dev/ttyS0 belongs to. At my side
                                          it belongs to uucp, so I need to be in that group too.

                                          > ls -l /dev/ttyS0
                                          crw-rw---- 1 root uucp 4, 64 Jul 10 12:35 /dev/ttyS0

                                          Here on Gentoo I can run

                                          usermod -G list_of_groups_to_belong user

                                          as root to change my group membership. Have a look into the user administration
                                          for your system.

                                          > > By the way, what version of hamlib do you using?
                                          >
                                          > I use this:
                                          > hamlib-devel-1.2.7.1-3.4
                                          > hamlib-1.2.7.1-3.4

                                          Ok, that is the actual one.


                                          > > Go to that side with your browser. Select the link 'Bugs'. On next
                                          > page you'll
                                          > > find a little 'submit new' link. There you can give a short summary
                                          > (as a
                                          > > header line) and a detailed description of the problem.
                                          > > But let us sort things out first. Maybe there is no real problem here.
                                          >
                                          > I don't think it's necessary now, as it was Murphy and the famous
                                          > error 40 too :-)

                                          Right. Just remeber it for any problems in future. Or give me a direct call, as
                                          I am interested in feedback for the rig.

                                          Glad to help you.

                                          Vy 73 and lots of fun with fldigi and hamlib,

                                          Tom DL1JBE.

                                          --
                                          "Do what is needful!"
                                          Ursula LeGuin: Earthsea
                                          --
                                        • Nate Bargmann
                                          Glad to see a resolution on this. Good luck, Erik and thanks, Tom. 73, de Nate -- The optimist proclaims that we live in the best of all possible worlds.
                                          Message 20 of 24 , Jul 10, 2008
                                          • 0 Attachment
                                            Glad to see a resolution on this. Good luck, Erik and thanks, Tom.

                                            73, de Nate >>

                                            --

                                            "The optimist proclaims that we live in the best of all
                                            possible worlds. The pessimist fears this is true."

                                            Ham radio, Linux, bikes, and more: http://n0nb.us/index.html
                                          • aalested
                                            ... Hi Tom. I m very glad too, and I m very greatfull, that you came here to help me to get it to work. ... MICGAIN. See ... level is ... Ok, will have a look
                                            Message 21 of 24 , Jul 10, 2008
                                            • 0 Attachment
                                              > Hi Erik,
                                              >
                                              > glad you get communication working.

                                              Hi Tom.

                                              I'm very glad too, and I'm very greatfull, that you came here to help
                                              me to get it to work.

                                              > > l is get level:
                                              > > Rig command: l
                                              > > Level: 2
                                              > > get_level: error = Invalid parameter
                                              >
                                              > You have to state which level you want to get, e.g. RFPOWER or
                                              MICGAIN. See
                                              > the output of command '1' and then look which 'Set level' or 'Get
                                              level' is
                                              > supported. Same for functions 'u' or 'U'.

                                              Ok, will have a look there, and for all the interesting things around
                                              the project.

                                              > > Now I set the baudrate to 57K6 in hamlib in fldigi, but I get the same
                                              > > "Transceiver not responding"
                                              > >
                                              > > Oh my, I got it. I'm sure this is due to the permission again for the
                                              > > /dev/ttyS0.
                                              >
                                              > Yep. Exactly that seems to be the problem.

                                              It was :-)

                                              > > I tried starting fldigi up as root, and did set the hamlib up here
                                              > > also, and it works :-)
                                              >
                                              > So, fine. Now you have to figure out how to set your permissions so
                                              that you
                                              > are allowed to access /dev/ttyS0 as user. You should *not* use
                                              fldigi as root
                                              > on the long run.

                                              No I won't, but was a great help in getting it to work.

                                              > Normally it is handled by adding your user account to some special group
                                              > (mostly 'uucp' or 'tty'), but it depends on the linux distribution
                                              you use.

                                              I use openSUSE 11.0, and here the tool Yast2 can do it. I now have to
                                              find out how.

                                              > As a first start you can look at the group /dev/ttyS0 belongs to. At
                                              my side
                                              > it belongs to uucp, so I need to be in that group too.

                                              It belongs to uucp like yours do:

                                              ls -l /dev/ttyS0
                                              crw-rw---- 1 root uucp 4, 64 Jul 10 14:22 /dev/ttyS0
                                              man man

                                              > > ls -l /dev/ttyS0
                                              > crw-rw---- 1 root uucp 4, 64 Jul 10 12:35 /dev/ttyS0
                                              >
                                              > Here on Gentoo I can run
                                              >
                                              > usermod -G list_of_groups_to_belong user
                                              >
                                              > as root to change my group membership. Have a look into the user
                                              administration
                                              > for your system.

                                              I do have the usermod too:

                                              usermod -G
                                              usermod: option requires an argument -- 'G'
                                              Try `usermod --help' or `usermod --usage' for more information.

                                              But this doesn't show the gorups.

                                              > > > By the way, what version of hamlib do you using?
                                              > >
                                              > > I use this:
                                              > > hamlib-devel-1.2.7.1-3.4
                                              > > hamlib-1.2.7.1-3.4
                                              >
                                              > Ok, that is the actual one.
                                              >
                                              Good.
                                              > > > Go to that side with your browser. Select the link 'Bugs'. On next
                                              > > page you'll
                                              > > > find a little 'submit new' link. There you can give a short summary
                                              > > (as a
                                              > > > header line) and a detailed description of the problem.
                                              > > > But let us sort things out first. Maybe there is no real problem
                                              here.
                                              > >
                                              > > I don't think it's necessary now, as it was Murphy and the famous
                                              > > error 40 too :-)
                                              >
                                              > Right. Just remeber it for any problems in future. Or give me a
                                              direct call, as
                                              > I am interested in feedback for the rig.


                                              For sure I will Tom. I wait for your comments on the usermod here.
                                              Else I want to again thank you for your valuable help.
                                              > Glad to help you.

                                              I'm glad you would.

                                              > Vy 73 and lots of fun with fldigi and hamlib,
                                              >
                                              > Tom DL1JBE.
                                              >
                                              > --
                                              > "Do what is needful!"
                                              > Ursula LeGuin: Earthsea
                                              > --
                                              >
                                              Erik Oz4kk
                                            • aalested
                                              ... I m very glad too Nate. Also for your help, and kindness. ... 73 Erik OZ4KK
                                              Message 22 of 24 , Jul 10, 2008
                                              • 0 Attachment
                                                > Glad to see a resolution on this. Good luck, Erik and thanks, Tom.
                                                >
                                                > 73, de Nate >>

                                                I'm very glad too Nate. Also for your help, and kindness.

                                                > --
                                                >
                                                > "The optimist proclaims that we live in the best of all
                                                > possible worlds. The pessimist fears this is true."
                                                >
                                                > Ham radio, Linux, bikes, and more: http://n0nb.us/index.html
                                                >
                                                73 Erik OZ4KK
                                              • Thomas Beierlein
                                                Hi Erik, ... As I have an OpenSuSE too (10.2) I can help: - Start Yast (Graphical Mode) - choose Security and Users in left tab - choose User Management -
                                                Message 23 of 24 , Jul 10, 2008
                                                • 0 Attachment
                                                  Hi Erik,

                                                  > > Normally it is handled by adding your user account to some special group
                                                  > > (mostly 'uucp' or 'tty'), but it depends on the linux distribution
                                                  > you use.
                                                  >
                                                  > I use openSUSE 11.0, and here the tool Yast2 can do it. I now have to
                                                  > find out how.
                                                  >
                                                  As I have an OpenSuSE too (10.2) I can help:

                                                  - Start Yast (Graphical Mode)
                                                  - choose 'Security and Users' in left tab
                                                  - choose 'User Management'
                                                  - select your account and click on 'Edit'-button below
                                                  - choose second tab for 'Details'
                                                  - scroll down the group list on the right side and select uucp
                                                  - 'Accept' should do it finally


                                                  If you want to do it in textmode, see bleow.

                                                  > I do have the usermod too:
                                                  >
                                                  > usermod -G
                                                  > usermod: option requires an argument -- 'G'

                                                  Opps. My mistake. Please use the 'groups' command to get the list of groups
                                                  you are in, e.g.

                                                  > groups my_account
                                                  users dialout video wheel

                                                  Than you can use 'usermod'

                                                  > usermod -G users,dialout,video,wheel,uucp my_account

                                                  afterwards you will get

                                                  > groups my_account
                                                  users dialout uucp video wheel

                                                  Be careful to use commas between the groups and no whitespaces.

                                                  73,

                                                  de Tom DL1JBE.

                                                  --
                                                  "Do what is needful!"
                                                  Ursula LeGuin: Earthsea
                                                  --
                                                • aalested
                                                  Hi Tom. ... Ok, but I have fixed it. What I forgot was to log in log out. I ran SuSEconfig, and it didn t work. Then I wondered why it was necessary to reboot.
                                                  Message 24 of 24 , Jul 10, 2008
                                                  • 0 Attachment
                                                    Hi Tom.

                                                    > As I have an OpenSuSE too (10.2) I can help:
                                                    >
                                                    > - Start Yast (Graphical Mode)
                                                    > - choose 'Security and Users' in left tab
                                                    > - choose 'User Management'
                                                    > - select your account and click on 'Edit'-button below
                                                    > - choose second tab for 'Details'
                                                    > - scroll down the group list on the right side and select uucp
                                                    > - 'Accept' should do it finally

                                                    Ok, but I have fixed it. What I forgot was to log in log out. I ran
                                                    SuSEconfig, and it didn't work. Then I wondered why it was necessary
                                                    to reboot. And it wasn't, but after it worked as user too :-)

                                                    >
                                                    > If you want to do it in textmode, see bleow.
                                                    >
                                                    > > I do have the usermod too:
                                                    > >
                                                    > > usermod -G
                                                    > > usermod: option requires an argument -- 'G'
                                                    >
                                                    > Opps. My mistake. Please use the 'groups' command to get the list of
                                                    groups
                                                    > you are in, e.g.
                                                    >
                                                    > > groups my_account
                                                    > users dialout video wheel

                                                    Yes, that also works here:

                                                    erikja@erikja:~> groups
                                                    users dialout uucp video

                                                    :-)


                                                    > Than you can use 'usermod'
                                                    >
                                                    > > usermod -G users,dialout,video,wheel,uucp my_account

                                                    That I'll save.

                                                    > afterwards you will get
                                                    >
                                                    > > groups my_account
                                                    > users dialout uucp video wheel
                                                    >
                                                    > Be careful to use commas between the groups and no whitespaces.

                                                    Tnx for the advice.

                                                    > 73,
                                                    >
                                                    > de Tom DL1JBE.
                                                    >
                                                    > --
                                                    > "Do what is needful!"
                                                    > Ursula LeGuin: Earthsea
                                                    > --
                                                    >
                                                    73,
                                                    Erik OZ4KK
                                                  Your message has been successfully submitted and would be delivered to recipients shortly.