Loading ...
Sorry, an error occurred while loading the content.

Puppy/fldigi/eeePC/RigCat

Expand Messages
  • Don Tuite
    I have fldigi on a USB memory stick up and running on my eeePC. I want to control my ICOM 703 using a RigExpert Tiny, which uses an FTDI chip to interface
    Message 1 of 6 , May 10 3:03 PM
    • 0 Attachment
      I have fldigi on a USB memory stick up and running on my eeePC. I want
      to control my ICOM 703 using a RigExpert Tiny, which uses an FTDI chip
      to interface between USB and the ICOM CI-V interface.

      Under Puppy, the USB drivers on the eeePC are /dev/usb/ttyUSB0
      and /dev/usb/ttyUSB1.

      I have been editing the RigCAT .xml file for the 703 without success.
      (After editing, I place it in "root" with the name ".fldigi.xml")

      Other than changing the name of the driver in the XML file, what else
      should I be doing? Obviously, the RigCAT XML files were written under
      the assumption the interface would be a TTY Com port. Can I just change
      a few more lines of XML, or is it a big deal?

      Don NR7X
    • Rich Newsom
      The edited xml file must be named rig.xml and must be in the hidden .fldigi directory which is in root (or username dependent on os). As long as the xml
      Message 2 of 6 , May 10 3:33 PM
      • 0 Attachment
        The edited xml file must be named "rig.xml" and must be in the
        hidden .fldigi directory which is in "root" (or username dependent
        on os). As long as the xml list the proper comm device name, it
        will work fine with the usb-serial or usb-ttl converters. Don't
        forget to hit initialize after setting up rigctl in the menu.

        BTW, fldigi works fine in the newest version Puppy Linux (4.0).

        Rich
        WA4SXZ



        --- In linuxham@yahoogroups.com, "Don Tuite" <dtuite@...> wrote:
        >
        > I have fldigi on a USB memory stick up and running on my eeePC. I want
        > to control my ICOM 703 using a RigExpert Tiny, which uses an FTDI chip
        > to interface between USB and the ICOM CI-V interface.
        >
        > Under Puppy, the USB drivers on the eeePC are /dev/usb/ttyUSB0
        > and /dev/usb/ttyUSB1.
        >
        > I have been editing the RigCAT .xml file for the 703 without success.
        > (After editing, I place it in "root" with the name ".fldigi.xml")
        >
        > Other than changing the name of the driver in the XML file, what else
        > should I be doing? Obviously, the RigCAT XML files were written under
        > the assumption the interface would be a TTY Com port. Can I just change
        > a few more lines of XML, or is it a big deal?
        >
        > Don NR7X
        >
      • Don Tuite
        ... Thanks. That s what the RigCAT instructions say. Been there. Those are contradicted by W1HJK here: http://www.w1hkj.com/flpuppy.html. Alas. What s a
        Message 3 of 6 , May 10 7:20 PM
        • 0 Attachment
          --- In linuxham@yahoogroups.com, "Rich Newsom" <richwa4sxz@...> wrote:
          >
          > The edited xml file must be named "rig.xml" and must be in the
          > hidden .fldigi directory which is in "root" (or username dependent
          > on os). As long as the xml list the proper comm device name, it
          > will work fine with the usb-serial or usb-ttl converters. Don't
          > forget to hit initialize after setting up rigctl in the menu.
          >
          > BTW, fldigi works fine in the newest version Puppy Linux (4.0).
          >
          > Rich
          > WA4SXZ
          >
          Thanks. That's what the RigCAT instructions say. Been there. Those
          are contradicted by W1HJK here: http://www.w1hkj.com/flpuppy.html.
          Alas. What's a mother to do?

          Do you have your rig working out of a USB port?. That seems to be the
          sticking point.

          And I forgot to mention -- I DO have ftdi.sio loaded. And Puppy sees
          the chip and reports its maker and device. I know that's not enough,
          but I'm stymied as to what else.

          Cheers

          NR7X
        • w1hkj
          ... Refer to the latest information about the Puppy release for fldigi: http://www.w1hkj.com/emcpup.html and for information on using and setting up the
          Message 4 of 6 , May 10 10:22 PM
          • 0 Attachment
            Don Tuite wrote:
            --- In linuxham@yahoogroups.com, "Rich Newsom" <richwa4sxz@...> wrote:
              
            The edited xml file must be named "rig.xml" and must be in the
            hidden .fldigi directory which is in "root" (or username dependent
            on os). As long as the xml list the proper comm device name, it 
            will work fine with the usb-serial or usb-ttl converters.  Don't
            forget to hit initialize after setting up rigctl in the menu.
            
            BTW, fldigi works fine in the newest version Puppy Linux (4.0).
            
            Rich
            WA4SXZ
            
                
            Thanks. That's what the RigCAT instructions say.  Been there.  Those 
            are contradicted by W1HJK here: http://www.w1hkj.com/flpuppy.html.  
            Alas. What's a mother to do?  
              
            Refer to the latest information about the Puppy release for fldigi:

            http://www.w1hkj.com/emcpup.html

            and for information on using and setting up the rig.xml file:

            http://www.w1hkj.com/FldigiHelp/TransceiverControl.html

            Dave, W1HKJ
          • Rich Newsom
            Yes, my laptop has no serial ports other than the USB connectors. I have looked at the 703 xml on Dave s website and it is already set to ttyUSB0. It will
            Message 5 of 6 , May 11 5:31 AM
            • 0 Attachment
              Yes, my laptop has no serial ports other than the USB connectors.
              I have looked at the 703 xml on Dave's website and it is already
              set to ttyUSB0. It will work unless your o/s has some other required
              parameter. Some different O/S versions have requirements to set
              permissions for the user to access the USB port.

              When you get this working you may wish to make a HOW-TO for the
              FAQ file section for your type computer-OS setup.

              Rich
              WA4SXZ

              --- In linuxham@yahoogroups.com, "Don Tuite" <dtuite@...> wrote:
              >
              > --- In linuxham@yahoogroups.com, "Rich Newsom" <richwa4sxz@> wrote:
              > >
              > > The edited xml file must be named "rig.xml" and must be in the
              > > hidden .fldigi directory which is in "root" (or username dependent
              > > on os). As long as the xml list the proper comm device name, it
              > > will work fine with the usb-serial or usb-ttl converters. Don't
              > > forget to hit initialize after setting up rigctl in the menu.
              > >
              > > BTW, fldigi works fine in the newest version Puppy Linux (4.0).
              > >
              > > Rich
              > > WA4SXZ
              > >
              > Thanks. That's what the RigCAT instructions say. Been there. Those
              > are contradicted by W1HJK here: http://www.w1hkj.com/flpuppy.html.
              > Alas. What's a mother to do?
              >
              > Do you have your rig working out of a USB port?. That seems to be the
              > sticking point.
              >
              > And I forgot to mention -- I DO have ftdi.sio loaded. And Puppy sees
              > the chip and reports its maker and device. I know that's not enough,
              > but I'm stymied as to what else.
              >
              > Cheers
              >
              > NR7X
              >
            • Don Tuite
              ... Thanks. That ought to do it. Okay, minor glitch. I don t do this every day. I used mount to extract the files from the ISO and place them into a
              Message 6 of 6 , May 11 5:28 PM
              • 0 Attachment
                --- In linuxham@yahoogroups.com, w1hkj <w1hkj@...> wrote:
                > Refer to the latest information about the Puppy release for fldigi:
                >
                > http://www.w1hkj.com/emcpup.html
                >
                > and for information on using and setting up the rig.xml file:
                >
                > http://www.w1hkj.com/FldigiHelp/TransceiverControl.html
                >
                > Dave, W1HKJ

                Thanks. That ought to do it.

                Okay, minor glitch. I don't do this every day.

                I used "mount" to extract the files from the ISO and place them into
                a subdirectory under /home/user on the eeePC. I think I ought to be
                able to copy them to a USB drive, but when I try sudo cp, I get
                an "input/output" error and the files written to the USB drive are
                empty or truncated. (I'm more or less following the instructions for
                the second approach at the eeePC Wiki:
                http://wiki.eeeuser.com/howto:installpuppylinux, which involve adding
                a section to the grub menu -- something I've done before.)

                At this point in the game, friends, I could use a hint.

                (Maybe two or three.)

                Don, NR7X
              Your message has been successfully submitted and would be delivered to recipients shortly.