Loading ...
Sorry, an error occurred while loading the content.

update on cheapie USB audio device

Expand Messages
  • Steve Conklin
    For reference, this is the one I ordered: http://www.google.com/ Experiments were using emcpup 3.01.07 on a HP pavilion a1540n media center PC. After a couple
    Message 1 of 1 , Jan 2, 2008
    • 0 Attachment
      For reference, this is the one I ordered:
      http://www.google.com/

      Experiments were using emcpup 3.01.07 on a HP pavilion a1540n media
      center PC.

      After a couple of hours of playing, here's what I know so far:

      Puppy will recognize this device if I run the alsa config, but it
      doesn't work after a reboot until I run alsa-config again. I can hear
      output and see action on the waterfall using a mic, and hear the fldigi
      output.

      None of the mixer controls affect the levels, whether control of mixing
      is enabled in fldigi or not. The puppy mixer only has one fader, for
      'mic', and additional ones can't be added (are deselected).

      Observation:
      When generating output using the tune feature in fldigi, I got output,
      but it looks pretty far off from a sine wave, more like a sine wave
      interpolated from straight lines. There was a click in the audio output.
      The click is also present when I use the existing system sound card.
      It's a little faster than 2 Hz from the USB device, and faster than 4 Hz
      from the system sound card. On the USB device, the LED blinks in time
      with the clicks, so I thought perhaps it had to do with polling the card
      for input. I found that increasing the audio sample rate in the fldigi
      configuration both improved the output sine wave and eliminated the
      clicking. The shape of the output makes perfect sense once I realized it
      was the sample rate - I don't know what caused the clicking. I left the
      sample rate at 48000, as recommended by an earlier email about USB sound
      card sampling rate quirks.

      One important thing to note about this device - The sleeve of the audio
      output connector (output "ground") is biased very hard to about 2.5
      volts. If you tie this to any point at the same potential as the USB 5V
      return (system ground) it will quickly get hot enough to burn you. Since
      performance was the same before and after this discovery, I don't think
      I killed it, but your mileage may vary. If I end up using this in my
      interface, I'll have to provide DC isolation.

      One final discovery - if I close fldigi while it's in "tune" mode, it
      hangs hard.

      The USB serial port device and USB hub both work fine, so there's still
      potential to get all this integrated.

      I'll keep posting as I learn more.

      Steve ai4qr
    Your message has been successfully submitted and would be delivered to recipients shortly.