Loading ...
Sorry, an error occurred while loading the content.

flrig/CAT problem

Expand Messages
  • william
    Need help getting the flrig and CAT to work together. I downloaded from the sellers site in this link
    Message 1 of 20 , Oct 26, 2013
    View Source
    • 0 Attachment
      Need help getting the flrig and CAT to work together.

      I downloaded from the sellers site in this link http://radioarena.co.uk/index.php?_a=product&product_id=2565 a file that is supposed to make CAT operate. But it seems flrig does not either see the program or I have the wrong CAT program.

      Any help of getting my OS (Ubuntu 12.10) to work with the Yaesu-897 (Not a D version, just standard 897 here).

      Will
      2E0WHN
    • Ernest Wagner
      Will, Those drivers you downloaded from that website are Windows drivers. On most Linux systems, the drivers are part of the Linux kernel. Just plug in the
      Message 2 of 20 , Oct 26, 2013
      View Source
      • 0 Attachment
        Will,

        Those drivers you downloaded from that website are Windows drivers. On most Linux systems, the drivers are part of the Linux kernel.  Just plug in the cable and the appropriate port(dev/ttyUSB0) should be created.

        You need to start a terminal(command line interface) and make yourself a member of the dialout group using the command:

            adduser yourusername dialout

        You also need to log out and back in for this change to take effect.

        Then start flrig,  and from the menu, select Config->Xciever Select.

        On th I/O ports dialog select /dev/ttyUSB0 from the ser. port drop down list. this is what it should be if the cable uses the ftdi chip.  It may contain some variation of "tty and "USB" for other chips.

        From the Rig Select drop-down select ft-897D.  The communications protocol should be the same as the plain ft-897.

        With the rig connected, click on he red init button and you should be ready to go.

        Regards,

        Ernie D


        On Sat, 2013-10-26 at 15:32 +0000, william wrote:
         
        Need help getting the flrig and CAT to work together.

        I downloaded from the sellers site in this link http://radioarena.co.uk/index.php?_a=product&product_id=2565 a file that is supposed to make CAT operate. But it seems flrig does not either see the program or I have the wrong CAT program.

        Any help of getting my OS (Ubuntu 12.10) to work with the Yaesu-897 (Not a D version, just standard 897 here).

        Will
        2E0WHN







      • william northcote
        Keep getting only root may add user to the system. Hmm! Will 2E0WHN
        Message 3 of 20 , Oct 26, 2013
        View Source
        • 0 Attachment
          Keep getting  only root may add user to the system.

          Hmm!

          Will
          2E0WHN


          On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
           

          Will,

          Those drivers you downloaded from that website are Windows drivers. On most Linux systems, the drivers are part of the Linux kernel.  Just plug in the cable and the appropriate port(dev/ttyUSB0) should be created.

          You need to start a terminal(command line interface) and make yourself a member of the dialout group using the command:

              adduser yourusername dialout

          You also need to log out and back in for this change to take effect.

          Then start flrig,  and from the menu, select Config->Xciever Select.

          On th I/O ports dialog select /dev/ttyUSB0 from the ser. port drop down list. this is what it should be if the cable uses the ftdi chip.  It may contain some variation of "tty and "USB" for other chips.

          From the Rig Select drop-down select ft-897D.  The communications protocol should be the same as the plain ft-897.

          With the rig connected, click on he red init button and you should be ready to go.

          Regards,

          Ernie D




          On Sat, 2013-10-26 at 15:32 +0000, william wrote:
           
          Need help getting the flrig and CAT to work together.

          I downloaded from the sellers site in this link http://radioarena.co.uk/index.php?_a=product&product_id=2565 a file that is supposed to make CAT operate. But it seems flrig does not either see the program or I have the wrong CAT program.

          Any help of getting my OS (Ubuntu 12.10) to work with the Yaesu-897 (Not a D version, just standard 897 here).

          Will
          2E0WHN








        • Geoff McAlpin
          The correct command is: sudo adduser yourusername dialout Geoff McAlpin, NW7GM (ex N7PGN) Seattle, WA CN87tr On Oct 26, 2013 10:18 AM, william northcote
          Message 4 of 20 , Oct 26, 2013
          View Source
          • 0 Attachment

            The correct command is:

            sudo adduser yourusername dialout

            Geoff McAlpin, NW7GM (ex N7PGN)
            Seattle, WA
            CN87tr

            On Oct 26, 2013 10:18 AM, "william northcote" <william.northcote@...> wrote:
             

            Keep getting  only root may add user to the system.

            Hmm!

            Will
            2E0WHN


            On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
             

            Will,

            Those drivers you downloaded from that website are Windows drivers. On most Linux systems, the drivers are part of the Linux kernel.  Just plug in the cable and the appropriate port(dev/ttyUSB0) should be created.

            You need to start a terminal(command line interface) and make yourself a member of the dialout group using the command:

                adduser yourusername dialout

            You also need to log out and back in for this change to take effect.

            Then start flrig,  and from the menu, select Config->Xciever Select.

            On th I/O ports dialog select /dev/ttyUSB0 from the ser. port drop down list. this is what it should be if the cable uses the ftdi chip.  It may contain some variation of "tty and "USB" for other chips.

            From the Rig Select drop-down select ft-897D.  The communications protocol should be the same as the plain ft-897.

            With the rig connected, click on he red init button and you should be ready to go.

            Regards,

            Ernie D




            On Sat, 2013-10-26 at 15:32 +0000, william wrote:
             
            Need help getting the flrig and CAT to work together.

            I downloaded from the sellers site in this link http://radioarena.co.uk/index.php?_a=product&product_id=2565 a file that is supposed to make CAT operate. But it seems flrig does not either see the program or I have the wrong CAT program.

            Any help of getting my OS (Ubuntu 12.10) to work with the Yaesu-897 (Not a D version, just standard 897 here).

            Will
            2E0WHN








          • william northcote
            I think I owe you both a beer. It is now working via the AT-897plus AMU. Will 2E0WHN
            Message 5 of 20 , Oct 26, 2013
            View Source
            • 0 Attachment
              I think I owe you both a beer.  It is now working via the AT-897plus AMU.

              Will
              2E0WHN


              On 26 October 2013 19:13, Geoff McAlpin <geoff.nw7gm@...> wrote:
               

              The correct command is:

              sudo adduser yourusername dialout

              Geoff McAlpin, NW7GM (ex N7PGN)
              Seattle, WA
              CN87tr

              On Oct 26, 2013 10:18 AM, "william northcote" <william.northcote@...> wrote:
               

              Keep getting  only root may add user to the system.

              Hmm!

              Will
              2E0WHN


              On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
               

              Will,

              Those drivers you downloaded from that website are Windows drivers. On most Linux systems, the drivers are part of the Linux kernel.  Just plug in the cable and the appropriate port(dev/ttyUSB0) should be created.

              You need to start a terminal(command line interface) and make yourself a member of the dialout group using the command:

                  adduser yourusername dialout

              You also need to log out and back in for this change to take effect.

              Then start flrig,  and from the menu, select Config->Xciever Select.

              On th I/O ports dialog select /dev/ttyUSB0 from the ser. port drop down list. this is what it should be if the cable uses the ftdi chip.  It may contain some variation of "tty and "USB" for other chips.

              From the Rig Select drop-down select ft-897D.  The communications protocol should be the same as the plain ft-897.

              With the rig connected, click on he red init button and you should be ready to go.

              Regards,

              Ernie D




              On Sat, 2013-10-26 at 15:32 +0000, william wrote:
               
              Need help getting the flrig and CAT to work together.

              I downloaded from the sellers site in this link http://radioarena.co.uk/index.php?_a=product&product_id=2565 a file that is supposed to make CAT operate. But it seems flrig does not either see the program or I have the wrong CAT program.

              Any help of getting my OS (Ubuntu 12.10) to work with the Yaesu-897 (Not a D version, just standard 897 here).

              Will
              2E0WHN









            • Geoff McAlpin
              I know I wouldn t turn one down. ;) Glad you re up and running. Maybe we ll catch each other on the air sometime. Have a great weekend. 73, Geoff McAlpin,
              Message 6 of 20 , Oct 26, 2013
              View Source
              • 0 Attachment

                I know I wouldn't turn one down. ;)

                Glad you're up and running. Maybe we'll catch each other on the air sometime.

                Have a great weekend.

                73,

                Geoff McAlpin, NW7GM (ex N7PGN)
                Seattle, WA
                CN87tr

                On Oct 26, 2013 11:56 AM, "william northcote" <william.northcote@...> wrote:
                 

                I think I owe you both a beer.  It is now working via the AT-897plus AMU.

                Will
                2E0WHN


                On 26 October 2013 19:13, Geoff McAlpin <geoff.nw7gm@...> wrote:
                 

                The correct command is:

                sudo adduser yourusername dialout

                Geoff McAlpin, NW7GM (ex N7PGN)
                Seattle, WA
                CN87tr

                On Oct 26, 2013 10:18 AM, "william northcote" <william.northcote@...> wrote:
                 

                Keep getting  only root may add user to the system.

                Hmm!

                Will
                2E0WHN


                On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
                 

                Will,

                Those drivers you downloaded from that website are Windows drivers. On most Linux systems, the drivers are part of the Linux kernel.  Just plug in the cable and the appropriate port(dev/ttyUSB0) should be created.

                You need to start a terminal(command line interface) and make yourself a member of the dialout group using the command:

                    adduser yourusername dialout

                You also need to log out and back in for this change to take effect.

                Then start flrig,  and from the menu, select Config->Xciever Select.

                On th I/O ports dialog select /dev/ttyUSB0 from the ser. port drop down list. this is what it should be if the cable uses the ftdi chip.  It may contain some variation of "tty and "USB" for other chips.

                From the Rig Select drop-down select ft-897D.  The communications protocol should be the same as the plain ft-897.

                With the rig connected, click on he red init button and you should be ready to go.

                Regards,

                Ernie D




                On Sat, 2013-10-26 at 15:32 +0000, william wrote:
                 
                Need help getting the flrig and CAT to work together.

                I downloaded from the sellers site in this link http://radioarena.co.uk/index.php?_a=product&product_id=2565 a file that is supposed to make CAT operate. But it seems flrig does not either see the program or I have the wrong CAT program.

                Any help of getting my OS (Ubuntu 12.10) to work with the Yaesu-897 (Not a D version, just standard 897 here).

                Will
                2E0WHN









              • william northcote
                Yup. Maybe on the PSK or in my favourite mode Fieldhell Thanks Will 2E0WHN
                Message 7 of 20 , Oct 26, 2013
                View Source
                • 0 Attachment
                  Yup.  Maybe on the PSK or in my favourite mode Fieldhell

                  Thanks

                  Will
                  2E0WHN


                  On 26 October 2013 20:16, Geoff McAlpin <geoff.nw7gm@...> wrote:
                   

                  I know I wouldn't turn one down. ;)

                  Glad you're up and running. Maybe we'll catch each other on the air sometime.

                  Have a great weekend.

                  73,

                  Geoff McAlpin, NW7GM (ex N7PGN)
                  Seattle, WA
                  CN87tr

                  On Oct 26, 2013 11:56 AM, "william northcote" <william.northcote@...> wrote:
                   

                  I think I owe you both a beer.  It is now working via the AT-897plus AMU.

                  Will
                  2E0WHN


                  On 26 October 2013 19:13, Geoff McAlpin <geoff.nw7gm@...> wrote:
                   

                  The correct command is:

                  sudo adduser yourusername dialout

                  Geoff McAlpin, NW7GM (ex N7PGN)
                  Seattle, WA
                  CN87tr

                  On Oct 26, 2013 10:18 AM, "william northcote" <william.northcote@...> wrote:
                   

                  Keep getting  only root may add user to the system.

                  Hmm!

                  Will
                  2E0WHN


                  On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
                   

                  Will,

                  Those drivers you downloaded from that website are Windows drivers. On most Linux systems, the drivers are part of the Linux kernel.  Just plug in the cable and the appropriate port(dev/ttyUSB0) should be created.

                  You need to start a terminal(command line interface) and make yourself a member of the dialout group using the command:

                      adduser yourusername dialout

                  You also need to log out and back in for this change to take effect.

                  Then start flrig,  and from the menu, select Config->Xciever Select.

                  On th I/O ports dialog select /dev/ttyUSB0 from the ser. port drop down list. this is what it should be if the cable uses the ftdi chip.  It may contain some variation of "tty and "USB" for other chips.

                  From the Rig Select drop-down select ft-897D.  The communications protocol should be the same as the plain ft-897.

                  With the rig connected, click on he red init button and you should be ready to go.

                  Regards,

                  Ernie D




                  On Sat, 2013-10-26 at 15:32 +0000, william wrote:
                   
                  Need help getting the flrig and CAT to work together.

                  I downloaded from the sellers site in this link http://radioarena.co.uk/index.php?_a=product&product_id=2565 a file that is supposed to make CAT operate. But it seems flrig does not either see the program or I have the wrong CAT program.

                  Any help of getting my OS (Ubuntu 12.10) to work with the Yaesu-897 (Not a D version, just standard 897 here).

                  Will
                  2E0WHN










                • william northcote
                  It seems the program works, but the sliders on the main flrig seem to be locked out. These are the ones that control volume, pwr, sql. Even found that doing
                  Message 8 of 20 , Oct 27, 2013
                  View Source
                  • 0 Attachment
                    It seems the program works, but the sliders on the main flrig seem to be locked out.

                    These are the ones that control volume, pwr, sql.  Even found that doing psk it is not letting any power for TX for fldigi to produce a signal.  It is looking like flrig in inhibiting the TX via fldifi.

                    So I used my 817 radio without antenna.  It makes a click but the fldigi is producing the signal but it looks like flrig is stopping it altogether.  Also at some points it seems there is a double click.  Once at the beginning when the TX happens and at the end.  So now that I have the flrig operating the VFO a and b, I now need to get it to operate between fldigi and produce the power for TX.

                    Will
                    2E0WHN


                    On 26 October 2013 20:31, william northcote <william.northcote@...> wrote:
                    Yup.  Maybe on the PSK or in my favourite mode Fieldhell

                    Thanks

                    Will
                    2E0WHN


                    On 26 October 2013 20:16, Geoff McAlpin <geoff.nw7gm@...> wrote:
                     

                    I know I wouldn't turn one down. ;)

                    Glad you're up and running. Maybe we'll catch each other on the air sometime.

                    Have a great weekend.

                    73,

                    Geoff McAlpin, NW7GM (ex N7PGN)
                    Seattle, WA
                    CN87tr

                    On Oct 26, 2013 11:56 AM, "william northcote" <william.northcote@...> wrote:
                     

                    I think I owe you both a beer.  It is now working via the AT-897plus AMU.

                    Will
                    2E0WHN


                    On 26 October 2013 19:13, Geoff McAlpin <geoff.nw7gm@...> wrote:
                     

                    The correct command is:

                    sudo adduser yourusername dialout

                    Geoff McAlpin, NW7GM (ex N7PGN)
                    Seattle, WA
                    CN87tr

                    On Oct 26, 2013 10:18 AM, "william northcote" <william.northcote@...> wrote:
                     

                    Keep getting  only root may add user to the system.

                    Hmm!

                    Will
                    2E0WHN


                    On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
                     

                    Will,

                    Those drivers you downloaded from that website are Windows drivers. On most Linux systems, the drivers are part of the Linux kernel.  Just plug in the cable and the appropriate port(dev/ttyUSB0) should be created.

                    You need to start a terminal(command line interface) and make yourself a member of the dialout group using the command:

                        adduser yourusername dialout

                    You also need to log out and back in for this change to take effect.

                    Then start flrig,  and from the menu, select Config->Xciever Select.

                    On th I/O ports dialog select /dev/ttyUSB0 from the ser. port drop down list. this is what it should be if the cable uses the ftdi chip.  It may contain some variation of "tty and "USB" for other chips.

                    From the Rig Select drop-down select ft-897D.  The communications protocol should be the same as the plain ft-897.

                    With the rig connected, click on he red init button and you should be ready to go.

                    Regards,

                    Ernie D




                    On Sat, 2013-10-26 at 15:32 +0000, william wrote:
                     
                    Need help getting the flrig and CAT to work together.

                    I downloaded from the sellers site in this link http://radioarena.co.uk/index.php?_a=product&product_id=2565 a file that is supposed to make CAT operate. But it seems flrig does not either see the program or I have the wrong CAT program.

                    Any help of getting my OS (Ubuntu 12.10) to work with the Yaesu-897 (Not a D version, just standard 897 here).

                    Will
                    2E0WHN











                  • Ed
                    ... Have you read through this ? http://www.w1hkj.com/FldigiHelp-3.21/TransceiverControl.html Ed W3NR
                    Message 9 of 20 , Oct 27, 2013
                    View Source
                    • 0 Attachment
                      On 10/27/2013 05:00 PM, william northcote wrote:
                      > It seems the program works, but the sliders on the main flrig seem to
                      > be locked out.
                      >
                      > These are the ones that control volume, pwr, sql. Even found that
                      > doing psk it is not letting any power for TX for fldigi to produce a
                      > signal. It is looking like flrig in inhibiting the TX via fldifi.
                      >
                      > So I used my 817 radio without antenna. It makes a click but the
                      > fldigi is producing the signal but it looks like flrig is stopping it
                      > altogether. Also at some points it seems there is a double click.
                      > Once at the beginning when the TX happens and at the end. So now
                      > that I have the flrig operating the VFO a and b, I now need to get it
                      > to operate between fldigi and produce the power for TX.
                      >
                      > Will 2E0WHN

                      Have you read through this ?

                      http://www.w1hkj.com/FldigiHelp-3.21/TransceiverControl.html


                      Ed W3NR
                    • Ernest Wagner
                      Sorry about that.... I m so used to using su (superuser mode) and one doesn t need to use sudo when already operating as superuser (HiHi). Earlier versions of
                      Message 10 of 20 , Oct 27, 2013
                      View Source
                      • 0 Attachment
                        Sorry about that....

                        I'm so used to using su (superuser mode) and one doesn't need to use
                        sudo when already operating as superuser (HiHi).

                        Earlier versions of Fedora did not automatically add the user to the
                        sudouser list on install and I didn't want to take the time to learn how
                        to use it.

                        I would recommend you continuing using sudo anytime you want to make
                        system changes as staying in superuser mode can be very destructive.

                        Glad Geoff, NW7GM, was able to help you and get you on your way.

                        Ernie D, AA1AD


                        On Sat, 2013-10-26 at 18:18 +0100, william northcote wrote:
                        >
                        > Keep getting only root may add user to the system.
                        >
                        >
                        > Hmm!
                        >
                        >
                        > Will
                        > 2E0WHN
                        >
                        >
                        > On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
                        >
                        > Will,
                        >
                        > Those drivers you downloaded from that website are Windows
                        > drivers. On most Linux systems, the drivers are part of the
                        > Linux kernel. Just plug in the cable and the appropriate
                        > port(dev/ttyUSB0) should be created.
                        >
                        > You need to start a terminal(command line interface) and make
                        > yourself a member of the dialout group using the command:
                        >
                        > adduser yourusername dialout
                        >
                        > You also need to log out and back in for this change to take
                        > effect.
                        >
                        > Then start flrig, and from the menu, select Config->Xciever
                        > Select.
                        >
                        > On th I/O ports dialog select /dev/ttyUSB0 from the ser. port
                        > drop down list. this is what it should be if the cable uses
                        > the ftdi chip. It may contain some variation of "tty and
                        > "USB" for other chips.
                        >
                        > From the Rig Select drop-down select ft-897D. The
                        > communications protocol should be the same as the plain
                        > ft-897.
                        >
                        > With the rig connected, click on he red init button and you
                        > should be ready to go.
                        >
                        > Regards,
                        >
                        > Ernie D
                        >
                        >
                        >
                        >
                        > On Sat, 2013-10-26 at 15:32 +0000, william wrote:
                        > >
                        > > Need help getting the flrig and CAT to work together.
                        > >
                        > > I downloaded from the sellers site in this link
                        > > http://radioarena.co.uk/index.php?_a=product&product_id=2565
                        > > a file that is supposed to make CAT operate. But it seems
                        > > flrig does not either see the program or I have the wrong
                        > > CAT program.
                        > >
                        > > Any help of getting my OS (Ubuntu 12.10) to work with the
                        > > Yaesu-897 (Not a D version, just standard 897 here).
                        > >
                        > > Will
                        > > 2E0WHN
                        > >
                        > >
                        > >
                        > >
                        > >
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                      • william northcote
                        Well I have had some success with flrig. It works nice when it wants to. Problem is that it is a bit temperamental. Some times it works, some times, not. But
                        Message 11 of 20 , Oct 30, 2013
                        View Source
                        • 0 Attachment
                          Well I have had some success with flrig.  It works nice when it wants to.  Problem is that it is a bit temperamental.  Some times it works, some times, not.

                          But the main issue is Fldigi.  Again, sometime it will work, then not.  Mostly on the not work side of things.  I did manage to get a PSK signal using the 897 as a receiver and it did produce PSK.  But to then go to flrig, it just ceased to work.  So after a log out and back in I decided to try again.  Nope. Still nothing.  It seems that flrig and fldigi do not like each other at this moment in time.

                          So, any ideas on how to get round this as I am following the rigcat and I had some working points until it went south.

                          Will
                          2E0WHN


                          On 27 October 2013 22:06, Ernest Wagner <wagnered@...> wrote:
                           

                          Sorry about that....

                          I'm so used to using su (superuser mode) and one doesn't need to use
                          sudo when already operating as superuser (HiHi).

                          Earlier versions of Fedora did not automatically add the user to the
                          sudouser list on install and I didn't want to take the time to learn how
                          to use it.

                          I would recommend you continuing using sudo anytime you want to make
                          system changes as staying in superuser mode can be very destructive.

                          Glad Geoff, NW7GM, was able to help you and get you on your way.

                          Ernie D, AA1AD



                          On Sat, 2013-10-26 at 18:18 +0100, william northcote wrote:
                          >
                          > Keep getting only root may add user to the system.
                          >
                          >
                          > Hmm!
                          >
                          >
                          > Will
                          > 2E0WHN
                          >
                          >
                          > On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
                          >
                          > Will,
                          >
                          > Those drivers you downloaded from that website are Windows
                          > drivers. On most Linux systems, the drivers are part of the
                          > Linux kernel. Just plug in the cable and the appropriate
                          > port(dev/ttyUSB0) should be created.
                          >
                          > You need to start a terminal(command line interface) and make
                          > yourself a member of the dialout group using the command:
                          >
                          > adduser yourusername dialout
                          >
                          > You also need to log out and back in for this change to take
                          > effect.
                          >
                          > Then start flrig, and from the menu, select Config->Xciever
                          > Select.
                          >
                          > On th I/O ports dialog select /dev/ttyUSB0 from the ser. port
                          > drop down list. this is what it should be if the cable uses
                          > the ftdi chip. It may contain some variation of "tty and
                          > "USB" for other chips.
                          >
                          > From the Rig Select drop-down select ft-897D. The
                          > communications protocol should be the same as the plain
                          > ft-897.
                          >
                          > With the rig connected, click on he red init button and you
                          > should be ready to go.
                          >
                          > Regards,
                          >
                          > Ernie D
                          >
                          >
                          >
                          >
                          > On Sat, 2013-10-26 at 15:32 +0000, william wrote:
                          > >
                          > > Need help getting the flrig and CAT to work together.
                          > >
                          > > I downloaded from the sellers site in this link
                          > > http://radioarena.co.uk/index.php?_a=product&product_id=2565
                          > > a file that is supposed to make CAT operate. But it seems
                          > > flrig does not either see the program or I have the wrong
                          > > CAT program.
                          > >
                          > > Any help of getting my OS (Ubuntu 12.10) to work with the
                          > > Yaesu-897 (Not a D version, just standard 897 here).
                          > >
                          > > Will
                          > > 2E0WHN
                          > >
                          > >
                          > >
                          > >
                          > >
                          >
                          >
                          >
                          >
                          >
                          >
                          >


                        • Dave Wright
                          Go into Fldigi. Turn off use rigcat or any other CAT settings EXCEPT XML-RPC which should have a check mark next to Use XML-RPC program. Hit initialize then
                          Message 12 of 20 , Oct 30, 2013
                          View Source
                          • 0 Attachment
                            Go into Fldigi.  Turn off "use rigcat" or any other CAT settings EXCEPT XML-RPC which should have a check mark next to Use XML-RPC program. Hit initialize then save. Now try it.

                            From the sounds of it, you're trying to do RIGCAT to control the rig via Fldigi, but Flrig is trying to control the rig using the same serial port.  Fldigi and Flrig co-exist using XML-RPC. 

                            Give it a shot.

                            Dave
                            K3DCW

                            "Real radio bounces off the sky"


                            On Wed, Oct 30, 2013 at 4:58 PM, william northcote <william.northcote@...> wrote:
                             

                            Well I have had some success with flrig.  It works nice when it wants to.  Problem is that it is a bit temperamental.  Some times it works, some times, not.

                            But the main issue is Fldigi.  Again, sometime it will work, then not.  Mostly on the not work side of things.  I did manage to get a PSK signal using the 897 as a receiver and it did produce PSK.  But to then go to flrig, it just ceased to work.  So after a log out and back in I decided to try again.  Nope. Still nothing.  It seems that flrig and fldigi do not like each other at this moment in time.

                            So, any ideas on how to get round this as I am following the rigcat and I had some working points until it went south.

                            Will
                            2E0WHN


                            On 27 October 2013 22:06, Ernest Wagner <wagnered@...> wrote:
                             

                            Sorry about that....

                            I'm so used to using su (superuser mode) and one doesn't need to use
                            sudo when already operating as superuser (HiHi).

                            Earlier versions of Fedora did not automatically add the user to the
                            sudouser list on install and I didn't want to take the time to learn how
                            to use it.

                            I would recommend you continuing using sudo anytime you want to make
                            system changes as staying in superuser mode can be very destructive.

                            Glad Geoff, NW7GM, was able to help you and get you on your way.

                            Ernie D, AA1AD



                            On Sat, 2013-10-26 at 18:18 +0100, william northcote wrote:
                            >
                            > Keep getting only root may add user to the system.
                            >
                            >
                            > Hmm!
                            >
                            >
                            > Will
                            > 2E0WHN
                            >
                            >
                            > On 26 October 2013 18:00, Ernest Wagner <wagnered@...> wrote:
                            >
                            > Will,
                            >
                            > Those drivers you downloaded from that website are Windows
                            > drivers. On most Linux systems, the drivers are part of the
                            > Linux kernel. Just plug in the cable and the appropriate
                            > port(dev/ttyUSB0) should be created.
                            >
                            > You need to start a terminal(command line interface) and make
                            > yourself a member of the dialout group using the command:
                            >
                            > adduser yourusername dialout
                            >
                            > You also need to log out and back in for this change to take
                            > effect.
                            >
                            > Then start flrig, and from the menu, select Config->Xciever
                            > Select.
                            >
                            > On th I/O ports dialog select /dev/ttyUSB0 from the ser. port
                            > drop down list. this is what it should be if the cable uses
                            > the ftdi chip. It may contain some variation of "tty and
                            > "USB" for other chips.
                            >
                            > From the Rig Select drop-down select ft-897D. The
                            > communications protocol should be the same as the plain
                            > ft-897.
                            >
                            > With the rig connected, click on he red init button and you
                            > should be ready to go.
                            >
                            > Regards,
                            >
                            > Ernie D
                            >
                            >
                            >
                            >
                            > On Sat, 2013-10-26 at 15:32 +0000, william wrote:
                            > >
                            > > Need help getting the flrig and CAT to work together.
                            > >
                            > > I downloaded from the sellers site in this link
                            > > http://radioarena.co.uk/index.php?_a=product&product_id=2565
                            > > a file that is supposed to make CAT operate. But it seems
                            > > flrig does not either see the program or I have the wrong
                            > > CAT program.
                            > >
                            > > Any help of getting my OS (Ubuntu 12.10) to work with the
                            > > Yaesu-897 (Not a D version, just standard 897 here).
                            > >
                            > > Will
                            > > 2E0WHN
                            > >
                            > >
                            > >
                            > >
                            > >
                            >
                            >
                            >
                            >
                            >
                            >
                            >



                          • Ed
                            On Wed, 30 Oct 2013 20:58:52 +0000 ... How did you install fldigi and flrig ???? Exactly ......... In flrig Config Xcvr select Send Command The 2 diamonds
                            Message 13 of 20 , Oct 30, 2013
                            View Source
                            • 0 Attachment
                              On Wed, 30 Oct 2013 20:58:52 +0000
                              william northcote <william.northcote@...> wrote:

                              > Well I have had some success with flrig. It works nice when it wants
                              > to. Problem is that it is a bit temperamental. Some times it works,
                              > some times, not.
                              >
                              > But the main issue is Fldigi. Again, sometime it will work, then not.
                              > Mostly on the not work side of things. I did manage to get a PSK
                              > signal using the 897 as a receiver and it did produce PSK. But to
                              > then go to flrig, it just ceased to work. So after a log out and
                              > back in I decided to try again. Nope. Still nothing. It seems that
                              > flrig and fldigi do not like each other at this moment in time.
                              >
                              > So, any ideas on how to get round this as I am following the rigcat
                              > and I had some working points until it went south.
                              >
                              > Will
                              > 2E0WHN

                              How did you install fldigi and flrig ???? Exactly .........

                              In flrig Config > Xcvr select > Send Command

                              The 2 diamonds lower right, top should be green and the bottom red, if
                              all is working correctly and fldigi & flrig are taliking to each other.

                              Ed W3NR
                            • william northcote
                              Tried the XML-RPC tick and initialized it along with save and close. Nothing. But my radio kept on with the TX light so I have had to restart the radio and
                              Message 14 of 20 , Oct 30, 2013
                              View Source
                              • 0 Attachment
                                Tried the XML-RPC tick and initialized it along with save and close.  Nothing.  But my radio kept on with the TX light so I have had to restart the radio and programs again.

                                Also both are green and red.  And fldigi was installed via terminal.  Since ticking XML-RPC the radio turns on with a beep on the audio from the other radio and when turns off another beep is heard.  I have absolutely no idea what is happening with this program as all directions have been followed and it just seems to confound me even more now.

                                Will
                                2E0WHN


                                On 30 October 2013 21:10, Ed <autek@...> wrote:
                                 

                                On Wed, 30 Oct 2013 20:58:52 +0000
                                william northcote <william.northcote@...> wrote:

                                > Well I have had some success with flrig. It works nice when it wants
                                > to. Problem is that it is a bit temperamental. Some times it works,
                                > some times, not.
                                >
                                > But the main issue is Fldigi. Again, sometime it will work, then not.
                                > Mostly on the not work side of things. I did manage to get a PSK
                                > signal using the 897 as a receiver and it did produce PSK. But to
                                > then go to flrig, it just ceased to work. So after a log out and
                                > back in I decided to try again. Nope. Still nothing. It seems that
                                > flrig and fldigi do not like each other at this moment in time.
                                >
                                > So, any ideas on how to get round this as I am following the rigcat
                                > and I had some working points until it went south.
                                >
                                > Will
                                > 2E0WHN

                                How did you install fldigi and flrig ???? Exactly .........

                                In flrig Config > Xcvr select > Send Command

                                The 2 diamonds lower right, top should be green and the bottom red, if
                                all is working correctly and fldigi & flrig are taliking to each other.

                                Ed W3NR


                              • Ed
                                On Wed, 30 Oct 2013 22:27:11 +0000 ... What other radio ??????? Are you trying to control 2 radios at the same time ????? Did you uncheck everything in Rig
                                Message 15 of 20 , Oct 30, 2013
                                View Source
                                • 0 Attachment
                                  On Wed, 30 Oct 2013 22:27:11 +0000
                                  william northcote <william.northcote@...> wrote:

                                  > Tried the XML-RPC tick and initialized it along with save and close.
                                  > Nothing. But my radio kept on with the TX light so I have had to
                                  > restart the radio and programs again.
                                  >
                                  > Also both are green and red. And fldigi was installed via terminal.
                                  > Since ticking XML-RPC the radio turns on with a beep on the audio
                                  > from the other radio and when turns off another beep is heard. I
                                  > have absolutely no idea what is happening with this program as all
                                  > directions have been followed and it just seems to confound me even
                                  > more now.
                                  >
                                  > Will
                                  > 2E0WHN

                                  What other radio ??????? Are you trying to control 2 radios at the same
                                  time ?????

                                  Did you uncheck everything in Rig Control, except the xml-rpc ????

                                  What version of fldigi and flrig ????????

                                  Have you read thru the Help file pertaining to rig control ????

                                  Ed W3NR
                                • william northcote
                                  The other radio is a 817 and is being used as a receiver to see if the tones are being sent. Flrig is version 1.3.14 and fldigi is 3.21.76 I have read the rig
                                  Message 16 of 20 , Oct 30, 2013
                                  View Source
                                  • 0 Attachment
                                    The other radio is a 817 and is being used as a receiver to see if the tones are being sent.

                                    Flrig is version 1.3.14 and fldigi is 3.21.76

                                    I have read the rig control document as well as one online which is a sort of walkthrough.

                                    Will
                                    2E0WHN


                                    On 30 October 2013 22:50, Ed <autek@...> wrote:
                                     

                                    On Wed, 30 Oct 2013 22:27:11 +0000
                                    william northcote <william.northcote@...> wrote:

                                    > Tried the XML-RPC tick and initialized it along with save and close.
                                    > Nothing. But my radio kept on with the TX light so I have had to
                                    > restart the radio and programs again.
                                    >
                                    > Also both are green and red. And fldigi was installed via terminal.
                                    > Since ticking XML-RPC the radio turns on with a beep on the audio
                                    > from the other radio and when turns off another beep is heard. I
                                    > have absolutely no idea what is happening with this program as all
                                    > directions have been followed and it just seems to confound me even
                                    > more now.
                                    >
                                    > Will
                                    > 2E0WHN

                                    What other radio ??????? Are you trying to control 2 radios at the same
                                    time ?????

                                    Did you uncheck everything in Rig Control, except the xml-rpc ????

                                    What version of fldigi and flrig ????????

                                    Have you read thru the Help file pertaining to rig control ????

                                    Ed W3NR


                                  • Ed
                                    On Wed, 30 Oct 2013 22:56:15 +0000 ... At this point Will, you need to use hamlib. There is no other support for your rig. Under Rig Control make sure you
                                    Message 17 of 20 , Oct 30, 2013
                                    View Source
                                    • 0 Attachment
                                      On Wed, 30 Oct 2013 22:56:15 +0000
                                      william northcote <william.northcote@...> wrote:

                                      > The other radio is a 817 and is being used as a receiver to see if the
                                      > tones are being sent.
                                      >
                                      > Flrig is version 1.3.14 and fldigi is 3.21.76
                                      >
                                      > I have read the rig control document as well as one online which is a
                                      > sort of walkthrough.
                                      >
                                      > Will
                                      > 2E0WHN

                                      At this point Will, you need to use hamlib. There is no other support
                                      for your rig. Under Rig Control make sure you uncheck everything but
                                      hamlib.

                                      Ed W3NR
                                    • william northcote
                                      Futher to this problem I have come across something strange. RigCAT allows me to send data but not control fldigi. Hamlib lets me control fldigi but not send
                                      Message 18 of 20 , Nov 3, 2013
                                      View Source
                                      • 0 Attachment
                                        Futher to this problem I have come across something strange.

                                        RigCAT allows me to send data but not control fldigi.

                                        Hamlib lets me control fldigi but not send data (like PSK or Hellscrieber)

                                        XML-RPC lets me send data but not have control of the VFO part on fldigi.

                                        I have not updated to the new one yet.  Been too busy trying to get this sorted so I can send data mode and control the VFO also.

                                        Maybe if I update the program (of which I may have to do) may solve it.

                                        Will
                                        2E0WHN


                                        On 31 October 2013 00:16, Ed <autek@...> wrote:
                                         

                                        On Wed, 30 Oct 2013 22:56:15 +0000
                                        william northcote <william.northcote@...> wrote:

                                        > The other radio is a 817 and is being used as a receiver to see if the
                                        > tones are being sent.
                                        >
                                        > Flrig is version 1.3.14 and fldigi is 3.21.76
                                        >
                                        > I have read the rig control document as well as one online which is a
                                        > sort of walkthrough.
                                        >
                                        > Will
                                        > 2E0WHN

                                        At this point Will, you need to use hamlib. There is no other support
                                        for your rig. Under Rig Control make sure you uncheck everything but
                                        hamlib.

                                        Ed W3NR


                                      • Marty Hartwell
                                        Hi When you are using xml-rpc, are you also using flrig? That is what connect flrig to fldigi to provide rig CAT control. Marty kd8bj
                                        Message 19 of 20 , Nov 3, 2013
                                        View Source
                                        • 0 Attachment
                                          Hi

                                          When you are using xml-rpc, are you also using flrig?
                                          That is what connect flrig to fldigi to provide rig CAT control.

                                          Marty kd8bj
                                          On 11/3/2013 1:12 PM, william northcote wrote:
                                          > Futher to this problem I have come across something strange.
                                          >
                                          > RigCAT allows me to send data but not control fldigi.
                                          >
                                          > Hamlib lets me control fldigi but not send data (like PSK or Hellscrieber)
                                          >
                                          > XML-RPC lets me send data but not have control of the VFO part on fldigi.
                                          >
                                          > I have not updated to the new one yet. Been too busy trying to get
                                          > this sorted so I can send data mode and control the VFO also.
                                          >
                                          > Maybe if I update the program (of which I may have to do) may solve it.
                                          >
                                          > Will
                                          > 2E0WHN
                                          >
                                          >
                                          > On 31 October 2013 00:16, Ed <autek@...
                                          > <mailto:autek@...>> wrote:
                                          >
                                          > On Wed, 30 Oct 2013 22:56:15 +0000
                                          > william northcote <william.northcote@...
                                          > <mailto:william.northcote@...>> wrote:
                                          >
                                          > > The other radio is a 817 and is being used as a receiver to see
                                          > if the
                                          > > tones are being sent.
                                          > >
                                          > > Flrig is version 1.3.14 and fldigi is 3.21.76
                                          > >
                                          > > I have read the rig control document as well as one online which
                                          > is a
                                          > > sort of walkthrough.
                                          > >
                                          > > Will
                                          > > 2E0WHN
                                          >
                                          > At this point Will, you need to use hamlib. There is no other support
                                          > for your rig. Under Rig Control make sure you uncheck everything but
                                          > hamlib.
                                          >
                                          > Ed W3NR
                                          >
                                          >
                                          >
                                        • Dave Wright
                                          Will, For starters, you should always run the latest versions of the software...that makes troubleshooting easier. Second, I recall that you re running Ubuntu
                                          Message 20 of 20 , Nov 3, 2013
                                          View Source
                                          • 0 Attachment
                                            Will,

                                            For starters, you should always run the latest versions of the software...that makes troubleshooting easier. 


                                            Second, I recall that you're running Ubuntu 12.04; are you a member of the DIALOUT group?  If you don't know for sure, then first thing do this:

                                            sudo adduser USERNAME dialout  (replace USERNAME with your username)

                                            Logout and then log back in. 


                                            Third, which rig are you trying to control?  At various times you've mentioned an 817 and a 897 (non-D).  As far as I know, the 897 is not supported in Fldigi, so RigCAT won't work for you.  Flrig supports the 897D, but I'm not sure if there are any differences between the non-D and the D version as far as CAT goes.  However, let's assume that the 897 and 897D have the same CAT structure, then to get Flrig and Fldigi to work should be simple.

                                            1) Open Fldigi and go to the Rig Control section.  Under the XML-RPC tab, select the box "Use XML-RPC", hit Initialize then save.  Close that out and close out Fldigi.

                                            2) Open Flrig.  Select your rig and set your COM port/Speed settings to match what is used by your computer and rig. Do you know for certain which COM port your rig is on?  It should be something like tty.USB0 or some other such port.

                                            3) Start Fldigi and Fldigi and Flrig should be talking to each other, and to the rig.  Try changing freqs on Fldigi....does Flrig change too? What about changing freqs on Flrig; does Fldigi change?  What is in the box right above the frequency display in Fldigi (Flrig XML-RPC or something like that? I can't remember exactly what it is supposed to say)  If so, they are talking to each other.  Of course, the next question is whether they are talking to your rig. 

                                            4) If your rig isn't changing freqs, then there is a configuration issue.  Either your comport is wrong, the speed is wrong, you're not a member of the DIALOUT group (see above), or your rig is not configured properly for CAT.  So you'll need to double-check every setting, WITHOUT messing with RigCAT, Hamlib, or anything else. 


                                            I hope this helps. 


                                            Dave
                                            K3DCW

                                            "Real radio bounces off the sky"


                                            On Sun, Nov 3, 2013 at 2:12 PM, william northcote <william.northcote@...> wrote:
                                             

                                            Futher to this problem I have come across something strange.

                                            RigCAT allows me to send data but not control fldigi.

                                            Hamlib lets me control fldigi but not send data (like PSK or Hellscrieber)

                                            XML-RPC lets me send data but not have control of the VFO part on fldigi.

                                            I have not updated to the new one yet.  Been too busy trying to get this sorted so I can send data mode and control the VFO also.

                                            Maybe if I update the program (of which I may have to do) may solve it.

                                            Will
                                            2E0WHN


                                          Your message has been successfully submitted and would be delivered to recipients shortly.